
  

TunerStudio MS Lite Reference
Megasquirt-3 Product Range

MS3 1.5.x

Dated: 2017-01-14
MS3 Firmware Version: 1.5.0

Reference manual for using TunerStudio 3.x with your Megasquirt-3 ECU.

This version of the documentation applies to the Megasquirt-3 range of products which includes:

• MS3 using the V3.0 or V3.57 mainboards;

• MS3-Pro, MS3-Pro-Ultimate

• Products derived from the MS3-Pro Module, e.g.,MSPNP-Pro

• MS3 Gold Box

Applies to firmware MS3 1.5.x (See the Setting Up manual for more detail on version numbers.)

MS3-Pro customers may prefer to use the MS3-Pro manuals.

This version of the documentation DOES NOT apply to:

• Megasquirt-1;

• EMS Pro;

• Megasquirt-2;

• Microsquirt

• Microsquirt-module or any products using it.

(c) 2014-7 James Murray. 



Megasquirt-3: TunerStudio MS Lite Reference Guide

Table of Chapters
1 Introduction....................................................................................................................................................... 11
2 File Menu.......................................................................................................................................................... 27
3 Options Menu.................................................................................................................................................... 42
4 Data Logging Menu........................................................................................................................................... 46
5 Communications Menu..................................................................................................................................... 68
6 Tools Menu........................................................................................................................................................ 72
7 Help Menu........................................................................................................................................................ 79
8 Basic / Load Settings........................................................................................................................................ 80
9 Fuel Settings................................................................................................................................................... 112
10 Ignition Settings............................................................................................................................................ 139
11 Startup / Idle.................................................................................................................................................. 160
12 Accel Enrich.................................................................................................................................................. 179
13 Boost / VVT................................................................................................................................................... 192
14 Table Choices............................................................................................................................................... 216
15 Advanced Engine.......................................................................................................................................... 228
16 3D Maps....................................................................................................................................................... 265
17 CAN bus / Testmodes................................................................................................................................... 272
18 Upgrade........................................................................................................................................................ 310
19 Dashboard Gauge Cluster............................................................................................................................. 311
20 Dashboard Indicators.................................................................................................................................... 327
21 Diagnostics & High Speed Loggers..............................................................................................................334
22 Tune Analyze Live......................................................................................................................................... 339
23 Megasquirt Glossary of Terms...................................................................................................................... 340
24 Firmware changes since 1.3.x...................................................................................................................... 347
25 Firmware changes since 1.4.x...................................................................................................................... 350
26 Revision history............................................................................................................................................. 351

(c) 2014-7 James Murray 2017-01-14 Page 2/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

Contents
1 Introduction....................................................................................................................................................... 11

1.1 Overview................................................................................................................................................... 11
1.2 Prerequisites............................................................................................................................................. 11
1.3 How to use the manuals............................................................................................................................ 11
1.4 TunerStudio MS Lite Interface..................................................................................................................13

1.4.1 Start Screen...................................................................................................................................... 13
1.4.2 Main Screen...................................................................................................................................... 14
1.4.3 Lite and Upgrade Versions of TunerStudio.......................................................................................16

1.5 Using the Software Interface.....................................................................................................................16
1.5.1 Data Input Screens........................................................................................................................... 16
1.5.2 Curves.............................................................................................................................................. 18
1.5.3 3D Tables.......................................................................................................................................... 20
1.5.4 3D Tuning Maps................................................................................................................................ 23

2 File Menu.......................................................................................................................................................... 27
2.1 Vehicle Projects........................................................................................................................................ 27

2.1.1  New Project..................................................................................................................................... 27
2.1.2 Open Project..................................................................................................................................... 34
2.1.3 Close Project.................................................................................................................................... 35
2.1.4 Create Project Backup...................................................................................................................... 35
2.1.5 Import Project Archive....................................................................................................................... 35
2.1.6 Project Properties............................................................................................................................. 35

2.2 Tune Restore Point Dialog........................................................................................................................ 39
2.3 Open Tune................................................................................................................................................ 39
2.4 Save Tune................................................................................................................................................. 40
2.5 Save Tune As............................................................................................................................................ 40
2.6 Work Offline.............................................................................................................................................. 40
2.7 Exit............................................................................................................................................................ 41

3 Options Menu.................................................................................................................................................... 42
3.1 Language.................................................................................................................................................. 42
3.2 Look and Feel........................................................................................................................................... 42
3.3 Navigation................................................................................................................................................. 42

3.3.1 Main Menu Style............................................................................................................................... 42
3.3.2 Wrapping Main Menu........................................................................................................................42
3.3.3 Toolbar Style..................................................................................................................................... 43
3.3.4 Navigation Options............................................................................................................................ 43

3.4 View.......................................................................................................................................................... 43
3.4.1 Show Gauges on VE Analyze...........................................................................................................43
3.4.2 Show Live Graphs on VE Analyze....................................................................................................43
3.4.3 Show Enable Condition in Menu Tooltips..........................................................................................43

3.5 Advanced.................................................................................................................................................. 43
3.5.1 Report INI Warnings......................................................................................................................... 43
3.5.2 Always Allow Multiple Instances........................................................................................................43

3.6 Preferences.............................................................................................................................................. 44
3.6.1 Set Dialog Font Size.........................................................................................................................44
3.6.2 Perform Difference Report on Connect.............................................................................................44
3.6.3 Automatically Load and Save Current Tune......................................................................................44

3.7 Performance............................................................................................................................................. 45
3.7.1 Gauge Float down on start................................................................................................................45
3.7.2 Modal Dialogs................................................................................................................................... 45
3.7.3 Run in Lite Mode............................................................................................................................... 45

4 Data Logging Menu........................................................................................................................................... 46
4.1 Start Logging............................................................................................................................................ 46
4.2 Stop.......................................................................................................................................................... 46

(c) 2014-7 James Murray 2017-01-14 Page 3/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

4.3 Logging Profiles........................................................................................................................................ 46
4.4 Automatic Logging.................................................................................................................................... 46
4.5 Import / Conversion................................................................................................................................... 47

4.5.1 PalmLog Import Utility....................................................................................................................... 47
4.5.2 Convert Binary Log (MS3, FRD).......................................................................................................47

4.6 View with MegaLogViewer........................................................................................................................ 48
4.6.1 MegaLogViewer Datalog Fields........................................................................................................50

4.7 SDcard datalogging.................................................................................................................................. 64
4.8 Browse/Import SDcard.............................................................................................................................. 66

5 Communications Menu..................................................................................................................................... 68
5.1 Settings..................................................................................................................................................... 68
5.2 Data Rate.................................................................................................................................................. 68
5.3 Enable GPS Support................................................................................................................................. 69
5.4 Mini Terminal............................................................................................................................................. 69
5.5 Debug Log Comm..................................................................................................................................... 70
5.6 Megasquirt Baud Rate.............................................................................................................................. 70

6 Tools Menu........................................................................................................................................................ 72
6.1 Protocol Stats........................................................................................................................................... 72
6.2 Update / Install Firmware..........................................................................................................................72
6.3 TunerStudio Plug-ins................................................................................................................................. 72
6.4 Calibrate TPS............................................................................................................................................ 72
6.5 Calibrate MAP / Baro................................................................................................................................ 73
6.6 Calibrate Battery Voltage.......................................................................................................................... 74
6.7 Un/Lock calibrations.................................................................................................................................. 74
6.8 Calibrate Thermistor Tables...................................................................................................................... 76
6.9 Calibrate AFR Table.................................................................................................................................. 77

7 Help Menu........................................................................................................................................................ 79
7.1 TunerStudio Help...................................................................................................................................... 79
7.2 Check for Update...................................................................................................................................... 79
7.3 Automatic Update Check..........................................................................................................................79
7.4 Enter Registration..................................................................................................................................... 79
7.5 About......................................................................................................................................................... 79
7.6 Megasquirt 3 Info...................................................................................................................................... 79

8 Basic / Load Settings........................................................................................................................................ 80
8.1 Engine and Sequential Settings................................................................................................................80

8.1.1 Required Fuel Settings..................................................................................................................... 80
8.1.2 Sequential Injection Settings.............................................................................................................81

8.2 General Settings....................................................................................................................................... 83
8.2.1 Baro Sensor Settings........................................................................................................................83
8.2.2 MAP Sensor Settings........................................................................................................................84
8.2.3 General Sensor Settings................................................................................................................... 84
8.2.4 Load Parameters.............................................................................................................................. 85

8.3 Rev Limiter................................................................................................................................................ 86
8.3.1 Hard Rev Limit.................................................................................................................................. 87
8.3.2 Coolant Temp Limiter........................................................................................................................ 87
8.3.3 Spark Retard..................................................................................................................................... 87
8.3.4 Spark Cut and Fuel Cut....................................................................................................................87

8.4 Shift Light.................................................................................................................................................. 88
8.5 Engine State Settings............................................................................................................................... 89
8.6 Tacho Output............................................................................................................................................. 90
8.7 Fan Control............................................................................................................................................... 91
8.8 Torque Convertor Lockup.......................................................................................................................... 93
8.9 Alternator Control...................................................................................................................................... 95
8.10 Barometric Correction............................................................................................................................. 98
8.11 MAP Sample Settings............................................................................................................................. 99
8.12 ITB Load Settings................................................................................................................................. 100
8.13 MAF Settings........................................................................................................................................ 101

(c) 2014-7 James Murray 2017-01-14 Page 4/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

8.14 MAF Flow Curve................................................................................................................................... 103
8.15 MAF/MAT Correction Table...................................................................................................................103
8.16 MAT Air Density Table........................................................................................................................... 104
8.17 MAT / CLT correction............................................................................................................................ 105
8.18 Real-Time Display................................................................................................................................. 106
8.19 Feature List Showing I/O Pins...............................................................................................................107
8.20 I/O pins List Showing Usage.................................................................................................................108
8.21 Expansion I/O pins List/Usage..............................................................................................................109
8.22 Gauge and Settings Limits.................................................................................................................... 110

9 Fuel Settings................................................................................................................................................... 112
9.1 Injector Dead-time / PWM....................................................................................................................... 112
9.2 Injector Small Pulsewidths...................................................................................................................... 114
9.3 Injector Timing Tables.............................................................................................................................. 114
9.4 Staged Injection...................................................................................................................................... 116
9.5 Fuel Sensor Settings (Flex)..................................................................................................................... 119
9.6 Over-Run Fuel Cut.................................................................................................................................. 121
9.7 AFR/EGO Control................................................................................................................................... 123
9.8 AFR Tables (1 and 2).............................................................................................................................. 125
9.9 EGO Authority Table............................................................................................................................... 126
9.10 EGO Delay Table.................................................................................................................................. 127
9.11 Narrowband EGO Targets.....................................................................................................................127
9.12 AFR Safety System............................................................................................................................... 127
9.13 Fuel VE Tables (1 to 4).........................................................................................................................129
9.14 Injector Trim Tables............................................................................................................................... 130
9.15  Sequenced Batch Fire.........................................................................................................................132
9.16 Fuel Pump and Pressure......................................................................................................................132
9.17 Temperature Adjustment.......................................................................................................................135
9.18 Pressure Adjustment............................................................................................................................. 136
9.19 Fuel Pressure Safety............................................................................................................................ 137
9.20 Fuel calculations Summary................................................................................................................... 138

10 Ignition Settings............................................................................................................................................ 139
10.1 Ignition Options / Wheel Decoder.........................................................................................................139
10.2 Trigger Wizard....................................................................................................................................... 144
10.3 Dwell Battery Correction....................................................................................................................... 145
10.4 Dwell vs RPM........................................................................................................................................ 145
10.5 Dwell Table............................................................................................................................................ 146
10.6 Cold Advance........................................................................................................................................ 146
10.7 MAT-Based Timing Retard....................................................................................................................147
10.8 Noise Filtering....................................................................................................................................... 148

10.8.1 Primary Tach (crank)..................................................................................................................... 148
10.8.2 Secondary Tach (cam).................................................................................................................. 149

10.9 Knock Sensor Settings.......................................................................................................................... 150
10.10 Knock Sensor Parameters.................................................................................................................. 153
10.11 Knock Window Settings....................................................................................................................... 154
10.12 Knock Coolant Scaling........................................................................................................................ 155
10.13 Ignition Tables (1 to 4)......................................................................................................................... 155
10.14 Rotary Settings................................................................................................................................... 156
10.15 Rotary Split Table................................................................................................................................ 157
10.16 Spark Trim Tables............................................................................................................................... 157
10.17 Spark Calculations Summary..............................................................................................................159

11 Startup / Idle.................................................................................................................................................. 160
11.1 Cranking / Startup settings.................................................................................................................... 160
11.2 Priming Pulse........................................................................................................................................ 161
11.3 Cranking Pulse %.................................................................................................................................. 161
11.4 Cranking Taper Curve........................................................................................................................... 162
11.5 AfterStart Enrichment (ASE)..................................................................................................................163
11.6 AfterStart Enrichment (ASE) Taper........................................................................................................164

(c) 2014-7 James Murray 2017-01-14 Page 5/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

11.7 Warmup Enrichment (WUE)..................................................................................................................164
11.8 Priming Pulse 2..................................................................................................................................... 165
11.9 Cranking Pulse 2................................................................................................................................... 165
11.10 AfterStart Enrichment (ASE) 2.............................................................................................................165
11.11 AfterStart Enrichment (ASE) Taper 2...................................................................................................165
11.12 Warmup Enrichment (WUE) 2.............................................................................................................165
11.13 Idle Control.......................................................................................................................................... 165

11.13.1 Stepper idle................................................................................................................................. 166
11.13.2 PWM idle..................................................................................................................................... 167

11.14 Idle Cranking Duty / Steps................................................................................................................... 168
11.15 Idle Warmup Duty / Steps................................................................................................................... 169
11.16 Closed-Loop Idle settings.................................................................................................................... 170

11.16.1 Closed-Loop Idle Settings...........................................................................................................170
11.16.2 Closed-Loop Idle PID Gains........................................................................................................171
11.16.3 Closed-Loop Idle PID Delays and Behavior................................................................................171

11.17 Closed-Loop Idle Target RPM Curve...................................................................................................172
11.18 Closed-Loop Idle Initial Values............................................................................................................172
11.19 PWM Idle Voltage Compensation........................................................................................................173
11.20 Air Conditioning Idle-up.......................................................................................................................173
11.21 Idle Advance Settings.......................................................................................................................... 176
11.22 Idle RPM Timing Correction Curve......................................................................................................177
11.23 Idle VE Settings................................................................................................................................... 178

12 Accel Enrich.................................................................................................................................................. 179
12.1 Accel Enrich Settings............................................................................................................................ 179
12.2 Time-Based Accel Enrichment..............................................................................................................180
12.3 Accel-pump Accel Enrichment Settings.................................................................................................182
12.4 Time-Based Accel Enrichment 2...........................................................................................................183
12.5 Accel-pump Accel Enrichment Settings 2..............................................................................................183
12.6 TPS WOT curve.................................................................................................................................... 183
12.7 EAE Adhere-to-walls Coefficient...........................................................................................................184
12.8 EAE Sucked-from-walls Coefficient......................................................................................................185
12.9 EAE Adhere-to-walls RPM Correction...................................................................................................185
12.10 EAE Sucked-from-walls RPM Correction............................................................................................186
12.11 EAE Adhere-to-walls CLT Correction..................................................................................................186
12.12 EAE Sucked-from-walls CLT Correction.............................................................................................187
12.13 EAE Adhere-to-walls Coefficient 2......................................................................................................187
12.14 EAE Sucked-from-walls Coefficient 2.................................................................................................187
12.15 EAE Adhere-to-walls RPM Correction 2..............................................................................................187
12.16 EAE Sucked-from-walls RPM Correction 2.........................................................................................187
12.17 EAE Adhere-to-walls CLT Correction 2...............................................................................................188
12.18 EAE Sucked-from-walls CLT Correction 2..........................................................................................188
12.19 Puddling Factors (accel).....................................................................................................................188
12.20 Puddling Factors (decel)..................................................................................................................... 188
12.21 Time Factors (accel)........................................................................................................................... 189
12.22 Time Factors (decel)........................................................................................................................... 189
12.23 X (Puddling) Temp. Corrections..........................................................................................................190
12.24 Tau (time) Temp. Corrections..............................................................................................................190

13 Boost / VVT................................................................................................................................................... 192
13.1 Boost Control Settings..........................................................................................................................192

13.1.1 Overboost Protection Settings......................................................................................................194
13.1.2 Boost Switching Settings..............................................................................................................195

13.2 Boost Control Duty Table......................................................................................................................197
13.3 Boost Control Target Table.................................................................................................................... 197
13.4 Boost Control Bias Duty Table 1...........................................................................................................198
13.5 Boost Delay (Timed From Launch).......................................................................................................199
13.6 Boost Control vs Speed........................................................................................................................ 199
13.7 Boost Control Settings 2.......................................................................................................................200

(c) 2014-7 James Murray 2017-01-14 Page 6/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

13.8 Boost Control Duty Table 2................................................................................................................... 202
13.9 Boost Control Target Table 2.................................................................................................................202
13.10 Boost Control Bias Duty Table 2.........................................................................................................202
13.11 Wastegate Dome Pressure Control Settings 1....................................................................................202
13.12 Dome Bias Table 1.............................................................................................................................. 205
13.13 Turbo Anti-Lag (ALS).......................................................................................................................... 205
13.14 Turbo Anti-Lag Tables.........................................................................................................................208
13.15 Turbo Anti-Lag Roving Idle..................................................................................................................209
13.16 VVT Settings....................................................................................................................................... 210

13.16.1 VVT Settings............................................................................................................................... 210
13.16.2 PID Parameters..........................................................................................................................212
13.16.3 Test............................................................................................................................................. 213
13.16.4 Cam Settings.............................................................................................................................. 213

13.17 VVT Intake Table................................................................................................................................. 214
13.18 VVT Exhaust Table.............................................................................................................................. 214
13.19 VVT On/Off Table................................................................................................................................ 215

14 Table Choices............................................................................................................................................... 216
14.1 Table Switch/Dual Fuel......................................................................................................................... 216

14.1.1 Table Switching............................................................................................................................. 216
14.1.2 Dual Fuel...................................................................................................................................... 218

14.2 Temperature Adjustment.......................................................................................................................220
14.3 Pressure Adjustment............................................................................................................................. 221
14.4 Alt. Injector Dead-time/PWM 2..............................................................................................................222
14.5 Alt. Injector Small Pulsewidths 2...........................................................................................................222

14.5.1 Blend Curve (1) VE1->2................................................................................................................222
14.5.2 Blend Curve (2) Spk1->2..............................................................................................................223
14.5.3 Blend Curve (3) VE1+2->3+4........................................................................................................223
14.5.4 Blend Curve (4) Spk1+2->3+4......................................................................................................224
14.5.5 Blend Curve (5) AFR1->2..............................................................................................................225
14.5.6 Blend Curve (6) Boost1->2...........................................................................................................225
14.5.7 Blend Curve (7) Crank%1->2........................................................................................................226
14.5.8 Blend Curve (8) Flex Blending......................................................................................................226

15 Advanced Engine.......................................................................................................................................... 228
15.1 Speed and Gear Sensors..................................................................................................................... 228

15.1.1 Vehicle Speed Sensor 1................................................................................................................228
15.1.2 Vehicle Speed Sensor 2................................................................................................................230
15.1.3 Vehicle Speed Sensor 3................................................................................................................230
15.1.4 Vehicle Speed Sensor 4................................................................................................................230
15.1.5 VSS output.................................................................................................................................... 230
15.1.6 VSSdot smoothing........................................................................................................................231
15.1.7 VSS Sampling............................................................................................................................... 231
15.1.8 Gear detection.............................................................................................................................. 231
15.1.9 Units.............................................................................................................................................. 232

15.2 Shaft Speed Sensors............................................................................................................................ 232
15.3 EGT/Thermocouple Settings................................................................................................................. 233

15.3.1 Configuration................................................................................................................................ 234
15.3.2 Data Capture................................................................................................................................ 234
15.3.3 Actions.......................................................................................................................................... 234

15.4 Generic Sensor Inputs..........................................................................................................................235
15.5 Accelerometer Parameters...................................................................................................................236
15.6 Traction Control..................................................................................................................................... 238
15.7 Traction Control - Perfect Run VSS......................................................................................................240
15.8 Traction Control - Perfect Run RPM......................................................................................................241
15.9 Traction Control - External Slip% input.................................................................................................242
15.10 Traction Control Reactions..................................................................................................................243
15.11 Launch / 2-step / 3-step / T-brake.......................................................................................................244

15.11.1 Launch Settings..........................................................................................................................244

(c) 2014-7 James Murray 2017-01-14 Page 7/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

15.11.2 Flat Shift Settings........................................................................................................................ 245
15.11.3 Timed Retard............................................................................................................................... 246
15.11.4 Transbrake, Throttle Stop............................................................................................................246
15.11.5 3-Step / Burnout Limiter..............................................................................................................247
15.11.6 Line Lock Staging........................................................................................................................247

15.12 Timed Retard After Launch.................................................................................................................247
15.13 Sequential Shift Cut............................................................................................................................ 249
15.14 Nitrous System.................................................................................................................................... 251

15.14.1 General Settings......................................................................................................................... 251
15.14.2 Nitrous System Stage 1..............................................................................................................252

15.15 Nitrous - Time-based progressive.......................................................................................................253
15.16 Nitrous - RPM-based progressive.......................................................................................................254
15.17 Nitrous - VSS-based progressive........................................................................................................254
15.18 Water Injection.................................................................................................................................... 255
15.19 High Power Time Enrichment..............................................................................................................256
15.20 Oil Pressure........................................................................................................................................ 257
15.21 Pit Lane Limiter................................................................................................................................... 257
15.22 Programmable On/Off Outputs 1........................................................................................................259

15.22.1 Output Port................................................................................................................................. 259
15.22.2 Port Settings............................................................................................................................... 260
15.22.3 Active Conditions........................................................................................................................ 260

15.23 Programmable On/Off Outputs 2........................................................................................................261
15.24 Generic PWM Outputs........................................................................................................................261
15.25 Generic Closed-Loop.......................................................................................................................... 262

16 3D Maps....................................................................................................................................................... 265
16.1 Fuel VE Tables [1 to 4]..........................................................................................................................265
16.2 AFR Tables [1 and 2]............................................................................................................................. 266
16.3 Ignition Tables [1 to 4]........................................................................................................................... 267
16.4 Rotary Split Table.................................................................................................................................. 268
16.5 Boost Control Duty Table......................................................................................................................269
16.6 Boost Control Target Table.................................................................................................................... 270
16.7 Injection Timing Tables [Primary and Secondary].................................................................................271

17 CAN bus / Testmodes................................................................................................................................... 272
17.1 CAN Parameters................................................................................................................................... 272

17.1.1 Digital Ports.................................................................................................................................. 274
17.1.2 PWM Outputs............................................................................................................................... 274
17.1.3 CAN ADC Selection...................................................................................................................... 275

17.2 CAN Broadcasting................................................................................................................................ 275
17.3 CAN Broadcast testing.......................................................................................................................... 277
17.4 CAN Realtime Data Broadcasting.........................................................................................................278
17.5 CAN Realtime Data Broadcasting 2......................................................................................................278
17.6 CAN Realtime Data Broadcasting 3......................................................................................................278
17.7 CAN Realtime Data Broadcasting 4......................................................................................................278
17.8 CAN Receiving...................................................................................................................................... 279
17.9 CAN VSS, Gear.................................................................................................................................... 280

17.9.1 CAN VSS and gear selection........................................................................................................280
17.10 CAN EGO, GPS.................................................................................................................................. 282

17.10.1 EGO Data Via CAN.....................................................................................................................282
17.10.2 GPS Data Via CAN.....................................................................................................................283
17.10.3 Accelerometer Data via CAN......................................................................................................283

17.11 Real Time Clock.................................................................................................................................. 283
17.12 IO-Box Settings................................................................................................................................... 284
17.13 Dash Broadcasting.............................................................................................................................. 286
17.14 Check Engine Light............................................................................................................................. 287
17.15 Limp Mode.......................................................................................................................................... 291
17.16 Fallback MAP Table............................................................................................................................ 293
17.17 Output Test Mode – Inj/Spk................................................................................................................. 294

(c) 2014-7 James Murray 2017-01-14 Page 8/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

17.17.1 Coil Testing................................................................................................................................. 295
17.17.2 Injector Testing............................................................................................................................ 295
17.17.3 PWM Settings............................................................................................................................. 296

17.18  Output Test Mode – I/O......................................................................................................................297
17.19  Output Test Mode – I/O 2................................................................................................................... 298

17.19.1 Output Test Mode – I/O 3............................................................................................................299
17.20  Output Test Mode – CAN I/O.............................................................................................................300
17.21 Output Test Mode – Idle Valve............................................................................................................301
17.22 Injector Sequential Testing.................................................................................................................. 302
17.23 Inj/Spk Disabling Test Mode................................................................................................................303

17.23.1 Outputs Per Cylinder................................................................................................................... 303
17.24 Special Options................................................................................................................................... 304
17.25 Long Term Trim Settings..................................................................................................................... 304
17.26 Long Term Trim Table 1.......................................................................................................................306
17.27 Outmsg 1............................................................................................................................................ 306
17.28 Throttle control (DBW)........................................................................................................................ 307

17.28.1 Throttle target.............................................................................................................................. 308
17.28.2 Throttle actual position................................................................................................................308
17.28.3 Pedal position............................................................................................................................. 308
17.28.4 Idle control.................................................................................................................................. 308
17.28.5 Additional throttles....................................................................................................................... 308
17.28.6 Throttle control target table.........................................................................................................308

17.29 Throttle Test Mode.............................................................................................................................. 309
18 Upgrade........................................................................................................................................................ 310
19 Dashboard Gauge Cluster............................................................................................................................. 311

19.1 TunerStudio gauges.............................................................................................................................. 312
19.2 AFR/EGO calculations..........................................................................................................................312
19.3 AFR/EGO inputs................................................................................................................................... 312
19.4 CAN board inputs/outputs.....................................................................................................................313
19.5 Calculations 1....................................................................................................................................... 313
19.6 Calculations 2....................................................................................................................................... 315
19.7 Calculations 3....................................................................................................................................... 316
19.8 EGT Inputs............................................................................................................................................ 318
19.9 Generic Sensor Inputs..........................................................................................................................318
19.10 Outputs 1............................................................................................................................................ 318
19.11 Outputs 2............................................................................................................................................. 318
19.12 Outputs 3............................................................................................................................................ 319
19.13 Sensor inputs 1................................................................................................................................... 320
19.14 Sensor inputs 2................................................................................................................................... 321
19.15 Sensor Inputs 3................................................................................................................................... 322
19.16 Sensor Inputs 4................................................................................................................................... 322
19.17 VE Analyze Gauges............................................................................................................................ 323
19.18 X-Code dev......................................................................................................................................... 323
19.19 Additional menus................................................................................................................................. 325
19.20 Other Menu Items on the Gauge Pop-up Menu..................................................................................326

19.20.1 Reset Value................................................................................................................................. 326
19.20.2 Background................................................................................................................................. 326
19.20.3 Antialiasing Enabled....................................................................................................................326
19.20.4 Designer Mode............................................................................................................................ 326
19.20.5 Gauge Demo.............................................................................................................................. 326

20 Dashboard Indicators.................................................................................................................................... 327
20.1 Application Indicators............................................................................................................................ 327
20.2 Predefined Indicators............................................................................................................................ 327
20.3 Predefined Indicators with PORT_STATUS Deactivated (Default)........................................................327

20.3.1 Predefined Indicators....................................................................................................................327
20.3.2 Predefined Indicators 2.................................................................................................................328
20.3.3 Predefined Indicators 3.................................................................................................................329

(c) 2014-7 James Murray 2017-01-14 Page 9/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

20.3.4 Predefined Indicators 4.................................................................................................................330
20.4 Predefined Indicators with PORT_STATUS Activated...........................................................................330

20.4.1 Predefined Indicators....................................................................................................................330
20.4.2 Predefined Indicators 2.................................................................................................................330
20.4.3 Predefined Indicators 3.................................................................................................................331
20.4.4 Predefined Indicators 4.................................................................................................................332
20.4.5 Predefined Indicators 5.................................................................................................................333
20.4.6 Predefined Indicators 6.................................................................................................................333

20.5 Other Menu Items on the Indicator Pop-up Menu.................................................................................334
21 Diagnostics & High Speed Loggers..............................................................................................................334

21.1 Logger Type.......................................................................................................................................... 334
21.2 Using the Loggers................................................................................................................................. 337
21.3 Analyzing Data from the Loggers..........................................................................................................338
21.4 Additional loggers.................................................................................................................................. 338

22 Tune Analyze Live......................................................................................................................................... 339
23 Megasquirt Glossary of Terms...................................................................................................................... 340
24 Firmware changes since 1.3.x...................................................................................................................... 347

24.1 Old baro................................................................................................................................................ 347
24.2 Tacho output - variable..........................................................................................................................347
24.3 Injector deadtime wording.....................................................................................................................347
24.4 Flex fuel / dual fuel mode......................................................................................................................347
24.5 Ignition Settings.................................................................................................................................... 347
24.6 Knock Sensor Settings.......................................................................................................................... 347
24.7 A/C idle-up............................................................................................................................................ 347
24.8 Accel enrichment................................................................................................................................... 347
24.9 Boost Control Settings..........................................................................................................................347
24.10 VVT Settings....................................................................................................................................... 347
24.11 Dual Fuel / Table Switching................................................................................................................. 347
24.12 Blend Curve (8) Flex Blending............................................................................................................348
24.13 EGT.................................................................................................................................................... 348
24.14 Launch / 2-step / 3-step / T-brake.......................................................................................................348
24.15 Sequential Shift Cut............................................................................................................................ 348
24.16 Nitrous System.................................................................................................................................... 348
24.17 Pit Lane Limiter................................................................................................................................... 348
24.18 Programmable On/Off Outputs...........................................................................................................348
24.19 CAN Broadcasting.............................................................................................................................. 348
24.20 CAN Broadcast testing........................................................................................................................348
24.21 CAN Realtime Data Broadcasting.......................................................................................................348
24.22 CAN Receiving.................................................................................................................................... 348
24.23 CAN Dash Broadcasting..................................................................................................................... 348
24.24 CAN VSS and Gear............................................................................................................................ 348
24.25 CAN EGO / GPS................................................................................................................................. 349
24.26 IO-Box Settings................................................................................................................................... 349
24.27 Output Test Mode - I/O........................................................................................................................349
24.28 Output Test Mode - CANOUTs............................................................................................................349
24.29 Datalogged fields................................................................................................................................ 349

25 Firmware changes since 1.4.x...................................................................................................................... 350
25.1 Engine States........................................................................................................................................ 350
25.2 Boost Dome Control.............................................................................................................................. 350
25.3 Progressive Nitrous............................................................................................................................... 350
25.4 Custom sensor calibration....................................................................................................................350
25.5 CAN integration..................................................................................................................................... 350
25.6 Throttle control...................................................................................................................................... 350

26 Revision history............................................................................................................................................. 351

(c) 2014-7 James Murray 2017-01-14 Page 10/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

1 Introduction

1.1 Overview
This guide aims to document the features of TunerStudio MS Lite, the tuning software that ships with the 
Megasquirt range of aftermarket ECUs (Electronic Control Units). This version of the documentation applies to 
the Megasquirt-3 range of products. The products in this range include:

• Megasquirt-3, often simply referred to as MS3;

• MS3-Pro;

• MS3-Gold

• Products derived from the MS3-Pro Module, e.g., MSPNP-Pro

In this guide Megasquirt will be used to refer to any of the above products unless a setting varies according to a 
specific Megasquirt-3 product. In this event the products will be named explicitly.

Megasquirt ECUs are designed to give enhanced flexibility in terms of engine control. They are designed for 
track, educational, and other off-road use. Certain jurisdictions place environmental controls over the use 
of aftermarket ECUs. Please check your local legislative controls before using a Megasquirt with your 
engine.

1.2 Prerequisites
In order to successfully use your Megasquirt with the software you will need the following:

• A Megasquirt connected to your engine using a viable sensor configuration;

• Reasonable electrical and computer knowledge. If not, consider purchasing support.

• A tuning computer/laptop running Windows, Linux or Mac/OS X;

• The appropriate Java Runtime Environment for your computer which can be downloaded free of charge 
from www.java.com;

• The latest versions of TunerStudio MS and MegaLogViewer MS which can be downloaded from 
http://www.tunerstudio.com/index.php/downloads;

• The latest firmware loaded onto your Megasquirt which can be downloaded from 
http://www.msextra.com/downloads.html;

• A good understanding of how your engine works and can be configured with your Megasquirt. If you 
need help community support is available at http://www.msextra.com.

1.3 How to use the manuals
The documentation for the Megasquirt-3 product family is split across a number of manuals.

Megasquirt-3 Setting Up

MS3base/V3.0 Hardware MS3X/V3.0 Hardware MS3/V3.57 Hardware MS3X/V3.57 Hardware

Megasquirt-3 TunerStudio Reference
(includes MegaLogViewer field names)

• Setting Up - this covers initial software installation, tuning concepts and some feature guides. Applies to 
all Megasquirt-3 variants.
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• Hardware - wiring, inputs and outputs specific to your ECU model. Be sure to check that you are using 
the manual that applies to your product!

• TunerStudio Reference - a reference to all of the individual settings. Applies to all Megasquirt-3 variants.

The latest versions of the manuals can be downloaded from www.msextra.com

As an absolute minimum, ensure that you have followed all of the steps in the Quickstart Guide from the 
Setting Up manual.

Customers new to EFI or less experienced with Megasquirt are strongly advised to read the manuals in greater 
detail.

This guide includes a number of notes which are indicated as follows:

This symbol indicates an “Information” note.

This type of note is typically used to indicate how to enable an option within the software and 
other useful tips which are intended to make the software easier to use.

This symbol indicates a “Caution” note.

This type of note is typically used to indicate the order in which you should make changes in 
order to tune your Megasquirt most efficiently.

This symbol indicates a “Warning” note.

Configuring your Megasquirt incorrectly can potentially cause damage to your engine. In 
addition, working with some engine components such as ignition coils can be dangerous. 
Warning notes indicate specific areas where you need to exercise extreme caution.

Please do not rely on these warnings as your only criteria for taking care of yourself or your engine!!
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1.4 TunerStudio MS Lite Interface

1.4.1 Start Screen

When you start the software you will initially see a splash screen from the developer (EFI Analytics) whilst the 
software loads, followed by a start screen similar to that shown below:

Although there are a number of options available to you from this screen, creating or opening a project is usually
the next step. The top menu is discussed below in more detail, but it is worth noting that the number of options 
within this menu is reduced at this start screen.

The File Menu (1)

The File menu can be used to open or create a new project.

The File menu of this screen contains an Open Tune (.msq) option. This is only so that a tune can be 
viewed for analysis and diagnostics – you cannot connect to your Megasquirt or make changes to a tune 
that you open from this screen, you must create or open a project to do this.

Open Last Project (2)

The Open Last Project feature is a useful way to quickly access your most recent project. For more detailed 
information about opening or creating a project see Section 2.1 of this guide. 
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For all normal tuning you must Open a 'Project'.

1.4.2 Main Screen

Once you have opened or created a project you will see the main TunerStudio screen as shown below:

Title Bar (1)

The Title Bar shows the TunerStudio version, active Project name and Firmware version.

Top Menu (2)

The Top Menu is documented in Sections 2, 3, 4, 5, 6, 7 of this guide.

This menu is largely related to the software itself, specifically dealing with areas such as:

• How to create, open and backup projects and tune files;

• How to manage the behavior and appearance of the software;
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• How to capture datalogs from your Megasquirt for analysis;

• How to manage communications between your Megasquirt and TunerStudio;

• How to calibrate some of the main sensors that you will use with your Megasquirt;

• How to access TunerStudio's internal help file and obtain information about your version of TunerStudio.

Toolbar “Button” Menu (3)

The Toolbar Menu is documented in Sections 8 to 17 of this guide.

This menu contains the features through which almost all of the configuration and tuning of your Megasquirt is 
carried out.

Main Screen Tabs (4)

This area of the screen displays different sets of data according to the selected tab:

• The gauge cluster and associated indicator labels (most commonly used);

• Diagnostics and high speed loggers. See section 21.

• Optional additional tuning screens available in the Upgrade version.

Dashboard Gauge Cluster (5)

The Main Screen Tabs are documented in Sections 19, 21 of this guide.

When the Gauge Cluster tab is selected, this area of the screen displays gauges showing engine sensors inputs
and calculated outputs.

Dashboard Indicators (6)

The Dash Indicators are documented in Section 20 of this guide.

When the Gauge Cluster tab is selected, this area of the screen displays 'indicators' showing inputs, feature 
status and error lights.

Status Bar (4)

The Status Bar is not specifically documented in this guide, although it is referred to where appropriate.

The Status Bar is relatively simple and, from left to right, shows:

• The name of the current project;

• A progress bar which is used from time to time whilst the software carries out tasks;

• A link to the manufacturer's website;

• Optionally, the name of the current tune file (or CurrentTune.msq) – See Section 2.3. of this guide for 
more information about tune files;

• A communications indicator – the red and green boxes on the right hand side of the status bar indicate 
when information is being transferred between TunerStudio and your ECU.
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1.4.3 Lite and Upgrade Versions of TunerStudio

On the splash screen, the start screen, the status bar, and the last of the toolbar menu options you will see 
references to the Upgrade version of TunerStudio.

TunerStudio MS Lite is a fully functional tuning software product that comes inclusive with your Megasquirt 
purchase. TunerStudio MS Lite includes all of the features required to enable and configure all of the options 
and settings within your ECU.

The Upgrade version also supports additional features such as autotune, dyno views and more. 

1.5 Using the Software Interface

1.5.1 Data Input Screens

Many of the screens within the software are comprised of text boxes, drop-down boxes and buttons. The 
following image (taken as an example from the Cranking/Startup settings screen within the Startup/idle Toolbar 
Menu) demonstrates how these can be used:

  

Text box (1)

Text boxes are designed to accept numeric entries, and so will only accept numbers and decimal points. Almost 
all of the text boxes include up and down buttons which allow you to make incremental values although it is 
often much quicker to simply type your chosen value into the box. When you have selected a text box you can 
also increase or decrease its value with the up and down buttons on your keyboard.

Drop-down box (2)

Drop-down boxes allow you to select one of many options. It is worth noting that when the value of a drop-down 
box is changed it can radically change the other options available in the software. Enabling or disabling a 
feature will often not only enable or disable other text and drop-down boxes on the screen that you are using, 
but may also enable or disable options in other areas of the software. Wherever possible, this guide aims to 
outline what changes you need to make in order to enable specific options and menu items.

Undo and Redo Buttons (3 and 4)

This concept will be familiar for many computer users. When enabled these buttons turn blue and allow you to 
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repeatedly reverse or re-implement recent changes.

One quirk of the software is that the “undo” button will allow you to undo changes you have made on 
previous screens, not just the one that you are working with. For this reason be careful how you use this 
feature.

Burn Button (5)

When you make changes in TunerStudio they usually need to be written (or “burned”) to the flash memory within
your Megasquirt before they take effect. The only exception to this is when you make changes to Fuel Tables, 
Ignition Tables (and their corresponding 3D Maps) where you can “live tune”. Even in this case the changes you 
make need to be burned to the Megasquirt's flash memory when you have finished live tuning before they 
become permanent.

Clicking “Burn” on any screen at any time will cause any changes you have made to be written to the flash 
memory in your Megasquirt.

You can burn changes as often as you like, although it is worth noting that the flash memory in your 
Megasquirt is only designed to withstand approximately 100,000 burn operations during its lifetime. 
Whilst you are extremely unlikely to exceed this number, it is always good practice to plan your changes 
carefully to enhance the life of your Megasquirt as well as to protect your engine.

 

The burn process takes approximately 0.02 seconds. In Megasquirt-3 this takes place in parallel with 
normal operation and there is no interruption or "burn-stumble" as occurred with Megasquirt-2.

Close Button (6)

This button behaves like the close button in your operating system (the red cross in the above image which is 
taken from a Microsoft® Windows 8® screen capture). If you have not already clicked “burn” any changes that 
you have made will be burned automatically whenever a screen (or TunerStudio) is closed.

Tool-tips (7)

The blue question mark icons that appear throughout the toolbar menu screens provide pop-up information 
when clicked. Much of the content provided by these tool-tips is also included and expanded upon within this 
guide, although the tool-tips can be extremely helpful if you do not have this guide available. For example, 
clicking the blue tool-tip button for Cranking RPM will display the following:

 

Help (8) 

On most settings screens, you will also find a Help menu, clicking on this will open up this document at the 
appropriate page so you can read about all of the settings for that particular screen.
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(You may need to be connected to the internet the first time you use this feature, so the PDF can be 
downloaded.)

    

1.5.2 Curves

Curves are a useful feature of TunerStudio as they allow you to make various adjustments depending on one or 
more states of your engine. The following image (taken as an example from the Barometric Correction screen 
within the Basic/Load Settings toolbar menu) demonstrates how these can be used: 
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X-Axis (1)

The X-Axis displays the main variable that is being used for manipulation (in this example barometric pressure) 
and units used (in this example kPa). It also displays a numerical range which increases from right to left (in this
example 60.0 to 110.0.)

Y-Axis (2)

The Y-Axis is usually used to show percentage correction (as in this example) although it can also be used for a 
second variable in some curves.

Options Menu Button (3)

The small button labeled “...” on the top left of the curve allows you to customize the ranges of the X and Y 
Axes. Clicking this button will display a pop-up menu from which you can set minimum and maximum settings 
for each axis. Optionally you can also ask TunerStudio to “Auto Scale” the maximum value for each axis by 
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enabling the appropriate option from the pop-up menu.

Variable Points (4)

Each curve has a fixed number of points (in this example there are eight) which you can use to set a correction 
to the curve. Clicking and dragging any of these points up or down, or left to right, sets the adjustment that you 
want to make.

Selected Point Information Box (5)

When any point is selected (in this example the furthest from the left) it changes color and a box of the same 
color appears giving its precise location relative to the axes (in this example it shows Barometer (kPa): 107.3, 
and Correction %: 104.4.

Data Tables (6)

Rather than clicking and dragging the points on the curve you can enter your settings into the associated data 
table. When you have done this the appropriate point on the curve will move. If you click and drag a point on the
curve its entry in the table is highlighted in red (in this example the eighth box down is highlighted and contains 
the same figures shown in the Selected Point Information Box.) TunerStudio refers to these as "text based 
arrays."

Often the data table for a curve is not visible by default although all curves do include a data table. The 
button labeled “8” (described below) can be used to display hidden data tables.

 

When you type an entry into a data table you will need to either use the “Enter” or “Tab” key on your 
keyboard to move out of that cell or click in another cell before the change will take effect. Unless you do 
this the point on the curve will not move and the change will not be saved or sent to your ECU when you 
burn or close the screen.

Show or Hide Data Tables (7)

This button can be used to either hide or display a data table. Some curves are quite small and have their data 
tables hidden by default. This button is especially useful when using these smaller curves as the table often 
obscures the curve, and so it can be useful to toggle between the curve the table.

Gauge (8)

The appropriate gauge for the value that you are setting may appear next to some curves.

Not all curves in TunerStudio include a gauge. See Sections 2.6. and 17. for more information about 
gauges.

Tooltip (9)

Clicking on the [?] will popup a window with brief information about the setting, curve or table.

1.5.3 3D Tables

3D Tables are used for a range of tuning roles, although Fuel VE Tables and Ignition Tables are the most 
commonly used. The following image (taken as an example from the Fuel VE Table 1 screen within the Fuel 
Settings Toolbar Menu) demonstrates how these can be used:
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X-Axis and Y-Axis Bin Values (1 and 2)

These values represent the thresholds for which values can be set within the table. In this example there are 16 
bin values that can be set for rpm and for fuel load (kPa). These thresholds can be changed by clicking any of 
the gray buttons on either axis. When this is done you will see a box pop-up asking you to enter a new value for 
that bin. 

It makes sense to make sure that you are happy with the bin values for each table before you begin to 
set any of its values.

Individual Cell Value (3)

In a 16 x 16 table there are a total of 256 different values that can be set (in this example the value that is set 
responds to volumetric efficiency.) These numbers can be entered individually, but there are also a number of 
ways to simplify this process using the Hot Keys and Buttons described below.

Hot Keys

Clicking on a single cell (or dragging to select a range of cells) and right clicking will display a useful pop-up 
menu. Most of the features of this menu can also be carried out using the buttons (5) and are described later in 
this section. This menu also lists the keyboard Hot Keys that can be used to manipulate the values in the table.

Current Running Point and History Trail (4)

If you are using your Megasquirt with your engine running, this screen will display a colored point to 
demonstrate its current position in the table. It will also display a history trail in the form of a trace line based on 
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recent data from the engine's sensors to illustrate the changes in table position as your engine changes (for 
example, when RPM increases.)

You can change the number of “reads back” that are used to build the history trail. To do this, right click on your 
table and click on "History Trail Length" at the bottom of the pop-up menu. This will open a pop-up text box 
where you can enter the number of reads you want to see displayed.

Buttons (5)

These buttons allow you to carry out a range of tasks to manipulate the values in the table. Most can be used 
either for a single cell, or for a range of cells that you can select by clicking and dragging with your mouse.

Allows you to export the table to a file.

Allows you to import a table from a file.

 Equals

Opens a pop-up text box and sets the value of the selected cells to the value that you enter.

 Increase

Increases the values of the selected cells by one unit each time the button is clicked.

 Decrease

Decreases the values of the selected cells by one each time the button is clicked.

 Subtract

Opens a pop-up text box and reduces the value of the selected cells by the value that you enter.

 Add

Opens a pop-up text box and increases the value of the selected cells by the value that you enter.

 Multiply

Opens a pop-up text box and increases the value of the selected cells by multiplying the original values by the 
value that you enter (for example, entering 1.25 will increase the values of the selected cells by 25%). This can 
also be used for reducing values (for example, entering 0.8 will reduce the values of the selected cells by 20%)

 Blend

Adjusts all of the selected cells to values interpolated by the cells in the four corners of the selection. (Note that 
this button is not divide.)

The standard Copy (Ctrl + C) and Paste (Ctrl + V) features are supported and will allow a selection of values to 
be copied into a second table or into a spreadsheet program.
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Menus (7)

View - has no effect on 3D tables.

Tools - Upgrade version only - the Table Generator option is available on some 3D Table screens. The table 
generator can be used as a starting point for tuning, it is never a substitute for tuning.

Help - opens this manual at the relevant section

1.5.4 3D Tuning Maps

3D Tuning Maps allow a flexible visual rendering of the data held in a 3D Table. Whist numbers alone can be 
useful, it is sometimes extremely helpful to see a visual interpretation of these numbers to get a better feel for 
the tune that you are putting together.

Generally, whenever a 3D Table appears in TunerStudio there is a corresponding 3D Map available. The 
following screen depicts the corresponding 3D Map for the Fuel VE Table 1 used in the previous example:

  

Whilst 3D Maps can appear quite complex at first glance they are actually relatively simple. For each of the 256 
points in the 3D table, a 3D map is created using the X and Y axis, with the height at each point reflecting the 
numerical value (often referred to as the Z axis). This allows you to get a feel for the gradients within your tune. 
Like 3D tables, lower numbers are shown in blue and higher numbers are shown in red with green representing 
mid-range values.

One of the major advantages of a 3D map over a table is that it can be rotated to allow views from different 
angles to give you a clear idea of the “shape” of your tune. Each map can be manipulated either by clicking and 
dragging it around, or by using the Yaw and Roll sliders.

Yaw Slider (1)

The Yaw Slider allows you to rotate the map along the horizontal plane – allowing it to be viewed from the front, 
back and sides.
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Roll Slider (2)

The Roll Slider allows you to rotate the map through the vertical plane – allowing it to be viewed from above or 
below.

Using a combination of Yaw and Roll it is possible to view a map from all possible angles.

Selected Point (3)

All of the intersections between the lines represent a value of a cell in the corresponding 3D table. You can 
select any of these points by clicking on them. When you do this the selected point in the table will be 
highlighted by a colored marker. You can change the value for the selected point by dragging it up or down. 
Rotating the map by clicking and dragging or by using the Yaw and Roll sliders will give you a good feel for how 
your changes fit in with the other points in the map.

Tuning is a matter of personal preference (and there are many possible approaches) but when changing 
any value it is generally a good idea to maintain some smoothness throughout the map. Sharp upwards 
or downwards points will usually result in a poor running of the engine.

Active Engine Point (4)

If your ECU is connected and your engine running, the active position at which the engine is operating is 
reflected by a second colored marker. For most (but not all) of the maps RPM is used as the X-Axis and so you 
will be able to see this marker moving when you open and close the throttle. Making changes to the points in a 
map whilst varying RPM can be a useful way to live tune.

Current and Selected Point Information Boxes (5)

When a current point is displayed you will see a text area at the top right of the map giving detailed information 
about what is happening at that point (in this example it shows rpm: 4501; fuelload: 99.4; %:92.)

If you are working offline or your engine is not running no Current Point will be highlighted on the map 
and this text area will not be displayed.

When a point on the map is selected, you will see a text area on the top left of the map giving detailed 
information about what would happen at that selected point (in this example it shows rpm: 801; fuelload: 35.0; 
Selected %: 31.) A point on the map can be selected and the  text area will be displayed even without your ECU 
connected.

Color Shade (6)

Clicking in the box next to Color Shade will toggle shading of the map on and off (it is “on” if there is a tick in the 
box). The choice of whether to use shading is a personal one, but most users find it easier to get a feel for the 
shape of the map with Color Shade on.

Color Theme (7)

This sets the background color for the map. Again it is a personal choice, but most users seem to prefer using a 
black background as it makes the shape of the shaded map appear very clearly.

Even Spacing (8)

Clicking in the box next to Even Spacing will toggle the spacing settings for the map. If Even Spacing is set as 
“on” the distance between lines on both axis is set to a fixed value regardless of the values associated with each
axis. This makes it easier to select a point as they are never very close together.

If this option is set as “off” (no tick in the box) the spacing of the  lines will reflect the values that you have set up
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for each axis.

Follow Mode (9)

If Follow Mode is set to off you can manually select and alter any point on the map. If it is switched on (and your 
ECU is connected and your engine running) the selected point will always reflect your engine position. For live 
tuning it is usually useful to have this setting set to on.

Map Gauge Cluster (10)

The Map Gauge Cluster will display an appropriate array of gauges to display your engine's behavior which may
be useful during live tuning. Right-clicking on this gauge cluster will display a pop-up menu from which you can 
customize the cluster. This menu is very similar to the menu for TunerStudio's main gauge cluster which is 
documented in section 2.6.

Help (11)

Clicking this menu item will allow you to select the embedded “3D Table Usage” help file within TunerStudio. 
This provides further support for how to use these screens which can be used alongside this guide.

3D Map Hot Keys

There are a number of keyboard shortcuts that can be used to make changes to a 3D Map. These are briefly 
described as follows:

Up, Down, Left and Right Arrows – Allow you to move the selected point.
Increase & Decrease Z values:

• Shift + (Up or Right) keys – Increment selected point by 1;
• Shift + (Down or Left) keys – Decrement selected point by 1;
• (> or . or q or + or =) keys – Any of these will increment the selected point by 1;
• (< or , or w or - ) keys – Any of these will decrement the selected point by 1;
• CTRL + (Up or Right or > or . or q or + or =) keys – Increment the selected point by a user 

defined value (the default increment is five);
• CTRL + (Down or Left or < or , or w or -) keys – Decrement the selected point by a user 

defined value (the default decrement is five).
G – Moves the selected point to the current active position.
F – Toggles Follow Mode on and off. 
M – Increases the Yaw Angle of the table by 10 degrees.
K – Decreases the Yaw Angle of the table by 10 degrees.
N – Increases the Roll Angle of the table by 10 degrees.
J – Decreases the Roll Angle of the table by 10 degrees.
Z – Shows a top down view of table.

3D Map Menu Options

Right-clicking on the map itself will display a pop-up menu which allows you to further customize the 
appearance and behavior of the map. These are covered briefly below.

Smart Select Movement – When on (the default setting), the arrow keys will alter the selection 
direction so that the right key will always move to the next point on the right, left to the next point on the 
left, and so on relative to the position of the map as it is displayed. If this is set to off, the up and down 
keys will always along the Y axis, and the left and right keys will always move along the X axis 
regardless of the maps visual position.

Show Active Table Values – When on (the default setting) the values for the Z-axis (height) for both 
the selected and active points will be displayed on the grid.

Show Selected X & Y Values – This is off by default, but if set to on the selected X & Y values will be 
displayed along the appropriate axis.
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Increment All Active Cells – This is off by default, but if set to on this only effects adjustments made 
using Follow Mode with your ECU connected and your engine running. In this scenario increments of Z 
values (height) will be applied to all table values that are currently active with a weight above the set 
value. This allows adjusting up to four map values (3D cells) at once if they are close enough to the 
active point. When set to off only the selected point will be adjusted.

Active Weight Threshold – This is only enabled if Increment All Active Cells is set to on. It allows for 
changing the weight used to determine what table values (3D cells) are adjusted. Valid values are 0% to
100% where 0% will allow up to four points to change, whilst 100% will only allow one point to move 
(assuming that value was matched perfectly by the engine outputs.)

Select Active Color – Allows you to change the color of the Active Point and Active text. By default the 
Active Point and text will be blue as described above.

Select Selected Color – Allows you to change the color of the Selected Point and Selected text. By 
default the Selected Point and text will be red as shown in the above example screen.

CTRL Increment By – As discussed in the Hot Keys section, when holding down the CTRL key whilst 
adjusting table values, you can increment or decrement values in steps greater than one (the default is 
five). This option allows you to change this multiple to a value other than five.
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2 File Menu
The File Menu, the first item in the top menu, allows you to:

• Create, open and close Projects;

• Open, close and manage tune (.msq) files;

• Make changes to the gauge cluster;

• Choose whether to work online or offline;

• Exit TunerStudio.

2.1 Vehicle Projects
In order to tune your ECU, you must first create a 'project'.

TunerStudio does have the ability to open an .msq file without opening a project (allowing you to review 
settings from that tune). To do this, TunerStudio uses a temporary project which will not enable 
communications. This means that you should always create or open a project if you intend to connect to 
and configure or tune your Megasquirt.

2.1.1  New Project

You can create a new project either from the start screen or from the main screen. The only difference is that 
from the start screen you need to select File > New Project, whilst from the main screen you need to select File 
> Vehicle Project > New Project. Either will display the first “Create New Project” screen as shown below:

 

Project Name

In the Project Name box you can give the project any reasonable name. (Using characters allowed by your 
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operating system.)

Project Directory

Generally, leave the “Project Directory” alone, there is no need to change it.

Depending on your operating system your project will be created in: 

1. Using Windows: Documents\TunerStudioProjects\ or My Documents\TunerStudioProjects\

2. Using Linux or OS X: [your home directory path]/TunerStudioProjects/ 

Firmware

You need to ensure that you have the correct firmware for your Megasquirt associated with your project. Unless 
you want to test a development (beta) version it is recommended that you use the latest stable version of the 
firmware, which can be downloaded from  http://www.msextra.com/downloads.html. This manual corresponds to
the stable version of the firmware shown on the front page.

To use the latest version you may need to update your Megasquirt. Information about how to do this is available 
in the Setting Up manual.

If you do need to update your firmware make sure that during the update you select the appropriate 
version according to your Megasquirt. Different versions exist for MS3 (the standard Megasquirt-3) and 
MS3-Pro. Always File -> Save Tune As before upgrading.

The firmware version can be changed after your project has been created (see Section 2.1.6.)

Firmware selection can be accomplished in three ways. The recommended approach is to use the “Detect” 
process which will automatically retrieve the firmware version from your ECU. This isn't always possible for 
various reasons – e.g., you may be having problems with your ECU connection or be using a beta version of the
firmware. In these cases you can use one of the alternative methods to selecting your firmware. The various 
methods can be carried out as follows:

Detect

To use this option you must have your Megasquirt powered up and connected to your computer. If your 
Megasquirt is connected to your engine it is recommended that you use Key On Engine Off (KOEO), i.e., with 
power to the ECU but without the engine running. You can alternately power up your Megasquirt by any other 
appropriate fused power source. Once this is done click the "Detect" button. TunerStudio will attempt to identify 
the firmware on your controller and select the appropriate firmware file for your Controller.

When you click the Detect button a “Detect Device” screen will appear whilst TunerStudio will attempt to find 
your Megasquirt and its firmware version. If successful it will list your product, firmware version and Baud rate. 
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Check that these are correct and then click “Accept” to continue. If the “Detect Device” screen reports “No 
controller found” check the power and computer connections and try again. If this still does not resolve the 
problem move on to the “Other / Browse” method described below to set the firmware up manually.

If your ECU is identified correctly, clicking “Accept” will load the necessary configuration file to match your 
firmware version and you can now move on to the Project Description described later in this section.

If your ECU is identified correctly but clicking “Accept” displays a message that reports “TunerStudio does not 
have a configuration to support the found hardware” then it is likely either that you are running an older version 
of TunerStudio, or you are running a beta version of the firmware. If you are running an older version of 
TunerStudio you should upgrade to the latest version. If you are using a beta version of the firmware you will 
need to use the “Other / Browse” method described below to set up your firmware configuration manually. 

Other / Browse

This method is recommended only if you are not able to connect to your Megasquirt, or if you are using a
beta version of the firmware.

The firmware on your Megasquirt may have been provided on a disk or downloaded as a .zip file from the 
msextra.com Internet site. If you have downloaded your firmware and haven't done so already extract the 
contents of the zip file to a directory of your choice. The configuration settings for TunerStudio are the ".ini" file 
within the firmware folder. Note that you need to have the Windows Folder Options setting "Hide known 
extension types" disabled to correctly see this file.

Clicking in the box next to “Other / Browse” opens a screen which lets you browse to your firmware folder. From 
here you should be able to select the .ini file that you want to use. It is essential that you use the .ini file that is 
appropriate for your Megasquirt. There are four .ini files to choose from within each version of the firmware:

• ms3.ini – used for the MS3 and MS3-Gold.

• ms3pro.ini – used for the MS3-Pro ECU and ECUs based on the MS3-Pro module.

• ms3pro-ult - used for the MS3-Pro Ultimate ECU.

Select the file that is appropriate to your product. Now move on to the Project Description described later in this 
section.

Show Advanced / Offline Setup 

This is the most complex and least desirable method of selecting your firmware, and generally should 
never be used.

To use this option you must know the firmware serial signature which is rarely the same as the 
firmware version!

Check the “Show Advanced / Offline Setup box to display the “ECU Definition” drop down box in place of the 
firmware label box. If you know the signature select it from this list. If you do not see the signature for your 
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firmware (or have any doubts about which ECU definition you should use) you are strongly advised to 
establish a connection to your Megasquirt and use “Detect”, or to download an appropriate firmware version and
use the “Other / Browse” method described above.

Project Description

This is not a required option, but it can be useful if you use a large number of projects and are creating a project
for a specific purpose. Enter any information that will help you to identify the project for your own use. This entry 
can be changed after you have created your project.

Once these settings are complete, clicking “Next” will take you to the second “Create New Project” screen as 
shown below:

 

Verify that what they are configured to match your set up. If you are unsure the default values are likely to work 
well. These settings can be changed after your project has been created.

The most likely options to change are the Oxygen Sensor and Temperature Display units.

Clicking “Next” will take you to the third “Create New Project” screen as shown below:
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This screen allows you to select the driver type and connection settings to connect your Megasquirt to your 
computer.

Driver

From the “Driver” drop down box, select the appropriate driver type that you use to connect to your Megasquirt. 
This setting is usually “RS232 Serial Interface”.

Port

From the “Port”  drop down box, select the COM port that your your computer is using to connect to your ECU. 
This is usually COM1, but if your computer has multiple connections to other serial devices it could be COM2, 
COM3, etc.

You can change the COM port that you use to connect to your ECU through Device Manager in Windows. 
Depending on the version of Windows that you are using, Device Manager can usually be accessed via the 
System settings in Control Panel. Alternately, typing “devmgmt.msc” in the Run option of the Start Menu or from 
a command prompt will open Device Manager in most versions of Windows.

Expanding the Ports (COM and LPT) entry in Device Manager should display a screen similar to that shown 
below:
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This image is taken from Windows 8.1. In other versions of Windows the screen may look slightly 
different.

Right clicking on the port to which your Megasquirt is connected, and clicking “Properties” will display the 
Properties screen for that port.

Clicking on the second tab (Port Settings) should display a screen similar to that shown below:
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Clicking the “Advanced” button should show a screen similar to that shown below:

  

Using this screen you can change the COM Port Number for the port connected to your Megasquirt. If you want 
to use COM1 and another device is already using COM1, you will need to change the settings for that other 
device before setting up the port for your Megasquirt.

For the MS3 internal USB connection or other FTDI based USB-serial adapters, the Latency Timer 
should be set to the minimum value (1).

To avoid conflicts, make sure that there is no other device using COM1 before you select this setting!

Baud Rate

All Megasquirt-3 products use a baud rate of 115200. If you do not set the baud rate to 115200 you will not get a
successful response when attempting to connect to your product.

Although it is extremely unlikely that you would need to do it, it is theoretically possible to set your 
Megasquirt to connect at a lower baud rate (see Section 5.1.) although it is not generally recommennded.

Test Port

Once you have entered the above settings, make sure that your Megasquirt is connected to your computer and 
powered up and click “Test Port”. If the settings are correct you should be able to establish a connection. If not 
confirm that the product is powered up and connected, and recheck your settings.

It is strongly recommended that you create your project with your Megasquirt connected and powered up 
and using Detect and Test to be certain that your project is correctly configured. It is not, however, 
essential to complete this test in order to create a project. If you create a project without your Megasquirt 
connected you can run both Detect and Test later from the Communications Menu (see Section 5.1.)

 
Clicking “Next” will take you to the final “Create New Project” screen shown below:
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TunerStudio MS Lite will always load the Default dashboard whenever a project is opened.

For the above reason, this screen is only really useful if you are running the Upgrade version of TunerStudio 
and so it is recommended that you leave the dashboard set to “Default”.

Clicking “Finish” will complete the creation of your new project. Any current project will be closed and the new 
project will be opened and ready to use.

2.1.2 Open Project

You can open a project either from the start screen or from the main screen. The only difference is that from the 
start screen you need to select File > Open Project, whilst from the main screen you need to select File > 
Vehicle Project > Open Project. Either will display the Open Project screen as shown below:
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By default the “TunerStudioProjects” directory will be selected, although you can browse to another location if 
you have saved a project elsewhere. To open a project simply select it from the list and click “Select”. If you 
already have a project open and your tune is unsaved you will be prompted to save it before that project is 
closed. The project that you have selected will then be opened.

2.1.3 Close Project

As you might expect, clicking File > Vehicle Project > Close Project will close the existing project. You will be 
prompted to save any changes to your tune file if any changes have been made. You will then be returned to the
TunerStudio Start Screen.

2.1.4 Create Project Backup

The Open Project screen lists projects rather than project files. In reality, each project is made up of a group of 
directories each containing a number of files required for the project.

In order to backup a project, or move it from one computer to another, the recommended method is to use the 
Export Project Archive feature.

From the top menu, clicking File > Vehicle Project > Create Project Backup will display a dialog which will allow 
you to save all of the attributes and settings associated with the project into a single TunerStudio file with the 
.tsproj file extension. 

2.1.5 Import Project Archive

This option is not available in the Lite version of TunerStudio.

2.1.6 Project Properties

As discussed in Section 2.1.1 (New Project) it is possible to change a number of the settings for each project 
after it has been created. 

From the top menu, clicking File > Vehicle Project > Project Properties will display the Project Properties screen.
This has three tabs. The first tab (configuration) is shown below:
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From this screen both the firmware version and the Project Description can be changed. If you were unable to 
use “Detect” to determine your firmware version from your ECU when you created your project you can do so 
now if you have your product connected and any connection issues resolved.

The second tab (Settings) is shown below. 
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As discussed in Section 2.1.1 the default settings should be expected to work with your Megasquirt, but they 
can be changed at any time as required.

The Third Tab (CAN Devices) is shown below:

  

CAN Devices are technical. You can skip the remainder of this section if you are not using an expansion 
board.

The CAN Devices tab has two main functions: Managing the “Project Main Controller” for the project; and
managing “CAN Devices” (which are expansion boards.) The Main Controller will be (under almost all 
circumstances) your Megasquirt.

Main Controller CAN ID

Main Controller CAN ID is a setting that is almost always set to 0. This setting must match the corresponding 
setting within the CAN Parameters screen (see Section 15.1.)

Do not change this setting unless specifically directed to by your vendor.

Serial Protocol

The Serial Protocol setting is almost always set to “Firmware Default” and should only be changed by very 
experienced Megasquirt and TunerStudio users. For reference, the options for this setting are:

• Firmware Default – use the serial protocol that is specified in the firmware supplied 'ini' file.

• Force – MS3 1.1+ - overrides the .ini (firmware) file and forces the CRC checked protocol. This protocol 
is used on MS2/Extra 3.3.x and MS3 1.2.x upwards.

•  without causing errorsForce – Standard MS2 and MS3 1.0 -  overrides the .ini (firmware) file and forces
the older non error-checked protocol. This protocol is used by older MS2 firmwares and some add-on 
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devices.

CAN Devices

The CAN Devices section of this tab allows you to join expansion boards into your project. For example, if you 
have a JBperf IO-extender board connected to your Megasquirt, then you could use TunerStudio to collect 
additional sensor data from the IO-extender at the same time as collecting engine data from your Megasquirt. 
This is called “CAN pass-through” - TunerStudio is communicating with the expansion board with the data 
passing through the Megasquirt.

Note that the Megasquirt will not see this remote data itself – it is simply being sent through to 
TunerStudio. To configure your Megasquirt to use the data from an additional board  use the CAN 
Parameters screen (again, see Section 15.1.)

An example of a CAN Device configuration is shown below:

  

Many of the settings in the CAN Devices section should be provided by the vendor of your expansion board. 
The general settings for the options for this sections are as follows:

+ – adds an additional CAN device (expansion board) to your project.

x – removes a CAN device from your project.

Up and Down Arrows – will move the selected CAN Device up and down the list.

Device Identifier (short)

This is an abbreviated name for the selected CAN device.
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Device description

This is a longer name that you choose for the selected CAN device.

Disable Runtime data

This option determines whether TunerStudio collects live runtime data (sensor data) from the CAN device. This 
will almost always need to be enabled. Leaving the box blank will allow you to configure the remote device 
through the settings menus, but will not fetch live data.

Device CAN ID

This must be set to match the CAN ID set on the CAN device. Each device on the CAN network must use a 
different CAN ID.

Device configuration file

Use the button containing three dots [...] to Browse for the .ini file supplied by the CAN device vendor.

Configuration settings

Any settings specific to this CAN device can be configured here as required. These work in the same way as the
Project Properties -> Settings for your Megasquirt.

2.2 Tune Restore Point Dialog

This is an optional feature of the Upgrade version of TunerStudio which allows a range of restore points 
to be established and quickly restored. With TunerStudio MS Lite, using Save Tune As (see Section 2.5.) 
is the recommended method of backing up your tune files. Open Tune (see Section 2.3.) is the 
recommended method of restoring a tune file with this version of the software.

2.3 Open Tune
A tune file (using the file extension .msq) contains all of the settings for a specific configuration for your 
Megasquirt. Depending on the various performance profiles you may require at different times you can save 
multiple tune files for each project.

When TunerStudio connects to your Megasquirt it automatically fetches the current tuning settings and allows 
you to live tune online. You do not need to use Open Tune to do this.

Open Tune is used to open and view an existing saved tune. Optionally you can write this tuning data onto your 
Megasquirt.

Default tune files are included in the tune_files directory of the zip file for each firmware version. These can be 
used to start a tune offline.

TunerStudio will prompt you if you load a tune file which is incompatible with the firmware version that you are 
using, but in most cases you will be able to load in old settings. TunerStudio will report any problems it finds as 
warnings or errors. Each of these should be reviewed.

You can open a tune file by clicking File > Open Tune (msq). This will display the Open Tune screen as shown 
below:
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Usually Tune files are saved and opened from the project directory, and so by default the directory for the 
current project is shown. Usually you will open Tune files from this directory to work with your current project. 
There are three possible exceptions to this:

• If you have downloaded and extracted a new version of the firmware you can browse to the tune_files 
directory within the firmware folder structure and open the default tune for your Megasquirt.

• From time to time you may have multiple projects using the same firmware and Megasquirt and it is 
perfectly acceptable to store and open tune files from a separate directory.

• As can be seen in Section 3.6. of this guide (Preferences) it is possible to choose from the Options 
Menu to automatically load and save the current tune. The advantages and disadvantages of this option
are discussed in more detail in section 3.6, but if this option is selected there is usually only a need to 
use Open Tune in order to restore a backup of a tune file.

2.4 Save Tune
As discussed in the previous section, TunerStudio includes an option to automatically load and save the current 
tune. If you are using this option tunes will be saved automatically and you will not need to use Save Tune.

If you are not using this option, you will need to save your tune file manually. Clicking Menu > Save Tune will 
ensure that any changes you have made to your configuration are saved. When you close a project or exit 
TunerStudio you will be prompted to save any changes if you have not already done so.

2.5 Save Tune As
Save Tune As allows you to save your tune to an external file. This is a useful feature as means that you can 
backup a range of different tunes as you experiment with the configuration options.

Clicking Menu > Save Tune As will display the Save Tune As screen. From here you can choose a name and 
location for your tune file. For convenience it is usually recommended that you save each tune file in the 
directory of the project that you are using, although there is no reason that tune files cannot be stored in any 
folder or external disk.

 without causing errorsIt is STRONGLY recommended to use Save Tune As each time before you make 
configuration changes so you have a set of known working tunes. You should also use this to create a unique 
tune file (MSQ) before uploading to the support forum.

2.6 Work Offline
This is an on/off option that allows you to make changes to your configuration without burning changes to your 
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Megasquirt. This can be also be a useful feature if your Megasquirt experiences connection problem and goes 
offline, or is not available. Once you have finished working offline it is essential that you disable this option 
so that TunerStudio can again communicate with your Megasquirt.

When hibernating a laptop with TunerStudio still running, such as at the race track, it may be useful to select 
"Work Offline" before hibernating for a smoother experience after hibernation. Otherwise, some computers may 
not correctly find the serial device again on wake-up.

If you are working offline the dashboard will display an “Off Line” message across the screen. If you see 
this and your Megasquirt should be connected make sure that the Work Offline option is not enabled.

2.7 Exit
Selecting File > Exit completely closes TunerStudio. In the event that your tune requires saving you will be 
prompted to do so before the software exits. Closing TunerStudio using your operating system's toolbar (e.g., 
the red close button on the top right of Microsoft® Windows®) will have exactly the same effect as File > Exit.

If you are updating your Megasquirt's firmware using the ms3loader_win32 application you must exit 
TunerStudio before you begin the firmware update. It is not possible for a Megasquirt to communicate 
with the firmware loader and TunerStudio at the same time without causing errors.
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3 Options Menu
The Options Menu, the second item on the top menu, allows you to:

• Customize the language used by, and the appearance of, TunerStudio;

• Customize how TunerStudio works.

3.1 Language
Clicking Options > Language gives you a list of the languages that TunerStudio supports. 

This guide, and most other Megasquirt guides, are only available in English at this time.

3.2 Look and Feel
Clicking Options > Look and Feel allows you to select from four options:

• Metal (Default)

• Nimbus

• CDE/Motif

• Windows

The choice of “Look and Feel” is entirely personal, and does not alter the layout or features of TunerStudio in 
any way.

The images in this guide are all taken using the “Metal” look and feel. Although the content will not be 
different, the screens in the software will appear differently to the images in this guide if any of the other 
“Look and Feel” options are used.

3.3 Navigation
The “Navigation” options allow you to make other changes to appearance and behavior of TunerStudio.

3.3.1 Main Menu Style

Options > Navigation > Main Menu Style is a selectable option that means that both the top menu items and the 
toolbar button menus are combined and displayed as a single main top menu.

This has an advantage in that more of the screen is available for the visual instrumentation – i.e.,  the gauge 
cluster and diagnostics and high speed loggers (see Section 21) This option also makes it easier to use 
TunerStudio solely using a keyboard. The disadvantage is that the top menu becomes crowded using anything 
other than a very high resolution monitor.

3.3.2 Wrapping Main Menu

Options > Navigation > Wrapping Main Menu is a selectable option that means that both the top menu items 
and the toolbar button menus are combined and displayed as a single main top menu, but the contents of that 
menu are able to take up multiple lines.

Again this has advantages in that more of the screen is available for the visual instrumentation and TunerStudio 
can be easily used without a mouse. The disadvantage that the top menu becomes crowded is reduced using 
this option.
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3.3.3 Toolbar Style

Options > Navigation > Toolbar Style is a selectable option that allows both the top menu items and the toolbar 
button menus are displayed separately. Whilst the room for the visual instrumentation is slightly reduced this is 
generally considered to be the easiest combination to use and this is the default layout.

The images in this documentation are all taken with the Toolbar Style selected. Some of the content of 
the screens in the software will appear different to the images in this guide if a different layout is used.

3.3.4 Navigation Options

Options > Navigation Options > Show Disabled Menu is an on/off selection that determines if disabled menu 
items are displayed.

The images in this document are taken with Show Disabled Menu switched on.

3.4 View
The “View” options allow you to show and hide some components of TunerStudio.

3.4.1 Show Gauges on VE Analyze

VE Analyze (VEAL) is an auto-tune feature of the Upgrade version of TunerStudio. Changing this option 
within TunerStudio MS Lite has no effect. The VEAL feature, whilst useful, is not a required feature in 
order to successfully configure your ECU.

3.4.2 Show Live Graphs on VE Analyze

VE Analyze (VEAL) is an auto-tune feature of the Upgrade version of TunerStudio. Changing this option 
within TunerStudio MS Lite has no effect. 

3.4.3 Show Enable Condition in Menu Tooltips

This option enables “tooltips” to be displayed when you hover the mouse over a disabled (grayed out) menu 
option. These tooltips can be helpful as they indicate the changes you need to make in order to enable an 
option.

3.5 Advanced
The “Advanced” options provide two specific choices that you can make in terms of how you use the software.

3.5.1 Report INI Warnings

Options > Advanced > Report INI Warnings is an on/off option that determines whether the software prompts 
you if there are any errors within the firmware version that your project is using. This option is largely for the use 
of the firmware developers and therefore most users will prefer to leave it disabled.

3.5.2 Always Allow Multiple Instances

Options > Advanced > Always Allow Multiple Instances is an on/off option that determines whether you are able 
to easily run more than one copy (or “instances”) of the TunerStudio at the same time.

In general terms it is not a good idea to have more than one instance of the software attempting to connect to 
your Megasquirt at the same time, as this potentially allows conflicting information to be sent to your product. 
For this reason it is strongly recommended that this option is always disabled.
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There are times when it may be useful to have more than one instance of the software running at the 
same time – for example if you want to compare two tunes side by side whilst working offline. You are still
able to do this with Always Allow Multiple Instances switched off although you will be prompted to confirm
that you want to start a second instance of TunerStudio. If you choose to do this it is essential that no 
more than one of the instances is connected to your Megasquirt. You can use the “Work Offline” option 
(See Section 2.6.) to make sure that any other instances of the software are not connected to (and 
cannot cause conflict with) your Megasquirt.

3.6 Preferences
The “Preferences” options allow you to alter additional aspects of the behavior of the software.

3.6.1 Set Dialog Font Size

Options > Preferences > Set Dialog Font Size allows you to choose the font size used throughout most of the 
software. It will alter the font size throughout TunerStudio with the exception of the top menu which has a fixed 
font size.

All images in this guide use the default dialog font size of 12. Screens will vary slightly with a different 
font size selected.

3.6.2 Perform Difference Report on Connect

Perform Difference Report on Connect compares the current configuration of your ECU with the configuration of 
your tune file. This can be useful if you have recently updated your firmware, or you want to restore an older 
tune created with an earlier version of the firmware. It is recommended that this option is enabled.

3.6.3 Automatically Load and Save Current Tune

Options > Preferences > Automatically Load and Save Current Tune is an on/off option that gives you a choice 
of two very different ways of managing the tune file for your Megasquirt. By default this option is enabled 
when you install TunerStudio. 

Since the use of this option is a matter of personal preference, the advantages and disadvantages of having this
option enabled are briefly discussed below.

Leaving Automatically Load and Save Current Tune Enabled (default setting)

With this option enabled a tune file called “CurrentTune.msq” is created in the main folder for each project that 
you create. Any changes you make to your tune are automatically saved to this CurrentTune.msq file, which is 
also automatically loaded whenever you open your project. This means that your tune file is constantly available
and up to date.

The downside of this option is that it is more difficult to keep track of backups, and it is more complicated to 
switch between tunes (as each backup needs to be loaded into CurrentTune.msq.) If you only use one tune file 
for each project, and you do need to regularly backup and restore, enabling this option may work well for you.

Disabling Automatically Load and Save Current Tune

If you disable this option you will need to open and save your tune files manually. This means that you will need 
to open and save tune files more often, although your latest tune will always be loaded from your Megasquirt 
whenever it is connected.

Whilst there is a little more opening and closing of files with this option disabled, it does give you more control in
terms of keeping track of changes, backups and the management of multiple tunes.
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Backing up Tune Files

Regardless as to whether or not you have this option enabled, you are still strongly recommended to make 
regular backups of your tune file using the “Save Tune As” option (see Section 2.5.) It is also recommenced that 
you backup your tune to a flash drive, external disk or cloud storage on a regular basis.

3.7 Performance
The “Performance” options give you some choices in terms of how you want to use the software. These can 
effect the efficiency of TunerStudio and how it communicates with your Megasquirt.

3.7.1 Gauge Float down on start

Options > Performance > Gauge Float down on start is a simple on/off option that determines whether the 
gauges in the gauge cluster are animated when the software starts. This option can be disabled without altering 
any other behavior of TunerStudio.

3.7.2 Modal Dialogs

Options > Performance > Modal Dialogs is an on/off option that determines whether more than one of the 
screens displayed from the toolbar menus can be displayed at the same time. It is recommended that this option
is disabled with Megasquirt-3.

3.7.3 Run in Lite Mode

Options > Performance > Run in Lite Mode is a feature of the Upgrade version which allows users to revert to 
the feature set of TunerStudio MS Lite. This option is not relevant to users of TunerStudio MS Lite and is 
disabled (grayed out) in this version of the software.
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4 Data Logging Menu
The Data Logging Menu allows you to:

• Stop and Start logging data from your Megasquirt;

• View your saved log files using the accompanying MegaLogViewer software.

4.1 Start Logging
Clicking Data Logging > Start will display the Start New Data Log screen as shown below:

  

This will prompt you to save a new TunerStudio .msl file which will contain the data that is logged from your 
Megasquirt. By default this file will be saved in the DataLogs directory within the current project directory, 
although you can choose to browse and save it elsewhere if you prefer. As soon as you click “Save” the 
software will start to log data from your Megasquirt into this new file.

When data logging is running the “Data Logging” indicator label at the bottom of the gauge cluster will 
turn green.

4.2 Stop
Data Logging > Stop will cease data logging and the collated data file selected in the above section will be 
closed. Your data is now ready to be reviewed using MegaLogViewer.

At this stage the “Data Logging” indicator label at the bottom of the gauge cluster will return to its usual 
color. 

4.3 Logging Profiles
Data Logging > Logging Profiles is a feature of the Upgrade version of the software which allows customization 
of the data collected. The standard format used for data logging will be sufficient to analyze the data collected 
from your Megasquirt.

4.4 Automatic Logging
Data Logging > Automatic Logging is also another Upgrade feature and is not documented in this guide.
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4.5 Import / Conversion
The “Import / Conversion” options allow data to be be imported from two other sources:

4.5.1 PalmLog Import Utility

This option allows data collected using propriety third party hardware and applications which save to the 
PalmLog format to be converted into a format that can be viewed with MegaLogViewer.

Clicking Data Logging > Import / Conversion > PalmLog Import Utility will display the Target Data Log screen as 
shown below:

  

Once you have chosen the file that you want to save your data log to, the Palm Extract Utility screen will be 
displayed as shown below:

  

By following the options on this screen you will be able to produce a file that can be used viewed using 
MegaLogViewer.

4.5.2 Convert Binary Log (MS3, FRD)

Clicking Data Logging > Import / Conversion > Convert Binary Log (MS3, FRD) will display the Transform Raw 
DataLog screen as shown below:
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MS3 datalogs are a binary logfile format that is written to the SDcard during SDcard datalogging. If the card is 
removed from the MS3 and inserted into your tuning computer, this option can be used to convert .MS3 logs into
regular .MSL logs that can be viewed with MegaLogViewer. Contrast the log downloader in section 4.8.

FRD files may possibly be accessible using proprietary 3rd party hardware and applications.

Following the options on this screen should produce a file that can be used viewed using MegaLogViewer.

4.6 View with MegaLogViewer
MegaLogViewer is an analysis application which accompanies TunerStudio, and for which a license is included 
along with your Megasquirt. MegaLogViewer needs to be installed for this option to work.

MegaLogViewer can be downloaded from: http://www.tunerstudio.com/index.php/downloads.

Complete documentation of MegaLogViewer falls outside the scope of this guide, although the key 
datalog fields that are relevant to your Megasquirt are documented in Section 4.6.1.

Clicking Data Logging > Import / Conversion > View with MegaLogViewer will display the Open Log File screen 
as shown below:
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Selecting the data log file that you want to view and clicking “Open” will start MegaLogViewer with the data from 
your log file loaded in. A sample of the main MegaLogViewer screen is shown below:

  

From this screen you can review many of the sensor outputs and other readings from your Megasquirt. The 
“Quick View” graphs are especially useful and are easily customized using the options on the left hand side of 
the screen.
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4.6.1 MegaLogViewer Datalog Fields

Below are listed all of the possible datalog fields for MegaLogViewer. Many fields are only visible if the relevant 
feature is enabled. e.g. EGT1 is only logged if EGT is enabled, VSS1 and fuel economy are only recorded if 
VSS is enabled etc. Some require additional hardware.

Accel X,Y,Z

The accelerometer X,Y,Z measured in SI units ms-2.

AFR (1-8)

Air:fuel ratio reading from wideband EGO sensors 1-8.

AFR load

The “load” (e.g., MAP, TPS) used on the Y-axis of the AFR table.

AFR target 1

The current target value for AFR, looked up from the active AFR target table.

AFR target 1 error

The difference between actual and target AFR.

ALS added fuel

The fuel pulsewidth (time) adder due to the anti-lag system.

Alternator control duty

Output duty to control alternator.

Alternator control frequency

Output frequency to control alternator.

Alternator load

Measured load on the alternator.

Alternator target voltage

The voltage being targetted by the alternator control system.

Barometer

The barometer reading. This will show a current value if a dedicated baro sensor is installed, the initial MAP 
reading, or 100kPa if barometric correction is disabled.

Battery Voltage

The measured battery voltage (if this is radically different from your actual battery voltage, check for wiring 
faults.)

Battery Current

The measured battery current measured through the alternator control system.
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Boost Duty1,2

The current duty cycle output to the boost solenoid1,2.

Boost psi

Boost in psi (derived from MAP and Barometer.)

Boost Target1,2

The target boost pressure 1,2 (in absolute kPa) for closed-loop mode.

CANin1_8

This bitfield variable is for optional CAN inputs. (Remote on/off switch inputs.)

128 64 32 16 8 4 2 1

CANIN8 CANIN7 CANIN6 CANIN5 CANIN4 CANIN3 CANIN2 CANIN1

CANout1_8

This bitfield variable is for optional CAN outputs. (Remote on/off ports.)

128 64 32 16 8 4 2 1

CANOUT
8

CANOUT
7

CANOUT
6

CANOUT
5

CANOUT
4

CANOUT
3

CANOUT
2

CANOUT
1

CANout9_16

This bitfield variable is for optional CAN outputs. (Remote on/off ports.)

128 64 32 16 8 4 2 1

CANOUT
16

CANOUT
15

CANOUT
14

CANOUT
13

CANOUT
12

CANOUT
11

CANOUT
10

CANOUT
9

CANpwmin0-3

Raw pulse period received over the CAN system from an expansion board.

CEL error code

This is the current error code. These are covered in more detail in the Megasquirt-3 Setting Up manual.

CEL status

This bitfield variable is a combination of binary bits about CEL faults. These are used to drive the CEL 
indicators:

128 64 32 16 8 4 2 1

EGT fault RPM-sync
fault

AFR fault Battery fault TPS fault CLT fault MAT fault MAP fault
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32768 16384 8192 4096 2048 1024 512 256

AFR
shutdown

EGT
shutdown

Fuel pressure
fault

Oil fault Cam fault Knock fault MAF fault Flex fault

CEL status2

128 64 32 16 8 4 2 1

- - - - - - Safety
shutdown

Water inj
fluid low

Closed-loop idle target RPM

The target engine speed for closed-loop idle control.

Closed-loop idle RPM error 

The difference between actual rpm and target rpm for closed-loop idle control.

CLT

The measured coolant temperature (CLT).

Duty Cycle 1 

The calculated injector duty cycle on channel 1 (85% is a recommended maximum, above 100% is impossible.)

Duty Cycle 2

The calculated injector duty cycle on channel 2.

Dwell

The ignition dwell (charge) time on the main spark outputs.

E85 Fuel Correction

The percentage multiplier to fueling due to the flex fuel sensor.

EAE1

The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 1.

EAE2

The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 2.

EAE load

The “load” (e.g., MAP, TPS) used on the Y-axis of the EAE curves.

EGO cor 1-8

The percentage fuel correction from AFR1-8 when closed-loop EGO control is used (100% means no change.)

EgoV 1 Target

The current target value for EGO voltage (1,2), looked up from the active target table.
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EgoV 1 Error

The difference between actual and target EGO voltage.

EGT 1-16

The reading from an external EGT sensor.

Engine

This bitfield variable is a combination of binary bits about engine status. These are used to drive the engine 
status indicators:

128 64 32 16 8 4 2 1

MAP decel
enrichment

MAP accel
enrichment

TPS decel
enleanment

TPS accel
enrichment

WUE active ASE active Cranking Ready
(active tach
signal and

pump
running)

These values can be added together, e.g., 17 means Ready and TPS accel.

Ethanol Percentage

The calculated ethanol percentage in the fuel reported from the flex fuel sensor.

Fuel: Air cor

The percentage multiplier to fueling due to air density.

Fuel: Accel enrich

The current fuel pulsewidth percentage multiplier due to acceleration enrichment.

Fuel: Accel PW

The current fuel pulsewidth (time) adder due to acceleration enrichment.

Fuel: Baro cor

The percentage multiplier to fueling due to barometric correction.

Fuel: Total cor

The total fuel percentage multiplier obtained by multiplying the other factors. If this is outside of the range 80%-
120% then there is likely something wrong with your tuning settings.

Fuel: Warmup cor

The percentage multiplier to fueling due to Warmup and Afterstart (this should be 100% on a warmed up 
engine.)

Fuel flow cc/min

Calculated averaged fuel flow. (Averaging period is set on Special Options - see Section 17.24.)

Fuel Pressure1_xxx

Primary differential fuel pressure in bar, kPa or bar. This is the differential fuel pressure above intake manifold 
pressure.
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Fuel Pressure2_xxx

Secondary differential fuel pressure in bar, kPa or bar. This is the differential fuel pressure above intake manifold
pressure.

Fuel pump control duty

The output duty cycle to control the fuel pump.

Fuel Temp1,2

Fuel temperature. 1 = primary fuel, 2 = secondary fuel

Fuel temperature cor

Correction to fuel due to fuel temperature.

Fuel pressure cor

Correction to fuel due to fuel pressure.

Gear

The current gear.

Generic Closed-Loop A,B duty

Output duty cycle from Generic Closed-Loop system.

GPS Altitude

Altitude in metres from external GPS.

GPS Course

The course/heading from external GPS.

GPS Latitude

Latitude degrees from external GPS. (Combination of degrees, minutes, seconds as one decimal number.)

GPS Lat. deg

Latitude degrees component from external GPS.

GPS Lat. min

Latitude minutes component from external GPS.

GPS Lat. sec

Latitude seconds component from external GPS.

GPS Longitude

Longitude degrees from external GPS. (Combination of degrees, minutes, seconds as one decimal number.)

GPS Lon. deg

Longitude degrees component from external GPS.
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GPS Lon. min

Longitude minutes component from external GPS.

GPS Lon. sec

Longitude seconds component from external GPS.

GPS Lon. E/W

Longitude East/West indicator from external GPS.

GPS Speed

The speed from external GPS in your chosen speed units.

GPS Speed ms-1

The speed from external GPS in ms-1.

Ign Load

The 'load' (e.g., MAP, TPS) used on the Y-axis of the ignition tables.

Injector Timing pri

The injection timing used for primary injector channels.

Injector Timing sec

The injection timing for secondary injector channels.

Knock cyl# 1-16

The signal value per-cylinder from the internal knock sensor interface.

Knock In

The signal value from an optional add-on knock sensor interface.

l/100km

Fuel economy in litres per 100 kilometres.

Lambda (1-8)

Lambda reading from wideband EGO sensors 1-8.

Lambda 1 Target

The current target value for Lambda (1,2), looked up from the active target table.

Lambda 1 Error

The difference between actual and target Lambda.

Launch retard timer

Timer for timed-retard after launch.
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Launch timed retard

The retardation to the timing due to the timed-retard after launch.

Load 

The primary '”load” for fuel calculations (this is equal to MAP on typical speed-density installs.)

Long term fuel trim cor

Fuel correction due to long term trim.

Loop

This bitfield is used with the  Programmable on/off outputs feature and allows other features to be controlled by 
user-defined combinations.

128 64 32 16 8 4 2 1

- - - - - Loop 3 Loop 2 Loop 1

Lost sync counter

The count of "lost-sync" events. If the engine stalls the counter will increase by one. During startup it is 
acceptable to have a few lost syncs. If you see this counting up under other conditions there is a problem with 
your tach input.

Lost sync reason

A technical reason code for why the ECU lost synchronization with the tach input. Not particularly useful. The 
codes are listed in the Setting Up manual.

MAF

The air-flow in g/sec calculated from the MAF sensor.

MAFload 

A calculated “load” value that works similarly to MAP in a speed-density system, (makes for better use of the 
lookup tables.)

MAF_volts

The raw voltage input from a voltage MAF sensor.

MAF_freq

The raw frequency input from a frequency MAF sensor.

MAP

The measured MAP (on typical speed-density installs this should read close to 100kPa during key-on, engine-off
and between 30kPa and 60kPa at idle.)

MAP accel

MAP acceleration component of accel-pump.

MAPdot

The rate of change of MAP (the increase in MAP per second.)
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MAT 

The measured intake manifold air temperature (MAT).

MPG(UK)

Fuel economy in miles per UK gallon (4.546 litres).

MPG(USA)

Fuel economy in miles per US gallon (3.8 liters.)

Nitrous 1,2 duty

The duty cycle to the nitrous solenoids in progressive mode.

Nitrous added fuel

The fuel pulsewidth (time) adder due to the nitrous system.

Nitrous timer

The delay timer for the nitrous system.

O2 (#1-8)

Input voltage from narrowband EGO sensors 1-8.

portXX

These datalog fields record the raw status of the input/output pins on the microcontroller within the Megasquirt 
ECU. The layout in this manual is:

128 Bit field value

PORTA7 CPU pin

Inj H MS3 name

Inj H MS3-Pro name

porta is PORTA

128 64 32 16 8 4 2 1

PORTA7 PORTA6 PORTA5 PORTA4 PORTA3 PORTA2 PORTA1 PORTA0

Inj H Inj G Inj F Inj E Inj D Inj C Inj B Inj A

Inj H Inj G Inj F Inj E Inj D Inj C Inj B Inj A

portb is PORTB

128 64 32 16 8 4 2 1

PORTB7 PORTB6 PORTB5 PORTB4 PORTB3 PORTB2 PORTB1 PORTB0

Spk H Spk G Spk F Spk E Spk D Spk C Spk B Spk A

Spk H Spk G Spk F Spk E Spk D Spk C Spk B Spk A
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porteh is a combination of PORTE and PTH

128 64 32 16 8 4 2 1

PTH7 PTH6 - PORTE4 - PORTE2 PORTE1 PORTE0

Nitrous in Tablesw. in F.PUMP FLEX PE1 PE0/JS7

Digi Switch
12V in

Digital in 4 - F.PUMP - Digi Switch
in 1

- -

portk is PORTK

128 64 32 16 8 4 2 1

PORTK7 PORTK6 PORTK5 PORTK4 PORTK3 PORTK2 PORTK1 PORTK0

PK7 (H1) - - - PK3 (H3) Launch in PK1 (H4) Tacho out

- - - - (internal) Digi Switch
in 2

(internal) Tach Out

portmj is a combination of PTM and PTJ

128 64 32 16 8 4 2 1

PTJ7 PTJ6* PTM5 PTM4 PTM3 PTM2 PTJ1 PTJ0

JS11 (IAC EN) D15 D16 D14 PM2(H2) IAC2 IAC1

(Internal) (IAC EN) (Internal) (Internal) (Internal) (Internal) Stepper Out
2

Stepper Out
1

* 1.3.3 upwards

portt is PTP

128 64 32 16 8 4 2 1

PTP7 PTP6 PTP5 PTP4 PTP3 PTP2 PTP1 PTP0

FIDLE VVT Nitrous2 Nitrous1 Boost Idle (INJ2 PWM) (INJ1 PWM)

PWM / Idle
Out 1

PWM Out 3 High Curr.
Out 2

High Curr.
Out 1

High Curr.
Out 3

PWM Out 2 - -

portt is PTT

128 64 32 16 8 4 2 1

PTT7 PTT6 PTT5 PTT4 PTT3 PTT2 PTT1 PTT0

- Datalog in JS10 PT4 INJ 2 Cam in INJ1 Crank in

- Digi Freq
In 3

Digi Freq
In 2

Digi Freq
In 1

Inj J CMP Inj I CKP

PW1

The base fuel pulsewidth for injector channel 1. This is the actual electrical pulsewidth including deadtime, but 
not trim. See also SeqPW1.
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PW2

The base fuel pulsewidth for injector channel 2. This is the actual electrical pulsewidth including deadtime, but 
not trim. Primarily for dual table or dual fuel.

PWM A-F duty

Output duty cycle from Generic PWM system.

PWM Idle Duty

The current duty cycle output to the idle valve.

RPM

The tachometer / rev counter (if this is dropping to zero or bouncing around, you probably have a problem with 
the tach-in signal.)

RPMdot

The rate of change of RPM (the increase in RPM per second.)

SDcard error

Error code for SDcard datalogging system - see the Setting Up manual for a list. Only relevant in "serial" 
datalogs.

SDcard file number

The current active datalog file number on the SDcard. Only relevant in "serial" datalogs.

SDcard phase

Technical code relating to SDcard datalogging system. Only relevant in "serial" datalogs.

SDcard status

Bitfield indicating current status of SDcard datalogging system. Only relevant in "serial" datalogs.

SecL

A built in clock that counts up seconds since the Megasquirt was last turned on. If this suddenly resets to zero, 
you probably have a power connection problem.

Secondary Ign Load

Like “Ign Load” but used for the secondary lookup table.

Secondary Load

Like “Load” but used for the secondary lookup table.

Sensor01-16

The reading from a sensor converted into your chosen units through the Generic Sensors system. You can also 
give the sensors a name of your choice which will then be used in the datalog.

Seq PW1-8

The base fuel pulsewidth for the injector on cyl#1. This is the actual output electrical pulsewidth including 
deadtime, all corrections and trim. (The "Firing Order" setting is used to determine which cylinder is which as the
injectors always fire in the same order. A,B,C...)
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SPK: 3-step Timing

The spark timing/advance taken from the 3-step system.

SPK: ALS Timing

The spark timing/advance taken from the anti-lag system.

SPK: Base Spark Advance

The spark timing/advance looked up from the ignition table before other adjustments are made.

SPK: CEL retard

The retardation to the timing due to check engine light and limp mode.

SPK: Cold advance

The advancement to the timing due to the cold advance curve.

SPK: External Advance

The external advancement to the timing, e.g., from a transmission controller. 

SPK: Flex Advance

The advancement to the timing due to flex fuel.

SPK: Fuel cut retard

The retardation to the timing due to over-run fuel cut.

SPK: Idle Correction Advance

The advancement to the timing due to idle correction.

SPK: Knock Retard

The retardation to the timing due to knock control.

SPK: Launch Timing

The spark timing/advance taken from the launch (2-step) system.

SPK: Launch VSS Retard.

The retardation to the timing due to the speed based launch system.

SPK: MAT Retard

The retardation to the timing due to the MAT retard curve.

SPK: Nitrous Retard.

The retardation to the timing due to the nitrous system.

SPK: Revlim Retard

The retardation to the timing due to the rev limiter.
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SPK: Spark Advance 

The overall ignition advance.

SPK: Spark Table 1

The looked up spark advance from ignition table 1.

SPK: Spark Table 2

The looked up spark advance from ignition table 2.

SPK: Spark Table 3

The looked up spark advance from ignition table 3.

SPK: Spark Table 4

The looked up spark advance from ignition table 4.

SPK: Traction retard

The retardation to the timing due to traction control.

Shaft rpm 1,2

Shaft speed in RPM.

status1-8

These bitfield variables is a combination of binary bits about engine status. These are used to drive various 
status indicators.

status1

128 64 32 16 8 4 2 1

Full-RPM
Synced

Spark
Table-sw

Fuel
Table-sw

(Synclatch) RPM
Synced

Config
Error

Lost
Data

Need
Burn

status2

128 64 32 16 8 4 2 1

CL
Idle

Over Boost Spark
Cut

Flat
Shift

Launch Launch
In

N2O
stage 2

N2O
stage 1

status3

128 64 32 16 8 4 2 1

Launch
On

Seq.
Shift

Soft Limit 3-Step
In

Test
mode

3-Step T
Log

Fuel
Cut

Status 4, 5

Typically only used by developers. The CEL system allows status5 to be used to record raw ADC counts or 
fluctuations of inputs.
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status6

128 64 32 16 8 4 2 1

MAPsample
error

Fan Idle
Advance

Idle
VE

AFR
Shutdown

AFR
Warn

EGT
Shutdown

EGT
Warn

status7

128 64 32 16 8 4 2 1

Limp
Mode

CEL AC Knock VVT4
Error

VVT3
Error

VVT2
Error

VVT1
Error

status8

128 64 32 16 8 4 2 1

- - VSS
Launch

VSS
Launch

Lock-out

PW4X
Mode

Water
Injection

Low

Spark
Disable
Mode

Injectors
Disable
Mode

Stepper Idle position

The current stepper valve position (0 means fully closed.)

Time

TunerStudio maintains a time since it was started and records this is the datalog. The time is shown at the 
bottom of the graph area. When discussing datalogs, be sure to refer to this time (e.g., look at 145s in the log 
where...)

Timing err

A calculation of how accurately the position of the next tach tooth was predicted. Not very useful.

Total accel

Combination of TPS and MAP acceleration components of accel-pump.

TPS

The 0-100% throttle (pedal) position (check the calibration settings if you do not get 0-100%)

TPS accel

TPS acceleration component of accel-pump.

TPSADC

The raw ADC input of the throttle (pedal) position.

TPSdot

The rate of change of TPS (the increase in TPS per second.)

VE1,2

The looked up VE value for channel 1,2 (includes blends)
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VSS1-4

Vehicle (wheel) speed sensor inputs in your chosen speed units.

VSS1-4 ms-1

Vehicle (wheel) speed sensor inputs in SI units ms-1.

VSS1dot VSS2dot

The rate of change of VSS (acceleration) measured in SI units ms-2.

VVT angle 1,2,3,4

The current relative angle of VVT cam 1,2,3,4

VVT duty 1,2,3,4

The solenoid output duty cycle for VVT cam 1,2,3,4

VVT target 1,2,3,4

The target angle of VVT cam 1,2,3,4

WallFuel1

The calculated fuel puddle volume on the intake port walls, channel 1.

WallFuel2

The calculated fuel puddle volume on the intake port walls, channel 2.

Water Duty

The duty cycle to the water injection solenoid.
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4.7 SDcard datalogging
The Megasquirt-3 includes provision to datalog to an internal SDcard without the need for a laptop. The SDcard 
system records smaller blocks of data at a higher speed than regular 'serial' datalogs on a laptop. As a result of 
this, you are required to select which Datalog Fields you want recorded.

 

SD card logging

• Disabled - turns off the SDcard logging feature

• Always - basically it means always log. It is best not to insert the SD card while the Megasquirt is 
powered on and most certainly do not unplug the card while the power is on. Card damage can result.

• Button - logging is controlled by a push button

• Trigger - logging starts when a trigger condition is met

Datalog button

This selects the input pin used for the button if used.

RPM >

A log is started when RPMs exceed this trigger value.
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TPS >

A log is started when TPS exceeds this trigger value.

LED indicator

This selects the output used for the optional LED indicator

Log data block size

• 64 byte is the most common setting

• 64 byte + stream allows the simultaneous recording of data and a 8kHz mono sound input. This could 
be used as a commentary during a datalog such as position on a racetrack or notable incidents in the 
log. Presently TunerStudio does not support extracting this audio data.

• 128 byte allows twice as many datafields to be recorded per log sample. The logs will be twice the size 
and it may not be possible to log at the fastest rate depending on your card.

Interleave GPS data

When Megasquirt is configured to fetch GPS data internally (not a GPS module on your tuning computer) it can 
also record this data onto the SDcard. As the GPS data is far slower than the other datalog fields, it is slotted in 
between the other data.

Sampling

• Timed - a data sample is taken at predefined time interval - this is the most common option

• every tooth, every cycle - for special logging and at low engine speeds these options take a data sample
at these events

Sample interval

How often to take a data sample.

3ms is the fastest supported, but many cards will only sustain 5ms before you start getting small gaps in the 
logs.

Frames/second

This shows how many data-points will be recorded per second at your chosen sample interval.

Log file max duration

How long each datalog should be.

The files are always created full size and fill up the allocated space during logging. If the log file is filled, a new 
file is started. If you turn off the power to the Megasquirt (which is safe to do during a log) the log will show full 
size however much data is actually in it. When the log file is extracted, the unused part of the allocated file will 
be ignored. (Note, it is impossible for the Megasquirt-3 to set the file length or otherwise "clean up" the log file in 
this case because there is no power and the processor is off !) A result of this is that all log files on the SD card 
will appear the same size.

Stream input

What input is used for a 0-5V audio signal for the stream logging option.

SPI comms speed

This setting is not needed with MS3 cards products manufacturer since 2013. Generally it should be set to 
"Normal" and only reduced in the rare cases of communication problems with the SDcard.
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Log field selection

The field selector allows you to choose which data fields you want to log. Because of the compact datalog 
format you need to pick the data that you find most critical.

To add a field, highlight it on the left and then click on > to move it to the right.

To remove a field, highlight it on the right and then click on < to move it to the left.  

4.8 Browse/Import SDcard
This allows the SDcard datalogs to be read back from the SDcard while it is still attached to the Megasquirt. This
is the only method to retrieve datalogs on the MS3-Pro.

It will only be accessible if SDcard datalogging is enabled and TunerStudio is online with the ECU. 

The main workflow on this page will consist of highlighting a file or a number of files in the file pane and then 
clicking the Download button. The engine must be powered on, but with zero RPMs to download files.

Start SD log

Typically this is only used for testing. Ordinarily the options on the SDcard datalogging page should be used for 
starting and stopping datalogs.

Re-initialize Card

Typically this is only used for testing. This forces the card to be re-initialized.

Reset

Typically this is only used for testing. This forces the SDcard system to reset.

Reset and wait

If a log is currently in-progress this will stop the log and wait for further instruction such as downloading a log 
file.
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Set MS3 Time to Now

For ECUs with a realtime clock this allows the time to be synchronized with your tuning computer.

Download select file(s).

Refresh file list.

Delete selected file(s).
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5 Communications Menu
The Communications Menu is used to set up and test communications between your computer and your 
Megasquirt. It will be useful if you are having problems connecting to your Megasquirt, or if you need to used an 
advanced setting.

Using many of the options within the communications menu will temporarily close the connection 
between your computer and your Megasquirt. This is normal and necessary for these options to work 
effectively. TunerStudio should reconnect to your Megasquirt again automatically after the 
communications screen you have been using has been closed. If this doesn't happen reopen the screen 
and carefully check any changes that you have made.

5.1 Settings
Clicking Communications > Settings will display the Communications Settings screen as shown below:

  

This screen is virtually identical to the third of the Create New Project screens (See Section 2.1.1.) Please refer 
to that section for most of the settings options shown on this screen.

The only real addition is the “Detect” button. This will scan your computer for Megasquirt products which can be 
helpful if you have changed the way that you are connecting to your Megasquirt and need to update the 
communications settings for your project. It is also helpful if you were having problems connecting to your 
Megasquirt whilst creating your project.

You may see two Megasquirt devices listed with JSSC and RXTX. RXTX will use the default legacy 
driver and is the correct device to use at this time. RXTX is an older communications technology that will 
probably be phased out in the future, but remains current at the time or writing.

5.2 Data Rate
Clicking Communications > Data Rate will display the Set Data Rate screen as shown below:
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As a general rule 15 Reads Per Second is the preferred setting. If you connect using a slower connection type 
such as bluetooth your actual data rate may be lower.

5.3 Enable GPS Support
This menu refers to TunerStudio communicating directly to a GPS for logging onto a laptop. That GPS data 
cannot be used internally within the Megasquirt. The TunerStudio GPS support is only included in the Upgrade 
version of TunerStudio.

See also the CAN/GPS section of the manual.

5.4 Mini Terminal
The Mini Terminal is a command line interface that can be used to interrogate your Megasquirt. Normally use of 
this terminal is restricted to diagnostics and support provided by Megasquirt technical experts.

Clicking Communications > Mini Terminal will display the Mini-Term screen as shown below:
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As simple example of how Mini Terminal works is as follows: With your ECU connected and powered up, typing 
“S” into the top half of the screen should display the version of your Megasquirt and the firmware that it contains 
as shown below:

  

The other commands that can be used with Mini Terminal fall outside the scope of this guide.

5.5 Debug Log Comm
Your TunerStudioProjects file will contain a filed called “TunerStudioAppDebug.txt”. This is TunerStudio's internal
log file which is created when the software is first installed and is updated whenever TunerStudio is used. This 
file is extremely useful for technical support in the event that you should experience problems with TunerStudio.

Occasionally it is useful for those providing TunerStudio support to obtain a more detailed log file to carry out 
troubleshooting. The Debug Log Comm option is an on/off setting which can be enabled or disabled by clicking 
Communications > Debug Log Comm. When enabled, this option instructs TunerStudio to write much more 
detailed information to the TunerStudioAppDebug.txt file.

Do not enable this option for any length of time or it will turn into a very large file very quickly. As a rule 
this option should only be enabled for a short period of time either at the request of a support technician, 
or for your own use if you have a good knowledge of the contents of the log file.

5.6 Megasquirt Baud Rate
Section 2.1.1. of this guide (New Project) details that for almost all Megasquirt-3 installations the baud rate 
should be set to 115200. The baud rate can theoretically be set to a lower level although this is generally not 
desirable and should only be done by advanced users under exceptional circumstances. 

Clicking Communications > Megasquirt Baud Rate will display the Megasquirt baud rate screen as shown 
below:
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Megasquirt Baud Rate

This sets the main serial communication speed that is used for all tuning and datalogging.

Generally it is advised that the main Megasquirt Baud Rate be left at 115200 unless you have a very 
good reason to change it.

 
To set your baud rate to a lower rate than 115200 carefully follow these five steps:

• Set the reduced baud rate using the above screen and click “Close”;

• Click Communications > Settings and display the Communications Settings screen;

• Under Baud Rate select exactly the same value you entered in the Megasquirt baud rate screen;

• Click “Accept”;

• Power off and then restart your ECU. It should now connect at the reduced rate.

These steps must be carried out in the order outlined above for the change to work correctly!

SDcard Readback Baud Rate

This sets the serial communication speed that is used when reading back SDcard datalogs. Many computers 
and serial driver combinations will support increased speeds. Useful options are 115200, 230400 and 460800. 
Use the highest speed that gives reliable operation. The higher the baud rate, the faster SDcard datalogs will 
download (see also section 4.8)

Use High Speed Runtime

There are two settings:

• On - enables a faster method of collecting realtime data from the ECU. Recommended.

• Off - use previous slower method for realtime data.
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6 Tools Menu
The Tools Menu contains a range of options. Of these, the options you are most likely to use are the calibration 
options which are an important component of your Megasquirt configuration.

Megasquirt-3 uses internal calibration tables to convert the resistance/voltage from the input sensors into
a real world number. It is necessary to setup this calibration so the inputs read correctly. The built-in 
calibrations for coolant temperature (CLT) and air temperature (MAT) are for GM sensors, so if you have 
GM sensors you are safe to leave these alone. All installs should set the calibration for the AFR (air fuel 
ratio) table that is used for the oxygen sensor (lambda sensor) whether narrowband or wideband.

6.1 Protocol Stats
Protocol Stats are generally used by developers and for technical support. This feature lies beyond the scope of 
this guide.

6.2 Update / Install Firmware
This offers a 'wizard' style function to easily update the embedded firmware on your ECU.

(This section will be expanded in a future version of this manual.)

This firmware loader is highly recommended instead of the previous 'DOS' style loader.

6.3 TunerStudio Plug-ins
TunerStudio Plug-ins are additional modules which are created at community level and can be used to add 
additional features to TunerStudio. Plug-ins are only available within the Upgrade version of TunerStudio. Any 
documentation for Plug-ins should be provided by their developers.

6.4 Calibrate TPS
The Calibrate TPS option allows you to calibrate your throttle position sensor. Clicking Calibrate TPS will display
the Calibrate Throttle Position Sensor screen as show below:

  

To calibrate the throttle position sensor do the following:

• Ensure that your Megasquirt is connected and the engine is not running (i.e.,  KOEO).

• Ensure that the throttle is closed;

• Click the “Get Current” button to the right of “Closed throttle ADC count”;

• Fully open the throttle;
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• Click the “Get Current” button to the right of “Full throttle ADC count”;

• Click Accept and your throttle sensor will be calibrated.

6.5 Calibrate MAP / Baro
The Calibrate MAP / Baro option allows you to calibrate your MAP (Manifold Absolute Pressure) and Barometric 
Pressure sensors.

Clicking Tools > Calibrate MAP / Baro will display the Calibrate MAP/Baro screen as shown below:

  

The options for these settings are described below:

Common MAP Sensors

This gives a list of the commonly used MAP Sensors. If you are using one of these sensors select if from the 
drop down list, otherwise select “Custom”.

Value at 0.0 volts (%)

If you have selected one of the Common MAP Sensors this setting will be set automatically. If you are using a 
custom sensor enter the appropriate value for your sensor in this text box.

Value at 5.0 volts (%)

Again, if you have selected one of the Common MAP Sensors this setting will be set automatically. If you are 
using a Custom sensor enter the appropriate value for your sensor in this text box.

Common Baro Sensors

This gives a list of the commonly used Baro Sensors. If you are using one of these sensors select if from the 
drop down list, otherwise select “Custom”.

Value at 0.0 volts (%)

If you have selected one of the Common Baro Sensors this setting will be set automatically. If you are using a 
custom sensor enter the appropriate value for your sensor in this text box.
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Value at 5.0 volts (%)

Again, if you have selected one of the Common Baro Sensors this setting will be set automatically. If you are 
using a custom sensor enter the appropriate value for your sensor in this text box.

Barometric Correction At total vacuum (%)

This setting related to the barometric correction to fuel at a total vacuum.

For new installs set this value to zero and the barometric correction curve to 100% across the board.

Imported settings from older code versions use a vacuum of 147 and have the curve at zero.

Barometric Correction Rate (%)

The rate of change of correction

For new installs set this value to zero and the barometric correction curve to 100% across the board.

Imported settings from older code versions use a rate of -47 and have the curve at zero.

6.6 Calibrate Battery Voltage

It is not usually necessary to calibrate the battery voltage. Do not alter these values from the defaults 
unless you have confirmed the actual voltage reading is inaccurate.

 
Clicking Tools > Calibrate Battery Voltage will display the Calibrate Battery Voltage screen as shown below:

  

These settings can be used to correct battery voltage readings at (and between) zero and max.

6.7 Un/Lock calibrations
The calibration settings for Thermistor Tables, AFR Tables and MAF Tables can be locked or unlocked to 
prevent them from being changed accidentally.

Clicking Tools > Un/Lock calibrations will display the Un/Lock calibrations screen as shown below:

  

Selecting “Locked” or “Unlocked” will disable or enable the remaining calibration options.
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If you unlock Sensor Calibrations please ensure that they are locked again once you have made your 
changes.
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6.8 Calibrate Thermistor Tables
Clicking Tools > Calibrate Thermistor Tables will display the Calibrate Thermistor Tables screen as show below:

  

From this screen you can set the CLT (coolant temperature) calibration if needed. The options for these settings 
are described below:

Sensor Table

Select whether you are calibrating the “Coolant Temperature Sensor”,  “Air Temperature Sensor” or "Custom#1 
Temperature Sensor".

• Coolant Temperature Sensor - the calibration table used for the CLT input or generic sensors.

• Air Temperature Sensor - the calibration table used for the MAT input or generic sensors.

• Custom#1 Temperature Sensor - the optional calibration table used for generic sensors.

The Coolant and Air temperature sensor calibrations must both be set to match your sensors.

The default pre-loaded tables are correct for GM type sensors.

Table Input Solution

This value will normally be set to “3 Point Therm Generator”. It can also be set to “Custom Inc File”

If you select “Custom Inc File” for this setting the screen will update and you will be given the option to 
browse for your .inc file. To use this option you need to have an .inc file containing your thermistor 
settings on your hard disk. If you use this option then you will not need to use the other settings 
described in this section.

Common Sensor Values

From this option you can select your sensor type. You can select from a predefined list of common sensors 
using the drop down list, or leave this option unselected if you are using custom settings specific to an unlisted 
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sensor.

Bias Resistor Value (Ohms)

If you have selected one of the common sensors this value should be set for you. If you are using a custom 
sensor you may need to set this value manually. If you are using a MS3-Pro or MS3-Gold these values should 
always be set to the default of 2490 ohms. If you are using an MS3 the values will usually also be the default of 
2490 ohms unless you or your vendor have changed the resistors on the mainboard. Your vendor should inform
you if these resistors have been changed prior to shipping.

If necessary, these can be checked by inspecting the Megasquirt mainboard (V3.0 or V3.57 only.) R7 is 
the bias resistor for the coolant temperature sensor, R4 is the bias resistor for the air temperature sensor.

Temperature Settings (°C or °F)

Again, if you have selected one of the common sensors these values should be set for you. If you are using a 
custom sensor enter the three measured temperature and resistance value pairs.

If you are setting custom values then measure these accurately rather than estimating. For greatest 
accuracy the bias resistor should be close to the sensor resistance at a “warm” temperature.

See the Setting Up manual for a method to measure the values.

Write to Controller

Once you have completed the settings in this screen click the “Write to controller” button to burn these settings 
to your Megasquirt.

6.9 Calibrate AFR Table
Clicking Tools > Calibrate AFR Table will display the Calibrate AFR Table screen as show below:

  

From this screen you can set the AFR (air fuel ratio) calibration if needed. The options for these settings are 
described below:
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EGO Sensor

This option allows you to select an exhaust gas oxygen sensor.  You can either select from the predefined list, 
select “Custom Linear WB” (wideband) or select “Custom Inc File”.

If you select “Custom Inc File” for this setting the screen will update and you will be given the option to 
browse for your .inc file. To use this option you need to have an .inc file containing your EGO sensor 
settings on your hard disk. If you use this option then you will not need to use the other settings 
described in this section.

Volts / AFR Values

If you have selected an EGO sensor from the predefined list these values will be set for you. If you have 
selected “Custom Linear WB” then you will need to enter the voltage/AFR pairs from your sensor or controller 
manual.

Write to Controller

Once you have completed the settings in this screen click the “Write to controller” button to burn these settings 
to your Megasquirt.
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7 Help Menu

7.1 TunerStudio Help
Clicking Help > TunerStudio Help will display the TunerStudio's own help file. This may provide further 
information in addition to the contents of this guide.

7.2 Check for Update
Clicking Help > Check for Update will check online to see if there is a more recent version of TunerStudio 
available. If you have Automatic Update Check (see Section 7.3. below) enabled you should not normally need 
to use this option.

7.3 Automatic Update Check
Clicking Help > Automatic Update Check toggles between enabling and disabling the automatic update check 
that takes place every time you run TunerStudio. It is strongly recommended that this option is enabled as it is
good practice to always use the latest stable release of TunerStudio.

7.4 Enter Registration
Clicking Help > Enter Registration will prompt you to enter a registration code if you have purchased a license 
for the Upgrade version of TunerStudio. You do not need to enter a registration code to use TunerStudio MS 
Lite.

7.5 About
Clicking Help > About will display an information screen which includes the developer's Internet site and 
technical support contact email address, along with the version number of TunerStudio that you are using.

7.6 Megasquirt 3 Info
Clicking Help > Megasquirt 3 Info will display an information screen which includes a link to the MSExtra 
website.
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8 Basic / Load Settings
One of the essential roles of an aftermarket ECU such as a Megasquirt is to manage EFI (electronic fuel 
injection). Achieving the correct fuel mixture and ignition timing are vital in terms of optimizing EFI. This involves 
monitoring airflow into the engine and calculating optimal fuel requirement based on airflow.

There are a number of different methods to measure airflow into an engine, each based on different complex 
algorithms. To briefly summarize the options: Speed Density uses a MAP (manifold air pressure) sensor; Alpha-
N uses a TPS (throttle position sensor); MAF (mass airflow) uses an actual airflow meter. All of these three 
methods have pros and cons and none is a 'magic bullet'. Some radical engines may need to use a combination
of more than one sensor configurations. Most engines will achieve good results with Speed Density or MAF.

The following sections deal with how to use TunerStudio to enter the parameters that describe your engine, and 
to configure your choice of airflow sensors and algorithm.

8.1 Engine and Sequential Settings
Clicking Basic / Load Settings > Engine and Sequential Settings displays the following screen:

  

The options for these settings are described below:

8.1.1 Required Fuel Settings

The value for 'Required Fuel' (often referred to as ReqFuel) is calculated for you automatically using the your 
chosen algorithm. In order to do this it is essential that the settings for your engine are entered correctly. This 
section describes the settings that you need to complete before TunerStudio can calculate 'Required Fuel'. 

Control Algorithm

The calculation method for fuel. The choices are:

• Speed Density (uses MAP sensor);

• Percent Baro (Speed-Density, but with barometric pressure difference included);
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• Alpha-N (uses TPS);

• MAF (uses MAF);

• ITB (a mode specifically for Independent Throttle Bodies).

Squirts per Engine Cycle & Injector Staging

Sets injector staging in non-sequential modes. For sequential set 2 Squirts/Alternating or 1 Squirt/Simultaneous.

Engine Stroke / Rotary

Most engines are four stoke, although some (particularly on motor-cycles) are two stroke. The other (relatively 
rare) option is rotary.

No. Cylinders / Rotors

The number of cylinders or rotors in your engine.

Engine Type

Most engines are Even Fire. Typical odd-fire engines are V-twin, some V4, Vmax, some V6, V10.

Engine Size

Engine size or displacement in cc. Ensure that you fill this in before using the Required Fuel calculator. To 
convert from cu.in to cc, multiply by 16.39.

Injector Size

The size of each of your main/primary injectors in cc/min. Typical conversion from lbs/hr is multiply by 10.5

Required Fuel Button

Once you have completed all of the appropriate entries for your engine, click the 'Required Fuel' button to 
calculate the required fuel for your configuration. This will display a pop-up screen similar to that shown below.   

  

The entries will have been calculated for you by complex algorithms based on the values you have already 
entered. Click 'Ok' to accept these settings. It is strongly recommended that you do not modify these 
values manually.

8.1.2 Sequential Injection Settings

Main Fuel Outputs

This does not apply to MS3-Pro.

• Std fuel - Use the V3/V3.57 mainboard batch injector outputs.

• MS3X fuel - Use the MS3X expansion board's outputs to drive the fuel injectors.
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Sequential Injection

There are four options that you can select from for this option:

• Untimed injection – batch fire injection non sequential;

• Sequential/Semi-sequential – injection is timed to specific crank angle, either once per rev (semi) or 
once per cycle (sequential);

• Semi-sequential Siamese – for siamese port engines;

• Sequential Siamese – for siamese port engines.

Sequential On

• Off - Use batch injection. On MS3X outputs or on MS3-Pro, the channels are divided into two 
groups, and all injectors in a group are squirted simultaneously.

• Semi-Sequential - Fire injectors in pair and allow the angle of injection to be specified, does not 
require a cam sensor. Injectors should be wired in the same manner they would be wired for fully 
sequential injection.

• Fully Sequential - Use fully sequential injection which typically requires a cam sensor. In this mode,
outputs A-H are squirted in sequence, so care must be taken to use the correct wiring for the 
engine's firing order. For example, for a four cylinder engine with firing order 1-3-4-2, the following 
wiring should be used:  Inj A = Cyl#1, Inj B = Cyl#3, Inj C = Cyl#4, Inj D = Cyl#2

Angle Specifies

• End of Squirt - The angle specified in the injector timing table specifies the angle of the end of 
each squirt. This is recommended for most engines.

• Middle of Squirt - The angle specified in the injector timing table specifies the angle of the middle 
of each squirt.

• Beginning of Squirt - The angle specified in the injector timing table specifies the angle of the 
beginning of each squirt.

Injector Trim

• Off - Per-injector fuel trim is disabled. All injectors will have the same pulse-width.

• On - Per-injector fuel trim is enabled. This allows the pulsewidth for each cylinder to be trimmed 
individually. Typically per-cylinder widebands or EGT are required to use this.

Firing order

The firing order should be set to the firing order that your engine uses. It does not affect the order in which the 
outputs are triggered. Instead it is used to associate an injector trim table with a particular physical output so 
that when injector trim is applied, it is applied to the correct cylinder. It is also used if closed-loop EGO is being 
done per-cylinder. 
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8.2 General Settings
Clicking Basic/Load Settings > General Settings will display the following screen:

 

From this screen you can set values for many of the settings you may need for your configuration, including 
barometric settings, MAP sensor settings, general sensor settings and secondary load parameters.

8.2.1 Baro Sensor Settings

These are settings that you may use if you want altitude to be taken into account in terms of determining your 
engine's performance.

Barometric Correction

Enables or disables fuel adjustment for barometer (altitude.) The options are as follows:

• Off – ignore baro;

• Initial MAP reading – take a sample from the MAP sensor at power-on; This setting is not recommended
as it can return an incorrect value if you are quick on the key or powercycle while the engine is running.

• Two independent sensors – use a second dedicated barometer sensor. (Additional hardware required.)

It is strongly recommended to use a dedicated baro sensor if your vehicle will see altitude changes. See the 
hardware manual for wiring.
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Realtime Baro Port

The connection to an external or internal barometer sensor (used if you are using two independent sensors.)

Upper Limit (kPa)

Maximum barometer reading that the engine will see (typically 102kPa.) Limits faulty readings.

Lower Limit (kPa)

Lowest possible barometer reading that the engine will see (typically 68-80kPa.) Limits faulty readings.

Default Baro (kPa)

Fixed barometer reading for when barometric correction is disabled.

Old baro calc

Enable old-style compatability barometric calculations. Not recommended for new installs.

8.2.2 MAP Sensor Settings

For both MAP and baro sensors, see also the Calibrate MAP/Baro in section 6.5.

MAP Sensor Input Port

The connection to the MAP sensor which should be set to “Off” for installs not using MAP.

MAP sensor type

• Off - disables the MAP input - only relevant on pure Alpha-N or MAF installs.

• Voltage  - A 0-5V analogue voltage used - by far the most common

• Frequency - a digital frequency input is used - rare

Voltage input port

 Where the primary MAP sensor is wired (when voltage is selected.)

Frequency input port

 Where the primary MAP sensor is wired (when frequency is selected.)

Low frequency

The frequency corresponding to the minimum pressure. The minimum pressure is set in the MAP calibration.

High frequency

The frequency corresponding to the maximum pressure. The maximum pressure is set in the MAP calibration.

2nd MAP port

Enables a secondary voltage MAP sensor and selects where it is wired.

8.2.3 General Sensor Settings

MegaView Temp. Units

Selects the temperature units displayed on the optional MegaView.
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Averaging Lag Factors

Lag factors for a number of sensors can be smoothed with 100% representing no smoothing, and 10% (not 
recommended) representing a high degree of smoothing. This applies to:

• MAP Averaging Lag Factor;

• MAF Averaging Lag Factor;

• RPM Averaging Lag Factor;

• TPS Averaging Lag Factor;

• Lambda Averaging Lag Factor;

• CLT/MAT/Battery/Baro Averaging Lag Factor.

Auto-zero TPS

Automatically recalibrate TPS if negative TPS values are seen. This can be useful if the zero position on your 
TPS varies. (The temporary recalibration is not saved.) Recommended to disable this setting.

8.2.4 Load Parameters

Fuel over-run is covered in Section 9.6. of this guide

Primary Fuel Load

The calculation method for fuel. The choices are:

• Speed Density (uses MAP sensor);

• Percent Baro (Speed-Density but with barometric pressure difference included);

• Alpha-N (uses TPS);

• MAF (uses MAF);

• ITB (a mode specifically for Independent Throttle Bodies.)

Secondary Fuel Load

Enables a second modifier fuel table (VE2) – for advanced use only.

Secondary Fuel

Selects the modifier method for the secondary fuel load – for advanced use only.

Multiply MAP

Normal Speed-Density should enable 'Multiply MAP'. In rare circumstances, this can be disabled. %baro works 
the same.  With Alpha-N, enabling multiply MAP gives 'Hybrid Alpha-N', disabling multiply MAP gives 'Pure 
Alpha-N'. MAF never multiplies in MAP.

This option should be used with caution – 99% of installations should use “Multiply”.

Incorporate AFRTarget

Including the AFR target in speed density mode allows the VE table to be a “real” VE table and the desired AFR 
to be specified in the AFR table.

With AFR not included, the AFR table is for reference only and the VE table takes full control.
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In MAF mode, this setting MUST be enabled.

It is advised that this setting is set BEFORE you start tuning. Changing the setting will require a re-tune.

Stoichiometric AFR

The stoichiometric (chemically ideal) AFR for the fuel in use. For gasoline leave this as 14.7 and set the internal 
calibration on your wideband to match.

Primary Ignition Load

The load Y-axis for ignition table lookups.

Secondary Ignition Load

Enables a second modifier fuel table (Spk2) – for advanced use only.

AFR table Load

The load Y-axis for AFR table lookups.

EAE curve load

The load Y-axis for EAE curve lookups.

8.3 Rev Limiter
Clicking Basic/Load Settings > Rev Limiter will display the following screen:

  

From this screen you are able to control settings such as hard rev limit, coolant temperature limit, spark retard, 
spark cut and fuel cut.
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8.3.1 Hard Rev Limit

Hard Rev Limit (RPM)

Specifies the rev limiter max RPM (you must also select a rev-limiter type below.)

After setting the Hard Rev Limit, you MUST also select a rev-limiter type below.

Soft Limit Zone

Sets an RPM deadband, soft limiters start this many RPM below the hard limit. If fuel cut is enabled, then the 
RPMs must fall by this much before fuel is re-enabled. A number of hundred RPM is suggested.

8.3.2 Coolant Temp Limiter

Rev Limiter CLT based

Enables optional coolant based rev limiter, so that the rev limit can be lowered when the engine is cold. The 
curve on the right hand of the screen (or the values for Coolant Temperature and Rev Limits) can be customized
either by dragging the points on the curve or entering values into the table. This sets the hard limit at your 
chosen temperatures.

Rev Limit TPS Bypass (TPS %)

Above this TPS% the coolant curve is ignored. This should be set to a high percentage, so that only in an 
emergency when you really need full throttle on a cold engine can you override the cold limit. Or set to over 
100% so that the limit in the curve is always used whatever the throttle position.

RPM When In TPS Bypass (RPM)

Rev limit when the TPS bypass limit has been passed. This is the full throttle hard rev limit and bypasses the 
coolant limit curve.

8.3.3 Spark Retard

Spark Retard Mode

There are four options for spark retardation to limit revs:

• Off – no spark retard used;

• Progressive retard – timing is progressively retarded above the set RPM;

• Fixed angle – above the soft RPM, the timing is immediately changed to this angle.

Maximum Retard (deg)

Maximum timing retard for progressive retard mode

Retard to (deg)

Timing value used in fixed angle mode.

8.3.4 Spark Cut and Fuel Cut

Enable Spark Cut Limiting

Enables spark-cut limiting (will not work with EDIS, TFI or GMDIS.)
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If enabled this option can cause catalyst damage and is noisy in operation.

Enable Fuel Cut Limiting

Whether fuel-cut rev limiting is enabled.

Progressive fuel cut

Enables a progressive non-rotational fuel cut that drops cylinders as revs rise between the lower and hard fuel 
cut limits. Requires Sequential/Semi-Sequential.

This option must not be used with staged or throttle-body injection.

8.4 Shift Light
Clicking Basic/Load Settings > Shift Light will display the following screen:

 

The options for these settings are described below:

Shift Light Output

Allows a specific output to be used to switch a shift light. (Do not also enable the same output in the generic 
on/off outputs.)

Per Gear Limit

Allows per-gear limits, can be useful to set a lower limit in lower gears to avoid overshooting.

Limit

The shift light is enabled above this RPM.

1st, 2nd, 3rd, 4th, 5th, 6th Gear Limit

When per-gear limits are enabled, these limits are used.
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8.5 Engine State Settings
Clicking Basic/Load Settings > Engine State Settings will display the following screen:

 

Use VSS

When VSS is enabled for engine states, this setting should be set just above the vehicle speed where idle 
operation is desired.

VSS Threshold

Use VSS to help get more accurate engine state.

Used by Closed-loop idle control.

Fast acceleration threshold

When RPMdot is above this threshold, your engine is considered to be accelerating quickly. This should be set 
to slightly below what is normal for WOT in a low gear.

Used by Closed-loop idle control, idle-VE and idle-advance.

Slow acceleration threshold

Between this value for RPMdot and the fast accel threshold, your engine is accelerating slowly. It should be set 
as low as possible to catch all actual acceleration, but not set so low that it catches RPM jitter.

Used by Closed-loop idle control, idle-VE and idle-advance.

Fast deceleration threshold

Below this value for RPMdot, your engine is decelerating fast. This should be set to a value that is slightly above
the RPMdot when you rev high and then let the engine fall back to idle. Use an RPMdot value from the middle of
the rev range.

Used by Closed-loop idle conBelow this threshold, as long as the engine is at least slowly decelerating, the 
engine is considered to be in overrun.

Used for overrun fuel-cut.trol, idle-VE and idle-advance, idle-VE, idle-advance and overrun fuel-cut.
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Slow deceleration threshold

Between this value for RPMdot and the fast threshold, your engine is decelerating slowly. To set this, cruise in a 
high gear, then see what RPMdot value you get by lifting off the throttle fully and decelerating. Set this value 
slightly above that RPMdot value.

Used by Closed-loop idle control, idle-VE and idle-advance, idle-VE, idle-advance and overrun fuel-cut.

Throttle closed TPS threshold

Below this threshold your throttle is considered to be closed.

Used by Closed-loop idle control, idle-VE and idle-advance, idle-VE, idle-advance and overrun fuel-cut.

Wide-open throttle threshold

Below this threshold your throttle iBelow this threshold, as long as the engine is at least slowly decelerating, the 
engine is considered to be in overrun.

Used for overrun fuel-cut.s considered to be closed.

Used by Closed-loop idle control, idle-VE and idle-advance, idle-VE, idle-advance and overrun fuel-cut.

Overrun MAP threshold

Below this threshold, as long as the engine is at least slowly decelerating, the engine is considered to be in 
overrun.

Used for overrun fuel-cut.

Indicators

The indicators at the bottom of the page show which engine state is currently active.

8.6 Tacho Output
Clicking Basic/Load Settings > Tacho Output will display the following screen:

 

The options for these settings are described below:

Tacho Output Enabled

Enables the tacho output.

Output On

Selects the output pin.
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Fixed or variable

• Fixed - use a fixed tachometer scaling of full speed or half-speed

• Variable - fully variable tachometer scaling

Speed

Can be set to one of two options:

• Normal – an output pulse is generated matching each cylinder event, i.e.,  4 cylinder engines have 4 
pulses per engine cycle;

• Half speed – output runs at half speed. This can enable a 4-cylinder tacho to be used on an 8-cylinder 
engine.

Scaling

Percentage scaling of tachometer output. 100% means a true output. Adjust up or down to correct for 
inaccuracies in your tachometer or to allow for different cylinder count between tacho and engine.

8.7 Fan Control
Clicking Basic/Load Settings > Fan Control will display the following screen:

 

The options for these settings are described below:
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Fan Control On

Enables fan control

Fan Control Idles up?

Whether the fan activation should also raise the idle.

Output Pin

Selects the output pin for the fan relay.

Idle-up Delay

How long to wait after raising idle before turning on fan. (If fan control idles up is enabled.)

Idle-up Duty

PWM open-loop duty cycle to increase by before activating fan. (If fan control idles up is enabled and PWM idle 
control is enabled.)

Idle-up Steps

Additional Stepper-Idle steps to increase by before activating fan. (If fan control idles up is enabled and stepper 
idle control is enabled.)

Idle-up Target Increase

Target RPM to increase by.  (If fan control idles up is enabled and closed-loop idle control enabled.)

Fan On Temperature

Turn fan on above this temperature.

Fan Off Temperature

Turn fan of below this temperature. (Must be lower than "on" temperature.)

Allow fan When Engine Off

Allows fan to run in key-on, engine-off situation.

Fan On With AC On

Whether the fan should be automatically turned on to help cool the A/C radiator.

TPS Shutoff Enable

Whether TPS is used to shutdown the fan.

TPS Shutoff

Disable fan above this TPS% (reduces load on engine when max power desired.) Set to over 100% to disable 
shutoff. 

TPS Hysteresis

Deadband of TPS% for shutoff. Typically set to 5-10%.

VSS Shutoff Enable

Whether VSS is used to shutdown the fan.
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VSS Shutoff

Disable fan above this vehicle speed (at high speeds airflow through radiator will be sufficient on its own.)

VSS Hyst

Deadband of VSS. Typically set to a 5-10 mph/kph.

8.8 Torque Convertor Lockup
Clicking Basic/Load Settings > Torque Convertor Lockup will display the following screen:

 

The options for these settings are described below:

Output Pin

Enables the Torque Convertor Lockup feature and selects the output port to connect to lockup solenoid.

Enable Input

Selects an optional input port for enable switch (could be used for 4th gear pressure switch.) 

Brake Switch

Selects optional input port for brake light switch (brake light unlocks convertor.) 

Minimum TPS

Minimum TPS to enable lockup.

Maximum TPS

Maximum TPS to enable lockup.
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Minimum MAP

Minimum MAP to enable lockup.

Maximum MAP

Maximum MAP to enable lockup.

Use VSS

Optionally allow VSS1 or VSS2 speed input as criteria to enable lockup.

Minimum Speed

Sets minimum speed for lockup. (Requires VSS input in speed/gear sensors.)

Use Gear Value

Optionally allows gear number as criteria. (Requires gear to be enable in speed/gear sensors.) 

Minimum Gear

Minimum gear to enable lockup.

Activation Delay

Wait this long after conditions are met before locking up.
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8.9 Alternator Control
Clicking Basic/Load Settings > Alternator Control will display the following screen:

The options for these settings are described below, but also refer to your Hardware Manual manual which has 
more general details and wiring schemes.

Control Mode

Control mode for alternator.

• Off = disabled

• On-Off = most basic control, typically on the 'L' lamp terminal

• Open-loop frequency = Frequency applied sets target voltage (Ford)
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• Open-loop duty = Duty cycle applied sets target voltage (GM)

• Closed-loop field control = MS3 uses a closed-loop algorithm to control the alternator field to target a 
voltage (obsoleter)

• High-speed feedback field switching = MS3 monitors the voltage at 20kHz and switches the field on or 
off to match the monitored voltage to the target voltage. (99-05 Miata, Chrysler or any direct field 
control)

Control Interval

How often to run the control calculations.

Control Output

Output connection to the alternator.

Output Polarity

Whether a positive or negative active edge is used.

Control Frequency

Frequency used for control output signal.

Warning Lamp Output

Output for charge/warning light.

Warn on Voltage Difference

Light warning lamp if actual voltage is too far away from target.

Load Monitor Input

PWM digital input from alternator as load sense - often the 'F' terminal.

Capture Polarity

Whether a positive or negative capture edge is used.

Warn on Load

Light warning lamp if sensed load is above this limit.

Current Monitor Input

PWM digital input used for monitoring battery current. (Display only.)

Capture Polarity

Whether a positive or negative capture edge is used.

Start Delay

How long after start before alternator control is enabled. Allows engine to stabilise before alternator load is 
applied.

Ramp Up Time

Time to ramp up to target voltage. (Not available in on/off mode.)
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Battery Temperature Input

If used, specifies a Generic Sensor that is configured for battery temperature. The temperature is then used to 
lookup a target charging voltage from the upper curve.

Charge Mode Target Voltage

Target voltage when in 'Charge' mode

Charge Time

How long after start is considered 'Charge' before transitioning to 'Run' mode.

Run Mode Target Voltage

Target voltage during 'Run' mode.

WOT TPS%

TPS% to trigger Wide Open Throttle (WOT) mode

WOT Target Voltage

Target voltage when in WOT mode, typically set lower than normal to free up some engine power.

WOT Timeout

Timeout before WOT mode ends and target voltage returns to charge or run mode.

Over-Run Target Voltage

Target voltage when over-run fuel cut is active. Setting a slightly higher voltage here will give a minor 
'regenerative braking' effect.
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8.10 Barometric Correction
Clicking Basic/Load Settings > Barometric Correction will display the following screen:

 

There are two ways that barometric correction may be used:

• The current way – on the MAP/Baro page the 'At total vacuum' and 'rate' numbers must be set to zero. 
This curve is then normally 100% at all points and adjusted up or down to alter fueling based on the 
barometer reading;

• The old way – the two numbers are set to 147 and -47 and the curve is normally 0% at all points.
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This setting is only enabled if all of the following settings are active

• Barometric correct is enabled (not set to 'None'.)

8.11 MAP Sample Settings
Clicking Basic/Load Settings > MAP Sample Settings will display the following screen:

 

The options for these settings are described below:

MAP Sample Method

There are two settings for this option:

• “Use event average” is useful for most engines;

• “Use timed min” is intended for 1 cylinder or V twins with highly cyclic MAP signals.

MAP Sample Window (deg)

How many degrees to sample over.

No. Sample Events

How many ignition events to sample over. Typically set to 1 for large engines, or set to 2 for single or twin 
cylinder engines.
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Phase Detect Threshold (kPa)

This setting is only enabled if all of the following settings are active – the last three of these settings are 
options within the Ignition Options / Wheel decoder screen, see section 10.1:

• You have a 1 or 2 cylinder engine;

• You are using “Toothed wheel” as spark mode;

• You have using “MAP sensor” for your Cam Input;

• You are using “Dual wheel with missing tooth” for your Trigger Wheel arrangement.

When using the MAP sensor to detect engine phase, this sets a pressure threshold that can identify the intake 
versus the exhaust phases. This will be highly engine dependent: 80kPa worked on a small 1 cylinder engine.

MAP sample timing

This curve sets the start of the sample window in degrees BTDC for each ignition event. The number must 
always be less than the number of degrees per event. (720 / num_cyls for a 4 stroke i.e. for 4cyl there are 
180deg per event, for 8cyl there are 90deg.) 

8.12 ITB Load Settings

The ITB Load Settings menu option is only enabled if ITB is selected as the control algorithm in Engine 
and Sequential Settings (see Section 8.2. of this guide.)

Clicking Basic/Load Settings > ITB Load Settings will display the following screen:

 

The left hand curve defines the TPS value where the MAP load reaches %Baro switchpoint. This curve will be 
different for each engine and should be set up using values obtained from log files from your engine. Setting this
curve is an important part of ITB mode.

The right hand curve is used to allocate the bins on the VE table to either Speed-Density or Alpha-N tuning. The 
area of the VE table below the load value from the curve will be used for Speed-Density tuning and the area 
above the curve will be used for Alpha-N tuning. It is recommended that the "ITB load at TPS switchpoint" curve 
be set to 50% at all RPMs.
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If either of these curves are changed then the VE table will need to be re-tuned.

%Baro switchpoint

Above this MAP value, tuning switches from MAP based to TPS based. Default is 90% and works for most 
engines.

Idle TPS Threshold %

This setting defines the minimum TPS value required to allow the transition to Alpha-N tuning. This feature 
allows the fast idle MAP to exceed the %Baro switchpoint without entering Alpha-N mode. On engines with 
aggressive cams with higher overlap, it is possible for the fast idle MAP to exceed the %Baro switchpoint. When
this happens, you do not want to enter Alpha-N mode tuning since the throttle is still reading fully closed. The 
Idle TPS Threshold % prevents you entering Alpha-N mode and you can use the warm up enrichment curve to 
compensate for any tuning errors caused by being stuck at the maximum Speed-Density bin while the MAP is 
greater than the %Baro switchpoint. 

8.13 MAF Settings
Clicking Basic/Load Settings > MAF Settings will display the following screen: 

 

The options for these settings are described below:

Sensor Type

Selects the MAF sensor type.

• Voltage - a 0-5V analogue input - most MAFs

• Frequency - some GM sensors on GM vehicles

• Off - disables the MAF input.

Voltage Input Port

Selects the analogue input pin where the MAF is connected.
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Frequency Input Port

Selects the frequency input pin where the MAF is connected.

Low frequency

The frequency the MAF outputs to indicate least air flow.

High frequency

The frequency the MAF outputs to indicate greatest air flow.

MAT Correction Curve

Optionally enables a trim curve based on MAT sensor input.

Use VE1 As Trim Table

Optionally enables VE table 1 as a trim table. Fill the table with 100% to begin with.

MAF Sensor Range

Sets the range to match your MAF sensor. On gasoline, 650g/s ~800hp; 1300g/s ~1600hp; 1950g/s ~2400hp 
and 2600g/s ~3200hp. Use the lowest range suitable for better low-end precision.

Always set this range before loading a MAF calibration curve.

In firmware 1.5.x support for the old-style curve has been removed.
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8.14 MAF Flow Curve

The MAF Flow Curve menu option is disabled if “Sensor Type” in the previous section is set to “Off”.

Clicking Basic / Load Settings > MAF Flow Curve will display the following screen:

  

This curve specifies grammes/sec versus frequency or voltage. Start out with the actual flow curve for your MAF
sensor and then 'tweak' to tune it to your install.

The Lite version of TunerStudio does not provide a method to load in the example flow curves provided in the 
tune_files directory of the firmware zip.

8.15 MAF/MAT Correction Table

To enable the MAF/MAT Correction Table menu option you must:

• Set a value for “Voltage input port” in MAF Settings to a value other than off (see Section 8.13.); 

• Set “MAT Correction Curve” in MAF Settings to “On” (see Section 8.13);

• Use MAF as either the Primary or Secondary Fuel Load in General Settings (see Section 8.2.)

Clicking Basic/Load Settings > MAF/MAT Correction table will display the following screen:
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This curve allows for minor corrections to fueling based on manifold air temperature (MAT) when using MAF to 
control fueling. The default curve is 0% meaning no correction.

8.16 MAT Air Density Table

To enable the MAT Air Density Table menu option you must not use MAF as either Primary or Secondary 
Fuel Loads (see Section 8.2.)

Clicking Basic/Load Settings > MAT air density table will display the following screen:

  

This curve is the whole air density correction exposed in full. It is based on the 'ideal gas law' and typically 
varies between 125% cold to 75% hot.
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Note that obsolete firmware 1.1.x used this curve as a correction factor on top of an internal calculation.

8.17 MAT / CLT correction

To enable the MAT / CLT correction menu option you must not use MAF as either Primary or Secondary 
Fuel Loads (see Section 8.2.)

Clicking Basic/Load Settings > MAT / CLT correction will display the following screen:

 

The curve is the %CLT blended into the MAT reading vs. airflow.

In theory, at zero airflow the air temperature in the intake manifold will reach the manifold (coolant) temperature. 
At infinite airflow, the air will be unaffected by the temperature of the manifold.

The curve is setup to give the 'best estimate' of intake air temperature as part of the speed-density fuel 
calculation.

It would be expected that some CLT should be blended in at low airflows, falling away rapidly to close to zero at 
higher airflows.

When first enabling this curve it will be necessary to adjust the VE values at low RPMs as they will have been 
compensating for the air density change.
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8.18 Real-Time Display
Clicking Basic/Load Settings > Real Time Display will display the following screen:

   

This screen shows real-time information for many of the key sensors for your Megasquirt. For further detail click 
the “All Output Channels” tab at at the bottom left to display a full list of variables, as shown below:

  

The fuel and spark calculations summaries in sections 9.20 and 10.17 are likely to be more helpful.
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8.19 Feature List Showing I/O Pins
Clicking Basic/Load Settings > Feature List Showing I/O Pins will show a screen similar to that shown in the 
following image:

  

Depending on your engine and how you have configured your Megasquirt there are many different 
options which could be enabled with a wide variety of settings.

This screen is for information only and settings cannot be changed using this part of the software.

This screen is useful as it shows a summary of your configuration which can be useful for analysis and 
troubleshooting. 
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8.20 I/O pins List Showing Usage
Clicking Basic/Load Settings > I/O pins List Showing Usage will show a screen similar to that shown in the 
following image:

 

Depending on your engine and how you have configured your Megasquirt there are many different 
options which could be enabled with a wide variety of settings.

This screen is for information only and settings cannot be changed using this part of the software.

You must be connected to your Megasquirt with the power on for this screen to work.

This screen is useful as it shows a summary of your configuration and which inputs or outputs are presently 
used and which are free. 
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8.21 Expansion I/O pins List/Usage
Clicking Basic/Load Settings > Expansion I/O pins List/Usage will show a screen similar to that shown in the 
following image:

 

Depending on your engine and how you have configured your Megasquirt there are many different 
options which could be enabled with a wide variety of settings.

This screen is for information only and settings cannot be changed using this part of the software.

You must be connected to your Megasquirt with the power on for this screen to work.

This screen is useful as it shows a summary of your configuration and which inputs or outputs are presently 
used and which are free. 
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8.22 Gauge and Settings Limits
Clicking Basic/Load Settings > Gauge and Settings Limits displays the following screen:

  

Changing these settings does not alter the behavior of your engine in any way, they ONLY change the 
limits which can be displayed on the screen and set the threshold limits for your tune.

 
This screen allows you to set the limits on the gauges within the main gauge cluster. The default settings are for 
cars, bike users will certainly need to change the limits available.

The options for these settings are outlined below:

RPM – Max (rpm)

The maximum for RPM on gauges, tables, curves and entry boxes. Adjust to suit your engine.

RPM – Warn Level (rpm)

The RPM 'warning' on gauges – displayed in yellow on the gauge.

RPM – Danger Level(rpm)

The RPM 'danger' on gauges – displayed in red on the gauge.

Load/kPa – Max

The maximum 'load' value, e.g., kPa on gauges, tables, curves and entry boxes.

VE Value max

The maximum for VE values.

Allow WUE Below 100% (only for LPG)

For most installs, setting warmup enrichment (WUE) to below 100% indicates a serious tuning mistake and the 
code will flag up a 'Configuration Error' to alert the user. In rare conditions such as using LPG (propane) for fuel,
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it can be valid. This setting disables the Config Error warning message.

Preferred Speed Units

Chooses the speed units - either Mile-per-hour or Kilometres-per-hour

Preferred Length Units

Chooses the size units - either metres or inches.

Air-cooled Expanded CLT Range

Allows gauges and curves to use an expanded coolant temperature range for air-cooled engines using the CLT 
sensor to measure oil or head temperature.

Once these settings have been changed it is necessary to close and restart TunerStudio for the changes 
to be reflected in the gauge cluster.
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9 Fuel Settings
Ensuring that you have the correct fuel settings is essential in terms of achieving an effective tune for your 
Megasquirt.

The Fuel Settings toolbar menu deals with the many options that are supported, including injection settings and 
timing, fuel sensor settings, automated fuel cut off, exhaust gas oxygen sensors, air fuel ratio tables, fuel 
volumetric efficiency tables and trim tables, and injector sequencing.

The following sections deal with these settings and options.

9.1 Injector Dead-time / PWM
The dead time (or offset) of an injector is effectively the portion of the pulsewidth when no fuel is injected, this is 
because the injector is an electro-mechanical valve and takes a measurable time to open and close. (Note that 
some older documentation referred to this as just "opening time".)

Clicking Fuel Settings > Injector Dead-time / PWM displays the following screen:

 

There are three main areas on this page:

• The sequential (MS3X) injector settings 
• The non-sequential mainboard injector settings (not MS3-Pro)
• The voltage correction curves. These allow fine tuning the battery voltage correction of the dead time. 

The options for these settings are described below:

Inj Parameters

This selects whether the same or individual injector parameters should be set. Most installs with a single set of 
squential injectors should use "same". Installs using staged injection or dual fuel with two different types of 
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injector connected can configure each injector.

• Same = one dead-time across all injectors. Recommended setting.

• Individual = the dead time for each injector is set individually.

Injector Dead Time @ 100% (ms)

This column of values sets the injector dead time per injector or for all injectors.

 Typically settings:

• High impedance injectors - dead time = 0.8-1.0 ms 

• Low impedance injectors with resistors - dead time = 0.8-0.9 ms 

• Low impedance injectors with external peak/hold - dead time = 0.6-0.8 ms

Voltage Dead Time Curve

This column of values sets the voltage correction curve to use per injector or for all injectors.

Recommended - select Curve 1 and leave the curve alone.

Dead Time Voltage % Curves

These four curves allow the fine tuning of the dead-time voltage correction. You will typically need to determine 
this experimentally for your exact injectors with the Megasquirt.

The curve must be 100% at the injector calibration voltage.

i.e. if you have dead-time data for XXX volts, then ensure that XXX volts gives 100% in the curve and 
enter the stated dead-time in the dead-time field. The default curves uses 13.2V but there is nothing 
special about this number.

The following settings only apply to the batch-fire mainboard injectors on a V3.0/V3.57 mainboard:

Bank 1 Injector Dead Time @ 100% (ms)

Injector dead time. Typically 0.7ms for low-z (~2.5ohm) and 0.9ms for high-z (~14ohm.)

Correction Curve

This column of values sets the voltage correction curve to use per injector or for all injectors.

PWM Current Limiting

Enables PWM (peak and hold) current limiting for low-z injectors. 

PWM Current Limit (%)

This is the 'hold' percentage current. 30-50% is typical.

PWM Time Threshold (%)

The full-current 'peak' time at the beginning of each pulse and is typically set to 1-1.5ms.

Injector PWM Period (us)

The period/frequency during the hold phase. Safe to leave at 66us.
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Different Bank Settings

Enables different settings for a second bank of injectors. Set to “Off” unless you have installed different injectors 
and are using Staged Injection.

9.2 Injector Small Pulsewidths
At most pulsewidths (say above 2ms) injectors behave in a linear manner, where 10% increase in effective 
pulsewidth gives a 10% increase in fuel flow. This linear behaviour is relied upon in the Megasquirt fuel 
calculations. 
However, at small pulsewidths, injectors behave non-linearly. The Injector Small Pulsewidths feature allows the 
user to make a correction and make the non-linear region more linear in nature. 

Clicking Fuel Settings > Injector Small Pulsewidths displays the following screen:

 

The options for these settings are outlined below:

Enable Non-Linear Small Pulsewidths

This enables or disables the feature. Unless you have calibration data for your injectors measured on your 
Megasquirt, this feature should be left turned off. 

Curve selection

Each injector can be set to use one of the four small pulsewidth curves.

Small Pulsewidth Curves

The X-axis of the curve is the Megasquirt pulsewidth (before deadtime is applied) and the Y-axis is the required 
injector pulsewidth (before deadtime) that the injector needs to approximate linearity. 

The start and end point pairs must be equal. e.g. 0.0ms, 0.0ms and 2.0ms,2.0ms

9.3 Injector Timing Tables
These tables allow you to set values for injection timing in degrees BTDC vs load/RPM. Conventional wisdom 
says that the injection event should finish just as the inlet valve is opening. This corresponds to around 360 
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BTDC as the timing is measured with respect to the spark event. Actual best timing can be determined by 
testing on a dyno or through road testing.

Injection Timing Table 1

The Injection Timing Table 1 menu option is only enabled if:

• The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports 
sequential ignition settings, i.e., NOT EDIS, EDIS Multispark, Basic trigger, Trigger return or 
some of the highly specific engine spark modes.

• AND “Sequential Injection” has been configured to “Sequential" or "Semi-sequential” (see 
section 8.1.2.)

 
Clicking Fuel Settings > Injection Timing Table 1 displays the following screen:

  

This is the main Injection Timing Table.

For details of how to use tables of this type see Section 1.5.3.

Secondary Injection Timing Table

The Injection Timing Table 2 menu option is only enabled if:

• The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports 
sequential ignition settings, i.e., NOT EDIS, EDIS Multispark, Basic trigger, Trigger return or 
some of the highly specific engine spark modes;

• AND “Staged Injection” has been enabled (see section 9.4.)

Clicking Fuel Settings > Secondary Injection Timing Table displays a screen almost identical to that shown 
above and which holds separate data.
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This Secondary Injection Timing Table is used alongside the Injection Timing Table 1 for the Staged 
Injection outputs.

9.4 Staged Injection
Clicking Fuel Settings > Staged Injection displays the following screen:

 

The options for these settings are outlined below:

Staged Ignition First Parameter

This setting enables staged injection and sets the primary staging parameter which is used to determine when 
to engage the secondary injectors. When using Staged Injection, the "Table" option is recommended.

• Off - Staging disabled.

• RPM - Stage at a specific RPM.

• MAP - Stage at a specific MAP.

• TPS - Stage at a specific throttle position.

• Duty - Stage at a specific primary injector duty cycle.
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• Table - Stage based on the table included in the dialog. (Recommended.)

Primary Injector Size (cc)

The size of each of your main/primary injectors in cc/min (typical conversion from lbs/hr is multiply by 10.5)

Secondary injector size (cc)

Size of secondary injectors in cc/min.

Transition fully to secondaries

This setting is used to determine whether the fully staged state means that the primary and secondary pulse-
widths are equal, or if the fully staged state means that primaries are shut down completely and staging 
transitions fully to the secondary injectors. The following settings are possible:

• Off - The fully staged state (100%) means the pulse-width on both the primaries and the secondaries 
is the same, and the pulsewidth is adjusted so that the total mass of fuel (grams) delivered by all 
injectors is equal to the theoretical mass of fuel that would be delivered by only the primary injectors if
the secondaries were not engaged. 

• On - The fully staged state means that the pulse-width on the primary injectors will be 0, and the full 
mass (grams) of fuel that would normally be delivered by the primaries will be delivered by the 
secondaries instead. If the secondaries are larger than the primaries, then the final pulse-width will 
end up smaller than the primary-only pulse-width. 

- For either method, the total mass of fuel (grams) when between 0% staged and 100% staged will be 
maintained at the same amount as if all the fuel were being delivered by the primary injectors, and the 
secondaries were not engaged. 

This way the commanded staging percent from the staging table can be adjusted without needing to readjust 
the VE table to maintain the proper amount of fuel being injected. 

Secondary Outputs

This setting controls whether the MS3X outputs are used for secondaries or the mainboard "V3" board outputs 
are used. This option is only available with 4 or less cylinders. The following options are possible:

• Use MS3x (if possible) - Use the sequential (MS3X) outputs if it is possible to do so.

•  Use V3 - Use the batch-fire board outputs.

Secondary V3 Alternate

This setting controls whether the secondaries (when using the V3 board outputs) alternate between injector 
channel 1 and injector channel 2, or inject simultaneously on injector channel 1 and injector channel 2. The 
following settings are available:

• Alternating (2 squirts) - Alternate between injector channel 1 and injector channel 2. Note that when 
in alternating mode, there are 2 squirts per cycle.

• Simultaneous (1 squirt) - Squirt fuel on injector channel 1 and injector channel 2 simultaneously. Note
that when in simultaneous mode, there is 1 squirt per cycle.

Gradual Transition

Allows a gradual transition into staging instead of a hard switch point.

Transition Events (ign events)

How many ignition events it will take to go from no staging to fully staged.
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Primary Reduction Delay (ign events)

Delays the reduction of the primary pulsewidth by a number of ignition events after the secondaries start coming
online. (Useful if the secondaries are mounted further upstream.)

Secondary Enrichment (ms)

This setting is used to inject more fuel on the secondaries than the fully staged calculation determines. This is 
useful when there is a small lean spot just after staged injection fully engages.

Primary Staging Thresholds (units)

Used to determine when staged injection engages when using RPM, MAP, TPS, or Duty.

Primary Staging Hysteresis (units)

Used as a deadband to determine when staged injection shuts off.

Second Parameter

This setting is used to add a second method for determining when to stage.

Secondary Staging Threshold (units)

Used to determine when staged injection engages when using RPM, MAP, TPS, or Duty.

Secondary Staging Hysteresis (units)

Used as a deadband to determine when staged injection shuts off.

Secondary Staging Logic

Whether both parameters or either parameter will enable staging.

Relay Output

Use a relay output to enable secondary injectors (GM systems) where primary and secondary injectors are 
wired to the same injector output.

Relay Output Polarity

Allows output polarity sense to be swapped

Pre-Relay Output

Use a relay output earlier than secondary injectors (GM air-flaps).

Pre-Relay Output Polarity

Allows output polarity sense to be swapped.

Pre-Relay Timer

How long the pre-output is active before the staging transition begins.

Staging Table

The table-based method allows for smooth transitions in and out of staged mode.

The values in the table determine the percent staged, 0% means not staged at all, 100% means fully staged, 
and a percentage value between means that injection is partially staged.
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Typically you would set to 0% around idle and low load regions and 100% under full load and higher RPMs.

9.5 Fuel Sensor Settings (Flex)
The flex fuel system allows the use of E85 or other ethanol and petroleum blended fuel mixes to be used when 
a fuel composition sensor is fitted.

Clicking Fuel Settings > Fuel Sensor Settings (Flex) displays the following screen:

 

The options for these settings are outlined below:

Flex Fuel Sensor 

This enables or disables the Flex Fuel system.

Sensor Port

Selects where the flex sensor is connected.

Temperature Input

Selects whether an optional fuel temperature sensor is connected. This is fuel_temp1.

• Off - do not read fuel temperature

• Flex - use the temperature encoded in the flex sensor signal.

• Sensor01..08 - take a temperature reading from the Generic Sensors system.

Sensor Frequency

Low – The low frequency generated by the sensor (e.g., 50Hz for the GM sensor.)

High – The high frequency generated by the sensor (e.g., 150Hz for the GM sensor.)
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Ethanol Mix

Low – The ethanol percentage corresponding to the low frequency.

High – The ethanol percentage corresponding to the high frequency.

Fuel Multiplier %

(100% means no change.)

Low – The fuel multiplier. The default of 100% for 0% ethanol gives 0% additional fuel.

High – The fuel multiplier. The default of 163% for 100% ethanol gives 63% additional fuel.

Timing Addition

Low – The timing addition in degrees at low frequency.

High – The timing addition in degrees at high frequency. (E85 burns more slowly than pure gasoline and will 
require more advance.)

Baseline Ethanol %

Ethanol percentage in regular fuel (assumes that the main fuel and spark tables are tuned for regular fuel.) 
Allows flex fuel system to be enabled without retuning base tables. Set to 0 for backwards compatibility.

Fallback Fuel Multiplier %

Multiplier to be used if the sensor sends an out of range frequency (faulty sensor or an error condition.)

Fallback Timing Addition (deg)

Timing to add under fault conditions (expected to be 0 or negative.)

Dual Fuel Mode

This read-only field shows whether flex-blending is enabled on the Dual Fuel page.
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9.6 Over-Run Fuel Cut
Clicking Fuel Settings > Over-run Fuel Cut displays the following screen:

   

The options for these settings are outlined below:

Over-Run Fuel Cut

Over-run fuel cut is a method to totally cut off fuel during over-run situations such as coasting down a hill in gear.

Be sure to set the parameters so that it is only triggered under true over-run conditions and not during 
regular driving.

Be sure to configure your Engine State Settings as these are used to allow Over-run fuel cut.

And Coolant Greater Than (°F/°C)

Set this to prevent over-run operation on a cold engine.

After Delay (s)

The delay prevents jerky on/off operation during transients.

Progressive Fuel Cut

Allows sequential injectors to be cut progressively for a smoother activation.
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Do not use with staged injection.

Ignition Timing Transition (Cut)

Allows ignition timing transition during fuel cut to gradually reduce power for smoother activation.

Ignition Timing During Over-run

The ignition advance during overrun. Typically set to a low number or ATDC timing.

Cut Transition Time

Once main fuel cut delay timer has run, this sets a transition time from normal spark advance to the advance 
during overrun. The timer is also used for the progressive fuel cut.

Typically set a retarded timing for overrun with one second or so of time for smooth activation.

Progressive Fuel Return

Allows sequential injectors to be returned progressively for a smoother return. Does not make sense to use this 
with the accel-event option.

Do not use with staged injection.

Ignition Timing Transition Return

Allow ignition timing transition during fuel return to gradually increase power for a smoother transition.

Return Transition Time

This sets a transition time from overrun to normal conditions and is used with progressive spark return and 
progressive fuel return.

If the throttle is applied above the threshold, the fuel and timing are immediately returned cancelling this timer.

Lowest RPM to re-engage fuel

Allows a deadband of RPM for smoother operation. Typically set this a few hundred RPM below your minimum 
RPM setting.

RPMdot For Upper RPM Re-Engagement

When revs are falling more quickly than this RPMdot value the initial RPM is used for fuel return.

In-between upper and lower RPMdot values, the return RPM is interpolated. This number must be larger than 
the 'lower' RPMdot setting.

Typically 1000.

RPMdot For Lower RPM Re-Engagement

When revs are falling more slowly than this RPMdot value the lower RPM is used for fuel return. This will 
happen when coasting down.

If revs are falling more quickly then any return transitions will be cancelled and the return RPM will be raised.

Set this so that clutch-in during fuel cut does not stall.  Typically 500.

(The RPMdot shows negative in datalogs when revs are falling, so a setting of 500 means less negative than 
-500)
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Duration of Fuel Adder

The length of time that additional fuel is added after over-run ends to avoid a lean-spike.

Size of Fuel Adder

Fuel adder after over-run ends to avoid a lean-spike.

Delay EGO after fuel return (s)

Over-run will give a full-lean EGO reading and so closed-loop EGO should be disabled until a sensible reading 
is available. Set this long enough so that the EGO sensor is returning a true reading.

9.7 AFR/EGO Control
Clicking Fuel Settings > AFR/EGO Control displays the following screen:

   

Make sure you have set your Project Properties to match the type of lambda/O2 sensor you have - see 
section 2.1.6 and also calibrated your AFR table - see section 6.9.

The options for these settings are outlined below:

Algorithm

• Simple – This method of closed-loop EGO control is well-suited to use with a narrowband O2 sensor. 

• PID – This closed-loop method incorporates a Proportional Integral Derivative control-loop which (when 
tuned properly) adjusts the amount of fuel being injected to quickly get to the target, and then maintains 
the target without any oscillation.

• No correction – no fuel changes are made in response to oxygen sensor readings, but the sensors will 
be read and can be datalogged.
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Use EGO Delay Table

Specifies whether to use IGN events or delay table to determine how often EGO runs.

Ignition Events Per Step

The number of ignition events between each correction.

EGO Sensor Response Time

Static value representing O2 sensor response time which is added to the EGO delay table value.

Controller Step Size (%)

Controls how large each correction 'step' is.

Use Authority Table

Enables a table of EGO authority based on RPM/load. This allows greater control over when closed-loop EGO 
is operational and permits variable authority. An authority of zero means there will be no correction made. 
Normally the RPM and load axes should be set the same as the AFR tables.

Controller Auth +/- (%)

The maximum amount of adjustment performed by the closed-loop algorithm.

Only Correct Above

Only correct above this AFR. Used to ignore faulty sensor readings.

And Correct Below

Only correct below this AFR. Used to ignore faulty sensor readings.

Active Above Coolant (°F/°C)

Only make correction above this temperature.

Active Above RPM

Only make correction above this RPM.

Active Below TPS (%)

Only make correction below this throttle position.

Active Below Load (kPa)

Only make correction below this load.

Active Above Load (kPa)

Only make correction above this load.

EGO Delay After Start (sec)

Only make correction when engine has been running at least this long.

PID Proportional Gain (%)

Proportional term.
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PID Integral (%)

Integral term.

PID Derivative (%)

Differential term.

EGO Sensor Type

• Disabled – No EGO sensor enabled;

• Narrowband – Enable narrowband sensor(s);

• Wideband – Enable wideband sensor(s).

Number of Sensors

Selects the number of oxygen sensors in use.

EGO Ports

For each EGO channel, selects where the sensor is connected.

AFR / EGO Sensor Mapping

Specifies which EGO sensor corresponds to each injector channel so that closed-loop corrections will alter the 
correct injectors.

e.g. on a V8 with one EGO sensor per bank, half of the injectors influence EGO1 and the other half influence 
EGO2. 

9.8 AFR Tables (1 and 2)
The AFR Tables allow you to set values for target AFR vs RPM/load.

When 'Incorporate AFR' is set to “off” (see Section 8.2.4.) this is a reference table only. When 
'Incorporate AFR' is set to “on”, this table is included in the fuel calculation.

 

If you intend to use these tables please ensure that you set its values before you begin tuning.
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AFR Table 1

Clicking Fuel Settings > AFR Table 1 displays the following screen:

  

For details of how to use tables of this type see Section 1.5.3.

AFR Table 2

The AFR Table 2 menu option is only enabled if using Dual Fuel, AFR table switching, AFR table blending
or through the Nitrous system.

 
Clicking Fuel Settings > AFR Table 2 displays a screen which looks almost identical to that shown above and 
which holds separate data.

9.9 EGO Authority Table
Specifies the EGO authority limit across the range of engine operation condition. Setting zero means there will 
be no change in fuel based on the lambda sensor i.e. open-loop mode. 

Clicking Fuel Settings >EGO Authority Table displays the following screen:

 

For details of how to use tables of this type see Section 1.5.3.
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9.10 EGO Delay Table
Table which specifies the delay between runs of the EGO algorithm in ms to compensate for differing exhaust 
gas velocities.

Clicking Fuel Settings >EGO Delay Table displays the following screen:

 

For details of how to use tables of this type see Section 1.5.3.

9.11 Narrowband EGO Targets
The target narrowband lamba sensor voltage vs. load/RPM.

Clicking Fuel Settings >EGO Delay Table displays the following screen:

 

For details of how to use tables of this type see Section 1.5.3.

9.12 AFR Safety System
The "AFR Safety" System is designed to help you protect your engine from unwanted dangerous lean 
conditions. Typically this will be used for wide open throttle and/or boosted conditions. It only makes sense to 
use this feature with a wideband lambda sensor on an already well tuned engine.

The system compares the wideband EGO input against your existing AFR target table and a safety limit 
difference table.

If the AFR is leaner then your different table allows beyond a time you specify, the engine will be shutdown as a 
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protective measure until you get out of boost, off the throttle and down in revs.

This system will only work if configured correctly and will not protect your engine against bad tuning or 
knock! However, it is likely it would detect a failing fuel pump or regulator. A single faulty injector could 
easily go un-noticed with a single wideband reading the average AFR.

This shutdown mechanism is shared with the EGT over-temperature settings. 

Clicking Fuel Settings > AFR Safety System displays the following screen:

 

The options for these settings are outlined below:

Enable AFR Safety

This enables or disables the system

Warning output

This can be used to turn on an output as soon as an over-lean condition is detected.

Load axis

Typically choose MAP if running speed-density or TPS if running Alpha-N

Check above load

The system only checks the AFR above this load.

Check above RPM

The system only checks the AFR above this RPM.

Wait for

This delay allows for a brief lean-spike without tripping the shutdown. Set as low as possible.
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Kill spark for

Intially spark is cut for this time and then fuel as well.

TPS below, MAP below, RPM below

Normal engine operation resumes when all three conditions are met.

AFR Difference Table

The table on the right is the "safety limit" difference table. This number is added to the current target AFR. If the 
actual AFR is leaner (larger), then the safety shutdown countdown begins.

9.13 Fuel VE Tables (1 to 4)
The three Fuel VE tables allow you to set values for volumetric efficiency (VE) at a range of points depending on
rpm and fuelload. Larger VE values correspond to more fuel, smaller values correspond to less fuel.

Fuel VE Table 1

Clicking Fuel Settings > Fuel VE Table 1 displays the following screen:

 

This is the main fuel table [VE1].

In MAF mode, this table operates as a trim table and should initially be filled with 100% in all cells.

For details of how to use tables of this type see Section 1.5.3.

Fuel VE Table 2

This secondary Fuel VE table [VE2] is used as a blend table with VE1.

The Fuel VE Table 2 menu option is only enabled if a Secondary Fuel Load source has been selected 
(see Section 8.2.4.)

 
Clicking Fuel Settings > Fuel VE Table 2 displays a screen which looks almost identical to that shown above and
which holds separate data.

Fuel VE Table 3

This Fuel VE table [VE3] can be used as:
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• a dual fuel main table for the secondary fuel.

• a table-switched alternative to VE1.

• blend table with VE1.

Table Blending and Switching is covered in section 14.1 and in the Setting Up manual.

Again, The Fuel VE Table 3 menu option is only enabled if:

• “Dual Fuel” is enabled (see Section 14.1.2.)

• OR: fuel table-switching is enabled

• OR: a blend table is enabled to VE1

Clicking Fuel Settings > Fuel VE Table 3 displays a screen almost identical to that shown above and which 
holds separate data..

Fuel VE Table 4

This Fuel VE table [VE4] is used as a blend table with VE3.

Again, The Fuel VE Table 4 menu option is only enabled if:

• Fuel VE Table 3 is already active

• AND: A Secondary Fuel Load source or blend has been selected that enables Fuel VE Table 2.

Clicking Fuel Settings > Fuel VE Table 4 displays a screen almost identical to that shown above and which 
holds separate data..

9.14 Injector Trim Tables
The InjectorTrim Tables allow you to specify a percentage multiplier for adjustment on the basic fuel pulsewidth 
to allow for difference per cylinder.

• 0% means no adjustment

• Positive numbers mean to add fuel to that cylinder or channel

• Negative numbers mean to add fuel to that cylinder or channel

(Note that this is different to Megasquirt-2 where 100% means no adjustment.)

Injector Trim Tables apply per cylinders and use the Firing Order table (see section 8.1.2) to determine which 
injector is linked to each cylinder.

Injector Trim Tables are only enabled if:

• The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports 
sequential ignition settings, i.e.,  NOT EDIS, EDIS Multispark, Basic trigger, Trigger return or 
some of the highly specific engine spark modes.

• AND “Sequential Injection” has been configured to use “Sequential injection” (see section 8.1.2.)

• AND “Injector Trim” has been set to “On” (see section 8.1.2.)

Injector 1 Trim

This is used with the first of the batch-fire outputs on the V3.0 or V3.57 mainboard and applies for 1 or 2 cylinder
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engines running sequential fuel only.

Clicking Fuel Settings > Injector 1 Trim displays the following screen:

 

Injector 2 Trim

This operates in the same was as Injector 1 Trim.

Cyl 1-4 Trims

This applies to the normal sequential fuel outputs. As mentioned above, the Firing Order needs to be set first.

 
Clicking Fuel Settings > Cyl 1-4 Trims 1 displays the following screen:

  

Changes made to the trim table for Cyl#1 will apply to the injector linked to cylinder #1 only.

For details of how to use tables of this type see Section 1.5.3.

Cyl 5+Trims

The trim tables for cylinders 5 upwards operate in the same manner.
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9.15  Sequenced Batch Fire

The Sequenced Batch Fire menu option is only enabled if “Sequential Injection” has been configured to 
use “Off” (see section 8.1.2.)

Clicking Fuel Settings > Sequenced Batch Fire displays the following screen:

  

This setting is provided for historical reasons, new customers should consider using semi-sequential or 
sequential fuel instead.

The options for these settings are described below:

Enable Sequenced Batch Fire

Sequenced batch fire can be useful to give more repeatable engine operation without sequential fuel. On every 
startup the batch firing is aligned to the same ignition event (cylinder) when a suitable tach-in signal is available 
(such as a toothed wheel.) Without this feature the alignment is random.

Injector Settings Start Trigger No.

Specifies the ignition 'trigger'. Typically try 0 or 1.

9.16 Fuel Pump and Pressure
This allows for control of the fuel pump and fuel pressure.

Clicking Fuel Settings > Fuel Pump and Pressure displays the following screen:
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The options for these settings are described below:

Fuel Pump Mode

• On/Off is used for basic control where the Megasquirt controls the negative side of a relay.

• Open-Loop PWM provides a table based duty cycle for a fuel pump controller.

• Closed-Loop PWM monitors actual rail pressure and adjusts the duty cycle output to the pump controller
to maintain a set differential pressure.

Control Interval

How often to run the control calculations

Fuel Pump Output

The output used to control the fuel pump (either to the relay or to a controller.)

When using On/Off control the output is always the dedicated "Fuel Pump" output.

When using PWM control, it is strongly recommended that fuel pump output be left controlling the fuel pump 
relay and a different output be used to supply the PWM signal to the pump controller.

Output Frequency

For PWM outputs, this sets the output frequency.

Fuel Pump Output Polarity

Allows the output signal to be inverted.
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Set to 'Normal' for On/Off.

This setting is useful for PWM outputs and should be set to 'Invert' when using one of the mid-current ECU 
outputs as they invert the signal in hardware. The Spark or Digital outputs do not invert the signal and 'Normal' 
should be used. Note that the on/off fuel pump output is always electrically a low-side driver and connects to the
negative side of the relay - changing this setting will have no impact on that. (i.e. the output will never become a 
12V output.)

Pressure Regulation/Correction

By preference, fuel systems use a vacuum/boost referenced regulator that maintains line pressure Xbar above 
inlet pressure. Some GM fuel systems use a fixed fuel pressure referenced to ambient air pressure instead. The
vac referenced systems give even injector flow across all inlet pressure conditions. The un-referenced systems 
give a varying flow and require a calculation within the ECU to compensate. Enabling 'Fixed' here turns on that 
automatic compensation.

Static/Target Rail Differential Pressure (psi.g)

The fuel rail pressure in PSI referenced to manifold pressure. Typically 43.5PSI for many installs.

Static/Target Rail Differential Pressure (kPa.g)

The fuel rail pressure in kPa referenced to manifold pressure. Typically 304kPa for many installs.

These two settings are in fact one setting just displaying in different units, they are linked together.

Priming Duty

The PWM duty cycle used during the priming pulse.

Off Duty

The PWM duty cycle used when the pump should be off. Set to 0 for most applications, or 75% for Ford FPDM 
modules.

Minimum Duty

The minimum PWM duty cycle to be used when running. Set to 0 for most applications, or 5% for Ford FPDM 
modules.

Maximum Duty

The maximum PWM duty cycle to be used when running. Set to 100 for most applications, or 50% for Ford 
FPDM modules.

Pressure Sensor Input (kPa)

If used, specifies a Generic Sensor that is configured for fuel pressure in kPa.

Sensor Type

• 'Gauge' sensors are referenced to atmospheric pressure - with a vac referenced regulator, the reported 
pressure will drop under vacuum and increase under boost.

• 'Differential' sensors are referenced to manifold vacuum/boost - this pressure will typically remain static 
e.g. 43psi, 3bar.

• 'Absolute' sensors are referenced to true vaccum and will read about 14.7psi/1bar when there is no fuel 
pressure.
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Temperature Sensor Input

If used, specifies a sensor input for fuel temperature.

Temperature Correction

Enables fuel correction based on fuel temperature.

Proportional Gain

Closed-loop Proportional term.

Integral Gain

Closed-loop Integral term.

Derivative Gain

Closed-loop Differential term.

Open-loop PWM Table

The table specifies the PWM duty cycle each each load/RPM point.

9.17 Temperature Adjustment
Clicking Fuel Settings > Temperature Adjustment displays the following screen:

 

Specifies a percentage adjustment in fuelling based on fuel temperature. 0% means no adjustment. 

The Temperature Adjustment is only enabled if a “Temperature Sensor Input” is enabled and 
"Temperature Correction" is set to "On" (see section 9.16)
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9.18 Pressure Adjustment
Clicking Fuel Settings > Pressure Adjustment displays the following screen:

 

Specifies a percentage adjustment in fuelling based on fuel pressure. 0% means no adjustment.

The pressure used for the lookup is always the pressure across the injector i.e. rail pressure - intake pressure.

The Pressure Adjustment is only enabled if “Fuel Pressure Regulation/Correction” has been configured to
use “Custom Correction.” (see section 9.16)
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9.19 Fuel Pressure Safety
The fuel pressure safety system links in to the AFR Safety engine shutdown mechanism (see Section 9.12) to 
protect the engine in the event of a fault with fuel pressure.

Clicking Fuel Settings > Fuel Calculations Summary will display the following screen:

 

The options for these settings are described below:

Enable Fuel Pressure Safety

Enables fuel pressure safety system.

If the measured fuel pressure drops too low for more than a set time, the engine is shutdown.

Static/Target Rail Differential Pressure (psi.g)

The fuel rail pressure in PSI referenced to manifold pressure. Typically 43.5PSI for many installs. Ths is set on 
the Fuel Pump and Pressure page.

Static/Target Rail Differential Pressure (kPa.g)

The fuel rail pressure in kPa referenced to manifold pressure. Typically 304kPa for many installs. Ths is set on 
the Fuel Pump and Pressure page.

Check Above Load

Only check for low pressure above this engine load (e.g. MAP, TPS, MAFload)

Check Above RPM

Only check for low pressure above this RPM.

Allowed Pressure Drop (psi.g)

Allowed drop in pressure below target.

Allowed Pressure Drop (kPa.g)

Allowed drop in pressure below target.

Time Allowed At Low Pressure

If fuel pressure stays too low for more than this time, the engine is shutdown using the AFR safety settings.

(c) 2014-7 James Murray 2017-01-14 Page 137/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

9.20 Fuel calculations Summary
Clicking Fuel Settings > Fuel Calculations Summary will display the following screen:

  

This screen offers a gauge cluster showing summary information of all the fuel related variables that are 
configured for your Megasquirt. This screen can be useful for analysis and troubleshooting.
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10 Ignition Settings
Correctly setting up your ignition settings to ensure that your Megasquirt works correctly with your engine
is one of the most critical areas of work when installing and configuring your Megasquirt. It is also an 
area where it is very easy to damage your engine if your configuration is poor, therefore take good 
care to plan your changes to ignition settings carefully. Seek support from your vendior or the online 
forums at www.msextra.com if you are not certain which settings you should use.

The MS3 firmware supports a wide range of ignition settings and configurations to suit many factory engine  
arrangements.

The Ignition Settings menu includes the fundamental settings such as spark mode, dwell battery correction, cold
advance and manifold air temperature based timing retard. It also includes noise filtering, knock sensor settings 
as well as ignition tables and settings for rotary engines.

The following sections deal with these settings and options.

10.1 Ignition Options / Wheel Decoder
Clicking Ignition Settings > Ignition Options / Wheel Decoder displays the following screen:

 

There are a significant number of different ways to configure the ignition options. The options for these settings 
are described below:
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You will not need to set all of these options for your engine, disregard any options that are disabled 
according to your selection.

Spark Mode (Dizzy, EDIS, Wheel)

It is absolutely essential that you select the correct Spark Mode setting for your engine. If you have any 
doubt about which option to use please ask for help before proceeding.

Spark Mode sets the type of tach input pattern decoder to be used. These are covered in detail in the Hardware 
manual for your product.

Trigger Angle/Offset (deg)

In 'Basic Trigger' and 'Trigger Return' this specifies the engine angle BTDC that each trigger pulse is received. 
(0-19 or 50-80 degrees for best results.)

In 'Toothed Wheel' this should always be set to zero – use tooth #1 angle instead.

In other modes this setting can be used to make a +/- 20 degree adjustment to the built-in reference angle.

Angle Between Main and Return (deg)

This is only used in CAS 4/1 mode and specifies the angular length of each tooth.

Oddfire First Angle

For oddfire engines this specifies the angle the engine must rotate from spark A output to spark B output.

HEI/GM DIS, TFI, C3I Options

GM HEI, Ford TFI and Buick C3I specific options.

With HEI7/8 and GM-DIS, this setting enables the 'bypass' output on spark B.

The C3I mode enables the 'bypass' and also quick-sync after the cam signal is received.

TFI Signature PIP mode is used with 'Basic Trigger' and allows the Megasquirt to use these distributors (where 
one vane is shorter than the others) for sequential fuel.

Oddfire Phasing

There are three settings for this option:

• Alternative – most oddfires such as Ford V4. Chevy V6, Viper V10;

• Paired – Yamaha Vmax;

• Custom – Set your own oddfire angles.

Skip Pulses

The number of tach input pulses at start-up that are ignored before ignition calculations and wheel decoding 
begins. The default value of 3 is suitable for most applications.

Ignition Input Capture

This must be matched to your tach input. If it is set incorrectly you can experience timing drift with rpms or mis-
detection of missing teeth on a missing tooth wheel.
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The tooth logger can be used to confirm polarity is correct - see Section 21.1.

Spark Output

Getting this setting right is CRITICAL or you will melt your ignition coils!

For 99% of installs using the sequential (MS3X) spark outputs, this should be set to 'Going high'

Number Of Coils

Specifies the type of ignition coils in use. TFI, HEI, EDIS, GMDIS must set to 'single coil'.

• Single coil - a single spark output is used, either to a coil or a module.

• Wasted spark - typically, double-ended coils are used to fire two plugs at once. Two outputs are used on
a 4-cylinder engine.

• Wasted COP - One coil is fitted for each cylinder on the engine, but they are fired in pairs.

• Coil on plug - One coil is fitted for each cylinder on the engine and they are fired individually.

• Dual dizzy - a few engines use two distributors and fire two coils alternately. Uses two outputs.

Spark Hardware in Use

Either MS3X or LEDs. The MS3X outputs are ready to use logic spark outputs. The 'LED' spark outputs will 
typically only be used on upgrades from MS2 or without the MS3X.

• JS10 spark - for compatability with MS2 installs (not on MS3-Pro)

• LEDs spark - for compatability with MS2 installs (not on MS3-Pro)

• MS3X spark - sequential logic spark outputs

• Tacho - can be used for TFI or CDI ignition boxes

Cam Input (If Used)

Selects the wiring of an electrical cam sensor or for 1 and 2 cylinder engines this optionally enables the MAP 
sensor input in place of a cam sensor. Used with 'Dual wheel with missing tooth' only.

Set the MAP sensor phase threshold on the General Settings screen (see Section 8.2.)

Tertiary Tach Input

Selects an input for the cam signal in "Flywheel Tri Tach" mode.

Flip Polarity on Hi-Res Tach / Cam

Allows the polarity to be changed on the high resolution or cam tach input signal. Most of the special decoders 
expect the crank and cam to have the same polarity. If that is not the case, this setting can be used to resolve it.

Trigger Wheel Arrangement

There are three settings for this option:

• Single wheel with missing tooth – typically a crank wheel such as 36-1 or 60-2;

• Dual wheel – two wheels without missing teeth e.g., Nippodenso 24/1 CAS;
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• Dual wheel with missing tooth – typically a 36-1, 60-2 crank wheel and an additional cam wheel.

Trigger Wheel Teeth (teeth)

The number of effective teeth counting the missing teeth as if they existed – i.e.  a 36-1 wheel has 35 
physical teeth, but enter 36.

Missing Teeth (teeth)

The number of missing teeth. Common are 1 for 36-1, or 2 for 60-2 or 36-2. Other variations exist.

Tooth #1 Angle (deg BTDC)

Generally (with a missing tooth crank wheel) tooth #1 is the first tooth to pass the sensor after the missing tooth 
gap. With a non-missing tooth configuration determining tooth #1 is a little more complex and requires two 
sensors (on the crank and cam respectively.)

You should have determined tooth #1 and the correct angle during configuration. If you are not sure please refer
to the Megasquirt-3 Setting Up and the appropriate Hardware Manual or ask on the forum at www.msextra.com.

Main Wheel Speed

Determines whether the main wheel speed used is based on the rotation at the Crank wheel or the Cam wheel.

Second Trigger Active On

Like ignition input capture above this specifies which voltage level is considered 'active'.

Level For Phase 1

In 'Poll level' mode this specifies which voltage level is used for each engine phase.

Check at Tooth #

Which crank tooth number to poll the cam level at. Default is 0. For Rover 4.6 V8 try 17.

Changing the tooth no. may also change the phase.

And Every Rotation Of

Sets how often are the second trigger (e.g., cam) input pulses received.

Fixed Advance

There are two options for this setting:

• Fixed Advance – locks timing to the value set below. This is used for confirming timing with a strobe 
timing light during setup;

• Use table – normal operation where the spark advance table is used.

Use Prediction

There are two options for this setting:

• 1st Deriv. Prediction – engine acceleration / deceleration is allowed for in timing calculation (normal 
setting);

• No Prediction – no allowance.

Timing For Fixed Advanced (degrees)

The timing to lock to in 'Fixed' mode.
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Cranking Dwell (ms)

Specifies the base coil dwell time during cranking before battery correction is applied.

Cranking Advance (degrees)

Specifies the ignition advance to be used while cranking. Typically 5-10 deg BTDC.

Toyota Multiplex

Enables specific multiplexed outputs for use with the Toyota ignition module such as used on the 7MGTE.

Dwell Type

There are four options for this setting:

• Standard Dwell – this is the setting to use for most installs;

• Fixed Duty – locks the spark output to a constant duty cycle instead of controlling dwell. e.g., Ford's 
'Push Start' TFI modules, Bosch 'smart' ignition modules, or MSD and other CD boxes;

• Time After Spark – only intended for Saab Tri-Ionic DI cassettes;

• Charge at trigger – rarely used. Could be used with MSD type CDI boxes when running Basic Trigger 
only.

Use Dwell vs RPM Curve

For time-after-spark, the dwell can be varied with RPM.

Use Dwell Table

For 'standard dwell', a table of dwell values can be used. Normally a single dwell value is used.

Nominal Dwell (ms)

The base dwell time before battery voltage correction. Typical values are 3-4 ms.

Spark Duration (ms)

The time required for the spark to complete, typically in the order of 1 ms.

Dwell Time (ms)

The backwards dwell time for Time-After-Spark

Dwell Duty (%)

For fixed duty, this specifies the percentage duty cycle of the output signal.

Spark Hardware Latency

Should only be used if you notice spark retard with increasing rpms.

If you notice a slight retarding of ignition timing with rpm while strobing with fixed timing, you can enter a small 
number in here to remedy it.
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Middle LED indicator

Only applies to MS3.

For Trigger Return mode only, the middle LED on the case can be used to echo the input signal from the 
distributor to help in setting up the base timing.

Spark Trim

Enables the adjustment of timing per individual cylinder.

Kick-start crank delay

Primarily for kick-start engines, this enables a delayed spark during cranking. The dwell and spark are both 
scheduled at the trigger-return point for less chance of kick-back.

Can only be used with :

• 'Trigger-Return' or 

• 'Basic Trigger' when the Trigger Angle < 20

Delay (ms)

How long after the trigger-return to wait before starting the coil dwell in kick-start mode.

Custom oddfire angles in sequence from #1

• 1st – Number of crank degrees engine rotates from spark A to spark B;

• 2nd – Number of crank degrees engine rotates from spark B to next cylinder;

• 3rd – Number of crank degrees engine rotates from spark C to next cylinder;

• 4th – Number of crank degrees engine rotates from spark D to next cylinder.

10.2 Trigger Wizard

The Trigger Wizard menu option is not enabled if “Fuel Only” or “Toothed Wheel” have been selected as 
the “Spark Mode” (see Section 10.1.)

 Clicking Ignition Settings > Trigger Wizard displays the following screen:
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In 'Basic Trigger' and 'Trigger Return' this specifies the engine angle BTDC that each trigger pulse is received.

• In 'Toothed Wheel' this should always be set to zero – use tooth#1 angle instead.

• In other modes this setting can make a +/- 20 degree adjustment to the inbuilt reference angle.

10.3 Dwell Battery Correction

The Dwell Battery Correction menu option is not enabled if “Fuel Only” has been selected as the spark 
mode (see Section 10.1.)

 Clicking Ignition Settings > Dwell Battery Correction displays the following screen:

 

This curve specifies the percentage adjustment to the nominal dwell based on battery voltage.

Inductive coils require greater dwell (charge time) at lower voltages.

10.4 Dwell vs RPM

The Dwell vs RPM menu option is not enabled if “Fuel Only” has been selected as the “Spark Mode” (see
Section 10.1.) It also requires "Dwell Type" to be set to "Time after spark"  and "Use dwell vs RPM curve"
to be enabled.

Clicking Ignition Settings > Dwell vs RPM displays the following screen:
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Consult Saab Tri-ionic information for optimum "dwell" times.

10.5 Dwell Table

The Dwell Table menu option is not enabled if “Fuel Only” has been selected as the “Spark Mode” (see 
Section 10.1.) It also requires "Dwell Type" to be set to "Standard dwell"  and "Use Dwell Table" to be 
enabled.

Clicking Ignition Settings > Dwell Table displays the following screen:

 

This allows for custom dwell settings at different load/RPM points.

10.6 Cold Advance

The Cold Advance menu option is not enabled if “Fuel Only” has been selected as the “Spark Mode” (see
Section 10.1.)

Clicking Ignition Settings > Cold Advance displays the following screen:
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This curve optionally allows ignition timing to be advanced during warmup. Conversely, some engines may 
prefer retard during warmup (to pre-heat the catalytic convertor).

10.7 MAT-Based Timing Retard

The MAT-Based Timing Retard menu option is not enabled if “Fuel Only” has been selected as the spark 
mode (see Section 10.1.)

Clicking Ignition Settings > MAT-Based Timing Retard displays the following screen:

 

This curve allows ignition timing to be retarded based on intake temperature. This is primarily for forced 
induction installs where there is charge heating.
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10.8 Noise Filtering

The Noise Filtering menu option is disabled if “EDIS” or “EDIS Multispark” have been selected as the 
“Spark Mode” (see Section 10.1.)

 Clicking Ignition Settings > Noise Filtering displays the following screen:

 

The options for these settings are described below:

Noise Filter Period

Sets the CPU hardware based noise filter. Typically a small number or zero.

10.8.1 Primary Tach (crank)

Noise Filter Enabled

Use the noise filter curve on the right hand side of the screen to tune.

Enables noise filtering. Uses the curve to set the filter period. The filter measures the width of the tach-in pulse 
in order to reject short noise spikes and allow through valid wider tach-in pulses. Typically set to 1000us or more
at low revs and 100us or more at high revs. Basic distributor setups can use far larger numbers.

Tach Period Rejection

Enables ignoring of bogus tach pulses, although they will still be recorded in the composite logger.

Tach Interrupt Masking

The tach input is disabled for a short period of time after a valid tach pulse to mask out any bogus tach pulses.
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Time (ms)

This value must be set to less than the shortest ever valid time on your install.

The absolute time after a valid tach pulse when new pulses are ignored. The time value that you should use 
here depends greatly on the type of tach input you are using, e.g., a 60-2 wheel spinning at 10000rpm has a 
real tach pulse every 0.1ms. A distributor pickup on a 4-cylinder engine at 600rpm has a real tach pulse every 
50ms.

Percentage (%)

This works as a percentage of the last valid tooth time. 30-50% are typical values.

10.8.2 Secondary Tach (cam)

Noise Filter Enabled

Enables a simple noise filter on the cam tach input.

Noise Filter Time Period (μs)

Equivalent to the time on the curve used for the crank input.

Tach Period Rejection

Enables ignoring of bogus tach pulses, although they will still be recorded in the composite logger.

Tach Interrupt Masking

The tach input is disabled for a short period of time after a valid tach pulse to mask out any bogus tach pulses.

Time (ms)

This value must be set to less than the shortest ever valid time on your install.

The absolute time after a valid tach pulse when new pulses are ignored. The time value here depends greatly 
on the type of tach input in use.

e.g., a 60-2 wheel spinning at 10000rpm has a real tach pulse every 0.1ms. A distributor pickup on a 4-cylinder 
engine at 600rpm has a real tach pulse every 50ms.

Percentage (%)

This works as a percentage of the last valid tooth time. 30-50% are typical values.
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10.9 Knock Sensor Settings
Clicking Ignition Settings > Knock Sensor Settings displays the following screen:

  

The options for these settings are described below:

Knock Control

There are three options for this setting: 

• Disabled: do not use knock feedback for ignition advance control;

• Safe Mode: use knock retard, but keep the advance below that which caused knock. This backs the 
advance one small step back and leaves it at that until TPS or MAP changes or knock comes back. This
'safe mode' scheme is recommended for a DIY set-up.

• Aggressive Mode: use knock retard, but keep advance at threshold of knock occurring. That is, the 
program advances (up to the timing table value) if it doesn't see knock, and retards if does see knock. 
The difference from safe mode is that the timing can be advanced all the way to the table value after 
knock, not just up to one step below knock. This may result in the knock returning, in which case the 
timing is retarded again, then advanced slowly, and so on.

Input Type

There are two options for this setting:

• On/Off: basic on/off 'knock' or 'no-knock' external input.

• Analogue: external analogue input proportional to knock signal level.

• Internal: internal knock module.
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If set to Analogue or Internal, the knock input threshold can be set using the table on the right hand side 
of the screen. This sets an allowable knock level before retard is triggered. The numbers here are highly 
engine dependent.

Knock Input Pin

Selects where the on/off sensor/module is connected.

Knock Indicated By:

The logic input level, i.e., when set to 'low' then a zero volt signal means there is knock. This matches the GM 
module.

Pull Up / Down On Input

Determines whether or not an internal pull-up resistor should be applied.

Input Pin

Input for knock analogue signal.

Window Sample Type

Either read single analogue value at end knock window or peak detect.

Window Output

Optional digital output for knock window signal.

Monitor per cylinder

For installs with the internal module and sequential spark or fuel, allows knock per cylinder to be recorded.

Control per cylinder

For installs with the internal module and sequential spark or fuel, allows knock retardation per cylinder.

Debug data

For analysis, stores individual knock retards into the "Sensors" datalog channels. i.e. this overwrites any data 
from "Generic Sensors".

Knock Count (knocks)

Number of knock events detected before control is started.

RPM Window Low (rpm)

Knock control is implemented above this RPM.

RPM Window High (rpm)

Knock control is implemented below this RPM.

Ignore During Launch/Flatshift

Knock detection can be disabled when launch/flatshift are active to prevent false detection.
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Maximum Retard (deg)

Maximum total retard when knock occurs.

Retard Check Time (seconds)

The time between knock retard corrections.

Retard Step Size (degrees)

How much to retard by on each correction step when knock is first detected. Make it large to quickly retard the 
timing and stop knock.

Advance Check Time (seconds)

The time between knock advance corrections (i.e., timing return to normal)

Advance Step Size (degrees)

How much to retard by on each correction step if knock restarts after it had stopped.

Recovery Advance (degrees)

If ignition table timing changes by this much then return to normal timing as the engine is clearly operating in 
different area.
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10.10 Knock Sensor Parameters

This is only enabled if Knock Sensing is enabled and set to "Internal"

Clicking Ignition Settings > Knock Sensor Parameters will display the following screen:

 

The options for these settings are described below:

Bandpass Frequency

This should be adjusted to suit the resonant frequency of you engine.

Integrator Time Constant

How long the signal is sampled for.

Number of Sensors

How many knock sensors (1 or 2)

Monitor per Cylinder

Enables linking of knock signal to cylinder number. This only works if coil-on-plug or sequential fuel are enabled.

Gain

Compensate for sensor sensitivity and distance between cylinder and sensor.
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Sensor

Pick which sensor to use for each cylinder.

10.11 Knock Window Settings

This is only enabled if Knock Sensing is enabled.

Clicking Ignition Settings > Knock Window Settings will display the following screen:

 

Knock Window Start

Set the crank angle (for each cylinder) when the knock system starts 'listening' for knock.

Knock usually occurs in the time after TDC

Knock Window Duration

Set the number of crank degrees that the knock system 'listens' for knock.
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10.12 Knock Coolant Scaling

This is only enabled if Knock Sensing is enabled.

Clicking Ignition Settings > Knock Coolant Scaling will display the following screen:

 

Allows the threshold to be scaled up on a cold engine. Frequently a cold engine is noiser and may cause false 
alarms without a raised threshold.

10.13 Ignition Tables (1 to 4)

All of the Ignition Tables menu options will be disabled if “Spark Mode” is set to “Fuel Only” (see Section
10.1.)

To enable the Ignition Table 2 menu option configure a “Secondary Ignition Mode” in Basic/Load Settings 
> General Settings (see Section 8.2.)

To enable the Ignition Table 3 menu option enable “Spark Table Switching” in Table Choices->Table 
Switch/Dual Fuel (see Section 14.1.1.)

To enable the Ignition Table 4 menu option enable “Spark Table Switching” in Table Choices->Table 
Switch/Dual Fuel (see Section 14.1.1 and configure a “Secondary Ignition Mode” in Basic/Load Settings 
> General Settings (see Section 8.2.)

Clicking Ignition Settings > Ignition Table 1, 2, 3 or 4 will display a variation of the following screen:
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Ignition Table 1

The main ignition table [Spark1]. Numbers are actual timing BTDC.

Ignition Table 2

The secondary ignition table [Spark2], can be used as a blend table with Spark1.

By default Ignition Table 2 will be filled with zero values and will require configuration.

Ignition Table 3

The alternate ignition table [Spark3]. Can be used as a switched table from Spark1. When Spark3 is active any 
secondary ignition table (Spark2) is ignored.

Ignition Table 4

The ignition table [Spark4], can be used as a blend table with Spark3.

If you intend to use any of these three additional Ignition Tables please ensure that you set them before 
you begin tuning.

10.14 Rotary Settings

To enable the Rotary Settings menu option you need to set Engine Stroke/Rotary to “Rotary” in the 
Engine and Sequential Settings screen (see Section 8.1.)

Clicking Ignition Settings > Rotary Settings displays the following screen:
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The options for these settings are described below:

Output Mode

There are two settings for this option:

• FC mode = combined trailing coil for two trailing plugs;

• FD mode = individual coils for each trailing plug.

This applies to the trailing coils. The leading coils are controlled by the main "Number of Coils" setting.

Allow Negative Split?

Split usually fires trailing coils after leading coils. If “negative split” is allowed, the split may be negative, causing 
the trailing coils to fire before the leading coils.

Trailing Dwell Time (ms)

Dwell time applied to trailing coil(s).

10.15 Rotary Split Table

To enable the Rotary Split Table menu option you need to set Engine Stroke/Rotary to “Rotary” in the 
Engine and Sequential Settings screen (see section 8.1.)

 
Clicking Ignition Settings > Rotary Split Table displays the following screen:

  

This table specifies the split (delay) in degrees between leading and trailing coils.

10.16 Spark Trim Tables
The Spark Trim Tables allow you to specify a timing adjustment in degrees per cylinder to allow for differences 
per cylinder.

• 0 means no adjustment
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• Positive numbers mean to advance the timing in that cylinder

• Negative numbers mean to retard the timing in that cylinder

To enable the Spark Trim tables you need to enable Spark Trim, see section 10.1.

Spark Trim Tables apply per cylinders and use the Firing Order table (see section 8.1.2) to determine 
which spark output is linked to each cylinder.

Spark Trim requires crank and cam inputs that provide cylinder identification. i.e. you are running 
sequential fuel. Will not work with EDIS or TFI.

So long as the tach inputs are acceptable, spark Trim can be applied per cylinder even with wasted spark
or single coil outputs.

Cyl 1-4 Trims

Clicking Ignition Settings > Cyl 1-4 Trims displays the following screen:

 

Cyl 5-8 Trims

These tables behave in the same way as Cyl1-4 Trims.
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10.17 Spark Calculations Summary
Clicking Ignition Settings > Spark Calculations Summary displays the following screen:

  

This screen is for information purposes only and displays the spark advance at any given stage when the 
engine is running. This screen can be useful for analysis and troubleshooting.

For the meaning of each gauge displayed, see section 19.1.
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11 Startup / Idle
Correctly selecting the fuel settings required when the engine is started, during the afterstart phase, and at idle 
is essential. These settings are all accessible from the Startup / Idle toolbar menu.

The following sections explain how to set up the basic cranking and startup options, configure priming and 
cranking pulses, and afterstart percentage and taper as well as warmup enrichment.

It also covers both closed-loop and open-loop idle control, managing changes when air conditioning is used and
idle advance settings (whether based on load, RPMs or adaptive advance).

11.1 Cranking / Startup settings
Clicking Startup / Idle > Cranking / Startup settings displays the following screen:

 

The options for these settings are described below:

Cranking RPM

Set this a few hundred RPM above your typical fast cranking speed.

Flood Clear TPS (%)

Above this throttle position no fuel will be injected during cranking to help clear a flood situation. It will also 
disable priming.

Batch Fire During Crank

Allows fuel to be fired on each tach event in a batch-fire mode on a sequential install. Can be useful in cold 
climates to allow large cranking fuel flow.

Cranking Taper Curve

Allows a taper curve on crank pulsewidth, either to reduce pulsewidth over time, or to allow an initial large shot 
of fuel.
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Cranking Taper Curve Units

Selects units of ignition events or 0.1 seconds.

Cranking Fuel Pulse Rate

Engines with many cylinders such as V12s may find that the injecting fuel on every tach event gives difficult hot 
starting due to small pulsewidths.

This option allows the fuel to be injected on alternate events (with twice the pulsewidth.)

Blended Cranking Curves

Enables a blend curve between cranking curves.

Priming pulse delay(s)

Delays the priming pulses to allow a lazy fuel pump to build pressure.

Ignore MAT correction during ASE

Can be used to help with perceived heat-soak issues.

ASE Count Units

Selects whether After Start Enrichment (ASE) uses Seconds or Ignition Events as the timer.

11.2 Priming Pulse
Clicking Startup/idle > Priming Pulse will display the following screen:

 

The priming pulse is used to wet the intake manifold walls and provide some initial starting fuel.

Setting the curve to all zeros will also disable fuel pump priming.

11.3 Cranking Pulse %
Clicking Startup / Idle > Cranking Pulse % will display the following screen:
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This percentage table controls the fuel injected when the engine is cranking. Most engines need 200-400% 
when cold and near 100% when hot.

This is a percentage of ReqFuel, so if you swap injectors this curve can be left alone.

11.4 Cranking Taper Curve
Clicking Startup / Idle > Cranking Taper Curve will display the following screen:

 

Allows cranking fuel to be tapered down during extended cranking to reduce flooding.

100% means normal cranking pulsewidth.
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11.5 AfterStart Enrichment (ASE)
Clicking Startup / Idle > AfterStart Enrichment (ASE) displays the following screen:

  

Immediately after the engine has started it is normal to need additional fuel. This curve specifies how much fuel 
is added as a percentage – usually (5 to 50%). 

Note that ASE is a percent adder, i.e. 5% means 5% additional fuel.

A value of 100% would mean doubling the fuel which is probably wrong.
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11.6 AfterStart Enrichment (ASE) Taper
Clicking Startup > idle > Afterstart Enrichment (ASE) Taper displays the following screen:

 

Specifies how long (in engine cycles) to apply afterstart enrichment.

11.7 Warmup Enrichment (WUE)
Clicking Startup / Idle > Warmup Enrichment (WUE) displays the following screen:

 

Specifies the percentage multiplier for fuel during warmup. At cold temperatures 200-300% may be required.
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At fully warm (the final row in the table or point on the curve) 100% must be specified.

The only except to this is engines running LPG may use values less than 100% if the "Allow WUE below 
100%" setting is enabled as shown in section 8.22

11.8 Priming Pulse 2
This is the priming pulse curve used by the Dual Fuel system in section 14.1.2.

11.9 Cranking Pulse 2
This is the cranking pulse curve used by the Dual Fuel system in section 14.1.2.

11.10 AfterStart Enrichment (ASE) 2
This is the afterstart enrichment curve used by the Dual Fuel system in section 14.1.2.

11.11 AfterStart Enrichment (ASE) Taper 2
This is the after start enrichment taper curve used by the Dual Fuel system in section 14.1.2.

11.12 Warmup Enrichment (WUE) 2
This is the warmup enrichment curve used by the Dual Fuel system in section 14.1.2.

11.13 Idle Control
Clicking Startup / Idle > Idle Control displays the following screen:

   

The options for these settings are described below, and in Sections 11.13.1. and 11.13.2.

Idle Valve Type

Selects the method of idle control. There are four possible options for this setting:

• None – no idle control valve;

• On/Off valve – basic open or closed valve (rare);
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• PWM valve (2,3 wire) – common from Ford or Bosch;

• Stepper valve (4,6 wire) – common with GM and Subaru.

Algorithm

This option only applies if “PMW valve” or “Stepper valve” are selected as the “Idle Valve Type”.

There are two possible options for this setting:

• “Open-Loop” controls the valve purely based on temperature;

• “Closed-Loop” adjusts the valve position to achieve a target RPM.

Fast Idle Temperature (°F/°C)

This option (also referred to as FIDLE Temperature) only applies if “On / Off valve” is selected as the “Idle
Valve Type”.

Opens the idle valve below this temperature for fast-idle.

Hysteresis (°F/°C)

This option only applies if “On / Off valve” is selected as the “Idle Valve Type”.

Sets a deadband of coolant temperature so the valve doesn't jitter on and off if the coolant is right on the limit.

11.13.1 Stepper idle

This section only applies if “Stepper valve” is selected as the “Idle Valve Type”.

Time Step Size (ms)

Time between each stepper motor step. Increase this if the motor appears to behave intermittently.

Initial Time Step Size (ms)

The length of the first motor step. Typically set a little longer to improve reliability.

Minimum # Steps To Move (steps)

Minimum number of steps to move in one go.

Increase from the default of 1 if the valve moves unreliably.

Homing Steps

On startup the stepper motor will move this many steps to ensure it has reached the home position. Set the 
value to a number larger than the number of steps required for full travel. (This was formerly called “Start Value”)

Homing Direction

Whether to home the valve to the fully closed (recommended) or fully open position.
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Wide Open Steps

Number of steps from closed to fully open. Homing steps must be set to a larger number.

Crank-To-Run Taper Time (s)

After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls
how long that transition takes.

Hysteresis (°F/°C)

Amount the coolant temperature must vary before the idle position is changed.

Power Between Steps

Stepper motor current control when not stepping. There are three possible options:

• Moving only – turns off power between steps, motor stays cooler but may be unreliable;

• Hold current – a holding current is applied between steps;

• Always on – full current is always applied. Reliable, but can cause excess heat in motor.

11.13.2 PWM idle

This section only applies if “PWM Valve” is selected as the “Idle Valve Type”.

Crank-To-Run Taper Time (s)

After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls
how long that transition takes.

Valve Mode

Virtually all valves work with “Normal –0%” = “Off” corresponding to valve closed, although rarely this setting is 
inverted.

Run Valve Before Start

Determines whether the idle valve runs during Key-On-Engine-Off (KOEO). This can potentially help starting by 
giving additional air during the first few engine rotations.

Output Port

Output for PWM idle valve. Use FIDLE as default unless it is being used elsewhere in your configuration.

3 Wire Mode

Either "Off" or an output is selected. See the Hardware manual for wiring.

• Off -  disables 3-wire mode and uses 2-wire mode. 

• Output - the chosen 2nd output for the idle valve.

Valve Frequency

Frequency to operate at. This varies with valve type. Ford/Bosch valves typically operate 50-100Hz. Miata 
valves are closer to 300Hz.
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Megasquirt-3 uses a hardware PWM channel for PWM idle so does not suffer any precision loss at 
higher frequencies.

11.14 Idle Cranking Duty / Steps

The Idle Cranking Duty / Steps menu option is only enabled if “Idle Valve Type” has been set to “PWM 
valve” or “Stepper valve” - see Section 11.13.

 
Clicking Startup / Idle > Idle Cranking Duty / Steps displays the following screen:

 

This curve sets the idle valve position during cranking. This should be set high enough so that the engine can 
start without touching the throttle when cold, but not so high that the engine revs up too far immediately after 
starting.

Large duties are more open. Typically zero is fully closed. (Some 2 wire Bosch valves have a closed position of 
about 35%)
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11.15 Idle Warmup Duty / Steps

The Idle Warmup Duty / Steps menu option is only enabled if “Algorithm” has been set to “Open-loop 
(warmup)” - see Section 11.13.

 
Clicking Startup / Idle > Idle Warmup Duty / Steps displays the following screen:

 

This curve specifies the PWM Idle Duty vs. coolant temperature to be used during warmup.

Large duties are more open. Typically zero is fully closed. (Some 2 wire Bosch valves have a closed position of 
about 35%)

The curve will start high at cold temperatures and descend towards zero at high temperatures.
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11.16 Closed-Loop Idle settings

The Closed-Loop Idle settings option is only enabled if “Algorithm” has been set to “Closed-loop” - see 
Section 11.13.

 
Clicking Startup / Idle > Closed-Loop Idle Settings displays the following screen:

 

The options for these settings are described in Sections 11.16.1 to 11.16.3 below:

11.16.1 Closed-Loop Idle Settings

Idle Valve Minimum Duty (%)

The duty below which changes in duty no longer have an effect on RPM.

Idle Valve Maximum Duty (%)

The duty above which changes in duty no longer have an effect on RPM.

Dashpot Adder (%)

The amount to increase the idle valve duty / steps by when throttle is lifted. This should be set to a value that 
results in RPM being slightly above the target RPM.

Use Last Value Or Table

This setting controls whether the initial duty value used upon entering closed loop idle is taken from the last time
in closed loop or taken from the initial value table.

Use CLT Or MAT In Table Lookup

This setting is used to set whether the initial values table y-axis lookup is done using CLT or MAT.

Close Delay – 0 Means Do Not Close (sec)

This setting controls the amount of time between pressing the throttle and closing the valve while driving. A 
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value of 0 disables this setting. 

The timer does not start until actual RPM is 200 RPM above the target.

Open valve on WOT

Whether to open the idle valve on wide-open throttle for maximum airflow.

Leave Valve Closed Above: (rpm)

The RPM above which the idle valve will remain closed when shifting gears.

For This Number Of Seconds: (sec)

The longest amount of time that a shift takes. After this timer expires, the valve will follow normal dashpot 
behavior.

11.16.2 Closed-Loop Idle PID Gains

Closed Loop Sensitivity

Use this setting to tune how aggressively the idle speed controller tries to reach the target RPM. Adjust the 
slider up until the idle speed starts oscillating, then back down until it stops. Wait 5-10 seconds between each 
adjustment to give your Megasquirt a chance to settle.

Tuning Mode

If set to “Basic” then Proportional Gain, Integral Gain and Derivative Gain are not used to calculate overall Gain.
If set to “Advanced” these three settings can be defined.

Proportional Gain

Proportional gain for closed loop idle PID loop. Reacts immediately to change in RPM.

Integral Gain

Integral gain for closed loop idle PID loop. Reacts to sustained difference between target RPM and actual RPM.

Derivative Gain

Derivative gain for closed loop idle PID loop. Reacts to rate of change of RPM.

11.16.3 Closed-Loop Idle PID Delays and Behavior

PID Delay (s)

Controls how long all conditions for entering closed-loop idle must be met for before entering closed-loop 
control.

Crank To Run Taper (s)

After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls
how long that transition takes.

PID Ramp To Target Time (s)

How long after entering closed loop idle it will take for actual RPM to match target RPM.
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PID Control Intervals (ms)

Controls how often the closed loop idle algorithm runs.

PID Disable RPMdot

Use so that engaging clutch without throttle does not leave PID running. Avoids situations where PID stays 
running while not actually idling causing stalls once PID is entered again.

Be sure to configure your Engine State Settings as these are used to determine when the engine is in 
Idle mode.

11.17 Closed-Loop Idle Target RPM Curve

The Closed-Loop Idle Target RPM Curve menu option is only enabled if:

• “Algorithm” has been set to “Closed-loop” (see Section 11.13.)

• OR “Idle Advance On” is set to “Adaptive” (see Section 11.21.)

 
Clicking Startup / Idle > Closed-Loop Idle Target RPM Curve displays the following screen:

  

This curve displays the closed loop idle RPM target depending on coolant temperature. It is normal to set a high
idle on a cold engine, tapering down as the engine warms up.

11.18 Closed-Loop Idle Initial Values

The Closed-Loop Idle Initial Values menu option is only enabled if:

• “Algorithm” has been set to “Closed-loop” - see Section 11.13;

• AND “Use Last Value Or Table” is set to “Use initial value table” - see Section 11.16.1.

 
Clicking Startup / Idle > Closed-Loop Idle Initial Values displays the following screen:
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The table should be filled with the best-guess idle valve position for each RPM and load. This allows you to 
'kick-start' the closed-loop idle by setting the valve to the most likely position.

11.19 PWM Idle Voltage Compensation

The PWM Idle Voltage Compensation menu option is only enabled if “Idle Valve Type” has been set to 
“PWM valve” (see Section 11.13.)

 
Clicking Startup / Idle > PWM Idle Voltage Compensation displays the following screen:

 

Some 2 wire PWM idle valves will operate differently depending on the system voltage. This allows a 
compensation to be applied to allow for that difference.

Typically at lower voltages the valve will need slightly more duty (positive number) and at higher voltages it will 
need less duty (negative number.)

11.20 Air Conditioning Idle-up
Clicking Startup / Idle > Air Conditioning Idle-up displays the following screen:

(c) 2014-7 James Murray 2017-01-14 Page 173/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

 

The options for these settings are described below:

A/C Idle-up

Enables feature.

Idle-up Output

Output to engage compressor.

Idle-up Input

Switch input.

Input Polarity

Typically the switch input expects a ground signal for 'on'. Setting this to "Inverted" means that the ground input 
means 'off' instead.

Idle-up Delay(ms)

Delay after switch is pressed before engaging compressor.

Idle-up Min RPM (rpm)

Lowest RPM that AC compressor can be turned on.

Compressor Delay Since Last On (s)

Sets a delay to prevent rapid cycling on/off.
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Idle-up Duty Adder (%)

Only enabled if “Idle Valve Type” has been set to “PWM valve” (see Section 11.13.)

Additional PWM idle duty cycle to add when A/C is active.

Idle-up Steps Adder (steps)

Only enabled if “Idle Valve Type” has been set to “Stepper valve” (see Section 11.13.)

Additional idle steps to add when A/C is active.

Idle up target rpm adder (rpm)

Bump up RPM by this much when A/C is active.

Idle-up CL Load Allowance

When A/C is active the engine load will increase. Set this number so that the additional load doesn't kick you out
of closed-loop idle.

TPS Shutoff

Disable A/C when TPS is above this. (Reduces load on engine when driver demands full power.)

TPS Hysteresis

Deadband in TPS to prevent A/C bouncing on/off.

VSS Shutoff

Only enabled if VSS is enabled (see Section 15.1.)

Disable A/C above this speed.

VSS Hysteresis

Deadband in VSS to prevent A/C bouncing on/off.

Maximum RPM

Disable A/C above this RPM.
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11.21 Idle Advance Settings
Clicking Startup / Idle > Idle Advance Settings displays the following screen:

  

The options for these settings are described below:

Idle Advance On

Enables / disables Idle-advance feature. The purpose of Idle-advance is to allow specific timing control when the
engine is idling, particularly for stabilization.

Idle RPM Timing Correction

Enables additional advance curve linked to closed-loop idle target. This allows you to use timing control to assist
with idle speed regulation.

PID Idle Activates

Either links idle-advance with closed-loop idle or follows the 'Idle' Engine State.

And CLT is above:

Only activate above this coolant temperature (typically idle-advance does not work too well during warmup);

And after delay:

After the conditions are met, wait this long before enabling idle-advance. This helps reduce false activations.

Be sure to configure your Engine State Settings as these are used to determine when the engine is in 
Idle mode.

Idle Advance Timing

This curve sets the timing vs engine load when Idle-Advance is active. Typically the curve will ramp from low 
advance at low load to more advance at higher loads to help stablize idle.
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11.22 Idle RPM Timing Correction Curve

The Idle RPMs Advance Timing menu option is only enabled if "Idle Advance On" is set to "On" and “Idle 
RPM Timing Correction” has been set to “On” (see Section 11.13.)

 
Clicking Startup / Idle > Idle RPM Timing Correction Curve displays the following screen:

 

Uses timing to assist closed-loop idle control.

The X axis of the curve is RPMs +/- the target. i.e. if the target was 800, then -75 in the curve means 800-75 = 
725RPM

The Y axis of the curve is timing +/-. i.e. + means add timing, - means subtract timing.

Typically, use positive (advanced) timing when RPMs are below target and negative (retarded) timing when 
RPMs are above target.
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11.23 Idle VE Settings
Clicking Startup / Idle > Idle VE Settings displays the following screen:

 

The options for these settings are described below:

Idle VE On

Enables Idle-VE feature.

PID Idle Activates

Either links idle-advance with closed-loop idle or follows the 'Idle' Engine State.

And CLT is Above

Only activate above this coolant temperature. (Typically idle-VE does not work too well during warmup.)

And After Delay

After the conditions are met, wait this long before enabling idle-advance. This helps reduce false activations.

Be sure to configure your Engine State Settings as these are used to determine when the engine is in 
Idle mode.
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12 Accel Enrich
The settings on the accel enrich menu are intended to improve engine performance during transients such as 
opening the throttle. There are a number of different methods available from simple to more scientific. At the 
most basic level, when you snap open the throttle, you will need a burst of additional fuel. Formerly this was 
provided by the acceleration pumper on a carburettor.

12.1 Accel Enrich Settings
Clicking Accel Enrich > Accel Enrich Settings displays the following screen:

  

The options for these settings are described below:

Use Time-Based or Accel-Pump Accel

Selects between time-based accel enrichment or pump-style enrichment.

• Time-based AE -  traditional Megasquirt accel enrichment system

• Accel-pump AE - a system the works similarly to the carburettor accel-pump

Wall-wetting AE (EAE)

Enables a well-wetting transient system. These systems model the underlying physics. They can be more 
difficult to tune, but can provide superior response.

• Off - no additional 

• EAE - one method of wall-wetting AE

• X-Tau - a different method of wall-wetting AE

• X-Tau with CLT correction - as above but adds a CLT factor also

TPSdot Uses %WOT

Enables a curve to model effective 100% TPS for a given RPM. This allows smaller throttle movements to be 
more responsive at lower RPMs and ignores changes in throttle above 'wide-open'.

Start Transition

X-Tau accel tables are used when MAPdot is positive or less negative than this start transition threshold. In-
between a blend is used.

Finish Transition

X-Tau Decel tables are used when MAPdot is more negative than this finish transition threshold. In-between a 
blend is used.
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12.2 Time-Based Accel Enrichment
This is the traditional Megasquirt accel enrichment where an extra shot of fuel is calculated based on the rate of 
throttle opening or rate of change of MAP or a blend of both.

Clicking Accel Enrich > Time-Based Accel Enrichment displays the following screen:

 

The options for these settings are described below:

Map Based AE Curve

The Map Based AE Curve is only enabled if the “Accel Enrichment MAPdot<->TPSdot Blend (%)” slider 
is set to a value less than 100% - see the third entry in this section.

This curve specifies a fuel pulsewidth percent adder based on rate of change of MAP (MAPdot).

This is part of the basic time based accel enrichment scheme. Larger changes in MAP require more fuel to be 
added. The number is a percentage of ReqFuel.

TPS Based AE Curve

This curve specifies a fuel pulsewidth percent adder based on rate of change of TPS (TPSdot).

This is part of the basic time based accel enrichment scheme. Larger changes in TPS require more fuel to be 
added. The number is a percentage of ReqFuel.

Accel Enrichment MAPdot<->TPSdot Blend (%)

This slider set a weight (0-100) to be given to TPSdot over MAPdot for accel enrichment.
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Accel MAPdot Threshold (kPa/s)

Triggers enrichment above this MAPdot value.

End Pulsewidth (ms)

After main enrichment event, taper down to this amount of enrichment.

“0” is suggested for this setting.

Time or Ignition Events

Length of enrichment pulse is measured in ignition events or seconds.

Accel Duration (events)

Length of main enrichment pulse in ignition events.

Accel Taper Time (events)

Length of 'taper' events after main enrichment pulse

“0” is suggested for this setting.

Accel Time (s)

Length of main enrichment pulse.

Accel Taper Time (s)

Length of 'taper' time after main enrichment pulse

“0” is suggested for this setting.

Accel TPSdot threshold (%/s)

Trigger enrichment above this TPSdot value.

Decel Fuel Amount (ms)

Deceleration fuel cut amount in percent. 100% is no cut, 0% is complete cut of fuel.

100% is suggested for this setting.

Cold Accel Adder (ms)

At full cold, add this amount to the enrichment. Linearly interpolates across temperatures in warmup table.

Cold Accel Multiplier (ms)

At full cold, multiply the enrichment by this percentage. Linearly interpolates across temperatures in warmup 
table.

Full Accel Below: (rpm)

Below this RPM full enrichment is enabled.
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Zero Accel Above: (rpm)

Above this RPM, there is no enrichment. In between, the enrichment is on a sliding scale.

12.3 Accel-pump Accel Enrichment Settings
This is a transient enrichement system that works similarly to the carburettor accel-pump

Clicking Accel Enrich > Accel-pump Accel Enrichment Settings displays the following screen:

 

The options for these settings are described below:

Accel MAPdot Curve

The curve specifies a fuel pulsewidth percent adder based on rate of change of MAP (MAPdot)

This is part of the accel-pump based accel enrichment scheme. Larger changes in MAP require more fuel 
added.

The negative part of the curve is used for decel enleanment, or set to zero PW% for no enleanment.

Ensure that there is a 0 0 point in the curve so that when MAP is not changing, no additional fuel is added. The 
number is a percentage of ReqFuel.

The curve specifies a fuel pulsewidth percent adder based on rate of change of TPS (TPSdot)

This is part of the accel-pump based accel enrichment scheme. Larger changes in TPS require more fuel 
added.

The negative part of the curve is used for decel enleanment, or set to zero PW% for no enleanment.

Ensure that there is a 0 0 point in the curve so that when TPS is not changing, no additional fuel is added. The 
number is a percentage of ReqFuel.

Accel TPSdot Curve

The curve specifies a fuel pulsewidth percent adder based on rate of change of TPS (TPSdot)

This is part of the accel-pump based accel enrichment scheme. Larger changes in TPS require more fuel 
added.

The negative part of the curve is used for decel enleanment, or set to zero PW% for no enleanment.
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Ensure that there is a 0 0 point in the curve so that when TPS is not changing, no additional fuel is added. The 
number is a percentage of ReqFuel.

Accel Enrichment MAPdot<->TPSdot Blend (%)

This slider set a weight (0-100) to be given to TPSdot over MAPdot for accel enrichment.

Accel MAPdot Threshold (kPa/s)

Triggers enrichment above this MAPdot value.

Accel TPSdot threshold (%/s)

Trigger enrichment above this TPSdot value.

Cold Accel Multiplier (ms)

At full cold, multiply the enrichment by this percentage. Linearly interpolates across temperatures in warmup 
table.

Full Accel Below: (rpm)

Below this RPM full enrichment is enabled.

Zero Accel Above: (rpm)

Above this RPM, there is no enrichment. In between, the enrichment is on a sliding scale.

12.4 Time-Based Accel Enrichment 2
This is an alternate set of accel-enrich settings that is used for dual-fuel or flex-fuel blending.

12.5 Accel-pump Accel Enrichment Settings 2
This is an alternate set of accel-enrich settings that is used for dual-fuel or flex-fuel blending.

12.6 TPS WOT curve

The TPS WOT menu option is only enabled if the “TPSdot uses %WOT” setting is set to “On” see 
Section 12.1.

Clicking Accel Enrich > TPS WOT curve displays the following screen:
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This curve sets the TPS% that is considered wide-open-throttle based on RPM.

i.e., at low RPMs, partial throttle will flow the same air as full throttle. At maximum RPMs full throttle is required 
for full air flow.

When the throttle is at, or beyond, the new 'full throttle' it is considered to be 100% throttle. This has the effect of
making TPS based accel enrichment more sensitive at lower throttle opening at lower RPMs and also prevents 
TPS accel enrichment if the throttle is already 'fully open.'

12.7 EAE Adhere-to-walls Coefficient

The EAE Adhere-to-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” 
setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich >  EAE Adhere-to-walls Coefficient displays the following screen:

 

This curve determines how much fuel is being added to the port walls per injection event. It is a percentage (Y-
axis) of each injection event based on load (X-axis).
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12.8 EAE Sucked-from-walls Coefficient

The EAE Sucked-from-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich > EAE Sucked-from-walls Coefficient displays the following screen:

  

This curve determines how much fuel is being sucked from the walls on each intake (valve open) event. It is a 
percentage (Y-axis) of the total amount of fuel that has adhered to the walls based on load (X-axis), so therefore
the percentages are much smaller (about 10x smaller) than the Adhere-to-walls coefficients.

12.9 EAE Adhere-to-walls RPM Correction

The EAE Adhere-to-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich >  EAE Adhere-to-walls RPM Correction displays the following screen:

   

This curve modifies the EAE Adhere-to-walls curve. It allows the amount of correction specified by the EAE 
Adhere-to-walls curve to be increased or decreased based on RPM.
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12.10 EAE Sucked-from-walls RPM Correction

The EAE Sucked-from-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE, 
X-Tau)” setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich >  EAE Sucked-from-walls RPM Correction displays the following screen:

  

This curve modifies the EAE Sucked-from-walls curve. It allows the amount of correction specified by the EAE 
Sucked-from-walls curve to be increased or decreased based on RPM.

12.11 EAE Adhere-to-walls CLT Correction

The EAE Adhere-to-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich >  EAE Adhere-to-walls CLT Correction displays the following screen:

 

This curve modifies the EAE Adhere-to-walls curve. It allows the amount of correction specified by the EAE 
Adhere-to-walls curve to be increased or decreased based on coolant temperature.
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12.12 EAE Sucked-from-walls CLT Correction

The EAE Sucked-from-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE, 
X-Tau)” setting is set to “EAE” see Section 12.1.

Clicking Accel Enrich >  EAE Sucked-from-walls CLT Correction displays the following screen:

 

This curve modifies the EAE Sucked-from-walls curve. It allows the amount of correction specified by the EAE 
Sucked-from-walls curve to be increased or decreased based on coolant temperature.

12.13 EAE Adhere-to-walls Coefficient 2

The EAE Adhere-to-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” 
setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.

12.14 EAE Sucked-from-walls Coefficient 2

The EAE Sucked-from-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.

12.15 EAE Adhere-to-walls RPM Correction 2

The EAE Adhere-to-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.

12.16 EAE Sucked-from-walls RPM Correction 2

The EAE Sucked-from-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE, 
X-Tau)” setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.
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12.17 EAE Adhere-to-walls CLT Correction 2

The EAE Adhere-to-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE, X-
Tau)” setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.

12.18 EAE Sucked-from-walls CLT Correction 2

The EAE Sucked-from-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE, 
X-Tau)” setting is set to “EAE” see Section 12.1 and Staging is enabled see Section 9.4.

This is for a second EAE channel for Staged Injection.

12.19 Puddling Factors (accel)

The Puddling Factors (accel) menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” setting is
set to “X-Tau” see Section 12.1.

Clicking Accel Enrich >  Puddling Factors (accel) displays the following screen:

 

This is the percentage of the fuel (0-100%) that goes into the wall puddle while accelerating (fuel pulse width 
increasing), with the remainder of the squirt going directly into the cylinder to be burned.

12.20 Puddling Factors (decel)

The Puddling Factors (decel) menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” setting is
set to “X-Tau” see Section 12.1.

Clicking Accel Enrich >  Puddling Factors (decel) displays the following screen:
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This is the percentage of fuel (0-100%) going into the wall puddle while decelerating (fuel pulse width 
decreasing.)

12.21 Time Factors (accel)

The Time Factors (accel) menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” setting is set
to “X-Tau” see Section 12.1.

Clicking Accel Enrich >  Time Factors (accel) displays the following screen:

 

This is the time factor vs. RPM used during acceleration.

12.22 Time Factors (decel)

The Time Factors (decel) menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” setting is set
to “X-Tau” see Section 12.1.

Clicking Accel Enrich >  Puddling Factors (accel) displays the following screen:
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This is the time factor vs. RPM used during deceleration.

12.23 X (Puddling) Temp. Corrections

The X (Puddling) Temp. Corrections menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” 
setting is set to “X-Tau” see Section 12.1.

Clicking Accel Enrich > X (Puddling) Temp. Corrections displays the following screen:

 

Coolant temperature (CLT) correction to the puddling factor X.

12.24 Tau (time) Temp. Corrections

The Tau (time) Temp. Corrections menu option is only enabled if the “Wall-Wetting AE (EAE, X-Tau)” 
setting is set to “X-Tau” see Section 12.1.

Clicking Accel Enrich >  Tau (time) Temp. Corrections displays the following screen:
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Coolant temperature (CLT) correction to the time factor Tau.
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13 Boost / VVT
This chapter focuses on how to configure electronic boost control for use with a turbocharger, anti-lag and 
variable valve timing (VVT.)

13.1 Boost Control Settings
Clicking Boost/VVT > Boost Control Settings displays the following screen:

  

The hardware and plumbing for boost control is described in the Setting Up Manual.

The options for these settings are described below:

Boost Control Enabled

Controls whether boost control is enabled.

System Type

Selects the type of boost control system:

• Single Solenoid -  OEM type single-solenoid control

• Dome Control - twin solenoid CO2 dome control - mainly used in racing applications.
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Boost Control Use Initial Value Table

This setting will only be enabled if “Closed-loop” is selected below.

For use with closed-loop boost control. Controls whether the initial values table is used to set the initial duty 
before closed-loop is engaged.

Solenoid Freq. Range

Controls the frequency range allowed on the boost control output(s).

• Mid allows 12-1021 Hz. 

• Slow allows 11.1-78Hz. (recommended)

Most solenoids will run successfully on the "slow" range. The "Mid" range of frequencies have to be shared with 
other outputs, so only use if necessary. Typical solenoids require 10-20Hz.

Solenoid Frequency (Mid)

Selects the frequency when using the mid range.

Boost Control Pin (Mid)

Output pin when using the mid range.

Solenoid Frequency (Slow)

Selects the frequency when using the slow range.

Boost Control Pin (Slow)

Output pin when using the slow range.

Output Polarity

Set this so that higher duty yields higher boost.

Control Interval (ms)

Controls how often the boost control algorithm runs. 50-100ms is recommended.

Minimum Duty (%)

(Closed loop) The duty below which changes in duty no longer cause changes in boost pressure.

Maximum Duty (%)

(Closed loop) The duty above which changes in duty no longer cause changes in boost pressure.

Boost Control Lower CLT Threshold

Coolant temperature must be above this value before boost control will work.

Boost Control Lower Limit Delta (kPa)

Boost pressure must be within this many kPa of the target boost before closed-loop control will activate.

Outside of this range the valve is held wide open (keeping the wastegate shut) for fastest spooling.

Algorithm

Controls whether open loop or closed loop control algorithm is used.
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Controls whether open loop or closed-loop control algorithm is used.

For single-solenoid systems:

• open-loop gives you a table of solenoid duties that will be used directly.

• closed-loop gives you a table of target MAP kPas. The closed-loop system adjusts the solenoid duty to 
achieve the target MAP.

Many settings will only be enabled if “Algorithm” is set to “Closed-loop”.

For dome control systems:

• open-loop gives you a table of dome pressure targets, not referenced to actual MAP.

• closed-loop gives you a table of target MAP kPas. The closed-loop system adjusts the dome target to 
achieve the target MAP. The dome control system adjusts its solenoids to achieve the dome target.

Tuning Mode

Only applies to closed-loop. Can be set to:

• Setup Mode - used for tuning the bias table, closed-loop is disabled.

• Basic Mode – uses fixed PID parameters (P = 100, I = 100, D = 100);

• Advanced Mode – uses adjustable PID parameters for greater control (as described below).

Closed-loop Sensitivity

Use this setting to tune how aggressively the boost controller tries to reach the target boost. Adjust the slider up 
until the boost oscillates around the target, then back down until it stops.

Proportional Gain (%)

Proportional gain for closed-loop control. Proportional control causes immediate changes to output duty with 
changes in boost error.

Integral Gain (%)

Integral gain for closed-loop control. Integral control causes changes in duty with boost error over time. The 
longer boost is off target, the stronger the reaction due to the integral term.

Differential Gain (%)

Derivative gain for closed-loop control. Derivative control causes larger reactions in boost duty with faster rate of
change of boost error. The faster error changes, the more duty will change to counteract.

13.1.1 Overboost Protection Settings

Overboost Protection

Selection can be fuel-cut, spark-cut, or both. “Fuel” cut only cuts fuel. “Spark” cut only cuts spark. “Both” cuts 
both fuel and spark.

Needs to be enabled when using Closed-Loop boost.

Maximum Boost (kPa)

Maximum desired MAP reading (absolute) before overboost protection cuts fuel/spark.
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Hysteresis (kPa)

With overboost protection enabled, this determines how far MAP must drop before spark / fuel are re-enabled 
after MAP reached the maximum,.

Boost Tolerance

Trips the overboost protection if boost is a certain pressure above boost target. Allows overboost to track the 
boost target table. e.g. if target boost was 150kPa and the tolerance was set to 10kPa, the over-boost protection
would trip if MAP is greater than 160kPa.

Tolerance (kPa)

How far MAP can exceed the boost target before overboost cuts in.

Overboost Switching

Allows an input pin to toggle maximum boost to an alternate value.

Alt. Maximum Boost

The alternate maximum desired boost before overboost protection cuts fuel/spark.

13.1.2 Boost Switching Settings

Boost Table Switching

Allow boost tables to be switched or blended.

• Off - no table switching or blending

• Input pin - selects an input for table switching

• Blend - enables a blend table

• Gear - enables switching by gear (requires gear detection)

Boost Table Switching Gear

Selects which gear to switch tables on when gear-based boost table switching is enabled.

The Boost Table Switching Gear menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Boost Table Switching is set to "Gear"

Boost Timed From Launch

Enables a table to ramp up boost after launch.

The Boost Timed From Launch menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Launch Control is enabled (see section 15.11)

Specific Launch Duty/Target

Allow a specific target (closed-loop) or duty (open loop) to be specified when launch control is active.
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The Specific Launch Duty/Target menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Launch Control is enabled (see section 15.11)

Launch Boost Duty

Duty to use when launch is active.

The Launch Boost Duty menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Boost Control is set to "Open-Loop"

• AND Launch Control is enabled (see section 15.11)

Launch Boost Target

Target boost (kPa) to use when launch is active.

The Launch Boost Target menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Boost Control is set to "Closed-Loop"

• AND Launch Control is enabled (see section 15.11)

Boost vs Speed/Gear

Allows boost duty or target to be controlled based on vehicle speed or detected gear.

• Off - option is disabled

• VSS1 - use VSS1 to lookup boost from table

• VSS2 - use VSS2 to lookup boost from table

• Gear - use specific closed-loop target based on current gear (see below)

The Boost vs Speed/Gear menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND VSS is enabled on Speed and Gear Settings (see section 15.1)

Above TPS%

For safety, the TPS must be above this value for the VSS target boost to be used.

The Above TPS% menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Boost vs Speed/Gear is enabled.

Per Gear Targets

These set closed-loop boost targets per gear when per-gear targets is enabled.
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The Per Gear Targets menu options are only enabled if:

• “Boost Control Enabled” is set to “On”

• AND "Closed Loop" is enabled.

• AND Boost vs Speed/Gear is set to "Gear".

13.2 Boost Control Duty Table

The Boost Control Duty Table menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Algorithm is set to “Open-loop” (see section 13.1. for these settings.)

 
Clicking Boost/VVT > Boost Control Duty Table will display the following screen:

 

For Open-loop boost, this table sets the output duty cycle vs. TPS/RPM.

13.3 Boost Control Target Table

The Boost Control Target Table menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

 
Clicking Boost/VVT > Boost Control Target Table will display the following screen:
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For Closed-loop boost, this table sets the target boost vs. TPS/RPM

13.4 Boost Control Bias Duty Table 1

The Boost Control Bias Duty Table menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Boost Control Use Initial Value Table is set to “On”

• AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

Clicking Boost/VVT > Boost Control Bias Duty Table displays the following screen:

  

This table is the best-estimate boost valve duty for target load vs. RPM, it is always in effect. The closed-loop 
control then acts as a refinement on top of this table to compensate for any operational differences.

The table is initially determined by using "Setup Mode" and tuning as an open-loop table. Once the table is close
enough, switch to "Basic Mode" (or "Advanced Mode") to enable the closed-loop control.

Bias table 1 is always used for boost channel 1, even when table-switching. 
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Note that this bias table replaces the "initial values" table that was present in earlier firmware releases 
and the control algorithm operates differently - the bias table is always in effect, while previously the 
initial value was only used to 'kick-start' the closed loop control.

13.5 Boost Delay (Timed From Launch)

The Boost Delay (Timed From Launch) menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Boost Timed From Launch" is set to “On” (see section 13.1. for these settings.)

Clicking Boost/VVT > Boost Delay (Timed From Launch) displays the following screen:

 

Allows boost to be feathered in (ramped up) after launching. 100% means use normal boost settings.

13.6 Boost Control vs Speed

The Boost Control vs Speed menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Boost vs Speed/Gear" is set to “VSS1” or "VSS2"  (see section 13.1. for these settings.)

• AND VSS is enabled (see section 15.1)

Clicking Boost/VVT > Boost Control vs Speed displays a screen similar to this:
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For open-loop boost control, this specifies a solenoid duty based on the wheel speed on VSS1 or VSS2.

For closed-loop boost control, this specifies a target boost level based on the wheel speed on VSS1 or VSS2.

This can be used to limit boost in lower gears to reduce the change of wheelspin or loss of control.

13.7 Boost Control Settings 2

The Boost Control Settings 2 menu option is only enabled if:

• “Enable Boost Control” is set to “On”

Clicking Boost/VVT > Boost Control Settings 2 displays the following screen:
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The options for these settings are described below:

Boost Control Enabled

Controls whether the second channel of boost control is enabled.

Boost Control Pin (Mid)

Output pin when using the mid range.

Boost Control Pin (Slow)

Output pin when using the slow range.

Minimum Duty (%)

(Closed loop) The duty below which changes in duty no longer cause changes in boost pressure.

Maximum Duty (%)

(Closed loop) The duty above which changes in duty no longer cause changes in boost pressure.

Boost Control Lower Limit (kPa)

Boost pressure must be within this many kPa of the target boost before closed-loop control will activate.

Outside of this range the valve is held wide open (keeping the wastegate shut) for fastest spooling.

Algorithm

Controls whether open loop or closed loop control algorithm is used.

Many settings will only be enabled if “Algorithm” is set to “Closed-loop”.

In this firmware version, closed-loop is not fully implement on the second channel. Use open-loop only.

Tuning Mode

Can be set to:

• Basic – uses fixed PID parameters (P = 100, I = 100, D = 100);

• Advanced – uses adjustable PID parameters for greater control (as described below).

Closed-loop Sensitivity

Use this setting to tune how aggressively the boost controller tries to reach the target boost. Adjust the slider up 
until the boost oscillates around the target, then back down until it stops.

Proportional Gain (%)

Proportional gain for closed-loop control. Proportional control causes immediate changes to output duty with 
changes in boost error.

Integral Gain (%)

Integral gain for closed-loop control. Integral control causes changes in duty with boost error over time. The 
longer boost is off target, the stronger the reaction due to the integral term.

Differential Gain (%)

Derivative gain for closed-loop control. Derivative control causes larger reactions in boost duty with faster rate of
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change of boost error. The faster error changes, the more duty will change to counteract.

MAP Sensor to Target

In a future code release this will specify the MAP sensor to use as the target for closed-loop.

13.8 Boost Control Duty Table 2

The Boost Control Duty Table menu option is only enabled if:

• “Boost Control Enabled” is set to “On”

• AND Algorithm is set to “Open-loop” (see section 13.1. for these settings.)

• AND Boost Control 2 is enabled (see section 13.7)

 
This works in the same way as the Boost Control Duty Table.

13.9 Boost Control Target Table 2

The Boost Control Target Table menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

• AND Boost Control 2 is enabled (see section 13.7)

 
This works in the same way as the Boost Control Target Table.

13.10 Boost Control Bias Duty Table 2

The Boost Control Initial Duty Table menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• AND “Boost Control Use Initial Value Table is set to “On”

• AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

• AND Boost Control 2 is enabled (see section 13.7)

This works in the same way as the Boost Control Bias Duty Table 1.

13.11 Wastegate Dome Pressure Control Settings 1

Wastegate Dome Pressure Control Settings 1 menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• "System Type" is set to "Dome Control"

Clicking Boost/VVT > Wastegate Dome Pressure Control Settings 1 displays the following screen:
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The hardware, plumbing and conceptual background for dome control are described in the Setting Up Manual.

The options for these settings are described below:

Empty Wastegate off boost

This setting controls whether channel 1 will empty the wastegate dome when off boost.

Control Method

Selects between Simple and PID control algorithms.

• Simple - the fill and empty solenoids are either full on or full off. The deadband setting is used with the 
dome target to determine when they are opened and closed.

• PID -  the fill and empty solenoids are operated in a PWM mode with the duties calculated using PID. 
This is more complicated to setup but could give superior results.

Min dome target

When operating boost control in closed-loop mode, this sets the minimum dome pressure to target. This and the
next setting are used to keep the target dome pressure within sensible bounds. You achieve less than 
atmospheric pressure (typically around 100kPa); or greater than your CO2 supply pressure.

Max dome target

When operating boost control in closed-loop mode, this sets the maximum dome pressure to target.
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Enable test mode

Enables or disables the test mode. When in test mode the dome target calculations are overridden and the 
target from the next box is used.

Dome target pressure

Sets the target dome pressure when in test mode. Use this to confirm operation using compressed air before 
attempting to run dome control on the engine.

Dome fill output

Output for solenoid that controls filling of wastegate dome with air.

Dome fill output min duty

Channel 1 dome pressure control output minimum duty. Set to just below the lowest duty that affects actual 
dome pressure. [Not used in simple mode.]

Dome fill output max duty

Channel 1 dome pressure control output maximum duty. Set to just above the highest duty that affects actual 
dome pressure. [Not used in simple mode.]

Dome empty output

Output for solenoid that controls emptying of wastegate dome pressure.

Dome empty output min duty

Channel 1 dome pressure control output minimum duty. Set to just below the lowest duty that affects actual 
dome pressure. [Not used in simple mode.]

Dome empty output max duty

Channel 1 dome pressure control output maximum duty. Set to just above the highest duty that affects actual 
dome pressure. [Not used in simple mode.]

Dome fill and empty output frequency

Solenoid output frequency.

Dome MAP sensor input

Channel 1 MAP sensor input. Uses generic sensors feature. This must be calibrated to give absolute kPa i.e. 
around 100kPa for no line pressure.

Dome pressure dead zone

Pressure dead-band between fill and empty in simple (non-PID) mode. If you experience overshoot during fill, 
try increasing the deadband. [Not used in PID mode.]

PID Settings Sensitivity

Dome pressure control's channel 1 PID sensitivity. Adjust to the right to make PID loop more sensitive.

Basic or advanced mode

This settings controls whether the PID routine is tuned with just the slider or with the slider for sensitivity and the
individual PID gains for fine-tuning.
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Proportional Gain

PID Proportional Gain for wastegate dome pressure control.

Integral Gain

PID Integral Gain for wastegate dome pressure control.

Differential Gain

PID Derivative Gain for wastegate dome pressure control.

13.12 Dome Bias Table 1

The Dome Bias Table 1 menu option is only enabled if:

• “Enable Boost Control” is set to “On”

• Boost control "Algorithm" is set to "Closed-loop"

• "System Type" is set to "Dome Control"

Clicking Boost/VVT > Dome Bias Table 1 displays the following screen:

 

When using dome control and the boost control algorithm is set to "Closed-loop" this table is the best-estimate 
dome pressure required to achieve the target manifold pressure on the Y-axis. See the Setting Up manual for 
background information.

13.13 Turbo Anti-Lag (ALS)
Anti-lag is a combination of features you can use to keep the turbo spooled while shifting, beyond the basic flat 
shift rev limiter. The MS3 has several strategies it can use to dump extra fuel into the exhaust and increase 
exhaust gas temperatures under these conditions. This increase in exhaust temperature will shorten turbo life 
and possibly result in increased wear and tear on other parts of the exhaust system as well.
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Clicking Boost/VVT > Turbo Anti-Lag (ALS) displays the following screen:

 

The options for these settings are described below:

Anti-Lag Enable Input

Enables the Anti-Lag system and selects the Enable input.

Maximum TPS

Disable ALS above this TPS%.

Minimum RPM

Disable ALS below this RPM.

Maximum RPM

Disable ALS above this RPM.

Maximum MAT

Disable ALS above this manifold temperature.

Maximum ALS time

Only allow ALS to be active for this long to reduce temperature build-up.
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Time Between Activations

Enforce a minimum time between activations to reduce temperature build-up.

Minimum CLT

Disable ALS below this coolant temperature.

Maximum CLT

Disable ALS above this coolant temperature.

Enable Cyclic Fuel Cut

Whether cyclic fuel cut should be used. ONLY for use with sequential fuel.

Enable Cyclic Spark Cut

Whether cyclic spark cut should be used.

Enable Roving Idle Fuel Cut

Whether roving idle fuel cut should be used.

Use Idle Valve

Enables the idle valve in ALS mode.

Idle Valve Duty

What PWM valve duty should be used to give the extra air needed for ALS.

This is only enabled if a PWM idle valve is enabled.

Idle Valve Steps

What stepper valve steps should be used to give the extra air needed for ALS.

This is only enabled if a stepper idle valve is enabled.

On/Off Output

Enables an additional output in ALS mode for extra-air valve.

PWM Output

Enables an additional pulsed output in ALS mode.

Output Port/Pin

Selects the pulsed (PWM) output.

Output Duty

Duty cycle on pulsed output when ALS is active.

Frequency

Frequency on pulsed output.
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13.14 Turbo Anti-Lag Tables

The Turbo Anti-Lag Tables menu option is only enabled if:

• “Anti-Lag Enable Input” is enabled (see section 13.13)

Clicking Boost/VVT > Turbo Anti-Lag Tables displays the following screen:

 

Added Fuel %age

The percentage of fuel to be added vs. RPM/load when in anti-lag mode.

ALS Timing

The ignition advance vs. RPM/load when in anti-lag mode.

Typically this will be -20 to -50 for ATDC timing.

Spark Cut %

The Turbo Anti-Lag Tables menu option is only enabled if:

• “Anti-Lag Enable Input” is enabled

• AND "Enable Cyclic Spark Cut" is enabled (see section 13.13)

The spark-cut percentage vs. RPM/load when in anti-lag mode.

This drops sparks in a round-robin manner.

Fuel Cut %

The Turbo Anti-Lag Tables menu option is only enabled if:

• “Anti-Lag Enable Input” is enabled

• AND "Enable Cyclic Fuel Cut" is enabled (see section 13.13)

The fuel-cut percentage vs. RPM/load when in anti-lag mode.
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This must ONLY be used with sequential fuel as it cuts off injectors in a round-robin manner.

13.15 Turbo Anti-Lag Roving Idle

The Turbo Anti-Lag Roving Idle menu option is only enabled if:

• “Anti-Lag Enable Input” is enabled

• AND "Enable Roving Idle Fuel Cut" is "On" (see section 13.13)

Clicking Boost/VVT > Turbo Anti-Lag (ALS) displays the following screen:

 

The fuel-cut percentage vs. RPM/load when in idling on an anti-lag vehicle mode.

This must ONLY be used with sequential fuel as it cuts off injectors in a round-robin manner.
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13.16 VVT Settings
Clicking Boost/VVT > VVT Settings displays the following screen:

The options for these settings are described below:

13.16.1 VVT Settings

No. VVTs

Enables VVT control and selects number of cams to control.
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Cam Decoder

The Cam Decoder menu option is only enabled if:

• VVT is enabled

• AND "Spark Mode" is set to "Toothed Wheel" (see section 10.1)

Frequency

The Frequency menu option is only enabled if:

• VVT is enabled

• AND an output is enabled.

Sets the VVT solenoid PWM frequency typically 200Hz or higher.

On/Off or Variable (PID)

Chooses between basic on/off mode or closed-loop variable position control.

Most settings on the VVT page are only available in Variable mode.

Adjust Inj. Timing Based On

Whether to adjust injection timing based on cam position and which cam.

Commanded vs. Actual

If injector timing is being adjusted, whether to adjust it based on target or actual current position.

Inj. Timing Adjustment

The Inj. Timing Adjustment menu option is only enabled if:

• VVT is enabled

• AND "On/Off" mode is enabled

• AND "Adjust Inj. Timing Based On" is enabled.

Angle to advance injector timing by when VVT is active on On/Off mode.

Load Y axis in Tables

The load unit used for the Y-axis on the lookup tables.

Minimum CLT

VVT only operates when coolant is above this temperature.

VVT Maximum Slew

The Inj. Timing Adjustment menu option is only enabled if:

• VVT is enabled

• AND "Variable" mode is enabled

Limits rate of change of VVT target to minimise overshoot caused by rapid target changes or low oil pressure at 
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low rpms.

Default is 2.0deg per cam event.

Control Interval

How often to run the calculations.

• Synced to cam - the calculations are run as soon as new cam tooth passes the sensor. Recommended.

• Timed - user set interval for calculations

Control Interval Time

Specifies a fixed calculation interval.

Range Check Measured Angles

Whether error checking should be applied to the measured cam angles. Recommended.

Minimum VVT Duty

Minimum duty cycle for VVT solenoids.

Maximum VVT Duty

Maximum duty cycle for VVT solenoids.

13.16.2 PID Parameters

There are settings that apply to all intake cams and all exhaust cams.

Use Hold Duty

Some VVT systems will hold at a fixed position when a certain duty cycle is applied, enable this on those 
systems. Others have no specific hold-duty.

Hold/Neutral Duty

If enabled, this specifies the desired hold duty.

Proportional Gain

Proportional gain for closed-loop control. Proportional control causes immediate changes to output duty with 
changes in VVT position difference.

Integral Gain

Integral gain for closed-loop control. Integral control causes changes in duty with VVT position difference over 
time. The longer VVT is off target, the stronger the reaction due to the integral term.

Differential Gain

Derivative gain for closed-loop control. Derivative control causes larger reactions in duty with faster rate of 
change of VVT position difference. The faster the difference changes, the more duty will change to counteract.

Table is Advance/Retard

The Intake cam always uses a table of advances.

Whether the exhaust cam table is a table of advances (old method) or a table of retards (matches most exhaust 
VVTs.)  Retard is recommended.
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13.16.3 Test

Cam

Sets the cam (solenoid) to test

Duty

The output duty to the solenoid during testing.

13.16.4 Cam Settings

Input

Selects the input used for this particular cam sensor. Cam 1 is always tied to the main cam input defined in the 
Ignition Settings.

Polarity

The capture polarity for the cam. If reported cam angle changes unexpectedly with RPM while the cam is 
stationary, try swapping polarity.

No. Teeth

The number of teeth on the cam trigger wheel. For cam wheels with evenly spaced teeth this will usually be the 
actual number of teeth. Missing tooth or irregular cam wheels should use the "effective" number of teeth. e.g. a 
4-1 cam wheel would specify 4 teeth as the 3 physical teeth are on a 90 degree pattern.

Output

The VVT control solenoid output.

Minimum

The minimum absolute angle from the cam sensor determined in test mode.

Maximum

The maximum absolute angle from the cam sensor determined in test mode.

Int./Exh.

Whether this is an intake or exhaust cam.

Tooth 1

Application specific, look for cam tooth after this crank tooth no.

Tooth 2

Application specific, look for cam tooth after this crank tooth no.

More Duty Means

What direction the cam moves with output duty.

Output (2)

For BMW S54 and S62 engines that use two solenoids per cam, this specifies the output used for the 
complementary solenoid. Note that BMW VANOS units as standard require high-side drivers, so either an 
external driver box is required or the VANOS must be modified to allow low-side drivers. Note also that only 
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certain outputs are available for output 1 and output 2 - check the available options before wiring.

13.17 VVT Intake Table

The VVT Intake Table menu option is only enabled if:

• VVT is enabled

• AND "Variable" mode is enabled

Clicking Boost/VVT > VVT Intake Table displays the following screen:

 

Desired VVT (relative) timing vs RPM/load.

0 degrees means to leave the VVT intake cam at its "rest" retarded position. Positive numbers mean to advance
the cam.

13.18 VVT Exhaust Table

The VVT Exhaust Table menu option is only enabled if:

• VVT is enabled

• AND "Variable" mode is enabled

• AND a cam is configured as an exhaust cam

Clicking Boost/VVT > VVT Exhaust Table displays the following screen:
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Desired VVT (relative) timing vs RPM/load.

There are two ways that this table can operate depending on the setting "Table is Advance/Retard"

When using the recommended setting of "Retard", 0 degrees means to leave the exhaust cam in its rest position
of fully advanced. Positive numbers then retard the cam.

When using the compatability setting of "Advance", the table works backwards. 0 degrees means fully retarded 
and your maximum number will command the rest position of fully advanced.

13.19 VVT On/Off Table

The VVT On/Off Table menu option is only enabled if:

• VVT is enabled

• AND "On/Off" mode is enabled

Clicking Boost/VVT > VVT On/Off Table displays the following screen:

 

In place of the angle target table, an on/off table is used. In this table, set 100 for cells where VVT should be 
active and 0 for cell where it should be inactive. Do not use other values. 
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14 Table Choices
These menus give a number of selections for table-switching, blending and dual-fuel control. See also the 
Setting Up manual for more examples and background explanations.

14.1 Table Switch/Dual Fuel
Clicking Table Choices > Table Switching/Dual Fuel displays the following screen:

   

The options for these settings are described below:

14.1.1 Table Switching

Fuel Table Switching

Enables Fuel Table switching. Switches from using Fuel VE Table 1 (with optional modifier Fuel VE Table 2) to 
using Fuel VE Table 3 (with optional modifier Fuel VE Table 4.)

Switch Source

• Hardware - use a physical input switch, a remote switch or a blend cuve
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• rpm - switch based on RPM

• kPa - switched based on MAP reading

• TPS - switch based on TPS reading

Depending on the selection you make here, one of the following four options will be enabled.

Switch Location

Enabled when “Switch Source” is set to “Hardware”. Selects where the switch is connected.

Expansion boards will need configuring through 'CAN parameters' (see Section 17.1.)

Blend curve (3) enables a blend curve instead of a switch function.

RPM Greater Than (rpm)

Enabled when “Switch Source” is set to “rpm”. Represents the rpm threshold for fuel switching.

MAPGreater Than (kPa)

Enabled when “Switch Source” is set to “kPa”. Represents the kPa threshold for fuel switching.

TPS Greater Than (%)

Enabled when “Switch Source” is set to “TPS”. Represents the TPS threshold for fuel switching.

Spark Table Switching

Enables Ignition Table switching. Switches from using Ignition Table 1 (with optional modifier Ignition Table 2) to 
using Ignition Table 3 (with optional modifier Ignition Table 4.)

Switch Source

• Hardware - use a physical input switch, a remote switch or a blend cuve

• rpm - switch based on RPM

• kPa - switched based on MAP reading

• TPS - switch based on TPS reading

Depending on the selection you make here, one of the following four options will be enabled.

Switch Location

Enabled when “Switch Source” is set to “Hardware”. Selects where the switch is connected.

Expansion boards will need configuring through 'CAN parameters' (see Section 17.1.)

Blend curve (4) enables a blend curve instead of a switch function.

RPM Greater Than (RPM)

Enabled when “Switch Source” is set to “rpm”. Represents the rpm threshold for spark switching.
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MAP Greater Than (kPa)

Enabled when “Switch Source” is set to “kPa”. Represents the kPa threshold for spark switching.

TPS Greater Than (%)

Enabled when “Switch Source” is set to “TPS”. Represents the TPS threshold for spark switching.

Req Fuel Switching

Enables ReqFuel switch input.

Alternative ReqFuel (lower number)

ReqFuel to use when switched.

AFR Table Switching

Enables AFR table switch input or blend curve to switch from AFR 1 to AFR 2 as the AFR target table.

Stoich Switching

Enables Stoich switch input.

Alternate Stoich

Stoich to use when switched.

14.1.2 Dual Fuel

Dual Fuel Enable

Enables Dual Fuel support (e.g. LPG or secondary race fuel on a different system.)

Mode

• Switching - swaps from fuel 1 to fuel 2. e.g. gasoline vs. propane

• Dual Table - parallel fuel tables allowing simultaneous control of both fuels. e.g. mapped methanol 
under boost.

• Flex blend - parallel fuel tables with one set of injector outputs, the blend between the two tables is 
controlled by the flex% value derived from a flex-fuel sensor.

Most of the following settings are only applicable to "Switching" mode.

Outputs Mode

• Shared outputs - used when two sets of injectors share one set of control wires from the ECU and have 
a relay to switch +12V.

• Different outputs - where each main and secondary injectors are wired to different outputs.
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Secondary Outputs

The Secondary Outputs menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Different Output" mode is enabled

Whether the secondaries are connected to MS3X outputs or to the mainboard 'V3' batch fire outputs.

Secondary V3 Alternate

The Secondary Outputs menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Different Output" mode is enabled

• AND "Secondary Outputs" is set to "Use V3"

Whether the batch fire outputs alternate during an engine cycle or fire once together.

Input Pin

Input for Dual Fuel switching.

Alt. Fuel Tables

Whether to switch fuel tables.

Alt. Spark Tables

Whether to switch spark tables.

Alt. AFR Tables

Whether to switch AFR tables.

Alt. ReqFuel

Whether to switch ReqFuel.

Alt. Stoich

Whether to switch Stoich.

Alt. Warmup

Whether to switch warmup curves.

Alt. AfterStart

Whether to switch afterstart curves.

Alt. Priming

Whether to switch priming curves.

Alt. Cranking Pulse

Whether to switch cranking pulse curves.
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Alt. Injector Params

Whether to switch injector parameters.

Alt. Small Pulsewidths

Whether to switch small pulsewidth curves.

Alt. Overboost

Whether to switch overboost limits.

Alt. Boost Table

Whether to switch boost tables.

Alt. Accel Enrich

Whether to switch accel enrich settings and curves. (LPG will often require different enrichment.)

Enable Temperature Adjustment

Enable secondary fuel temperature adjustment.

Temperature On

Secondary fuel temperature input. (Configured through the Generic Sensors system.)

Enable Pressure Adjustment

Enable secondary fuel pressure adjustment.

Pressure In kPa On

Secondary fuel pressure input. (Configured through the Generic Sensors system.)

Sensor Type

Sensor type: Gauge, Absolute, Differential.

14.2 Temperature Adjustment

The Temperature Adjustment menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Enable Temperature Adjustment" is on.

Clicking Table Choices > Temperature Adjustment displays the following screen:
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Specifies a percentage adjustment in fuelling based on fuel temperature. 0% means no adjustment.

14.3 Pressure Adjustment

The Pressure Adjustment menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Enable Pressure Adjustment" is on.

Clicking Table Choices > Pressure Adjustment displays the following screen:

 

Specifies a percentage adjustment in fuelling based on fuel pressure. 0% means no adjustment.
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14.4 Alt. Injector Dead-time/PWM 2

The Alt. Injector Dead-time/PWM 2 menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Alt. Injector Params" is on.

This provides an alternate set of injector parameters for dual-fuel use when switching to a different set of 
injectors. See section 9.1.

14.5 Alt. Injector Small Pulsewidths 2

The Alt. Injector Small Pulsewidths 2 menu option is only enabled if:

• "Dual Fuel Enable" is enabled

• AND "Alt. Small Pulsewidths" is on.

This provides an alternate set of injector small pulsewidth parameters for dual-fuel use when switching to a 
different set of injectors. See section 9.2.

14.5.1 Blend Curve (1) VE1->2

The Blend Curve (1) VE1->2 menu option is only enabled if:

• "Secondary Fuel Load" is enabled

• AND "Secondary Fuel" is set to "Blend Curve (1)". See Section 8.2.4.

Clicking Table Choices > Blend Curve (1) VE1->2 displays the following screen:

 

Sets a percentage blend from VE1 (0%) to VE2 (100%) based on the input X axis value.
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14.5.2 Blend Curve (2) Spk1->2

The Blend Curve (2) Spk1->2 menu option is only enabled if:

• "Secondary Ignition Load" is enabled

• AND "Secondary Ignition" is set to "Blend Curve (2)". See Section 8.2.4.

Clicking Table Choices > Blend Curve (2) Spk1->2 displays the following screen:

 

Sets a percentage blend from Spk1 (0%) to Spk2 (100%) based on the input X axis value.

14.5.3 Blend Curve (3) VE1+2->3+4

The Blend Curve (3) VE1+2->3+4 menu option is only enabled if:

• "Fuel Table Switching" is enabled

• AND "Switch Source" is set to "Hardware"

• AND "Input Pin" is set to "Blend Curve (3)". See Section 14.1.1.

Clicking Table Choices > Blend Curve (3) VE1+2->3+4 displays the following screen:
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Sets a percentage blend from the combined VE1+2 (0%) to VE3+4 (100%) based on the input X axis value.

14.5.4 Blend Curve (4) Spk1+2->3+4

The Blend Curve (4) Spk1+2->3+4 menu option is only enabled if:

• "Spark Table Switching" is enabled

• AND "Switch Source" is set to "Hardware"

• AND "Input Pin" is set to "Blend Curve (4)". See Section 14.1.1.

Clicking Table Choices > Blend Curve (4) Spk1+2->3+4  displays the following screen:

 

Sets a percentage blend from the combined Spk1+2 (0%) to Spk3+4 (100%) based on the input X axis value.
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14.5.5 Blend Curve (5) AFR1->2

The Blend Curve (5) AFR1->2 menu option is only enabled if:

• "AFR Table Switching" is set to "Blend Curve (5)". See Section 14.1.1.

Clicking Table Choices > Blend Curve (5) AFR1->2 displays the following screen:

 

Sets a percentage blend from AFR1 (0%) to AFR2 (100%) based on the input X axis value.

14.5.6 Blend Curve (6) Boost1->2

The Blend Curve (6) Boost1->2 menu option is only enabled if:

• Boost Control is enabled

• AND Boost/VVT > Boost Control Settings > Boost Table Switching is set to "Blend Curve (1)". 
See Section 13.1.2.

Clicking Table Choices > Blend Curve (6) Boost1->2 displays the following screen:

 

Sets a percentage blend from Boost1 (0%) to Boost2 (100%) based on the input X axis value.
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14.5.7 Blend Curve (7) Crank%1->2

The Blend Curve (7) Crank%1->2 menu option is only enabled if:

• Startup/Idle > Cranking/Startup Settings > Blended Cranking Curves is set to "Blend Curve (7)". 
See Section 11.1.

Clicking Table Choices > Blend Curve (7) Crank%1->2 displays the following screen:

 

Sets a percentage blend from Cranking Pulse1 (0%) to Cranking Pulse2 (100%) based on the input X axis 
value.

14.5.8 Blend Curve (8) Flex Blending

The Blend Curve (8) Flex Blending menu option is only enabled if:

• Table Choices > Table Switch/Dual Fuel > Mode is set to "Flex blend"

Clicking Table Choices > Blend Curve (8) Flex Blending displays the following screen:

This is the curve to control the blending between tables based on Flex fuel percentage.
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15 Advanced Engine
This menu covers some of the more complex and race related features.

15.1 Speed and Gear Sensors
The vehicle speed sensors (VSS) allow up to four wheel speeds to be monitored. The inputs read from either a 
wheel/axle mounted pickup or a pickup that is part of the transmission. The input can be magnetic (with suitable 
interface) or more directly a hall type input. This input is converted to a linear speed (ms-1, mph or kph) 
The VSS output feature provides a pulsed output in proportion to the VSS for driving a digital speedometer. 
The gear detection calculates the current gear selected in the gearbox by a number of methods.

Clicking Advanced Engine > Speed and Gear Sensors displays the following screen:

 

The options for these settings are described below:

15.1.1 Vehicle Speed Sensor 1

VSS1 is a wheel on the driven axle.

VSS1 input type

Type of speed sensor connection.

• Off - VSS1 input disabled

• Digital - any pulse input or capture from an expansion board.

• Analogue - 0-5V input directly reporting speed (rare.)
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Analogue Input

Input for analogue 0-5V speed sensor.

Full Scale Speed

Speed at 5V analogue input.

Digital Input

Selects digital pulse input or input via CAN from expansion board.

• Input - a pulse input directly connected

• CANVSS - capture actual speed number from an expansion board over CAN

Configure the CANVSS offset/table/id through the CAN menus.

• Use CAN PWMin - capture pulse period from an expansion board over CAN

Configure the CANPWM offset/table/id through the CAN menus.

Wheel diameter

Overall diameter of wheel and tire.

VSS Position/Type

Where the speed sensor is mounted

• Wheel: Directly on the wheel/hub. Select this when your sensor is picking up on a shaft spinning at the 
same speed as the wheels. Possibly the simplest option here is a gear tooth sensor (such as the 
Honeywell 1GT101DC) in close proximity to the back of the wheel studs, or a pre-existing ABS reluctor.

• Driveline: on the driveline/trans. Select this when your sensor is picking up on a shaft before the final 
drive gear. e.g. gearbox output shaft, propshaft. (This is most likely the setting to use for RWD 
transmission mounted sensors.)

Many transmissions already offer a VSS output, if this is suitable, you may be able to just tap into this. 
Alternatively you could utilise a magnet on the output flange and a hall sensor.

• Pulses per mile: a sensor that provides a pulses-per-mile signal

• Pulse per km: a sensor that provides a pulses-per-mile signal

Pulses

Number of pulses per mile/km when pulses per mile or km is selected.

Speed Sensor #Teeth

Number of teeth on speed pickup reluctor.

PWM Port

CAN PWM port for capturing from expansion board.

Scaler%

Scaler to convert from one unit system to another. 

Megasquirt uses 0.1 ms-2 internally, so to convert from 0.1 mph use 45.6%
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Smoothing Lag Factor

Smoothing factor. 100% = no smoothing, 15% = maximum smoothing.

15.1.2 Vehicle Speed Sensor 2

VSS2 is a wheel on the undriven axle.

The same settings are used as Vehicle Speed Sensor 1

15.1.3 Vehicle Speed Sensor 3

VSS3 is a wheel on the same axle as VSS1. Many settings are shared with VSS1.

VSS3 Input Type

Off - VSS3 input disabled

On - uses same type as VSS1

Analogue Input

Input for analogue 0-5V speed sensor.

Digital Input

Selects digital pulse input or input via CAN from expansion board.

• Input - a pulse input directly connected

• CANVSS - capture actual speed number from an expansion board over CAN

Configure the CANVSS offset/table/id through the CAN menus.

• Use CAN PWMin - capture pulse period from an expansion board over CAN

Configure the CANPWM offset/table/id through the CAN menus.

PWM Port

CAN PWM port for capturing from expansion board.

15.1.4 Vehicle Speed Sensor 4

VSS4 is a wheel on the same axle as VSS2. Many settings are shared with VSS2.

The same settings are used as Vehicle Speed Sensor 3

15.1.5 VSS output

VSS output

The output is used to run a digital tacho. Specify the output port you are using.

VSS units

Type of output conversion.

• Time - The output time period is calculated as time factor / speed in ms-1

• Pulses per mile - scale to match what your speedo is expecting

• Pulses per km - scale to match what your speedo is expecting
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Scale

The scaling factor or pulses per mile/km.

15.1.6 VSSdot smoothing

These settings control how the VSSdot (acceleration) calculation is performed. The lower the sample interval, 
the more respsonsive the calculation but the noisier it will be. Experimentation will be required to get the best 
settings for your application.

Calculating launch acceleration is particularly difficult to get right. Very low tooth counts and wheel speed 
collected via CAN will be the most difficult due to the low data rate and the communication delays.

Sample Interval

How often to calculate VSSdot (acceleration.)

Lag factor

Smoothing factor on VSSdot. 100% = no smoothing, 15% = maximum smoothing.

15.1.7 VSS Sampling

VSS Sample Interval

How often to sample/accumulate VSS teeth. Normally 50ms is ok and gives smoothing.

Hard accelerating vehicles will need to lower this number for improved zero-speed response.

15.1.8 Gear detection

Configures a method to determine what gear your vehicle is in.

Final Drive Ratio

The final drive gear ratio.

Method

The gear detection supports three methods

• VSS/RPM - This calculates gear from engine rpm and wheel speed. It works well with a clutch, but 
might be difficult to get right with a loose convertor. You need to setup VSS1 input, final drive ratio, 
method, number of gears and the gear ratios.

• Analogue - Some bikes are fitted with a Gear Position Sensor. This 0-5V analogue input can be used 
directly to determine gear. You need to setup the method, specify an input port and the mean voltage for
each gear.

• CAN gear# - If you are running a CAN equipped transmission controller, you might be able to directly 
fetch the gear from it. Setup the method here and configure the CAN settings on the CAN menus.

Number of Gears

How many gears you have.

1st Gear Ratio etc.

Ratio of each gear. Only used with VSS/RPM method.
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Input Port

Analogue input for gear-position-sensor.

Gear Voltages

Nominal voltage in each position.

15.1.9 Units

The selections here determine the units used for inputing speed and length. (Programmers note, internally the 
units are always SI units metres and metres per second.) 

Preferred Speed Units

Chooses the speed units - either Mile-per-hour or Kilometres-per-hour

Close the page and re-open after changing.

Preferred Length Units

Chooses the size units - either metres or inches

Close the page and re-open after changing.

15.2 Shaft Speed Sensors
The shaft speed inputs work in a similar way to the vehicle speed but calculates to rpms. It could be used as 
gearbox input shaft speed to monitor convertor or clutch slip; or for turbo turbine speed.

Clicking Advanced Engine > Shaft Speed Sensors displays the following screen:

 

The options for these settings are described below:

Sensor 1

Selects digital pulse input.

Speed sensor #teeth

Number of pickup teeth on reluctor. Fractional teeth are allowed.
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High Speed Input

Where possible, configures this as a high-speed input. Only applies to inputs that are internally connected to a 
timer. Very high speed inputs such as turbo speed sensors will need to use a high-speed input.

Smoothing Lag Factor

Smoothing factor. 100% = no smoothing, 15% = maximum smoothing.

Sensor 2

Selects digital pulse input.

Speed sensor #teeth

Number of pickup teeth on reluctor. Fractional teeth are allowed.

High Speed Input

Where possible, configures this as a high-speed input. Only applies to inputs that are internally connected to a 
timer. Very high speed inputs such as turbo speed sensors will need to use a high-speed input.

Smoothing Lag Factor

Smoothing factor. 100% = no smoothing, 15% = maximum smoothing.

15.3 EGT/Thermocouple Settings
The EGT system in Megasquirt-3 allows inputs from EGT sensors to be datalogged by serial or SDcard. It 
optionally allows the engine to be shutdown if EGT exceeds a set temperature. If an EGT probe is fitted to each 
exhaust port it can be used in conjunction with per-cylinder fuel trim to balance cylinders to account for air flow 
and injector flow differences. Typically an external interface module is required.

Clicking Advanced Engine > EGT/Thermocouple settings displays the following screen:

 

(c) 2014-7 James Murray 2017-01-14 Page 233/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

The options for these settings are described below:

15.3.1 Configuration

No. EGT inputs

Enables the system and specifies the number of channels you have connected.

Calibration

The calibration depends on the thermocouple amplifier in use. Consult the documentation that came with it.

A common calibration is 0V = 32°F/0°C, 5V= 2282°F/1500°C

Temp at 0V

The temperature indicated by a 0V input.

Temp at 5V

The temperature indicated by a 5V input.

15.3.2 Data Capture

Here you specify the local or remote analogue channels that the EGT inputs are connected to. For remote CAN 
inputs, see the CAN section for configuration.

CANEGT settings are covered in the CANEGT manual.

15.3.3 Actions

These settings allow you to specify action if EGT gets too high.

EGT Actions

Enables the EGT warning and shutdown settings.

Warn temperature

Above this temperature the warning output selected on the AFR Safety system (section 9.12) is turned on.

Add fuel

Specifies a raw pulsewidth in milliseconds of additional fuel. This could be used to help protect the engine if 
EGT is too high.

Add to

Normally this is set to "Both". When using staged fuel outputs or dual table you may want to specify a particular 
channel.

Per Cylinder

For sequential fuel ONLY, allows fuel to be added per cylinder. Requires that EGT1 = Cyl#1, EGT2 = Cyl#2 etc.

Shutdown engine

Enables the engine shutdown feature.

Time > warn temp

 If any of the EGTs stay above the warn temperature for more that this time the engine is shutdown.
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Max temperature

If any of the EGTs exceeds this temperature then the engine is shutdown immediately. 

15.4 Generic Sensor Inputs
The Generic Sensors allows optional analogue inputs to be connected and easily recorded in datalogs or used 
as parameters in other features.

Clicking Advanced Engine > Generic Sensor Inputs displays the following screen:

 

The options for these settings are described below:

Each row in the main table applies to a sensor channel.

Source

The input port for a 0-5V analogue signal - either local or on a remote expansion board via CAN. CANADC 
inputs need to be configured in the CAN Parameters also, see section 17.1.

Field Name

Allows for a custom name for the input e.g. "Intercooler temp." This name will be used in dash gauges and 
datalogs.

Transformation

Type of transformation from raw input to useful numbers.

• Raw - raw 0-1023 ADC count

• Linear - useful for many ratiometric sensors with a linear scale.

• Same as MAP - if you have an identical pressure sensor as the main MAP sensor

• Same as CLT - if you have an identical temperature sensor and bias resistor as the main CLT sensor
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• Same as MAT - if you have an identical temperature sensor and bias resistor as the main MAT sensor

• Same as EGO - if you have an identical EGO calibration as the main EGO sensor

• Custom #1 - use custom calibration table that was uploaded through the 'Calibrate Thermistor Tables' in
section 6.8.

• GM calibration - same transform as GM air/coolant thermistor sensors.

0V Value, 5V Value

These are only used with the Linear transformation.

• 0V value - specifies the number you want to see when 0V is applied

• 5V value - specifies the number you want to see when 5V is applied

Many sensors specify output at other voltages, e.g. some datasheets advise pressure at 0.5V and 4.5V. This 
needs to be converted to the 0V and 5V values using a calculator.

Take, 'A' = low voltage   'B' = high voltage  'C' = low pressure  'D' = high pressure

Calculate E = (D - C) / (B - A)

0V value = C - (E * A)

5V value = (E * 5) + 0V value 

e.g. a Honeywell 100psi sensor specifies 0.5V = 0psi and 4.5V = 100psi, this calculates to -12.5 in the 0V box 
and 112.5 in the 5V box.

Lag Factor

Smoothing factor. 100% = no smoothing, 15% = maximum smoothing.

Allow Input Sharing

Normally each input can only be used by one feature. This setting allows inputs to be shared between generic 
sensors and other features. (Obviously you can still only connect one sensor to each input!)

CLT/MAT Units

Selects degF/degC for temperature units when using CLT/MAT calibrations.

15.5 Accelerometer Parameters
This allows configuration of an optional external accelerometer, primarily for datalogging purposes.

The accelerometer is calibrated to +/-1g for convenience, but internally the code uses SI measurement units 
(ms-2) so accelerometer acceleration can be compared to VSSdot measured acceleration. 

The calibration procedure is covered in the Setting Up manual.

Clicking Advanced Engine > Acceleromter Parameters displays the following screen:
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The options for these settings are described below:

X Input

Analogue 0-5V input for X-axis.

Y Input

Analogue 0-5V input for Y-axis.

Z Input

Analogue 0-5V input for Z-axis.

X -1g Calib.

Raw ADC input value when X is -1g.

X +1g Calib.

Raw ADC input value when X is +1g.

Y -1g Calib.

Raw ADC input value when Y is -1g.

Y +1g Calib.

Raw ADC input value when Y is +1g.

Z -1g Calib.

Raw ADC input value when Z is -1g.

Z +1g Calib.

Raw ADC input value when Z is +1g.

Lag Factor

Smoothing factor. 100% = no smoothing, 15% = maximum smoothing.
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15.6 Traction Control
There are a number of different traction control strategies that may suit your vehicle and be permitted with your 
competition rules.

Clicking Advanced Engine > Traction Control displays the following screen:

 

The options for these settings are described below:

Traction Control

Enables the traction control system.

Method

Traction control method:

• Perfect Run - a drag race strategy for a single pass comparing actual VSS against best possible.

• VSS %slip - compares VSS1 to VSS2 and detects slip%.

• Perfect Run RPM - similar to Perfect Run but without VSS for classes where that is not allowed.

• Switch input - for use with an external slip detector.

Enable Input

Optional digital switch input

Minimum TPS

Only enable traction control above this TPS%

Minimum MAP

Only used in VSS %slip mode. Only enable traction control above this MAP
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Minimum VSS

Only enable traction control above this driven wheel speed.

Driven

Which sensors are used as the 'driven' speed in calcs.

Side2side compares VSS1 with VSS2 and compares VSS3 with VSS4. Whichever side has the most slip is then
used for the remaining calculations.

On a rear weel drive car with four sensors you might choose to have VSS1 = rear right, VSS2 = front right, 
VSS3 = rear left, VSS4 = front left.

Undriven VSS

Which sensors are used as the 'driven' speed in calcs.

Side2side compares VSS1 with VSS2 and compares VSS3 with VSS4. Whichever side has the most slip is then
used for the remaining calculations.

Slip % Setting

Whether to use a fixed slip% limit or an adjustable curve.

Slip Threshold

Fixed slip% limit.

Nitrous Control

Only on/off control is presently supported.

Add Fuel To:

Which bank of injectors to add fuel to.

Normally select 'Both'

When staging bank 1 = primary, bank 2 = secondary
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15.7 Traction Control - Perfect Run VSS

The Traction Control - Perfect Run VSS menu option is only enabled if:

• Advanced Engine > Traction Control > Traction Control is set to "On".

• AND Method is set to "Perfect Run" See Section 15.6.

Clicking Advanced Engine > Traction Control - Perfect Run VSS displays the following screen:

 

The perfect run traction control sets a curve of the 'best' speed (VSS) that you can run for each time-point after 
launch.

If your VSS is reporting a higher number than the curve, it is assumed to be wheelspin and the reactions come 
into force.

This traction control strategy is typically applied early in a run only.

Note that VSS based traction control is outlawed in some race classes.
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15.8 Traction Control - Perfect Run RPM

The Traction Control - Perfect Run VSS menu option is only enabled if:

• Advanced Engine > Traction Control > Traction Control is set to "On".

• AND Method is set to "Perfect Run RPM" See Section 15.6.

Clicking Advanced Engine > Traction Control - Perfect Run RPM displays the following screen:

 

The perfect run traction control sets a curve of the 'best' RPM that you can run for each time-point after launch.

If your RPM is higher than the curve, it is assumed to be wheelspin and the reactions come into force.

This traction control strategy only makes sense in first gear. Set the final row in the table to just earlier than the 
time when you expect to shift with an RPM higher than your maximum RPM.
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15.9 Traction Control - External Slip% input

The Traction Control - External Slip% input menu option is only enabled if:

• Advanced Engine > Traction Control > Traction Control is set to "On".

• AND Method is set to "VSS %slip" 

• AND Slip % Setting is set to "Adjustable" See Section 15.6.

Clicking Advanced Engine > Traction Control - External Slip % input displays the following screen:

 

0-5V knob input

This enables a link to a Generic Sensor input to enable you to set the slip threshold. Configure the Generic 
Sensor to give 0-100 as the linear output.

Slip Threshold vs. Knob Input

This curve sets the desired slip threshold against the input knob position.
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15.10 Traction Control Reactions

The Traction Control - External Slip% input menu option is only enabled if:

• Advanced Engine > Traction Control > Traction Control is set to "On".

Clicking Advanced Engine > Traction Control Reactions input displays the following screen:

 

Each curve allows you to modify ECU outputs based on the amount of slip. You can view and datalog the 
SlipxTime variable. The fastest method to reduce engine torque is through timing retardation.

Experimentation and datalog review will be required to achieve the best results.
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15.11 Launch / 2-step / 3-step / T-brake
Clicking Advanced Engine > Launch / 2-step / 3-step / T-brake displays the following screen:

 

The options for these settings are described below:

15.11.1 Launch Settings

Launch Control Option

This option can be set to one of three options:

• Off – all of launch is turned off;

• Launch – launch only, no flat shift;

• Launch/flatshift – launch and flat shift.

Flat shift is used on manual gearboxes for full throttle shifts with a clutch switch to engage the limiter.

For bike shifting, consider the Sequential Shift Cut instead, see section 15.13.

Input On

Input for launch switch.

Launch Hard Limit (rpm)

Above this rpm the hard limiter methods are used when the launch conditions are met.
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Soft Limit Zone (rpm)

The soft limit is this many rpm below the hard limit (this is sometimes called the control range.)

200 rpm is typical.

Soft Limit Retard To (deg)

The absolute timing to retard to, i.e., 5 gives 5 BTDC timing.

Launch Fuel Add/Remove

Allows fuelling to be changed while the launch limiter is on.

Fuel Addition

The raw millisecond pulsewidth addition to make. Positive numbers add fuel, negative subtract it.

Enable Launch When TPS Above (%)

Launch is only active when the throttle is open a certain percentage. Most users can safely set this to a very low
percentage.

Limiter Method

This option can be set to one of four settings:

• None – do not use;

• Spark cut – drop sparks, this is the most common limiter used but will not work with EDIS ignition;

• Fuel cut – cuts fuel;

• Spark and fuel – cuts both.

Disable Launch when VSS1 Above

Prevents launch from activating once you are rolling. Requires VSS to be enabled.

15.11.2 Flat Shift Settings

Disable Flat-Shift when VSS1 Below

Prevents flat-shift from activating at low speeds e.g. just after launch

Flat Shifting Arming RPM (RPM)

This rpm set point is used to differentiate between a flat shift and launch condition, typically set to a few 
thousand RPM above idle.

Flat shift hard to rev limit (RPM)

Above this rpm the hard limiter methods are used when the flat-shift conditions are met.

Soft Limit Retard To (deg)

The absolute timing to retard to, i.e., 5 gives 5 BTDC timing.

Cut Fuel Above

During the flat-shift up-shift and the revs are falling, the fuel is cut off until the revs have fallen below this set 
point to reduce exhaust explosions.
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15.11.3 Timed Retard

Timed Retard After Launch

Enables feature to feed in timing after launch.

Variable Launch

Input for 0-5V analogue potentiometer used to vary launch RPM.

Minimum Setting

With a 0V(minimum) input, the launch hard limit is set to this RPM.

Maximum Setting

With a 5V (maximum) input, the launch hard limit is set to this RPM.

15.11.4 Transbrake, Throttle Stop

Transbrake Button Input

Switch input for transbrake button.

Transbrake Output

Output for transbrake solenoid. Typically this will be wired to a solid-state-relay (SSR) to control the transbrake.

Delay

Delay between button release and transbrake release.

Turbo Staging Button

Input for Turbo Staging control. (aka "bump box")

Release Time

How long to release trans-brake for on each move step. This should be set long enough to move the car a little 
without gaining any speed.

On Time

How long the trans-brake should be re-activated for between each step. This should be set long enough to fully 
grab again.

Main # Moves

How many moves (trans-brake release steps) on the first press of the button. Each subsequent press of the 
button gives a single move.

Throttle Stop Output

Output for throttle-stop solenoid.

On Delay After Launch

Delay after launch before solenoid is activated.
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Keep On For

How long to keep solenoid on for.

15.11.5 3-Step / Burnout Limiter

This limiter gives another switch operated rev-limiter. It can be used as a burnout limiter, 'valet mode' or can be 
used with 3rd party sequential shift controllers to cut ignition (set limit to 1000.)

3-step Input

Input for 3-step switch.

Soft Limit Retard To

The timing is retarded to this angle when the 3-step is on.

Hard Limits

Sets the hard limit RPM when the 3-step is on.

15.11.6 Line Lock Staging

This feature allows the line-lock to hold the front wheels (typically) stationary while in launch mode to prevent 
rolling the beams in drag racing. It is mainly of use for manual cars. When the button is pressed it enables the 
relay output. When the engine enters and then leaves launch mode, the relay is released (unlocking the 
wheels.) Pressing the button will toggle the output.

Typical usage:

• Drive up close to startline

• Press button once.

• Tap the brakes.

• Creep forward (working against the brakes.)

• Bring car up to launch limiter.

• Launch as normal.

The Line-Lock Staging menu options are only enabled if:

• Advanced Engine > Launch / 2-step / 3-step / T-brake > Launch Control Option is enabled.

Button Input

The ground-switch button input to arm the line-lock staging system and set the output.

Relay Output

The output to the relay to control the line-lock.

15.12 Timed Retard After Launch

The Timed Retard After Launch input menu option is only enabled if:

• Advanced Engine > Launch / 2-step / 3-step / T-brake > Launch Control Option is enabled.

• AND Timed Retard After Launch is enabled. See Section 15.11.1.

Clicking Advanced Engine > Timed Retard After Launch displays the following screen:
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The curve sets the degrees of ignition subtracted from the normal timing (i.e. retarding it) against time after 
launch.

This can be used to launch at higher RPMs without blowing the tires away and then feeding the timing back in.

Be sure to end the curve with zero degrees of retard to use normal timing for the rest of the run.
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15.13 Sequential Shift Cut
Clicking Advanced Engine > Sequential Shift Cut will display the following screen:  

 

The options for these settings are described below:

Shifter Spark Cut System

Enables the sequential / bike shift cut system.

Mode

Whether the system operates from a push-button or automatically.

Cut Fuel

Whether fuel is also cut during the shift-cut.

Button Input

Input used for the button.

Solenoid Output

Output to the shift solenoid.
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RPM > (RPM)

Minimum RPM to allow shifting.

And TPS > (%)

Minimum throttle to allow shifting.

Delay Before Spark Cut (s)

The solenoid is activated immediately, then wait this long before cutting spark.

Spark Cut Times (s)

How long to cut spark for.

Gear Based Delay

Option to add additional spark cut time per gear.

Additional Delay

For each gear-shift specifies the additional delay to add to the basic "Delay before spark cut"

Solenoid Delay (s)

How long to keep the solenoid powered after the spark is returned.

Re-shift Hold-off Time (s)

Ignore button for this long after shifting – to prevent a false shift.

Automatic shift mode points

RPM for each gear to initiate an up-shift.
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15.14 Nitrous System
Clicking Advanced Engine > Nitrous System displays the following screen: 

 

The options for these settings are described below:

15.14.1 General Settings

Nitrous Control

Enables the feature.

Turn N20 On When Above (RPM)

The minimum RPM to enable nitrous.

And Coolant Temp Above (°F/°C)

The minimum coolant temperature to enable nitrous.

And TPS > (%)

The minimum throttle position to enable nitrous.

Max RPM

The maximum RPM to enable nitrous.

Enrich Which Bank

Set to “Both” for most installs. If using “Dual table” or “Staging” are in use it selects which injector bank receives 
any addition fuel pulsewidth.
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On/Off vs Progressive

Selects between On/Off or Progressive control mode.

Time, RPM, VSS-based

Selects the control factor for progressive nitrous.

• Time - the curves are based on time since launch (requires using launch control)

• RPM - the curves are based on engine RPM

• VSS - the curves are based on vehicle speed (VSS1)

Solenoid Frequency

Selects solenoid frequency. Typically around 13Hz.

AFR Safety uses AFR2 Targets

Allows optional AFR safety system to use alternate AFR targets when nitrous is active.

Fuel adder percent calc

Whether the fuel adder percentage shares the N2O duty curve or uses its own curve. The added fuel is a 
percentage of the Additional Fuel PW lookup between min and max RPMs.

For dry nitrous systems the added fuel is related to pulsewidth and engine RPM.

This setting is applicable in "VSS-based" and "Time-based" progressive only. For "RPM-based" the fuel 
is set directly on the progressive curve.

15.14.2 Nitrous System Stage 1

Stage 1 Output - Nitrous

Selects where the outputs are connected.

Expansion boards will need configuring through 'CAN parameters' (see Section 17.1.)

Stage 1 Output - Fuel

Selects where the outputs are connected.

Enable Input On

Input to use to enable the nitrous system.

Expansion boards will need configuring through 'CAN parameters' (see Section 17.1.)

Additional Fuel PW @ N20 Min RPM (ms)

Fuel pulsewidth to add at the min RPM (tapers down between min and max.) For On/Off mode; "VSS-based" 
and "Time-based" progressive.

Additional Fuel PW @ N20 MAX RPM (ms)

Fuel pulsewidth to add at the max RPM (tapers down between min and max.) For On/Off mode; "VSS-based" 
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and "Time-based" progressive.

Retard Ignition By (deg)

Sets a fixed ignition retard when nitrous is active. Only for On/Off mode.

Nitrous Delay After Launch (s)

Sets a minimum time after launch control is released before nitrous can activate.

Nitrous Delay After Flat Shift (s)

Sets a minimum time after flat-shift is released before nitrous can activate.

Nitrous Stage 2

Enables the second stage.

The Nitrous Stage 2 options are only enabled if “Nitrous Stage 2” is enabled.

Stage 2 Output - Nitrous

Selects where the outputs are connected.

Expansion boards will need configuring through 'CAN parameters' (see Section 17.1.)

Stage 2 Output - Fuel

Selects where the outputs are connected.

Enable Stage 2 Above (RPM)

The activation RPM for stage 2.

Max RPM

The maximum RPM for stage 2.

Delay After Stage 1 (s)

Sets a minimum time delay after stage 1 activates before stage 2 can activate.

Retard Ignition By (deg)

Sets an additional ignition retard when stage 2 is active. Only for On/Off mode.

Additional Fuel PW @  N20 Min RPM (ms)

Fuel pulsewidth to add at the min RPM (tapers down between min and max.) Only for On/Off mode.

Additional Fuel PW @  N20 Max RPM (ms)

Fuel pulsewidth to add at the max RPM (tapers down between min and max.) Only for On/Off mode.

15.15 Nitrous - Time-based progressive
The curves allow control of nitrous solenoid duty cycle, fuel additional pulsewidth, ignition retard : for nitrous 
stages 1 and 2.
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15.16 Nitrous - RPM-based progressive
This works similarly to the time-based curves, but engine speed (RPM) is used.

15.17 Nitrous - VSS-based progressive
This works similarly to the time-based curves, but vehicle speed from VSS1 is used.

(c) 2014-7 James Murray 2017-01-14 Page 254/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

15.18 Water Injection
Water injection is typically used with forced induction to reduce charge temperature and reduce detonation 
problems.

Clicking Advanced Engine > Water Injection displays the following screen:

 

The options for these settings are described below:

Enable Water/Meth Injection

Enables the feature.

Pump Output

Output to pump relay.

Valve Style

• 'Off' - no valve output (used fixed nozzle)

• 'Slow' - slow speed valve output with chosen PWM duty cycle

• 'Fast' - valve switches at injector speed with chosen PWM duty cycle.

Frequency

Valve operating frequency.

Valve Output

Output for valve.

TPS >

Only enable above this TPS%.

RPM >

Only enable above this RPM.

MAP >

Only enable above this MAP.
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MAT >

Only enable above this MAT.

Low Fluid Level Input

Allows a low fluid level sensor switch input.

The switch must be wired so that the input is grounded when the level is ok and no connection is made in low or
fault conditions.

If fluid reserve is low when water injection is required, for safety the engine will be shutdown using the 
parameters in the AFR Safety System.

Duty Table

The duty cycle of the output vs RPM/load

15.19 High Power Time Enrichment
This feature will enrich the fuel mixture under prolonged high load to mitage internal engine temperatures.

This features requires that "Incorporate AFR" is enabled. See Section 8.2.4.

Clicking Advanced Engine >High Power Time Enrichment displays the following screen:

 

The options for these settings are described below:

High Power Time Enrichment

Allows a richer mixture after prolonged high power operation to cool the piston crown. The richer mixture is 
calculated by decreasing the AFR target using the number from the curve. The 'high power timer' counts up 
when above the load/rpm points and counts down below those points. The relevant enrichment is applied until 
the counter returns to zero.

Above Load

Only enable above this fuel-load.
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Above RPM

Only enable above this RPM.

Enrichment vs Time

The curve specifies AFR decrease (richer) vs. time.

It is normal for the first row to be 0, 0.

The second row typically specifies when the enrichment should begin. e.g. 7, 0. This means that there is no 
change from 0-7 seconds as both are set to a 0 decrease in AFR.

The third row onwards specify the richening.

15.20 Oil Pressure
The oil pressure system allows for monitoring of oil pressure and can also link into the Check Engine Light 
system. See section 17.14.

Clicking Advanced Engine > Oil Pressure displays the following screen:

 

The options for these settings are described below:

Oil Pressure Input

Sensor channel used for oil pressure input.

Oil Pressure Warning

Output for warning lamp.

Min/Max Oil Pressure vs RPM

For each RPM setting, set the min and max oil pressures allowed at that RPM.

Outside of the limits the warning light will be illuminated.

It is suggested that the first row be 0 RPM. Set the Min and Max limits above 0 so that the oil warning light is 
tested on each start.

15.21 Pit Lane Limiter
This is designed as an active speed limiter, either for pit lane speed limits or race classes that use a rolling start.
(It may be subject to change in future releases.)
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Clicking Advanced Engine > Pit Lane Limiter displays the following screen:

 

 

Pit Limiter Enable

Enables Pit Lane Limiter

Input

Switch input.

Mode

Fixed = one fixed limiter speed

Holding = takes speed when button pressed as limiter and holds it.

Use VSS or RPM Target

Whether VSS or RPM is used as the hold target.

Speed

Fixed speed limit.

Speed control range

Control range of speed to apply limiters across. 5mph recommended as a starting point. Setting the range too 
small will cause oscillation.

RPM control range

Control range of RPM to apply limiters across. Setting the range too small will cause oscillation.

Tracking sensitivity

Adjust tracking sensitivity to adjust limiter window. Initially the 0% fuel/spark cut is applied at the limit and full cut
is applied at the limit+range. If the speed is above the limit, the lower limiting point is lowered slowly.

Spark Retard Mode
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Whether to use spark retard.

Maximum Retard

Maximum allowed spark retard.

Enable Spark Cut Limiting

Whether to use spark cut. (Can cause backfires and exhaust damage.)

Enable Fuel Cut Limiting

Whether to use fuel cut.

Progressive Fuel Cut

Whether to use a progressive fuel cut (sequential only.)

15.22 Programmable On/Off Outputs 1
Clicking Advanced Engine > Programmable On/Off Outputs displays the following screen:

 

This screen allows you to configure programmable outputs in addition to the outputs defined in other specific 
features. The options for these settings are outlined in Sections 15.22.1. to 15.22.3. below:

15.22.1 Output Port

On the left hand side of this screen is a list of ports that you can program to carry out different tasks.

This gives a list of the ports that can be programmed. The above image is a sample list of ports shown 
when connected to a Megasquirt. Your lists of ports may differ depending on your product, although they 
can be used in the same way.

When you click on any of the ports listed, the settings in the “Port Settings” and the “Active Conditions” sections 
on the right hand of the screen (documented in Sections 15.22.2. and 15.22.3. respectively) will apply to the port
you have selected.
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Be careful that you don't attempt to program a port that is already in use! The most obvious example is 
FIDLE, which can optionally be set as the PWM Idle port in the “Idle Control” screen (see Section 11.13.) 
If you are using FIDLE for this purpose you will encounter errors if you attempt to program it for a second 
role. Whilst this is the most obvious potential conflict, it is worth making sure that any port that you 
program is not being used for any other role.

15.22.2 Port Settings

These settings allow you to select whether a port is used and when it is used.

Enabled

Clicking the check box (so that it contains a tick) means that you are going to use the selected port. The gray 
bulb next to the port you are using in the Output Port list will change to green when this setting is checked.

Power On Value

This is a setting that determines if the output will be on or off when your Megasquit powers up. Please take the 
active conditions (see Section 15.22.3.) into account when deciding whether to set this to on or off.

Typically this value is set to “Off”.

Active Value

This is an on/off setting that determines if the output is triggered when the conditions for it to become active are 
met.

Typically this value is set to “On”.

15.22.3 Active Conditions

These settings allow you to determine the conditions under which the output becomes active.

Output channel 

This is a list of Megasquirt variables - much the same as the various gauges you can select in dashboard. For 
details on these, see the MegaLogViewer Datalog Fields section.

Operator

This 'logical operator' forms part of the equation. There are four options for this setting:

• > (is greater than);

• = (is equal to – this options is rarely useful);

• < (is less than);

• And (performs a bitwise AND operation – useful for setting outputs based on status bits.) The Setting Up
Manual contains examples on using this operator.

Threshold 

The value at which the output channel is compared using the operator to establish whether the condition is 
considered to be “Active”.

Hysteresis 

It is very common for a value to hover around the threshold which would cause the output to turn on and off 
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rapidly. This setting helps to prevent that by creating a deadband below the threshold which prevents the output 
from being repeatedly activated during borderline conditions.

Threshold and Hysteresis in bitwise AND mode

Bitwise AND changes the meaning of the threshold and hysteresis field such that, in programming terms:

result = ((value & THRESHOLD) == HYST)

Additional condition

There are three options for this drop down box:

• No additional condition – only a single condition is used

• Or – output triggers if either condition 1 OR condition 2 is met

• And – output triggers only when condition 1 AND condition 2 are both met

If “Or” or “And” are selected then complete the second Output Channel, Operator, Threshold and 
Hysteresis using the procedures described above.

15.23 Programmable On/Off Outputs 2
This operates in the same way as the Programmable On/Off Outputs 1 above, but for the optional CANOUT and
'Loop' channels.

The 'CANOUT' channels can be used to operate an output on an expansion board configured through the CAN 
Parameters (section 17.1) or IO-box (section 17.12) settings.

The special purpose "Loop" options allow conditions to be daisy-chained or the "Loop" values can be selected 
as input pins into other features.

15.24 Generic PWM Outputs
The Generic PWM system allows up to six independent open-loop PWM (pulse width modulated) or on/off 
outputs. The duties are programmed through an 6x6 table of rpm vs. Y-axis. The output is typically used to drive 
a solenoid valve (PWM mode) or relay (on/off.) PWM is a method that pulses an output on and off, the on-time 
percentage (duty) is variable, this is often used for idle valves and allows a valve to "float" in-between closed 
and open for variable flow rates. 

Clicking Advanced Engine > Generic PWM Output A displays the following screen (table mode):

 

Clicking Advanced Engine > Generic PWM Output B displays the following screen (curve mode):
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The options for these settings are described below:

Enable Generic PWM

Enables Generic PWM feature. A table or curve is used to plot the desired output based on a lookup from the 
input variables.

Output Port/Pin

Output for relay/solenoid.

Frequency / On-Off

Selects:

• On-Off - output is turned on or off based on the table/curve.

• Variable frequency - output runs at the frequency set by the table/curve with 50% duty.

• xxHz - output runs at a fixed frequency with duty set by the table/curve.

On Above Duty

Output is on when the table/curve is above this number. On/Off mode only.

Off Below Duty

Output is off when the table/curve is below this number. On/Off mode only.

Load Axis

This selects the 'load' axis on the table or curve.

Table or Curve

Chooses between a 3D mapped table or a 2D curve.

CLT/MAT Units

This display only field shows whether degC or degF are selected. It is set on the Generic Sensors page.

15.25 Generic Closed-Loop
The Generic Closed-Loop system allows up to two independent closed-loop PWM (pulse width modulated)  
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outputs. A table is used to plot the desired value of the feedback value (PV) based on a lookup from the input 
variables. A closed-loop PID method adjusts the PWM output until the desired feedback value is achieved.

Clicking Advanced Engine > Generic Closed-Loop Output A displays the following screen:

 

The options for these settings are described below:

Enable

Generic Closed-Loop channel A on or off.

Closed-loop (PID) type

Type B (change in error affects P term) or

Type C (change in PV affects P term) PID

Load Axis

Variable used as the Y load axis in the lookup table

Feedback Input Variable (PV)

Variable used as feedback input (PV)

Max Feedback Input

Maximum value for feedback input (PV)

Min Feedback Input

Minimum value for feedback input (PV)

Control Output Port/Pin

Output pin.

This is the output to control the actuator (or whatever) that change the process.

e.g. opens or closes a valve.

(c) 2014-7 James Murray 2017-01-14 Page 263/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

Frequency

Frequency to use for PWM output

Max Control Duty

Maximum output duty

Min Control Duty

Minimum output duty

Output Polarity

Output polarity for control output, the options are

• Normal (higher duty = higher PV)

• Inverted (lower duty = higher PV)

Control Interval

Time in milliseconds between each run of the control loop

P term

Proportional gain.

I term

Integral gain.

D term

Derivative gain.

CLT/MAT units

This display only field shows whether degC or degF are selected. It is set on the Generic Sensors page.

Target Table

This is the target value which the closed-loop algorithm aims to match to the feedback input by controlling the 
PWM output.
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16 3D Maps
As described in Section 1.5.4 there are 3D Maps for many of the 3D Tables that are used throughout 
TunerStudio. That section outlines the purpose of these maps and how they can be used.

All of the maps are accessible from the 3D Maps toolbar menu. Sections 16.1. to 16.7. below outlines the type 
of maps available and refers back to the relevant sections that include the 3D Tables to which they correspond. 
You can make changes to either the 3D Table or the 3D Map at any time, although it is strongly 
recommended that you do not change both simultaneously as it can be confusing..

16.1 Fuel VE Tables [1 to 4]
The three Fuel VE 3D Maps directly correspond to the four Fuel VE Tables which are documented in Section
9.13. That section of this guide outlines the options that are required to enable each of those tables. Those 
same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Fuel VE Table [1, 2, 3 or 4] will displays variant of the following screen:

  

The screen will be a direct transformation of the numerical values in the matching Fuel VE Table. The X & Y 
axes represent rpm & fuelload respectively, and the height at each point reflects the percentage for the same 
point in the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.2 AFR Tables [1 and 2]
The two AFR Maps directly correspond to the two AFR Tables which are documented in Section 9.8. That 
section of this guide outlines the options that are required to enable both of those tables. Those same options 
will enable the equivalent menu options in the 3D Maps toolbar menu.

  

Clicking 3D Maps > AFR Table [1 or 2] displays a variant of the following screen:

The screen will be a direct transformation of the numerical values in the matching AFR Table. The X & Y axes 
represent rpm & afr load respectively, and the height at each point reflects the AFR for the same point in the 
table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.3 Ignition Tables [1 to 4]
The three Ignition Maps directly correspond to the four Ignition Tables which are documented in Section 10.13. 
That section of this guide outlines the options that are required to enable each of those tables. Those same 
options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Ignition Table [1, 2, 3 or 4] displays a variant of the following screen:

  

The screen will be a direct transformation of the numerical values in the matching Ignition Table. The X & Y axes
represent rpm & ignition load respectively, and the height at each point reflects the degrees for the same point in
the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.4 Rotary Split Table
The Rotary Split Map directly corresponds to the Rotary Split Table which is documented in Section 10.15. That 
section of this guide outlines the options that are required to enable that tables. The same options will enable 
the Rotary Split Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Rotary Split Table displays the following screen:

  

The screen will be a direct transformation of the numerical values in the Rotary Split Table. The X & Y axes 
represent rpm & ignition load respectively, and the height at each point reflects the degrees for the same point in
the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.5 Boost Control Duty Table
The Boost Control Duty Table Map directly corresponds to the Boost Control Duty Table which is documented in 
Section 13.2. That section of this guide outlines the options that are required to enable that table. The same 
options will enable the Boost Control Duty Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Boost Control Duty Table displays the following screen:

  

The screen will be a direct transformation of the numerical values in the Boost Control Duty Table. The X & Y 
axes represent rpm & throttle respectively, and the height at each point reflects the percentage for the same 
point in the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.6 Boost Control Target Table
The Boost Control Target Table Map directly corresponds to the Boost Control Target Table which is documented
in Section 13.3. That section of this guide outlines the options that are required to enable that table. The same 
options will enable the Boost Control Target Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Boost Control Target Table displays the following screen:

  

The screen will be a direct transformation of the numerical values in the Boost Control Target Table. The X & Y 
axes represent rpm & throttle respectively, and the height at each point reflects the percentage for the same 
point in the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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16.7 Injection Timing Tables [Primary and Secondary]
The two Injection Timing 3D Maps directly correspond to the two Injection Timing Tables which are documented 
in Section 9.3. That section of this guide outlines the options that are required to enable each of those tables. 
Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Injection Timing Table [Primary or Secondary] displays a variant of the following screen:

  

The screen will be a direct transformation of the numerical values in the matching Injection Timing Table. The X 
& Y axes represent rpm & fuelload respectively, and the height at each point reflects the degrees for the same 
point in the table.

You can use the methods described in Section 1.5.4 to view and make changes to these values.
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17 CAN bus / Testmodes
The feature set of the Megasquirt can be extended using external expansion boards which connect to the 
mainboard over a two wire "CAN" connection. The CAN connection is documented in the Hardware manual for 
your Megasquirt. CAN (Controller Area Network) bus settings configure the communication with the expansion 
board. Sections 17.1 onwards outline how this can be done.

The majority of the CAN settings relate to the proprietary Megasquirt 29bit CAN header protocol. Standard 11bit 
broadcasting is covered in section 17.2. Additional documentation is available at www.msextra.com describing 
the 29bit protocol and the 11bit broadcasting options.

Sensor validation ("Check Engine Light") and Limp mode strategies are covered on this menu.

Megasquirt also includes a number of “test modes” to allow you to check your hardware. These allow you to 
confirm operation of some system components independant of the normal ECU operation. This is highly 
recommended before first starting the engine.These are outlined in sections 17.17. to 17.21. below.

17.1 CAN Parameters
Clicking CAN bus / Testmodes  > CAN Parameters displays the following screen:

  

The options for these settings are described below:

My CAN ID

Set to 0 unless you specifically want to configure this as a secondary data capture ECU.
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Master Enable

Master enable/disable for all CAN polling and broadcasting.. Setting to "Off" still allows CAN-passthrough for 
tuning but turns off all other messages. This can be useful for performing a firmware upgrade on a remote 
expansion board.

29bit Megasquirt CAN Enable

Master enable/disable for 29bit 'Megasquirt CAN'. Normally this should be enabled to allow 'passthrough' tuning 
or data exchange with other MS3 compatible CAN devices.

If not needed, it may be disabled to prevent interference from other devices broadcasting standard 29bit 
messages or to allow communication with 3rd party devices using 29bit broadcasts.

Normally leave this enabled.

CAN baud rate

Sets the CAN baud rate. 500k is the standard baud rate, changing this will prevent communications with 
Megasquirt-compatible devices. Alternatives for 3rd party devices are 250k and 1M.

Normally leave this set to 500k.

The remaining settings on this screen are only available if 29bit Megasquirt CAN is enabled.

Enable PWM Polling

Enables capturing PWM (pulse/frequency) from expansion board and selects either 16bit or 32bit data. Refer to 
your expansion board documentation for the appropriate setting.

 If this setting is not enabled the next five settings will remain disabled.

Remote CAN ID

CAN ID of the expansion board used for PWM polling.

Remote Table Number For PWM Data

The table number on the expansion board for PWM data.

Remote Table Offset For PWM Data (bytes)

Data offset on the expansion board used for PWM data.

Remote PWM Clock Frequency (MHz)

Clock frequency on expansion board (see the documentation that came with the expansion board.)

Remote PWM Clock Prescale

Prescaler on expansion board (see the documentation that came with the expansion board.)

Remote PWM Clock Divider

Dividerer on expansion board (see the documentation that came with the expansion board.)
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Enable ADC Polling

Enables analogue (ADC) polling from expansion board. See section 17.1.3.

17.1.1 Digital Ports

The next two settings are only enabled if an Input Port or Output Port is enabled.

Remote CAN ID

The CAN ID of expansion board used for ports polling.

Remote Table Number For Ports Data

The table number on the expansion board used for ports data.

Enable Input Port

Enables ports polling from expansion board.

Remote Table Offset For Ports Data (bytes)

Data offset on the expansion board used for input ports data.

Enable Output Port

Enables ports sending to expansion board.

Remote Table Offset For Ports Data (bytes)

Data offset on the expansion board used for output ports data.

17.1.2 PWM Outputs

A select number of features can use a PWM output on an expansion board, these settings configure the 
expansion board parameters.

Enable PWM Outputs

Enables sending PWM/pulsed outputs to expansion board.

Remote CAN ID

CAN ID of the expansion board used for PWM outputs.

Table

The table number on the expansion board for PWM outputs.

Offset

Data offset on the expansion board used for PWM outputs.

Force Duty to 0-255.

Forces PWM duty cycle to 0-255 range.

e.g. generic PWMs operate on a 0-100 scale, but your remote device might require a 0-255 scale.
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17.1.3 CAN ADC Selection

These options are only enabled if

• “Master Enable” is set to “Enabled” 

• AND Enable ADC Polling is set to "Enabled" (see above)

These selections allow the collection of remote analogue data which is then stored into the "CANADCxx" 
variable within the Megasquirt. This is then available for datalogging or use by an internal feature. This method 
ensures that most of the CAN data capture settings are held on one screen and other features can use a 
simpler interface.

CAN ADC 1-4

Enables capturing analogue inputs from expansion board and stores then in CANADC1-4.

The following three options are only enabled if this setting is enabled.

CAN Id

The CAN Id of the expansion board for capture to CAN ADC 1-4.

Table

The table number on the expansion board for capture to CAN ADC 1-4.

Offset

Data offset on the expansion board for capture to CAN ADC 1-4.

CAN ADC 5-8, 9-12, 13-16, 17-20, 21-24

These settings work in exactly the same way as those for ADC 1-4.

17.2 CAN Broadcasting

The CAN bus / Testmodes > CAN Broadcasting menu option is only enabled if “Master Enable” is set to 
“Enable” in the CAN Parameters screen (see Section 17.1.)

This screen contains a selection of built-in broadcasts using standard 11bit headers to support specific customer
requirements.

Clicking CAN bus / Testmodes > CAN Broadcasting displays the following screen:
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The options for these settings are described below:

Enable Broadcasting

Enables broadcasting of parameters over CAN using standard 11bit headers.

Unless this setting is enabled, all other settings on the screen will be disabled.

Broadcast Interval (ms)

How frequently to broadcast.

Broadcast Messages

Specific messages can be enabled for broadcasting. These messages are encoded to suit specific OEM gauge 
clusters.

Any appropriate selection can be set to “On”. These messages are listed as follows:

• 0x280 – rpm * 4;

• 0x280 – rpm * 1;

• 0x289 – coolant;

• 0x316 – rpm;

• 0x329 – coolant;

• 0x561 – Alfa / Fiat / Lancia Dash;

• 0x361 – Alfa / Fiat / Lancia;

• 0x041 – Alfa / Fiat / Lancia.

• Holset HE351VE VGT turbo - this broadcasts 'boost duty' with a 29bit CAN identifier specific to the turbo
to control the variable vanes. It is necessary to set the CAN baud rate to 250k.
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• 0x23d Nissan 350Z temp/RPM - enables broadcast for Nissan 350Z dash

• User defined testing - enables user defined messages to be broadcast, see next section.

17.3 CAN Broadcast testing
A custom identifier (decimal) and payload can be broadcast. (Always 8 bytes.)

Clicking CAN bus / Testmodes > CAN Broadcast Testing displays the following screen:

 

Identifier

The message ID in decimal

Data 0-7

The 8 data bytes in decimal.

(c) 2014-7 James Murray 2017-01-14 Page 277/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

17.4 CAN Realtime Data Broadcasting
This allows all of the engine parameters to be broadcast to the CAN using standard 11bit identifiers which can 
then be received and displayed by suitable 3rd party dashes or dash loggers. 

See also the simplified Dash Broadcasting in section 24.23 which is recommended for 3rd party integrators.

Clicking CAN bus / Testmodes > CAN Realtime Data Broadcasting displays the following screen:

  

Once enabled, the user can select which data packets to broadcast and at what frequency. Be aware that the 
maximum capacity of CAN is around 4000 packets per second i.e. 40 channels at 100Hz. For reliable operation 
of other devices on the network it is suggested that a lower limit of 1-2000 be applied.

More technical details of this feature are available in a specific PDF available from 
http://www.msextra.com/doc/pdf/

17.5 CAN Realtime Data Broadcasting 2
More data channels in the real-time broadcasting system.

17.6 CAN Realtime Data Broadcasting 3
More data channels in the real-time broadcasting system.

17.7 CAN Realtime Data Broadcasting 4
More data channels in the real-time broadcasting system.
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17.8 CAN Receiving
This allows the reception and processing of standard 11bit CAN messages. These can be used to collect remote
sensor data or wheel speed from ABS modules etc.

Clicking CAN bus / Testmodes > CAN Receiving displays the following screen:

Enable receiving CAN data

This is a master enable for CAN receiving. Set this to 'Off' while adjusting the configuration fields below and then
set to 'On' to enable reception.

Be sure to set the enable to 'On' once you have configured the lower fields!

Local variable/channel

Megasquirt variable to store resulting data to. This can then be used by other subsystems. 

Std/Ext

Standard (11bit) or Extended (29bit) headers on message.

If you want to receive 29bit messages you will almost certainly need to disable Megasquirt-CAN (section 17.1.)

Identifier (decimal)

CAN identifier to listen for. (See also Offset)

Offset

Offset of data within each 8-byte CAN message.

For systems sending sequential messages, you need to calculate the actual identifier and offset.
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e.g. Take the offset and divide by 8. e.g. offset = 19. Divide by 8 gives 2 remainder 3. Add 2 to the identifier and 
the offset is 3.

Size

Endianism, data size and sign.

B = Big endian (Motorola, high byte first)

L = Little endian (Intel, low byte first)

# = # bytes

U = Unsigned

S = Signed

e.g. L4S = little endian, 4 bytes, signed data

Multiply, Divide, Add

Result = ((raw_data * mult) / divide) + add

17.9 CAN VSS, Gear
Clicking CAN Bus / Testmodes > CAN VSS, Gear displays the following screen:

 

The options for these settings are described below:

17.9.1 CAN VSS and gear selection

These settings allow the fetching of a pre-calculated speed (VSS) from an expansion board. (Contrast CAN 
PWM capture where a pulse time is collected and converted into a speed within the Megasquirt.)

Mode

• Listen - CAN messages are received without first sending. Requires remote device to broadcast.

• Poll - Messages are sent and then received.
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Remote CAN ID

CAN ID of the expansion board used for VSS and/or gear inputs.

Table

The table number on the expansion board used for VSS and/or gear inputs.

VSS1 Offset

These settings require

• "VSS1 Input Type" is set to "Digital"

• "Digital Input" is set to  "CANVSS" (See Section 15.1.)

Data offset on the expansion board used for VSS1 gear inputs.

VSS1 Data Size

How the data is stored on the expansion board (8bit or 16bit). See your expansion board documentation.

VSS2 Offset

These settings require

• "VSS2 Input Type" is set to "Digital"

• "Digital Input" is set to  "CANVSS" (See Section 15.1.)

Data offset on the expansion board used for VSS2 inputs.

VSS2 Data Size

How the data is stored on the expansion board (8bit or 16bit). See your expansion board documentation.

Gear # Offset

These settings require

• Gear Detection "Method" is set to "CAN Gear #" (See Section 15.1.)

Data offset on the expansion board used for 8bit gear number.
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17.10 CAN EGO, GPS
Clicking CAN Bus / Testmodes > CAN EGO, GPS displays the following screen:

 

The options for these settings are described below:

17.10.1 EGO Data Via CAN

This allows integration with an expansion board (such as those from JBperf) or CAN-enabled wideband 
controller.

Fetch EGO Data

Enables collecting EGO/AFR from CAN connected widebands on expansion board.

• Disable will still allow Megaspartan messages to be received.

• Innovate requires a JBperf IO-extender using 29bit Megasquirt-CAN.

• AEM 4ch UEGO uses 29bit messages at 500k from ID 0x0000001F and requires that Megasquirt-CAN 
be disabled.

• ECOTRONS ALM uses 250k and requires that Megasquirt-CAN be disabled.

• Generic allows messages to be received using the 'CAN Receiving' system. The input value must be 
converted to give Lambda * 10000.

• AEM X UEGO uses 29bit messages at 500k from ID 0x00000180 and requires that Megasquirt-CAN be 
disabled.

Remote CAN Id

The CAN Id of the expansion board. (Typically 5.) [Only for Innovate format.]

Table

The table number on the expansion board. (Typically 7.) [Only for Innovate format.]
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Offset

Data offset on the expansion board. (Typically 153.)  [Only for Innovate format.]

Smoothing

Enables or disables the 'lag factor' smoothing for EGO data collected from a CAN device. Typically set to Off.

17.10.2 GPS Data Via CAN

This allows integration with an expansion board that natively support GPS.

Fetch GPS Data

Whether to enable GPS data reception via CAN.

• Off - disables

• JBPerf GPS = Use Megasquirt-CAN to poll for data from a JBperf IO-extender GPS.

• Race Technology 11bit = listen for 11bit broadcasts from a Race Technology dash/GPS.

Remote CAN Id

The CAN Id of the expansion board. (Typically 5.) [Only for JBperf]

Table

The table number on the expansion board. (Typically 7.) [Only for JBperf]

Offset

Data offset on the expansion board. (Typically 128.) [Only for JBperf]

CAN base address

Base CAN id for broadcasts. Default is 769 (0x301). Dash must be configured to match. [Only for Race 
Technology]

17.10.3 Accelerometer Data via CAN

This allows integration with an expansion board that natively supports an accelerometer.

Fetch Accelerometer Data

• Off - disables

• Race Technology 11bit = listen for 11bit broadcasts from a Race Technology dash

CAN base address

Base CAN id for broadcasts. Default is 768 (0x300). Dash must be configured to match. [Only for Race 
Technology]

17.11 Real Time Clock
This allows configuration of a real-time clock, either internally or on an expansion board.
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Clicking CAN Bus / Testmodes > Real Time Clock displays the following screen:

 

The options for these settings are described below:

Enable Real Time Clock

Enables collecting GPS on expansion board.

• Off - disables

• On-board - enables the internal clock. (Optional on MS3, standard on MS3-Pro.)

• CAN - fetches clock data from an expansion board.

Trim +/-

Applies a trim to correct for slow/fast running clock.

Remote CAN Id

The CAN Id of the expansion board. (Typically 5.)

Table

The table number on the expansion board. (Typically 7.)

Offset

Data offset on the expansion board. (Typically 110.)

Set MS3 Time to Now

This button sends the date and time from your computer to the real-time clock. The change will only show the 
next time you open the page.

17.12 IO-Box Settings
Configures settings for remote Microsquirt IO-box(es).
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Clicking CAN Bus / Testmodes > IO-Box Settings displays the following screen:

 

IO-Box#1 Enable

This enables or disables the first IO-Box.

VSS Setting

Selects which speed inputs are used on the IO-box.

• Speed in 1,2 - Inputs 1 & 2 on the IOBox can be used for VSS1,2

• Speed in 3,4 - Inputs 3 & 4 on the IOBox can be used for VSS1,2

• Speed in 1,2,3,4 - Inputs 1,2,3,4 on the IOBox can be used for VSS1,2,3,4

Configuration

Selects between automatic and manual advanced configuration. 'Automatic' is recommended.

The following settings are only available in 'Advanced' mode.

Base CAN Identifier

Base CAN identifier used by IO-box.
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Base CANIN

Base CANIN for this IObox. i.e. input 1 is CANIN1, input2 is CANIN2 etc.

Base CANOUT

Base CANOUT for this IObox. i.e. output 1 is CANOUT1, output2 is CANOUT2 etc.

Base CANADC

Base CANADC for this IObox. i.e. ADC1 is CANADC1, ADC2 is CANADC2 etc.

Tach Transmit Rate

Rate to broadcast wheel speed data from IO-box.

Inputs Transmit Rate

Rate to broadcast inputs data from IO-box.

Outputs Transmit Rate

Rate to send outputs to IO-box.

The settings for IO-Boxes 2,3,4 work similarly, but beware of the maximum number of concurrent features that 
may be supported.

Further details and configuration examples can be found in the Microsquirt IO-box manual.

17.13 Dash Broadcasting
Dash broadcasting allows a simplified pre-defined set of data channels to be broadcast over CAN. These can 
then be received by compatible third-party dashes or dataloggers. 

The aim is to allow simple data sharing without the user having to get involved in the technical details of CAN. 
"Just turn it on and go!"

Technical details of the channels broadcast are available in a PDF at: http://www.msextra.com/doc/pdf/

Clicking CAN Bus / Testmodes > Dash Broadcasting displays the following screen:

Enable

Enables or disables the broadcasting.

Configuration

• Automatic - CAN id = 1512, rate = 50Hz
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• Advanced - allows CANid and transmit rate to be set.

Generally it is advised to leave it set to Automatic. The following settings are only available in Advanced mode.

Base CAN identifier

The decimal identifier used for the first packet in the dataset broadcast.

Outputs transmit rate

The transmission interval (data rate.)

17.14 Check Engine Light
The Check Engine Light system allows various sensor inputs to be range checked for correct operation and can 
set a dash warning light or trigger a limp mode (limited operating strategy.)

Clicking CAN Bus / Testmodes > Check Engine Light displays the following screen:

 

The options for these settings are described below:

Sensor checking

Enables or disables this system

Light output

Selects an optional output for the Check Engine Light. Recommended.
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CEL Solid/Flash Codes

Selects whether CEL lights up solidly or flashes codes to aid diagnostics.

Number of flashes and fault:

2=MAP 3=MAT 4=CLT 5=TPS 6=BATT 7=AFR0 8=SYNC 9=EGT 10=FLEX 11=MAF 12=KNOCK 13=CAM 
14=OIL 15=FUELPRESS 16=EGTSHUT 17=AFRSHUT

Light When Not Running

Do you want the light on when the engine is off?

Ignore fluctuations for first

The number of seconds that sensor flucations are ignored after startup. This is to allow conditions to settle down
and avoid false alarms.

MAP sensor check

Enable or disable checking of the MAP sensor input.

Minimum ADC

minimum valid ADC reading for the MAP sensor (try 5)

Maximum ADC

maximum valid ADC reading for the MAP sensor (try 1018)

Minimum Fluctuation

minimum fluctuation during smooth running

Maximum Fluctuation

maximum fluctuation during operation

(The minimum fluctuation setting is likely the most useful setting here as it can be used to detect a failed or 
'stuck' sensor or if a hose fell off.)

MAT sensor check

Enable or disable checking of the MAT sensor input.

Minimum ADC

minimum valid ADC reading for the MAT sensor (try 5)

Maximum ADC

maximum valid ADC reading for the MAT sensor (try 1018)

Maximum Fluctuation

maximum fluctuation during operation

CLT sensor check

Enable or disable checking of the CLT sensor input.
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Minimum ADC

minimum valid ADC reading for the CLT sensor (try 5)

Maximum ADC

maximum valid ADC reading for the CLT sensor (try 1018)

Maximum Fluctuation

maximum fluctuation during operation

(The CLT sensor should be smooth in operation, the max fluctuations can be used to detect a fault.)

TPS sensor check

Enable or disable checking of the TPS sensor input.

Minimum ADC

minimum valid ADC reading for the TPS sensor (try 10 below your 'closed' calibration)

Maximum ADC

maximum valid ADC reading for the TPS sensor (try 10 above your 'open' calibration)

Maximum Fluctuation

maximum fluctuation during operation

(The min/max limits will often detect a fault.)

Battery check

Enable or disable checking of the battery voltage input.

Minimum voltage

minimum acceptable voltage reading

Maximum voltage

maximum acceptable voltage reading

Maximum Fluctuation

maximum fluctuation during operation

(This can be used to warn of charging system faults or ground issues causing excessive voltage 'noise'.)

EGO1 sensor check

Enable or disable checking of the EGO1 sensor input.

Minimum ADC

minimum valid ADC reading for the EGO1 input

Maximum ADC

maximum valid ADC reading for the EGO1 input
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Minimum Fluctuation

minimum fluctuation during smooth running

Maximum Fluctuation

maximum fluctuation during operation

(The fluctuation settings are key to detecting a failed sensor. Many wideband controllers will get 'stuck' if the 
sensor fails although appearing to show a valid AFR reading. Combined with closed-loop EGO or autotuning 
this can be troublesome without this detection scheme. Other controllers allow an 'out of range' voltage output - 
match the min/max ADC readings to capture this.)

Sync-loss check

Enable or disable checking of RPM sync-losses

No. sync losses allowed

how many recorded losses of tach-in synchronisation are allowed before setting the CEL.

(During normal operation you may see one or two sync-losses during startup. Beyond that there is a problem 
with your tach-in wiring or configuration.)

EGT sensor check

Enable or disable checking of the EGT sensor inputs.

Minimum EGT

minimum valid EGT while engine is running

Maximum EGT

maximum valid EGT while engine is running

Minimum Fluctuation

minimum fluctuation during smooth running

Maximum Fluctuation

maximum fluctuation during operation

(The temperatures are not checked immediately after startup, so the minimum temperature can be set to 200C 
to detect a dead cylinder or faulty sensor. The maximum will depend on your engine. N/A could be around 900C,
boosted perhaps 1000C.)

Flex sensor check

Enable or disable checking of the Flex sensor input.

(An error condition will be triggered if the frequency on the flex input is outside of the set range.)

status5 input

Selects input for 'status5' value. Observe the dash gauge and examine datalogs to determine sensible min/max 
fluctuation limits and ADC counts for each sensor input in turn.

status5 shows

Sets gauge "status5" to record "fluctuations" number or raw ADC count for the chosen sensor input.
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e.g. Set the status5 input to MAP, set to "fluctuations" and then enable "status5" on your dash or view in a 
datalog. Allow the engine to idle and observe the lowest number. You can then set the MAP minimum fluctuation
to some value LOWER than this number. If the MAP input becomes too stable (e.g. the hose falls off) then the 
alarm will be raised. 

17.15 Limp Mode

This menu option will only be available if

• "Sensor Checking" is set to "On" (See Section 17.14.)

The Limp Mode allows a response to out of range sensors beyond the CEL warning light.

Clicking CAN Bus / Testmodes > Limp Mode displays the following screen:

 

The options for these settings are described below:

Settings for specific sensors will only be enabled if that sensor is being checked (See Section 17.14.)

MAP triggers limp mode

whether a MAP fault triggers limp mode

Use fallback MAP table

in the event of a MAP sensor failure, a fallback throttle based table can be used
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MAT triggers limp mode

whether a MAT fault triggers limp mode

Fallback MAT

replacement MAT value

CLT triggers limp mode

whether a CLT fault triggers limp mode

Fallback cold CLT

replacement initial CLT value

Fallback warmed up CLT

replacement final CLT value

Time to warmup engine

time taken to blend from cold to warm value (simulating a warmup cycle)

TPS triggers limp mode

whether a TPS fault triggers limp mode. TPS based acceleration is disabled if TPS is faulty.

Batt triggers limp mode

whether an out of range battery voltage reading triggers limp mode

EGO triggers limp mode

whether an EGO fault triggers limp mode

Flex triggers limp mode

whether a Flex fault triggers limp mode

EGT triggers limp mode

whether an EGT fault triggers limp mode

Oil pressure triggers limp mode

Whether an out of range oil pressure reading will trigger limp mode.

Limp rev limit

the hard fuel cut rev limiter when in limp mode

Limp boost limit

the boost limt when in limp mode. Typically this will be no boost to prevent engine damage in unknown 
conditions.

Limp boost valve duty

forces boost valve1 to a set duty in limp mode.
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Limp boost valve2 duty

forces boost valve2 to a set duty in limp mode.

Limp retard timing by

retards timing by the set amount in limp mode. 

17.16 Fallback MAP Table

This menu option will only be available if

• "Sensor Checking" is set to "On"

• AND "MAP Sensor Check" is set to "On" (See Section 17.14.)

• AND "MAP Triggers Limp Mode" is set to "On"

• AND "Use Fallback MAP Table" is set to "On" (See Section 17.15.)

In the event of a MAP sensor failure, it is possible to use a 'synthesised' MAP value based on TPS/RPM. This 
will be less accurate than the real MAP reading, but the aim is to allow some driveability in the absence of a real
sensor reading before the root cause failure is fixed.

Clicking CAN Bus / Testmodes > Fallback MAP Table displays the following screen:

 

The initial vales for this table can be derived from datalogs comparing MAP, RPM, TPS while driving.

To test and tune this table, unhook the MAP hose and wait until 'Limp Mode' engages. Then this table will be 
operative and you can tune. 
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17.17 Output Test Mode – Inj/Spk
Clicking CAN Bus / Testmodes > Output Test Mode – Inj/Spk displays the following screen:

 

This test mode allows direct control and testing of the coils and injectors.

Used by accident this could cause flooding of the engine and potential damage, therefore a special 
initialisation method is required to enable it. Do not attempt to test injectors or coils on a running engine. 
Before testing injectors on a engine be sure to depressurise the fuel rail - this can be achieved by 
unplugging the fuel pump while the engine is idling. Unless you are flow testing injectors on a flow-bench,
you are strongly advised to remove the fuel pump fuse during all of this testing. 

Before using the test mode ensure that you have already configured the correct number of cylinders and 
type of injector and spark output etc, i.e., if you want to test 8 cylinder COP mode, you need to have 
correctly configured those settings beforehand.

First ensure that you are key-on, engine-off (or that RPM is set to zero on the stim if you are carrying out bench 
testing.) In this condition the 'Enable Test Mode' button will be available. Click the button to enable the test 
mode.

Fuel Pump

• Clicking “Fuel Pump On” will enable the fuel pump output and light the 'Ready' indicator on TunerStudio.

• Clicking “Fuel Pump Off” will disable the fuel pump output and turn off the 'Ready' indicator.
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17.17.1 Coil Testing

The coil test mode is useful to confirm you have the coils wired correctly and to check dwell settings.

Exercise extreme caution during this test as ignition coils put out a potentially lethal voltage – typically 
30,000V or more!

 
There are five settings to consider when carrying out coil testing:

Output Interval (ms)

How often to pulse the coil.

RPM (Coil On Plug) (RPM)

Approximate equivalent RPM (this cannot be set directly, but is a function of Output Interval.)

Coil Testing Mode

• Off - no coil testing

• One - test a single coil

• Sequence - test coils in sequence up to the selected coil output

Coil Output to test

Gives a list of available coils than can be tested.

Dwell (ms)

Dwell used during testing – no voltage correction is applied.

Follow the following steps to carry out coil testing:

• Choose the desired Output Interval;

• Set Coil Testing Mode to “One”;

• Choose which coil to test (e.g. CoilA);

• Choose your Dwell time in milliseconds (start low, e.g., 2.5ms);

• If your coils are powered via the fuel pump relay (recommended) set the fuel pump to “On”;

• Check the above settings, then click the “Start” button;

• When finished, click “Stop”.

If the coils get hot or your coil fuses pop, then you almost certainly have a basic settings mistake with 
output polarity. Turn off power immediately and review those settings. 

17.17.2 Injector Testing

The coil test mode is useful to confirm you have the injectors wired correctly and to experiment with opening 
times, PWM settings or to measure flow rate if you have an injector test bench setup.

Using flammable liquids while testing is hazardous and can lead to serious fires. Non-flammable injector 
test liquid is available and you are strongly recommended to use it.
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If your injectors are fitted to the engine you must not run the test mode with fuel pressure or you will fill 
your engine with fuel! Remove the fuse from your fuel pump and depressurise the line first.

 
There are six settings to consider when carrying out injection testing:

Output Interval (ms)

How often to pulse the injector.

RPM (Full Sequential) RPM

Approximate equivalent RPM (again, this cannot be set directly, but is a function of Output Interval.) 

Injector Testing Mode

• Off - no injector testing

• One - test a single injector output

• Sequence - test injectors in sequence up to the selected coil output

• All - operate all injector outputs simultaneously

Injector Channel To Test

Gives a list of available injectors than can be tested (only applies if “One” or "Sequence" has been selected in 
Injector Testing Mode.

Pulsewidth (ms)

Pulsewidth used during testing – no dead-time is added and no voltage correction is applied.

Total Number Of Injections

Number of injection pulses in each test.

Follow the following steps to carry out injection testing:

• Choose the desired Output Interval (the estimated RPM equivalent will be displayed.);

• Set Injector Testing Mode to “One” or “All” (depending whether you want to test one ijnector alone or all 
injectors together;

• If you have selected “One” in step 2, choose which injector to test, e.g., “InjA”;

• Choose your Pulsewidth time in milliseconds;

• If your injectors are powered via the fuel pump relay (as is recommended) set the fuel pump to On;

• For functional testing, set the total number of injections to 65535 (the maximum) or for flow tesing use 
your chosen number;

• With valid settings entered the “Start” button should be active, if so click it.

• The number of injections gauge will count down and stop at zero.

• To stop testing sooner, click “Stop” at any time during the test.

17.17.3 PWM Settings

The PWM settings section allows you to test different PWM settings for the two injector bank outputs while in 
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test mode. There are four settings that can be configured for this.

Injector PWM Parameters

Allows testing of different PWM current limiting parameters.

• Standard - use the PWM parameters configured in the main settings

• As Below - use custom settings in following fields.

PWM Current Limit (%)

The PWM duty cycle.

PWM Time Threshold (ms)

The full-current time at the beginning of each pulse.

Injector PWM Period (μs)

The PWM period (or frequency.)

When you have finished using the test mode, close the test mode window and power off your Megasquirt
product. If you disconnected your fuel pump you can reconnect it now.

17.18  Output Test Mode – I/O
Clicking CAN Bus / Testmodes > Output Test Mode – I/O displays the following screen:
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This allows you to test some of the on/off and pulsed outputs in a controlled manner. 

As with the other tests, be cautious – this mode allows you complete control over the outputs and it is 
important to take care not to cause any accidental damage.

First ensure that you are key-on, engine-off (or that RPM is set to zero on the stim if bench testing.) In this 
condition the 'Enable Test Mode' button will be available. Click the button to enable the test mode.

For each of the outputs you can select

• Off – turns the selected output off;
• On – turns the selected output on;
• Pulsed – pulses the output at the selected frequency and duty.

Remember that all of the power outputs from the Megasquirt are ground switching, so typically you will 
not be able to measure any voltage at the output with a meter. Use a small test lamp or test LED 
connected between 12V and the output.

When you have finished using the test mode, close the test mode window and power off your Megasquirt
product.

17.19  Output Test Mode – I/O 2
This operates similarly to the Output Test Mode, but with a different set of outputs.

As with the other tests, be cautious – this mode allows you complete control over the outputs and it is 
important to take care not to cause any accidental damage.

Manually turning on Spk outputs that are connected to coils will almost certainly cause damage!

Clicking CAN Bus / Testmodes > Output Test Mode – I/O 2 displays the following screen:
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17.19.1 Output Test Mode – I/O 3

This operates similarly to the Output Test Mode, but with a different set of outputs.

As with the other tests, be cautious – this mode allows you complete control over the outputs and it is 
important to take care not to cause any accidental damage.

Clicking CAN Bus / Testmodes > Output Test Mode – I/O 3 displays the following screen:
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17.20  Output Test Mode – CAN I/O
This operates similarly to the Output Test Mode, but controls the outputs on an optional expansion board (e.g. 
Microsquirt IO box.) The status of CANIN inputs are also visible.

Clicking CAN Bus / Testmodes > Output Test Mode – CAN I/O displays the following screen:
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17.21 Output Test Mode – Idle Valve

This Output Test Mode – Idle Value menu option will only be enabled if you have an appropriate setting 
selected for “Idle Valve Type” (see Section 11.13.)

Clicking CAN bus > Testmodes > Output Test Mode – Idle Valve displays the following screen:

   

The idle valve test mode can be used with the engine running or stationary. Note that with a PWM idle 
valve you may need to run a temporary fused 12V supply to the valve if you normally take power from the
fuel pump relay and are testing with the engine off. You need to have enabled idle control before this is 
available.

There are three main settings for this screen:

Idle Valve Homing Steps

This   only applies to stepper idle valves. This setting determines how many steps the motor should move 
during homing to ensure it has reached the home position. The number needs to be large enough to close the 
valve from any unknown starting position (this is because there is no position feedback – in non-automotive 
control applications there is often a feedback encoder.)

Idle Valve Step

The desired valve position, larger numbers should give a more open valve and higher rpm (for stepper motors.)

PWM idle duty%

The desired valve position, larger numbers should give a more open valve and higher rpm. (For PWM valves)

Some Bosch rotary PWM valves feature a failsafe mode so that zero flow is at, for example, 20% duty. 
Above that the valve operates as expected where more duty gives more airflow. Below this specific point 
is a failsafe mode that allows airflow even if there is no control signal. This is readily observed during test
mode.

There are also three control buttons:

Enable Test – Home Position

For stepper idle valves this moves the valve through the number of homing steps back to the home position. (If 
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it doesn't get all the way back to the stop, increase the number of homing steps.) The valve will move to the run 
position shortly afterwards.

Enable Test – Run Position

Enable test mode where the steps or duty setting controls the valve position.

Enable Test – In/Out Cycle

For stepper idle valves, this enables a test mode that continually opens and closes the valve.

Stop Testing

Disable test mode and allow normal idle control to operate.

17.22 Injector Sequential Testing
Clicking CAN bus > Testmodes > Injector Sequential Testing displays the following screen:

 

This allows on-the-fly switching between full sequential and other modes to test the effect on engine operation, 
not all options are appropriate for all engine configuration. 

The buttons are described below:

Stop Testing

Disables the Injector Sequential Testing

Batch Fire

Switches to batch fire mode

Semi Sequential

Switches to semi-sequential mode - only works if you are already configured for semi-sequential or full 
sequential.

Full Sequential

Switches to full sequential mode - only works if you are already configured for full sequential.
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17.23 Inj/Spk Disabling Test Mode
Clicking CAN bus > Testmodes > Inj/Spk Disabling Test Mode displays the following screen:

 

This allows on-the-fly disabling of fuel and spark outputs - particularly for full sequential installations. Not all 
options are appropriate for all engine configuration. 

This can be used to see what RPM drop there is when disabling a cylinder (to check for weak cylinders) and to 
confirm that injectors and coils or EGT sensors are wired to the correct cylinders.

The buttons are described below:

Off

Disables the test mode.

Injectors

Allow injectors to be disabled.

Coils

Allows coils to be disabled - beware of flooding.

17.23.1 Outputs Per Cylinder

For each cylinder output, a button lights up in the Enabled or Disabled rows. Clicking on the button will disable 
or enable that output.
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17.24 Special Options
These settings are rarely used special purpose settings.

Clicking CAN bus > Testmodes > Special Options displays the following screen:

 

The options for these settings are described below:

Pulsewidth Scaling

Only used on low-revving extremely large engines for extra-long pulsewidths. MUST also set PW4X in Project 
Properties.

Nitrous-In Pulldown

Normally this should be on so that the input responds to a +12V signal. Ensure the JP8 is NOT installed on the 
MS3X card.

Log trigger times to sensors9-16

This enables an experimental feature to record engine trigger times to sensors9-16 to monitor per-cylinder 
effort. Only for developers.

Fuel flow/consumption calculation interval

How often to perform fuel consumption calculations. By default this is set to around 1000ms for 1 second 
updates to give a slowly changing averaged output.

Maximum SpkAdj Value

Sets a limit on the maximum adjustment a remote device (e.g. trans controller) can apply to the ignition timing.

This is a positive number, meaning advance.

Minimum SpkAdj Value

Sets a limit on the minimum adjustment a remote device (e.g. trans controller) can apply to the ignition timing.

This is a negative number, meaning retard.

17.25 Long Term Trim Settings
Long-term fuel trim can be used to automatically make minor corrections to fuelling to allow for operating 
changes. It should only be used after the engine is fully tuned. It requires EGO control to be enabled and 
operational.
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Due to an issue in TunerStudio 2.6, when Long Term Trim is used you need to disable "High Speed Runtime" on
Communications->Megasquirt Baud Rate.

Clicking CAN bus > Testmodes > Long Term Trim Settings displays the following screen:

 

The options for these settings are described below:

Enable Experi. Long Term Trim

Enables the long-term fuel trim. This is intended to automatically make minor corrections in fuelling AFTER the 
engine is fully tuned. It requires EGO control to be enabled and operational.

Sample Interval

How often (in seconds) the code checks the current EGO correction.

Correction Softness

How softly the trim correction is applied. Larger numbers mean a softer/slower correction.

Write Method

• Timed - if needed, the trim table is automatically saved to flash

• Button - an external button is used to save the trim table to flash.

Burn Button

User operated button to burn trim table from RAM to flash so it is used at next power-on.

Burn Interval

Minimum time between automatic burns to flash.
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LED Output

LED output is illuminated when RAM trim table exceeds change threshold. The user can then choose to Burn to 
flash.

Total Change Before Burning

If the sum of all changes exceeds this threshold than a burn to flash is requested - either automatically or by 
lighting the LED for user intervention. The purpose is to only make permanent changes if there was a 
widespread change.

Display Current %Change in Sensor15

Reports the total %change in 'sensor15' - mainly for testing.

Read Table 1 to RAM

This takes the saved table #1 and copies it to the working RAM area.

Read Table 2 to RAM

This takes the saved table #2 and copies it to the working RAM area.

Burn Table to Flash

This saves the current working table into flash memory.

Zero Tables

This resets the working table and two saved tables to zero trim. It should be used after any fuel tuning. 

17.26 Long Term Trim Table 1
Clicking CAN bus > Testmodes > Long Term Trim Settings displays the following screen:

This read-only table shows the long-term-terim values the ECU has calculated based on lambda sensor 
feedback.

17.27 Outmsg 1
The 'Outmsg' menus will only appear if OUTMSG_EDITING is enabled in your Project Properties > Settings.

This system allows configuration of specific datasets that can be transferred over CAN. It is highly specialised 
and will not be documented here.
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17.28 Throttle control (DBW)
Important safety note:

The MS3 control code is not implemented in a safety critical manner. We make no promises that 
the target throttle position will be timely or accurate. We take no responsibility for loss or damage that 
results from the use of this feature.

It is essential that any drive-by-wire controller that operates the primary throttle on a motor vehicle is 
designed to be safe and is implemented to comply with safety critical standards. Amongst other controls,
such a system must tolerate and reject any out of range commands from the MS3.

A regular non-safety engineered servo controller must not be used for primary throttle control.

The throttle control sub-system is a provisional module to allow integration with an external throttle controller.

The external controller interfaces with the accelerator pedal sensors, throttle position sensors and servo motor 
and communications with the MS3 via CAN. The MS3 receives pedal position and actual throttle position and 
sends target throttle position. The external controller manages all safety aspects such as ensuring the throttle is 
closed when the accelerator is released, ignoring any bogus messages from the MS3, handling faults in a safe 
manner etc.

The CAN protocol document can be downloaded from www.msextra.com.

As highlighted in the important safety note above, it is essential that only safety engineered products are used 
for primary throttle control.

Clicking CAN bus > Testmodes > Throttle Control (DBW) displays the following screen:

 

The options for these settings are described below:

Enable / mode

Enables Drive-by-Wire (DBW) electronic throttle control where the target throttle position is controlled by the 
ECU using the pedal/RPM table and modifiers.
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Idle control mode uses the output for idle control only. The idle control system must still be configured as normal
and this throttle control system will then take the idle duty value and send it out to a CAN-connected servo 
controller.

Base CAN identifier

Base CAN identifier for broadcast and received messages. Default is 256.

17.28.1 Throttle target

Minimum value

Minimum data value for target throttle position output.

Maximum value

Maximum data value for target throttle position output.

17.28.2 Throttle actual position

Minimum value

Minimum data value for actual throttle position input.

Maximum value

Maximum data value for actual throttle position input.

17.28.3 Pedal position

Minimum value

Minimum data value for accelerator pedal position input.

Maximum value

Maximum data value for accelerator pedal position input.

17.28.4 Idle control

Max idle addition

Maximum throttle target addition from idle control. (Typically 5-10%)

17.28.5 Additional throttles

Throttle 2, 3, 4 follow throttle 1

Whether throttle 2,3,4 targets should be set to match throttle 1 target. Otherwise they are broadcast as zero.

17.28.6 Throttle control target table

The target table gives a lookup of throttle target% against pedal position and RPM. This could be configured as 
a 1:1 throttle follower or a non-linear relationship to give greater pedal response at lower airflows.
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17.29 Throttle Test Mode
Clicking CAN bus > Testmodes > Throttle Test Mode displays the following screen:

 

The options for these settings are described below:

Position

Target throttle position in test mode.

As noted on the screen, a maximum of 5% is allowed when the engine is running to prevent unexpected 
overrevving. Beware of testing on an automatic in 'D'.

Enable test

This button enables test mode and forces the throttle target to the value set in the 'position' box.

Stop testing

This button stops test mode and the throttle target will return to whatever is set in the throttle control system.
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18 Upgrade
The Upgrade toolbar does not display a drop down menu, but will instead display a page of information screen 
about the Upgrade version of TunerStudio similar to that shown below:

  

This screen includes information from the developer's website and is subject to change. It provides detailed 
information about the additional features included within the Upgrade version, and includes a link to purchase 
an upgrade license should you so wish.
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19 Dashboard Gauge Cluster
In the main screen, there are three tabs “Gauge Cluster”, “Diagnostics & High Speed Loggers”, and “Tune 
Analyze Live – Tune For You”, labeled as (1) in the following image:

  

“Gauge Cluster” is the default tab which is displayed when you open TunerStudio. Using the default dash this 
gives you access to eight customizable gauges and a set of indicators. The gauges are labeled as (1) in the 
following image and are documented in this section. The dash indicators are documented in Section 20.
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Right-clicking on any gauge in this gauge cluster will bring up a pop-up menu allowing you to swap the gauge 
for one of the alternatives as described in Sections 19.1. to 19.18. below:

19.1 TunerStudio gauges
These gauges are technical statistics for TunerStudio itself and will be rarely used.

Interrogation Progress

For developer use only.

Log time

For developer use only.

Records Logged

The total number of datalog records recorded.

Runtime Data Rate

Shows how fast TunerStudio is communicating with the Megasquirt in frames per second.

(The data rate can be adjusted on the Communications menu.)

19.2 AFR/EGO calculations

AFR1 error

The difference between actual and target AFR1.  AFR1 error = AFR1 - AFR1 target

AFR1 target

The current target value for AFR1, looked up from the AFR1 target table. Usually AFR1 target is used as the 
target AFR for all fuel channels.

AFR2 error

The difference between actual and target AFR2.

AFR2 target

The current target value for AFR2, looked up from the AFR2 target table. AFR2 Target is typically only of use in 
dual-fuel or custom blended table configurations.

EGO Correction 1,2..

The percentage fuel correction from AFR1,2.. when closed-loop EGO control is used (100% means no change.)

Stoich

The value of the stoichiometric setting (typically 14.7 AFR for gasoline.)

19.3 AFR/EGO inputs

Air: Fuel Ratio1,2..

The current AFR reading from oxygen sensor 1,2.. Useful for wideband sensors. (Will only be available if 
Wideband - AFR is enabled in File > Vehicle Project > Project Properties > Settings.)
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Exhaust Gas Oxygen 1,2...

The current voltage reading from oxygen sensor 1. Useful for narrowband sensors.

Lambda 1,2..

The current lambda reading from oxygen sensor 1,2.. (Will only be available if Wideband - Lambda is enabled in
File > Vehicle Project > Project Properties > Settings.)

19.4 CAN board inputs/outputs

CAN PWMin0,1,2,3

Raw pulse period received over the CAN system from an expansion board.

CAN inputs 1-8

This bitfield variable is a combination of binary bits for CAN inputs 1-8.

128 64 32 16 8 4 2 1

CAN input
8

CAN input
7

CAN input
6

CAN input
5

CAN input
4

CAN input
3

CAN input
2

CAN input
1

CAN outputs 1-8

This bitfield variable is a combination of binary bits for CAN inputs 1-8.

128 64 32 16 8 4 2 1

CAN output
8

CAN output
7

CAN output
6

CAN output
5

CAN output
4

CAN output
3

CAN output
2

CAN output
1

CAN outputs 9-16

This bitfield variable is a combination of binary bits for CAN inputs 1-8.

128 64 32 16 8 4 2 1

CAN output
16

CAN output
15

CAN output
14

CAN output
13

CAN output
12

CAN output
11

CAN output
10

CAN output
9

19.5 Calculations 1
Calculations 1 consists of fuel related calculations.

Unless otherwise noted, all multiplier values use 100% to mean no change. 

ALS added fuel

The fuel pulsewidth (time) adder due to the anti-lag system.

Accel Enrich PW

The current fuel pulsewidth adder due to acceleration enrichment.

Accel Enrich%

The current fuel pulsewidth percentage multiplier due to acceleration enrichment.
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Air Density Correction

The percentage multiplier to fueling due to air density.

Barometric Correction

The percentage multiplier to fueling due to barometric correction.

DeadTime 1

The current injector deadtime value (allowing for battery voltage correction.)

E85 Fuel Correction

The percentage multiplier to fueling due to the flex fuel sensor.

EAE Fuel Correction 1

The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 1.

EAE Fuel Correction 2

The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 2.

Fuel Pressure Correction

Fueling correction due to pressure for currently active fuel system.

Fuel Temperature Correction

Fueling correction due to temperature for currently active fuel system.

Fuel on the walls 1

The calculated fuel puddle volume on the intake port walls, channel 1.

Fuel on the walls 2

The calculated fuel puddle volume on the intake port walls, channel 2.

Long Term Trim Correction

Fuel correction due to long term trim.

Nitrous Added Fuel

The fuel pulsewidth adder from the nitrous system.

Req Fuel (calc)

The current effective 'ReqFuel' value.

Total cor

The total fuel percentage multiplier obtained by multiplying the other factors. If this is outside of the range 80%-
120% then there is probably something wrong with your tuning settings.

VE Current 1

The looked up VE value for channel 1. This may be a combination of two tables due to switching or blending.
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VE Current 2

The looked up VE value for channel 2. This may be a combination of two tables due to switching or blending.

Warmup Enrichment

The percentage multiplier to fueling due to Warmup and Afterstart (this should be 100% on a warmed up 
engine.)

map_accel

MAP acceleration component of accel-pump.

total_accel

Combination of TPS and MAP acceleration components of accel-pump.

tps_accel

TPS acceleration component of accel-pump.

19.6 Calculations 2
Calculations 2 consists of spark/ignition related calculations.

3-step Timing

The spark timing/advance taken from the 3-step system.

ALS Timing

The spark timing/advance taken from the anti-lag system.

Base Spark Advance

The spark timing/advance looked up from the advance table before other adjustments are made.

CEL retard

The retardation to the timing due to check engine light and limp mode.

Cold advance

The advancement to the timing due to cold advance curve.

External Advance

The external advancement to the timing, e.g., from a transmission controller. 

Flex Advance

The advancement to the timing due to flex fuel.

Fuel cut retard

The retardation to the timing due to over-run fuel cut.

Idle Correction Advance

The advancement to the timing due to idle correction.
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Knock Retard

The retardation to the timing due to knock control.

Launch Timing

The spark timing/advance taken from the launch (2-step) system.

Launch VSS Retard.

The retardation to the timing due to the speed based launch system.

Launch timed retard

The retardation to the timing due to the timed-retard after launch.

Launch timer

Timer for timed-retard after launch.

MAT Retard

The retardation to the timing due to the MAT retard curve.

Nitrous Timer

The delay timer for the nitrous system.

Nitrous retard

The retardation to the timing due to the nitrous system.

Revlim Retard

The retardation to the timing due to the rev limiter.

Spark Table 1,2..

The looked up spark advance from ignition table 1,2..

Timing pred err

A calculation of how accurately the position of the next tach tooth was predicted (not often used).

Traction retard

The retardation to the timing due to traction control.

19.7 Calculations 3

Boost Target1,2

The target boost pressure for closed-loop mode channels 1,2.

CL idle target

The target engine speed for closed-loop idle control.

Clock

A built in clock that counts the seconds since the Megasquirt was last turned on. If this suddenly resets to zero, 
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you probably have a power connection problem.

Fuel economy - l/100km)

Fuel economy in litres per 100 kilometres.

Fuel economy - MPG(UK)

Fuel economy in miles per UK gallon (4.546 litres).

Fuel economy - MPG(USA)

Fuel economy in miles per US gallon (3.8 liters.)

Fuel flow cc/min

Calculated averaged fuel flow. (Averaging period is set on Special Options - see Section 17.24.)

Lost Sync Counter

The count of "lost-sync" events. If the engine stalls the counter will increase by one. During startup it is 
acceptable to have a few lost syncs. If you see this counting up under other conditions, there is a problem with 
your tach input.

Lost Sync Reason

A technical reason code for why the ECU lost synchronization with the tach input. Not particularly useful. The 
codes are listed in the Setting Up manual.

MAPdot

The rate of change of MAP (the increase in MAP per second.)

RPMdot

The rate of change of RPM (the increase in RPM per second.)

T/C Slip * Time

Traction control Slip % * time slipping. This is used as the lookup on the traction control reaction curves.

TPSdot

The rate of change of TPS (the increase in TPS per second.)

VE1_raw-VE4_raw

The raw VE values looked up from the four fuel tables.

VSS1,2 Acceleration

The rate of change of VSS (VSS1dot) measured in SI units ms-2. Same for VSS2.

VVT target 1,2,3,4

The target angle of VVT cam 1,2,3,4
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19.8 EGT Inputs

EGT 01,02...

The reading from an external EGT sensor.

19.9 Generic Sensor Inputs

Sensor01-16

The reading from a sensor converted into your chosen units through the Generic Sensors system. You can also 
give the sensors a name of your choice which will then be used in the datalog and gauge name.

19.10 Outputs 1

Pulse Width 1

The base fuel pulsewidth for injector channel 1. This is the actual electrical pulsewidth including deadtime, but 
not trim. See also Pulse Width Seq 1,2.

Pulse Width 2

The base fuel pulsewidth for injector channel 2. This is the actual electrical pulsewidth including deadtime, but 
not trim. Primarily for dual table or dual fuel.

Pulse Width Seq 1,2..

The base fuel pulsewidth for the injector on cyl#1,2.. This is the actual output electrical pulsewidth including 
deadtime, all corrections and trim. (The "Firing Order" setting is used to determine which cylinder is which as the
injectors always fire in the same order. A,B,C...)

Pulse Width V3 Inj1,2..

The base fuel pulsewidth for mainboard injector output 1,2.. This is the actual electrical pulsewidth including 
deadtime, but not trim.

19.11 Outputs 2

Boost Duty,2

The current duty cycle output to the boost solenoid. Channels 1,2.

Duty Cycle 1 

The calculated injector duty cycle on channel 1 (85% is a recommended maximum, above 100% is impossible.) 
This is the base pulsewidth before any trim has been allowed for.

Duty Cycle 2

The calculated injector duty cycle on channel 2. Mainly for staged injection.

Dome Empty Duty 1

This is the empty output duty on channel 1.

Dome Fill Duty 1

This is the fill output duty on channel 1.
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Dwell (Trailing)

The ignition dwell (charge) time on the rotary trailing outputs.

Dwell

The ignition dwell (charge) time on the main spark outputs.

Idle PWM%

The current duty cycle output to the idle valve.

Idle Stepper position

The current stepper valve position (0 means fully closed.)

Ignition Advance 

The overall ignition advance.

Injection Timing (pri)

The injection timing used for primary injector channels.

Injection Timing (sec)

The injection timing used for secondary injector channels.

19.12 Outputs 3

Alternator Control Duty

Output duty to control alternator.

Alternator Control Period

Output time period to control alternator for frequency controlled systems.

Alternator Target Volts

The voltage being targetted by the alternator control system.

Fuel pump duty

The output duty cycle to control the fuel pump.

Generic Closed-Loop A,B duty

Output duty cycle from Generic Closed-Loop system.

Generic PWM A-F duty

Output duty cycle from Generic PWM system.

Nitrous 1,2 duty

The duty cycle to the nitrous solenoids in progressive mode.

VVT duty 1,2,3,4

The solenoid output duty cycle for VVT cam 1,2,3,4
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Water Duty

The duty cycle to the water injection solenoid.

19.13 Sensor inputs 1

AFR load

The 'load' (e.g. MAP, TPS) used on the Y-axis of the AFR table.

Barometer 

The barometer reading. This will show: a current value if a dedicated baro sensor is installed; the initial MAP 
reading; or 100kPa if barometric correction is disabled.

Battery Voltage

The measured battery voltage (if this is radically different from your actual battery voltage, check for wiring 
faults.)

Boost – boostbarGauge

The relative boost pressure in bar.

Boost – boostpsigGauge

The relative boost pressure in psig.

Coolant Temp

The measured coolant temperature (CLT.)

EAE load

The 'load' (e.g. MAP, TPS) used on the Y-axis of the EAE curves.

Engine MAP 

The measured MAP (on typical speed-density installs this should read near 100kPa during key-on, engine-off 
and 30-60kPa at idle.)

Engine Speed

The tachometer / rev counter (if this is dropping to zero or bouncing around, you probably have a problem with 
the tach-in signal.)

Est. Intake Air Temp

A calculated estimate to the intake air temperature using a blend of measured air and coolant temperatures. 
See the MAT/CLT blending setting.

Fuel Load 

The primary 'load' for fuel calculations (this is equal to MAP on typical speed-density installs.)

Ign Load

The 'load' (e.g. MAP, TPS) used on the Y axis of the ignition tables.
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Knock Input

The signal value from an optional add-on knock sensor interface.

MAF Frequency

The raw frequency input from a frequency MAF sensor.

MAF Volts

The voltage from the MAF sensor.

MAFload 

A calculated 'load' value that works similarly to MAP in a speed-density system (make for better use of the 
lookup tables.)

Manifold Air Temp 

The measured intake manifold air temperature (MAT.)

Mass Air Flow

The airflow in g/sec calculated from the MAF sensor.

Pedal/Grip Position

The pedal or grip position from an external throttle control when using the DBW system.

Secondary Fuel Load

Like 'Fuel Load' but used for the secondary lookup table.

Secondary Ign Load

Like 'Ign Load' but used for the secondary lookup table.

Throttle Position

The 0-100% throttle (pedal) position (check the calibration settings if you do not get 0-100%.)

Vac/Boost

Shows the MAP sensor in vacuum / boost imperial units.

19.14 Sensor inputs 2

Accel X,Y,Z

The accelerometer X,Y,Z measured in SI units ms-2.

Alternator Load Duty

Measured load on the alternator.

Battery Current

The measured battery current measured through the alternator control system.
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Ethanol Percentage

The calculated ethanol percentage in the fuel reported from the flex fuel sensor.

Fuel Pressure1_xxx

Primary differential fuel pressure in bar, kPa or bar. This is the differential fuel pressure above intake manifold 
pressure.

Fuel Pressure2_xxx

Secondary differential fuel pressure in bar, kPa or bar. This is the differential fuel pressure above intake manifold
pressure.

Fuel Temp1,2

Fuel temperature. 1 = primary fuel, 2 = secondary fuel

Gear

The current gear.

Shaft Speed 1,2

Shaft speed in RPM.

Stream Level

The volume level of the audio stream being recorded to an SDcard datalog.

TPSADC

The raw ADC input of the throttle (pedal) position.

VSS1-4

Vehicle (wheel) speed sensor inputs in your chosen speed units.

19.15 Sensor Inputs 3

Knock cyl# 1-16

The signal value per-cylinder from the internal knock sensor interface.

VVT angle 1,2,3,4

The current relative angle of VVT cam 1,2,3,4

19.16 Sensor Inputs 4

GPS Altitude

Altitude in metres from external GPS.

GPS Course

The course/heading from external GPS.

GPS Latitude

Latitude degrees from external GPS. (Combination of degrees, minutes, seconds as one decimal number.)
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GPS Longitude

Longitude degrees from external GPS. (Combination of degrees, minutes, seconds as one decimal number.)

GPS Speed

The speed from external GPS in your chosen speed units.

19.17 VE Analyze Gauges
The are not useful in the Lite version of TunerStudio.

19.18 X-Code dev
These gauges are typically only of use by developers.

-- - deadGauge 

A gauge that does nothing.

Advance Bucket

This gauge is for historical purposes only.

CAN error bits

The lower byte holds transient errors

128 64 32 16 8 4 2 1

Passthrough
timeout

Out of range
request

Passthrough
failure

TX error TX warning RX error RX warning RX overrun

The upper byte holds latched errors

32768 16384 8192 4096 2048 1024 512 256

Passthrough
timeout

Out of range
request

Passthrough
failure

TX error TX warning RX error RX warning RX overrun

CAN error count

The number of CAN errors detected.

CEL Error Code

Current Check Engine Light error code.

CEL status

This bitfield variable is a combination of binary bits about CEL faults. These are used to drive the CEL 
indicators:

32768 16384 8192 4096 2048 1024 512 256

AFR
shutdown

EGT
shutdown

Fuel pressure
fault

Oil pressure
fault

Cam fault Knock MAF fault Flex fault
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128 64 32 16 8 4 2 1

EGT fault RPM-sync
fault

AFR fault Battery fault TPS fault CLT fault MAT fault MAP fault

CEL status2

This bitfield variable is a combination of binary bits about CEL faults. These are used to drive the CEL 
indicators:

32768 16384 8192 4096 2048 1024 512 256

- - - - - - - -

128 64 32 16 8 4 2 1

- - - - - - Engine
shutdown

Water
injection fault

Injection Count

Used by injector test mode to show the number of remaining test squirts.

Loop bits 1-8

This bitfield is set by the on/off outputs and can be used to daisy-chain conditions. See the setting up manual for
examples.

128 64 32 16 8 4 2 1

Loop 8 Loop 7 Loop 6 Loop 5 Loop 4 Loop 3 Loop 2 Loop 1

Mainloop time

How long each pass through the 'mainloop' of code is taking in microseconds.

SDcard error

Error code for SDcard datalogging system - see the Setting Up manual for a list.

SDcard file number

The current active datalog file number on the SDcard.

SDcard status

Bitfield indicating current status of SDcard datalogging system.

128 64 32 16 8 4 2 1

VBR FAT32 Ver 2.0 card Error Logging Ready SDHC Card present

SDcard phase

Technical code relating to SDcard datalogging system.

status1-8

These bitfield variables is a combination of binary bits about engine status. These are used to drive various 
status indicators.
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status1

128 64 32 16 8 4 2 1

Full-RPM
Synced

Spark
Table-sw

Fuel
Table-sw

(Synclatch) RPM
Synced

Config
Error

Lost
Data

Need
Burn

status2

128 64 32 16 8 4 2 1

CL
Idle

Over Boost Spark
Cut

Flat
Shift

Launch Launch
In

N2O
stage 2

N2O
stage 1

status3

128 64 32 16 8 4 2 1

Launch
On

Seq.
Shift

Soft Limit 3-Step
In

Test
mode

3-Step T
Log

Fuel
Cut

Status 4, 5

Typically only used by developers. The CEL system allows status5 to be used to record raw ADC counts or 
fluctuations of inputs.

status6

128 64 32 16 8 4 2 1

MAPsample
error

Fan Idle
Advance

Idle
VE

AFR
Shutdown

AFR
Warn

EGT
Shutdown

EGT
Warn

status7

128 64 32 16 8 4 2 1

Limp
Mode

CEL AC Knock VVT4
Error

VVT3
Error

VVT2
Error

VVT1
Error

status8

128 64 32 16 8 4 2 1

DBW fault DBW test VSS
Launch

VSS
Launch

Lock-out

PW4X
Mode

Water
Injection

Low

Spark
Disable
Mode

Injectors
Disable
Mode

VE Value

This gauge is for historical purposes only.

19.19 Additional menus
Some TunerStudio versions may have additional gauge categories. Refer to TunerStudio application 
documentation for their meaning.
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19.20 Other Menu Items on the Gauge Pop-up Menu

19.20.1 Reset Value

19.20.2 Background

Selecting Background displays four options as outlined below:

Set Background Color

This setting allows you to set the background color of the screen on which the gauges are displayed. This 
setting is not saved when you close your project or exit TunerStudio MS Lite.

Set Background Dither Color

This setting allows you to set the background dither color of the screen on which the gauges are displayed. This 
setting is not saved when you close your project or exit TunerStudio MS Lite.

Set Background Image

This setting allows you to set a background image to sit behind the gauges that are displayed. This setting is not
saved when you close your project or exit TunerStudio MS Lite.

Image Position

If you have selected a background image that sits behind the gauges that are displayed, this option allows you 
to choose whether this image should be stretched to fill the screen, tiled to fill the screen or centered within the 
screen. Again, this setting is not saved when you close your project or exit TunerStudio MS Lite.

19.20.3 Antialiasing Enabled

This is an on/off option that allows you to choose whether the edges of the graphical gauges are smoothed or 
not. On most modern monitors and laptop screens this has a negligible effect.

19.20.4 Designer Mode

This is an Upgrade feature allowing the dash to be redesigned that is not available in TunerStudio MS Lite.

19.20.5 Gauge Demo

The gauge demo is intended to give an impression of the abilities of the gauge cluster. This option has two sub-
Menu Options which start and stop the Gauge demonstration respectively.
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20 Dashboard Indicators
The Dashboard Indicators are located at the bottom of the default dash below the gauges and are labeled as (1)
in the following image. The indicators are generally customizable and are used to indicate on/off events.

  

Right-clicking on any of these indicators will bring up a pop-up menu allowing you to swap the indicator for one 
of the alternatives as described in Sections 20.1. to 20.4. below:

20.1 Application Indicators
Connected - not used

Connecting - not used

Datalogging – highlighted if data logging is active

Protocol Error – highlighted if there is a serial communication problem

20.2 Predefined Indicators
The list of alternative indicators will vary depending on whether you have activated “PORT_STATUS” in your 
Project Properties. Activating PORT_STATUS will add access to additional indicators and also changes the way 
the menus are laid out.

20.3 Predefined Indicators with PORT_STATUS Deactivated (Default)

Sections 20.3.1 to 20.3.4 list the options that will be offered to you if you right click on any of the 
indicators if PORT_STATUS for your project has been left deactivated.

20.3.1 Predefined Indicators

3 step in - whether 3-step input is active
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3 step on - whether 3-step input is active

AC – determines whether air conditioning is active.

AFR Shutdown - if AFR shutdown is in-process

AFR warn - if warning of AFR shutdown is in-process

AFR0 fault - fault on AFR sensor

ASE / ASE OFF – determines whether running in After Start Enrichment mode.

BATT fault - fault on battery voltage.

CEL AFR Shutdown - AFR shutdown is in-process

CEL EGT shutdown - EGT shutdown is in-process

CEL W.Inj low! - water injection system has low fluid

CL idle on – closed-loop idle control active.

CLT fault - fault on CLT sensor

Cam fault - fault on cam sensor

Check Engine - Check Engine Light system detected a fault

Config Error – if there is an error in your settings, in this case fix the settings.

Cranking / Not Cranking – currently cranking.

DBW fault - fault with the DBW system

EGT fault - fault on EGT sensor

EGT shutdown - if EGT shutdown is in-process

EGT warn - if warning of EGT shutdown is in-process

Fan - fan output active

Fast accel - Engine state is fast acceleration

20.3.2 Predefined Indicators 2

Fast decel - Engine state is fast deceleration

Flat shift – flat shift in effect.

Flex fault - fault on flex fuel sensor

Fuel Cut – fuel cut in effect.

Fuel press - fault on fuel pressure

Full-RPM sync / Half RPM sync – whether the Megasquirt is fully synchronized to crank and cam signals 
enough to run coil-on-plug or sequential (this might show a cam fault.)

Idle Adv - idle advance is active

Idle VE - idle VE is active

Knock fault - knock occurring

Knock - the on/off knock input is active

Launch in – launch input active.

Launch on – launch control active.

Limp mode - limp mode is active
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Lost Data – if something went wrong and data was not saved.

MAF fault - fault on MAF sensor

MAP Accel – currently in an accel enrichment event due to MAP.

MAP Decel – currently in an decel enleanment event due to MAP.

MAP fault - fault on MAP sensor

MAPsample error! – something is wrong with your MAP sample settings.

MAT fault - fault on MAT sensor

N2O 1 – nitrous stage 1 output

N2O 2 – nitrous stage 2 output

Need Burn – if unsaved data is waiting to be burned to flash memory.

Oil fault - fault with oil pressure

20.3.3 Predefined Indicators 3

Over boost – boost limiter in effect.

Overrun - Engine state is overrun

PW4X - 4x pulsewidth mode is active

RPM Synced / Not RPM synced – whether the Megasquirt is synchronized to the crank and cam signals

Ready / Not Ready – shows when there is an active tach signal and pump is running.

SD Err - Error on SDcard

SD Log - Logging active on SDcard

SD in - SDcard is inserted

SD ready - SDcard is initialised and ready to datalog

SPK3/4 – spark (ignition) table switching in effect. (Shows SPK1/2 when un-switched.)

SYNC fault - RPM sync faults detected

Safety Shutdown - AFR or EGT shutdown in effect

Seq. shift / No Seq. Shift – sequential shift control active.

Slow accel - Engine state is slow acceleration

Slow decel - Engine state is slow deceleration

Soft limiter / No soft limit – soft rev limiter in effect.

Spark cut – spark cut in effect.

T-log – tooth/trigger/composite log ready (TunerStudio internal use.)

TPS Accel – currently in an accel enrichment event due to TPS.

TPS Decel – currently in an decel enleanment event due to TPS.

TPS fault - fault on TPS

Test mode – spark / injector test mode is active.

Tune error - Total cor is less than 70%. Almost certainly there is a mistake in your tune.

VE3/4 - fuel table switching in effect. (Shows VE1/2 when un-switched.)

VSS launch L/O - Speed/VSS launch mode is locked out.
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20.3.4 Predefined Indicators 4

VSS launch on - Speed/VSS launch mode is active.

VVT1 err - error detected on VVT1 input (out of range angles.)

VVT2 err - error detected on VVT2 input (out of range angles.)

VVT3 err - error detected on VVT3 input (out of range angles.)

VVT4 err - error detected on VVT4 input (out of range angles.)

W.I. low! - water injection system has low fluid

WOT - Engine state is wide open throttle

WUE OFF / WUE – in WarmUp Enrichment mode.

20.4 Predefined Indicators with PORT_STATUS Activated

Sections 20.4.1 to 20.4.6 list the options that will be offered to you if you right click on any of the 
indicators if PORT_STATUS for your project has been activated.

20.4.1 Predefined Indicators

3 step in - whether 3-step input is active

3 step on - whether 3-step input is active

AC – determines whether air conditioning is active.

AFR Shutdown - if AFR shutdown is in-process

AFR warn - if warning of AFR shutdown is in-process

AFR0 fault - fault on AFR sensor

ASE / ASE OFF – determines whether running in After Start Enrichment mode.

BATT fault - fault on battery voltage

CANIN1,2.. - status of optional CAN input pin. (Usually these are active low.)

CEL AFR Shutdown - AFR shutdown is in-process

CEL EGT shutdown - EGT shutdown is in-process

CEL W.Inj low! - water injection system has low fluid

CL idle on – closed-loop idle control active.

CLT fault - fault on CLT sensor

Cam fault - fault on cam sensor

Check Engine - Check Engine Light system detected a fault

Config Error – if there is an error in your settings, in this case fix the settings.

20.4.2 Predefined Indicators 2

Cranking / Not Cranking – currently cranking.

DBW fault - fault with the DBW system

EGT fault - fault on EGT sensor

EGT shutdown - if EGT shutdown is in-process
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EGT warn - if warning of EGT shutdown is in-process

Fan - fan output active

Fast accel - Engine state is fast acceleration

Fast decel - Engine state is fast deceleration

Flat shift – flat shift in effect.

Flex fault - fault on flex fuel sensor

Fuel Cut – fuel cut in effect.

Fuel press - fault on fuel pressure

Full-RPM sync / Half RPM sync – whether the Megasquirt is fully synchronized to crank and cam signals 
enough to run coil-on-plug or sequential (this might show a cam fault.)

Idle Adv - idle advance is active

Idle VE - idle VE is active

Knock fault - knock occurring

Knock - the on/off knock input is active

Launch in – launch input active.

Launch on – launch control active.

Limp mode - limp mode is active

Lost Data – if something went wrong and data was not saved.

MAF fault - fault on MAF sensor

MAP Accel – currently in an accel enrichment event due to MAP.

20.4.3 Predefined Indicators 3

MAP Decel – currently in an decel enleanment event due to MAP.

MAP fault - fault on MAP sensor

MAPsample error! – something is wrong with your MAP sample settings.

MAT fault - fault on MAT sensor

N2O 1 – nitrous stage 1 output.

N2O 2 – nitrous stage 2 output.

Need Burn – if unsaved data is waiting to be burned to flash memory.

Oil fault - fault with oil pressure

Over boost – boost limiter in effect.

Overrun - Engine state is overrun

PORTA indicators

128 64 32 16 8 4 2 1

PORTA7 PORTA6 PORTA5 PORTA4 PORTA3 PORTA2 PORTA1 PORTA0

Inj H Inj G Inj F Inj E Inj D Inj C Inj B Inj A

Inj H Inj G Inj F Inj E Inj D Inj C Inj B Inj A
PORTB indicators
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128 64 32 16 8 4 2 1

PORTB7 PORTB6 PORTB5 PORTB4 PORTB3 PORTB2 PORTB1 PORTB0

Spk H Spk G Spk F Spk E Spk D Spk C Spk B Spk A

Spk H Spk G Spk F Spk E Spk D Spk C Spk B Spk A

20.4.4 Predefined Indicators 4

PORTE, PORTH indicators

128 64 32 16 8 4 2 1

PTH7 PTH6 - PORTE4 - PORTE2 PORTE1 PORTE0

Nitrous in Tablesw. in F.PUMP FLEX PE1 PE0/JS7

Digi Switch
12V in

Digital in 4 - F.PUMP - Digi Switch
in 1

- -

PORTJ, PORTM indicators (PTJ, PTM)

128 64 32 16 8 4 2 1

PTJ7 PTJ6 PTM5 PTM4 PTM3 PTM2 PTJ1 PTJ0

JS11 (IAC EN) D15 D16 D14 PM2(H2) IAC2 IAC1

(Internal) (IAC EN) (Internal) (Internal) (Internal) (Internal) Stepper Out
2

Stepper Out
1

PORTK indicators

128 64 32 16 8 4 2 1

PORTK7 PORTK6 PORTK5 PORTK4 PORTK3 PORTK2 PORTK1 PORTK0

PK7 (H1) - - - PK3 (H3) Launch in PK1 (H4) Tacho out

- - - - (internal) Digi Switch
in 2

(internal) Tach Out

PORTP indicators (PTP)

128 64 32 16 8 4 2 1

PTP7 PTP6 PTP5 PTP4 PTP3 PTP2 PTP1 PTP0

FIDLE VVT Nitrous2 Nitrous1 Boost Idle (INJ2 PWM) (INJ1 PWM)

PWM / Idle
Out 1

PWM Out 3 High Curr.
Out 2

High Curr.
Out 1

High Curr.
Out 3

PWM Out 2 - -
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20.4.5 Predefined Indicators 5

PORTT indicators (PTT)

128 64 32 16 8 4 2 1

PTT7 PTT6 PTT5 PTT4 PTT3 PTT2 PTT1 PTT0

- Datalog in JS10 PT4 INJ 2 Cam in INJ1 Crank in

- Digi Freq
In 3

Digi Freq
In 2

Digi Freq
In 1

Inj J CMP Inj I CKP

PW4X - 4x pulsewidth mode is active

RPM Synced / Not RPM synced – whether the Megasquirt is synchronized to the crank and cam signals

Ready / Not Ready – shows when there is an active tach signal and pump is running.

SD Err - Error on SDcard

SD Log - Logging active on SDcard

SD in - SDcard is inserted

SD ready - SDcard is initialised and ready to datalog

SPK3/4 – spark (ignition) table switching in effect. (Shows SPK1/2 when un-switched.)

SYNC fault - RPM sync faults detected

Safety Shutdown - AFR or EGT shutdown in effect

Seq. shift / No Seq. Shift – sequential shift control active.

Slow accel - Engine state is slow acceleration

Slow decel - Engine state is slow deceleration

Soft limiter / No soft limit – soft rev limiter in effect.

Spark cut – spark cut in effect.

T-log – tooth/trigger/composite log ready (TunerStudio internal use.)

TPS Accel – currently in an accel enrichment event due to TPS.

TPS Decel – currently in an decel enleanment event due to TPS.

TPS fault - fault on TPS

Test mode – spark / injector test mode is active.

Tune error - Total cor is less than 70%. Almost certainly there is a mistake in your tune.

VE3/4 - fuel table switching in effect. (Shows VE1/2 when un-switched.)

VSS launch L/O - Speed/VSS launch mode is locked out.

VSS launch on - Speed/VSS launch mode is active.

VVT1 err - error detected on VVT1 input (out of range angles.)

VVT2 err - error detected on VVT2 input (out of range angles.)

20.4.6 Predefined Indicators 6

VVT3 err - error detected on VVT3 input (out of range angles.)

VVT4 err - error detected on VVT4 input (out of range angles.)
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W.I. low! - water injection system has low fluid

WOT - Engine state is wide open throttle

WUE OFF / WUE – in WarmUp Enrichment mode.

20.5 Other Menu Items on the Indicator Pop-up Menu
The “Background”, “Antialiasing Enabled”, “Designer Mode” and “Gauge Demo” menu options are replicated 
from the Gauge Cluster sub menu, which is documented in Section 19.20.

21 Diagnostics & High Speed Loggers
The diagnostics tab allows access to the high-speed ignition loggers built into the Megasquirt firmware. These 
should be used during initial installation to confirm that tach signals are present and clean. They can also be 
used later as fault finding tools. Selecting the Diagnostics & High Speed Loggers tab from the main screen will 
display a screen similar to that shown below:

  

Note! This feature will not give you regular datalogs of engine operation including RPM, CLT, TPS, AFR 
etc. See section 4 instead.

21.1 Logger Type
This selects which of the Megasquirt firmware supplied loggers to use. The tooth logger and composite logger 
are generally the most useful. Although your firmware may give you additional options, the four standard loggers
are briefly described below.

For all of the loggers, you are seeing a decoded version of the input signal. The processor inside the Megasquirt
only sees a 0-5V signal, the raw analogue signal is pre-processed by the tach-in circuits.
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Composite Logger

 

This logger records both crank and cam signals in a format similar to an oscilloscope. The exact display will 
depend on a number of factors

• ignition mode

• whether the cam signal is used

• noise filtering

Most ignition modes only listen for a single "edge" of the input signal and the composite logger will reflect that 
with a series of vertical lines for each input pulse. The cam signal will only display if the input is in use and 
enabled and there is a cam signal coming in.

Enabling the "noise filter" makes the ECU listen to both edges of the input signal and the display will look 
different for the same actual signal.

During initial setup or for test purposes the ignition mode "Log crank & cam" can be selected to put the 
Megasquirt into a diagnostics mode that will record the full digital signal on both crank and cam inputs. (The 
engine will not run in this mode.)

 

(c) 2014-7 James Murray 2017-01-14 Page 335/351



Megasquirt-3: TunerStudio MS Lite Reference Guide

Sync Error Logger

This logger records a composite log up until a sync-loss occurs. The data shown is the crank and cam pattern 
that led up to the faulty signal causing sync-loss.

Tooth Logger

The tooth logger records just the crank pattern. It is useful for validating crank sensor polarity on missing-tooth 
wheels. (Correct polarity will show as a single long tooth, incorrect polarity will show as two fairly long teeth.) 
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Trigger Logger

The trigger logger records the internally decoded tach signal with one pulse per cylinder. This is not particularly 
useful for tracking down tach input problems. It will show up any uneven running of the engine.

  

21.2 Using the Loggers
Using the loggers is relatively straightforward. The options are described below:

Start

Starts capture of data from the Megasquirt.

Stop

Stops capture of data from the Megasquirt.

Clear

Clears the screen of any captured data.

Fetch interval

How often to collect data from the Megasquirt. This only applies to the Tooth and Trigger loggers.

During cranking when the engine is turning slowly, set the time to longer (e.g. 4000ms means 4 seconds) to 
enable a useful amount of data to be captured. You will need to wait at least this long before any data is 
displayed, so be patient.

Capture to Logfile

Enables the log to be recorded to a file on disk. The file can then be shared for support purposes.

Typical use of the logger:

Generally the following steps will enable you to capture data for analysis using one of the loggers.

• Turn on Megasquirt.
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• Pick the Logger type

• Tick 'Capture to Logfile'

• Choose a filename or just press Enter.

• Click Start

• Crank the engine

• Wait for data to show

• Click Stop

• Untick “Capture to Logfile”.

21.3 Analyzing Data from the Loggers
When the logger is running the data that is being collected will be displayed in the list on the left side of the 
screen. This screen can be re-sized using the left and right arrows on the top right of this list.

The log traces (the visual representation of the output) is displayed in the chart area on the right hand side of 
the screen.

Depending on your engine and your Megasquirt configuration the loggers can provide a wide range of outputs. 

21.4 Additional loggers
The MS3 provides additional high speed diagnostic loggers which are only usable with the registered version of 
TunerStudio.

• MAP logger - records MAP reading vs. crank angle. Useful for setting MAP sampling.

• MAF logger - records MAF reading vs. crank angle

• Engine logger - records crank and cam inputs and injector and spark outputs at high speed

• Engine logger + MAP - as engine logger but includes MAP

Once data is captured, it would normally be viewed in MegaLogViewer
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22 Tune Analyze Live
Tune Analyze Live is a feature of the Upgrade version of TunerStudio. Documentation of this feature lies outside
the scope of this document. Clicking this option will display an upgrade screen as shown below from which it is 
possible to purchase a license to the upgrade version should you so wish.
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23 Megasquirt Glossary of Terms
ADC – stands for "analog-to-digital converter". In this case, it is part of the conversion circuitry in the CPU that 
translates the varying voltage signal to a digital value that the CPU can understand and operate on. All of the 
sensors (TPS, MAP, CLT, MAT) send their signal to a particular ADC pin on the processor. The ADC result is 
used by the processor as a 'count'. MS-I has an eight bit ADC, so the counts can be from 0 to 255. MS2 and 
MS3 have a more precise 10-bit ADC, so the count can be from 0-1023. Both of these are mapped over a 0-5 
Volt range (so the voltage into the ADC = ADC count * 5.0/1023 for MS2, for example); however, higher external 
voltage may be brought down to a 0-5 volt range with a voltage divider or boosted with an amplifier (such as for 
EGTs).

AE – Acceleration Enrichment, the enriched mixture provided when the throttle position sensor signal (TPSdot) 
or map sensor signal (MAPdot) changes at various rates.

AFM – Air Flow meter. Often a vane or flapper type device used to measure air-flow into an engine.

AFR – Air Fuel Ratio, the mass ratio of air to fuel in the combustion chamber. See lambda, NB- and WB-EGO 
sensors, below.

Alpha-N – Fuelling algorithm that uses throttle position as the primary load. Should not be used on 
turbocharged engines.

ASE – After Start Enrichment, the enriched mixture provided for a number of engine cycles when MegaSquirt 
detects that the engine has transitioned from cranking to running.

AMC – Automatic Mixture Control, a control system available in MS2/BG code to automatically tune fuel within 
the ECU using feedback from the oxygen sensor without use of a laptop. Should be used with great caution as a
defective O2 sensor could cause a good VE table to be wiped out.

ATDC – After Top Dead Center, the crankshaft position with respect to the piston being at the top of its travel, 
meaning it has passed it's highest position and is descending.

Baro – Barometer - the ambient air pressure. At sea level this is around 100kPa. At high elevations it may be 
80kPa. The fuelling needs to take account of this.

%baro – a fuelling algorithm where engine load = MAP/Baro and the speed-density system is used. This alters 
what values are looked up in the fuel VE table.

Barometric correction – a calculation that alters fuelling based on the ambient air pressure. Important at 
varying elevations. Of little importance in low-lying countries.

BIP373 – a robust ignition driver transistor from Bosch. Features over-currrent and over-temperature protection.
Used in all good Megasquirt kits. Beware of lesser alternatives.

BTDC – Before Top Dead Center, the crankshaft position with respect to the piston being at the top of its travel, 
meaning it has NOT passed it's highest position and is rising. Most normal spark event occur BTDC.

CAN – (Controller Area Network) - a dedicated automotive networking system to allow different automotive 
processors to communicate and share inputs and calculated results. Used as a convenient way to extend the 
inputs and outputs of the Megasquirt ECU. (Not available on Megasquirt-1)

Carbon Monoxide (CO) – Poisonous gas produced during combustion process. In an automotive context, 
generally refers to regulated carbon monoxide (CO) tail pipe emissions.

CAS – Crank Angle Sensor. Often used to refer to combined crank and cam position sensors mounted where 
historically a distributor would have been.

Catalytic converter – a chemical device in the vehicle's exhaust system that can reduce the amount of 
regulated emissions emitted by converting Nox to N2 + 02, CO to CO2 and HC to CO2 + H20. Catalytic means 
the converter active substrate facilitates the reactions, but is not consumed (and thus has a long life with no 
replenishment requirements).

CID – Cubic Inch Displacement. The imperial measure of the swept volume of the pistons. 61.02 cubic inches = 
1 litre.
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Closed loop – refers to those times when an EFI computer is using feedback from a sensor to alter outputs

Closed loop boost – Megasquirt uses a PID to keep boost in line with a boost target table

Closed loop EGO – Megasquirt controls the EGO to the target table by varying the injected fuel amounts.

Closed loop idle – Megasquirt controls the idle rpm by opening or closing the idle valve as required.

CHT – Cylinder Head Temperature, used instead of coolant temperature (CLT) on air-cooled engines.

CKP – Crankshaft position sensor

CLT – Coolant Temperature sensor (aka. CTS). Usually the CLT sensor is an NTC (Negative Temperature 
Coefficient) thermistor, or a resistor whose resistance varies with temperature (NTC means the resistance goes 
down as the temperature goes up).

CMP – Camshaft position sensor

CNP – Coil Near Plug – See Coil on Plug

Coil On Plug – One ignition coil is installed per spark plug. Either directly on top of the plug e.g., a 'pencil' coil. 
Or in close proximity with a short plug-lead (actually coil near plug.) This setup can give maximum spark energy 
and can be the neatest install with least lost spark energy.

COP – Coil on Plug – See Coil on Plug

CPS – Possibly ambiguous Crankshaft or camshaft position sensor

CPU – Central Processing Unit, aka. "processor" or "microprocessor" the computational engine that performs 
the calculations to operate the injection and ignition functions in MegaSquirt®. It has a number of support 
circuits, like the power circuit, the clock circuit, the serial and CAN communications circuits, and various input 
and output conditioning circuits.

CTS – Coolant Temperature Sensor (aka. CLT). Usually the CTS is an NTC (Negative Temperature Coefficient) 
thermistor, or a resistor whose resistance varies with temperature (NTC means the resistance goes down as the
temperature goes up.

Diode – A two lead electrical device that allows current to flow in only one direction (see also Zener diodes).

DIY – Do-It-Yourself.

DMM – (digital multi meter) electronic current/resistance/potential measuring tool. (Required tool for any 
Megasquirt install.) May also be referred to as DVM (digital volt meter.)

Dual table – A firmware feature allowing different injector outputs to have independent fuel tables. Can be used 
as an awkward method to achieve per-bank trim. More commonly used (with external relays) to map for regular 
fuel and LPG.

Duty Cycle – (DC)– A number indicating the amount of time that some signal is at full power. In the context of 
MegaSquirt EFI Controller, duty cycle is used to describe the amount of time that the injectors are on, and to 
describe the “hold” part of the peak and hold injector drivers (see Low Impedance Injectors, below).

ECU – (Electronic Control Unit) is the general term for a fuel injection controller, of which MegaSquirt is an 
example.

EDIS – Electronic Distributorless Ignition System is Ford's wasted-spark computer-controlled ignition module, 
which has a simple two wire hookup to MegaSquirt for full mapped ignition control.

EGO Sensor – Exhaust Gas Oxygen sensor, used to describe the sensor in the exhaust that measures the 
lean/rich state of the intake mixture. Used to control the fuel via a feedback algorithm called “closed loop”.

EGR – Exhaust Gas Recirculation. Used by OEMs for emissions purposes. Not supported by Megasquirt.

EGT – (Exhaust Gas Temperature) is the temperature of the exhaust gases, typically measured with a K-type 
thermocouple. Megasquirt does not have on-board hardware for a direct connection. An add-on board is 
required.

FET – (field effect transistor) - In MegaSquirt EFI Controller, the transistors used to control the activation of the 
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injectors.

FIdle – Fast Idle. A device used to control idle speed with additional air supplied by a vacuum solenoid. More 
commonly a fully variable PWM idle valve is used instead. This term is most frequently applied to a connection 
from the Megasquirt ECU that can be used to drive an on/off valve or a PWM valve.

Gamma – Used to indicate the change in a fuel amount from the calculated amount.

GammaE – A collection of all enrichments and minor corrections to fuel (see speed density.) Now renamed as 
'totalcor'.

Gear tooth sensor – an "active", tooth presence sensor. It is based on the Hall effect. The Hall effect sensor 
consists of semiconductor material which will conduct current when the material is subject to a magnetic field. 
These types of sensors include a magnet within the sensor and will detect a steel tooth in close proximity. No 
external magnets are required. Very simple to use.

Gego – Gego is short for 'Gamma – Exhaust Gas Oxygen'. It is the change applied to the fuelling equation 
based on the EGO O2 sensor feedback. This feedback can (and is) done in a number of different ways, 
depending on the type of sensor, etc. The important thing is that this is a result of an external measurement, not 
a pure calculation, so it appears a bit mysteriously in the equation. Now renamed as 'egocor'.

Hall sensor – an "active", magnetic field presence sensor. It is based on the Hall effect. The Hall effect is the 
change of resistance in a semiconductor in a magnetic field. The Hall effect sensor consists of semiconductor 
material which will conduct current when the material is subject to a magnetic field. These types of sensors 
require a "flying magnet", wheel. Instead of teeth on the wheel, as in a variable reluctor sensor, you must have 
small magnet and a shutter wheel.

Hydrocarbon (HC): in an automotive context, generally refers to regulated unburned hydrocarbon tail pipe 
emissions.

HEI – , the distributor based electronically controlled ignition system from General Motors. There are a number 
of variants, identified by the module they use:

•4-Pin module: non-computer controlled electronic ignition,

•7-Pin module: computer controlled electronic ignition used in 'large cap' distributors,

•8-Pin module: computer controlled electronic ignition used in 'small cap' distributors.

High Impedance Injectors – (a.k.a. hi-Z or high ohm) Fuel injectors designed to work with a simple switch in a 
12 volt circuit, no special signal conditioning is required to drive them. The resistance of a high impedance 
injector is about 10-15 ohms.

Hz – (Hertz) the measurement of the frequency of a cyclical event, it represent the number of times per second 
the cycle is completed.

IAC – Idle Air Controller, though this term is sometimes used more generally, it usually refers to GM's 4 wire 
stepper motor controller for additional idle air (and hence engine speed) during warm-up and for idle regulation.

IAT sensor – Intake Air Temperature sensor, same as MAT, see below.

IGBT – Insulated Gate Bipolar Transistor a particular kind of transistor especially suitable for driving ignition 
coils. e.g., VB921, BIP373

Incorporate AFR – An MS2 and MS3 feature where the AFR target table is included in the fuelling equation. 
The Fuel VE table then becomes far closer to a true VE table. Enrichment or enleanment from stoichiometric 
comes from the AFR table. Ideally this setting should be turned on before any tuning and the AFR table set to 
your target AFRs. Then the VE table is tuned to achieve that AFR. Turning the setting on/off will require a 
complete re-tune.

Interpolate – The dictionary meaning is to insert an intermediate value into a series by estimating or calculating 
it from surrounding known values. On all tables and curves, when you are between points, the Megasquirt 
interpolates the intermediate values. Some older other brands were unable to do this and required monstrously 
large tables to overcome this limitation.
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kPa (kiloPascals) – the measurement of air pressure used in MegaSquirt® computations. It ranges from 0 
(vacuum) to 101.3 kPa (standard atmospheric pressure at sea level) to 250 kPa (21psi of boost) or higher.

Lambda – an alternative term to AFR where 1.0 is stoichiometric. Lambda numbering is fuel independent. 1.0 is
always stoich.

Low Impedance Injectors – (a.k.a low-Z, low ohm) Fuel injectors that are designed to run at a much lower 
current than would be supplied by a direct 12 volt connection. They require a special signal that is initially at full 
current (4-6 amps, a.k.a. “peak current”) for about 1.0-1.5 ms, but then drops down to about 1 amp (“hold 
current”) for the rest of the opening pulse. The resistance of a low-impedance injector is typically 1-3 ohms. 
These may need a "peak and hold" board or a resistor pack.

LSU-4 – Bosch wide-band oxygen sensor.

MAF sensor – Mass Air Flow sensor. A sensor used to measure the mass of air flow through the intake tract 
(which must be sealed at the senor and downstream).

MAP sensor – Manifold Absolute Pressure sensor. Measure of the absolute pressure in the intake manifold 
(related to the engine vacuum), to determine the load on the engine and the consequent fueling requirements. 
The standard MAP sensor in MegaSquirt® is the MPX4250 (2.50 BAR, or 15 psi (vacuum) + 21 psig (boost)). A 
basis of the "speed density" fuelling algorithm.

MAPdot – rate of change of MAP value. (dMAP/dt) Used mainly to trigger Accel enrichment.

MAT Sensor – Manifold Air Temperature sensor, the same as IAT. The MAT circuit is identical to the CLT circuit, 
see CLT, above.

.MSL – file extension used by the MegaSquirt for storing datalogs (.XLS might also be used for datalogs with 
older versions of tuning software).

MPX4250AP – the standard internal MAP sensor used in MegaSquirt.

MS – MegaSquirt, used in this document to refer to the MegaSquirt® fuel injection controller or its embedded 
software. e.g., MS1 = Megasquirt-1, MS2 = Megasquirt-2, MS3 = Megasquirt-3

MS1/Extra – The most commonly used firmware on the Megasquirt-1 chip. Gives fuel and spark control. Used 
to be called Megasquirt'n'spark-extra or MSnS-extra. The original basic MS1 code was fuel only.

MS2/Extra – Firmware for the MS2 chip and Microsquirt with multiple spark outputs, many wheel decoders, 
closed loop idle, boost, nitrous, table switching and more

MS2/BG – More basic firmware for the MS2 chip and Microsquirt from Bowling and Grippo.

.MSQ – file extension used for saving MegaSquirt fuel injection controller user settings (aka. "parameters") on a 
tuning computer. Since approximately 2005, these have been readable XML format, so you can open these in 
Notepad or similar text editors. This format allows some exchange of tune data between different code versions.

NB-EGO Sensor – Narrow Band EGO sensor, gives a switch at the stoichiometric ratio (the chemically correct 
mixture of air and fuel), but unreliable for AFR other than stoichiometric.

Ohm's Law – A fundamental law of electricity, that states that the current flow (I) is equal to the voltage (V) 
divided by the resistance (R), or:

I = V/R

Oxides of Nitrogen (NOx) – in an automotive context, generally refers to regulated 'mono-nitrogen oxides' (NO 
and NO2) tail pipe emissions.

OEM – (original equipment manufacturer) - refers to parts produced for initial assembly of a new vehicle. (As 
opposed to after market parts.)

Open Loop – refers to those times when MegaSquirt works entirely from its calculations with no feedback from 
a sensor (compare Closed Loop.)

Open Loop Boost – there is no feedback from the map sensor – boost duty is controlled by the duty table only.

Open Loop EGO – there is no feedback from the oxygen sensor – fuelling is from the VE table only.
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Open Loop Idle – there is no feedback loop with rpm – idle valve position is set only from the table.

PCB – (printed circuit board) – the fiberglass board that has the MegaSquirt component layout and circuits 
imprinted on it.

PID – (Proportional, Integral, Derivative) - a method of closed-loop feedback control

Pull-up Circuit – A very simple circuit consisting of a voltage supply and a current limiting resistor designed to 
prevent a signal from floating, it forces the signal to either be high (equal to the pull up voltage) or low 
(grounded).

P&H Injectors – Peak and hold injectors; see Low Impedance injectors.

PIP – Profile Ignition Pick-up is the term used for the signal sent from Ford's Electronic Distributorless Ignition 
System (EDIS) to the electronic control unit. The EDIS module decodes the 36-1 wheel and sends 2, 3 or 4 PIP 
pulses per engine revolution depending on EDIS4,6,8. The PIP signal into the ECU is a square wave switched 
at 12 volts. It provides information about both the engine speed and position.

PW – (Pulse Width) is the amount of time a signal is applied during each period. For example, is the amount of 
time (in milliseconds) an injector is pulled low (grounded) to inject fuel.

Pulse Width Modulation (PWM) – A signal with a fixed pulse width (frequency), which is turned on for part of 
the pulse. The percent of time that the signal is on is called its duty cycle. PWM is used to limit current to low 
impedance fuel injectors, as well as for solenoids such as idle valves, boost solenoids and VVT

Realtime baro – a dedicated second pressure sensor is used to monitor ambient pressure. Required if your 
vehicle will go on journeys at varying elevations.

Required Fuel – (Req_Fuel) The injector pulse width, in milliseconds, required to supply the fuel for a single 
injection event at stoichiometric combustion, 100% volumetric efficiency and standard temperature.

RPM – Revs Per Minute. The term used to describe engine speed.

SAW – Spark Advance Word is the 'returning' signal to a Ford EDIS ignition unit from the ECU that sets the 
amount of ignition advance requested. It is in the form of a 5 volt square wave.

Semi-sequential – Fuelling system where injection events are timed to each cylinder (like spark is) but occur 
twice per cycle. Offers some of the benefits of full sequential without needing a cam wheel input.

(Fully) Sequential – Fuelling system where injection events are timed to each cylinder (like spark is) and occur 
once per cycle. Do not confuse with direct injection. Sequential uses normal injectors of a normal size, but their 
timing can give slight power and/or economy increases

Stim (MegaStimulator) – the original stimulator is a small board which plugs into the connector of the 
MegaSquirt® controller. It simulates all the sensor the inputs the MegaSquirt® controller would normally see 
(but the rpm signal is only suitable for use with distributor or EDIS configurations) and provides power to the 
MegaSquirt® controller. The Stimulator also allows you to monitor the MegaSquirt® controller's injection pulses 
[actual], fuel pump relay operation, and fast idle solenoid output with four LEDs. The JimStim is an enhanced 
version that simulates many wheel patterns and has more LEDs for multiple spark outputs.

Speed Density – Fuel control algorithm that calculates fuelling based primarily on pressure, air temperature 
and volumetric efficiency. 
PW = dead time + (ReqFuel * MAP * VE(rpm,map) * GammaE)
All the corrections are included within GammaE.

Stoichiometric – the chemically ideal air:fuel mixture. Expressed as 1.0 Lambda for all fuels or 14.7 for 
petroleum/gasoline.

SPOUT – Spark Out is the spark advance signal sent from MS-II™ to the Ford TFI module to set the timing 
advance.

Table blending – A firmware feature that allows the user to combine two tables, usually using different 
algorithms. e.g., one table could be a regular speed-density table and the other alpha-n. This could be useful on 
an individual throttle body install or as a way of extending the table size.

Table switching – A firmware feature that allows the user to swap to a different fuel, spark, etc table. Can be 
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used in conjunction with dual fuels or nitrous or as a way of extending the table size.

TBI – Throttle Body Injection is a form of injection is which the fuel is injected above the throttle(s). It was 
typically used on older engines since it can be a simpler system, but is also found on some very high output 
racing engines because the vaporization time is longer than with port injection.

TPI – Tuned Port Injection is General Motors bank-fire port fuel injection system. It was widely used on 305 and 
350 cid V8 in the mid to late 1980's.

TPS – Throttle Position Sensor, a voltage divider that gives information to a MegaSquirt® controller about 
throttle opening, from which it computes rate of throttle opening for acceleration enrichment.

TPSdot – rate of change of TPS value. (dTPS/dt) Used mainly to trigger Accel enrichment.

Transistor – A solid-state (no moving parts) electronic device that uses a small voltage (on the base pin) to 
control a larger current (across the emitter and collector pins). There are two basic types of transistors, PNP and
NPN. A PNP transistor allows current to flow if there is no signal on the base, and restricts the current as the 
base current increases. An NPN transistor allows current to flow in proportion to the signal on the base, and 
restricts the current as the base current decreases.

TS (TunerStudio MS) – The standard software for tuning MegaSquirt EFI controllers. (The previous, now 
obsolete, software was called Megatune.)

Volatile Organic Compounds (VOC) – in an automotive context, generally refers to organic components or 
precursors to smog formation. Organic compounds are all chemical compounds containing carbon-hydrogen (C-
H) bonds of covalent character. The U.S. Environmental Protection Agency defines a VOC as any organic 
compound that participates in a photoreaction. An example of a VOC is PAN (peroxyacetyl nitrate), 
CH3COOONO2.

Voltage divider – A simple circuit that uses two resistors in series to reduce the output voltage Vo  
proportionally to the input voltage Vi. Two resistors, R1 and R2, are arranged in series, with one end connected 
to the external signal, and the other to ground. The signal is taken from between the two resistors. From Ohm's 
Law we can calculate that the total current will be I = Vi/(R1+R2). The same current flows in each resistor 
because they are in series. The voltage drop across each resistor is: V1 = I*R1 and V2 = I*R2 = Vo. V2 is output
voltage Vo, which we can write as:

Vo = Vi* R2/(R1+R2)

V2.2 – The first mainstream circuit board used within Megasquirt. While still available for sale, it is largely 
obsolete.

V3.0 – The current circuit board used within Megasquirt (accurate Nov 2010). This superceded the V2.2 adding 
better support for low-z injectors and a circuit for VR conditioning.

V3.57 – A surface mount circuit board, largely the same as the V3.0 board.

VB921 – a particular IGBT designed for use with automotive ignition coils. Now superceded by BIP373.

VE – Volumetric Efficiency. The actual amount of air being pumped by the engine as compared to its theoretical 
maximum. A 2000 cc engine will theoretically move 2000 cc of air in one cycle at 100% efficiency. If the engine 
is actually running at 75% VE, then it will move 1500 cc of air on each cycle.

Vref – a 5 Volt supply used to power the TPS (and sometimes other external components needing a 5 Volt 
supply, like ignition modules or pull-ups).

VR sensor - Variable reluctor sensor – is an induction type sensor, it is "passive", i.e.,  it does not require a 
power source, and has a small magnet built in. Needs to use a conditioning circuit – as provided on the V3.0 
and V3.57 mainboard. Cannot be used directly on the V2.2 mainboard.

Wasted-COP – a method where individual coils are fitted per spark plug, but the coils are fired in a 'wasted' 
manner twice per cycle. This is used during startup in some wheel modes and could also be used temporarily by
a user before full coil-on-plug is installed.

Wasted Spark – A method of firing spark plugs in which one 'double-ended' coil simultaneously fires two coils 
on different cylinders. One of the cylinders is the intended 'target', and is near TDC on its compression stroke, 
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the other cylinder is offset by 360° in the firing order (of the 720° 4-stroke cycle), so it is near TDC on its exhaust
stroke. The second spark is said to be 'wasted' because it does not ignite a mixture. On the other hand, the hot 
ionized exhaust gases require little energy to create a spark, so nearly all the energy goes to the 'target' 
cylinder. An example of a wasted spark system is Ford's EDIS. The advantage is that while a missing tooth 
crank wheel is required, no cam sync signal (and the corresponding wheel and sensor) are needed.

WB-EGO Sensor – Wide Band EGO sensor, can be used to derive real AFR data with mixtures from 10:1 to 
20:1, i.e.,  anything you are likely to be interested in. Allows for lean or rich tuning.

WOT – Wide open throttle.

WUE – Warm Up Enrichment, the enriched mixture applied when the coolant temperature is low.

Zener diode – A diode that allows current to flow in one direction, unless the reverse voltage is higher than its 
rated avalanche voltage, in which case it will flow in the reverse direction. Often used to limit excessive voltage 
to certain circuits by shunting it either to ground or the power supply.
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24 Firmware changes since 1.3.x
This section gives a brief overview of firmware features that have changed between 1.3.x and 1.4.x firmware 
releases.

24.1 Old baro
The "old" baro calculation included 1/baro in the fuel calculation, this is disabled by default now.

24.2 Tacho output - variable
A fully variable tacho output is now available to correct for inaccurate tachos or differing cylinder counts.

24.3 Injector deadtime wording
The injector deadtime screen no longer refers to 13.2V as some magic number. Actual code and behaviour is 
unchanged.

24.4 Flex fuel / dual fuel mode
The setting is visible on the flex screen.

24.5 Ignition Settings
The "Flip polarity on hi-res tach / cam" settings can now be used to invert the cam polarity if needed for modes 
where this was not previously possible.

Kick-start mode is a new feature.

24.6 Knock Sensor Settings
Retarding timing on a per-cylinder basis is now possible.

24.7 A/C idle-up
Max RPM is a new setting.

24.8 Accel enrichment
A secondary set of enrichments are available for use with Flex Blending.

24.9 Boost Control Settings
The initial value table has been replaced by a "bias" table and more classic PID is used. To tune the bias table a
"setup" Tuning mode is available. The table is tuned as an open loop table, with the closed-loop refining the 
duty.

Boost Control Bias Duty 1 always applies to boost channel 1, even in the case of table switching or blending.

24.10 VVT Settings
The VVT settings have been changed for BMW S54 and S62 engines that use two solenoids per VANOS. Eight 
outputs in total are now possible.

24.11 Dual Fuel / Table Switching
Flex Blending is a new option for Mode.
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24.12 Blend Curve (8) Flex Blending
This is the curve to control the blending between tables based on Flex fuel percentage.

24.13 EGT
Fuel adder can now be per cylinder.

24.14 Launch / 2-step / 3-step / T-brake
There is now a Line-Lock Staging feature.

24.15 Sequential Shift Cut
There is now an option to cut fuel also.

24.16 Nitrous System
VSS based progressive now an option.

24.17 Pit Lane Limiter 
New feature

24.18 Programmable On/Off Outputs
The meaning of threshold and hysteresis are changed when using a bitwise AND operation.

Additional of "Loop" pseudo ports.

24.19 CAN Broadcasting
Two new options

Holset HE351VE VGT turbo - this broadcasts 'boost duty' with a 29bit CAN identifier specific to the turbo.

User defined testing - allows custom CAN packets to be broadcast

24.20 CAN Broadcast testing
A custom identifier (decimal) and payload can be broadcast.

24.21 CAN Realtime Data Broadcasting
This is a major enhancement allowing all of the engine parameters to be broadcast to the CAN using standard 
11bit identifiers which can then be received and displayed by suitable 3rd party dashes or dash loggers.

24.22 CAN Receiving
Another major enhancement is the ability to receive and process standard 11bit CAN messages. These can be 
used to collect remote sensor data or wheel speed from ABS modules etc.

24.23 CAN Dash Broadcasting
Allows a fixed set of data to be broadcast for use by dashes.

24.24 CAN VSS and Gear
The page has been re-arranged slightly.
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24.25 CAN EGO / GPS
Same settings, own page.

24.26 IO-Box Settings
New feature.

24.27 Output Test Mode - I/O
The test mode has been expanded to allow control of all outputs.

24.28 Output Test Mode - CANOUTs 
This allows expansion board outputs to be tested.

24.29 Datalogged fields
Some more fields added.
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25 Firmware changes since 1.4.x
This section gives a very brief overview of firmware features that have changed between 1.4.x and 1.5.x 
firmware releases.

25.1 Engine States
New feature that combines settings used by idle and overrun into one place. Reduces settings and helps 
features from "fighting" each other.

25.2 Boost Dome Control
New feature for CO2 'dome' control.l

25.3 Progressive Nitrous
Reworked calculation for dry fuelling.

25.4 Custom sensor calibration
The old MAF calibration is gone and replaced by a custom sensor calibration.

25.5 CAN integration
Additional options to support 3rd party devices.

25.6 Throttle control
Preliminary feature for DBW integration.
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26 Revision history
2014-09-08 Revision history started. Minor edits.

2014-11-17 CEL status correction

2014-12-01 MS2->MS3 typo correction.

2015-01-30 Fix some typos. Gloassary from Setting Up. Add A/C idleup invert input.

2015-02-02 Minor staging typo.

2015-03-23 Staging notes.

2015-04-08 Add missing sections: Shift Light, Fan Control, Torque Convertor Lockup, Alternator 
control.

2015-07-06 Bump to 1.4. Add new features summary section. Add new features sections. Add 
updated screenshots for changed features.

2015-09-28 Added note that spark trim doesn't work with TFI.

2016-01-19 Incorp AFR targ note for MAF.

2016-01-22 Add trigger angle note for basic trigger.

2017-01-14 Updates for 1.5 firmware. Engine states, Dome control, CAN receiving and more.
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